Upgrade to 0.70.
This commit is contained in:
parent
42e2b6d294
commit
c390bad0e7
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=79696
7 changed files with 81 additions and 86 deletions
|
@ -6,8 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= muttprint
|
||||
PORTVERSION= 0.64
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 0.70
|
||||
CATEGORIES= print mail
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= muttprint
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (muttprint-0.64.tar.gz) = bf248c768af2293cd55aad677e9a1939
|
||||
MD5 (muttprint-0.70.tar.gz) = 1ae01f2d4b198c05f76b01c4a3fe3f1d
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- Makefile.orig Tue Sep 10 20:01:54 2002
|
||||
+++ Makefile Wed Sep 11 23:06:32 2002
|
||||
@@ -7,27 +7,27 @@
|
||||
--- Makefile.orig Mon Apr 14 17:51:47 2003
|
||||
+++ Makefile Sat Apr 26 23:58:41 2003
|
||||
@@ -7,34 +7,34 @@
|
||||
|
||||
# Change this for local installation,
|
||||
# e. g. /home/user or /usr/local
|
||||
|
@ -36,32 +36,39 @@
|
|||
|
||||
#####################################################
|
||||
#####################################################
|
||||
@@ -42,17 +42,18 @@
|
||||
|
||||
-install = install
|
||||
-INSTALLBIN = $(install) -m 0755
|
||||
-INSTALL = $(install) -m 0644
|
||||
+#install = install
|
||||
+#INSTALLBIN = $(install) -m 0755
|
||||
+#INSTALL = $(install) -m 0644
|
||||
|
||||
|
||||
nothing:
|
||||
@@ -42,16 +42,17 @@
|
||||
|
||||
|
||||
install:
|
||||
- mkdir -p $(docdir)/muttprint $(bindir) $(sharedir)/muttprint $(mandir)/man1 \
|
||||
- $(mandir)/de/man1 $(mandir)/es/man1 \
|
||||
- $(mandir)/cs/man1 $(mandir)/it/man1 \
|
||||
+ mkdir -p $(bindir) $(sharedir)/muttprint \
|
||||
$(libdir)/muttprint
|
||||
- mkdir -p $(docdir)/muttprint $(bindir) $(sharedir)/muttprint/translations \
|
||||
- $(mandir)/man1 $(mandir)/de/man1 $(mandir)/es/man1 \
|
||||
- $(mandir)/cs/man1 $(mandir)/it/man1
|
||||
- $(INSTALLBIN) muttprint $(bindir)/
|
||||
- $(INSTALL) CHANGES COPYING INSTALL README* sample-muttprintrc-* \
|
||||
- $(docdir)/muttprint/
|
||||
- $(INSTALL) `find pics -type f -print` $(sharedir)/muttprint/
|
||||
- $(INSTALL) `find translations -type f -print` $(libdir)/muttprint/
|
||||
- $(MAKE) -C doc/manual docdir=$(docdir) install
|
||||
- $(MAKE) -C doc/manpages mandir=$(mandir) install
|
||||
+ mkdir -p $(bindir) $(sharedir)/muttprint/translations
|
||||
+ ${BSD_INSTALL_SCRIPT} muttprint $(bindir)/
|
||||
+ ${BSD_INSTALL_DATA} `find pics -type f -print` $(sharedir)/muttprint/
|
||||
+ ${BSD_INSTALL_DATA} `find translations -type f -print` $(libdir)/muttprint/
|
||||
+ ${BSD_INSTALL_DATA} `find translations -type f -print` $(sharedir)/muttprint/translations
|
||||
+ $(MAKE) -C doc/manpages mandir=$(mandir) install
|
||||
+
|
||||
+install-with-doc: install
|
||||
+ mkdir -p $(docdir)/muttprint
|
||||
+ ${BSD_INSTALL_DATA} CHANGES COPYING INSTALL README* \
|
||||
+ sample-muttprintrc-* $(docdir)/muttprint/
|
||||
+ ${MAKE} -C doc/manual docdir=$(docdir) install
|
||||
+ ${MAKE} -C doc/manpages mandir=$(mandir) install
|
||||
+ ${BSD_INSTALL_DATA} CHANGES COPYING INSTALL README* sample-muttprintrc-* \
|
||||
$(docdir)/muttprint/
|
||||
- $(INSTALL) `find pics -type f -print` $(sharedir)/muttprint/
|
||||
- $(INSTALL) `find translations -type f -print` $(sharedir)/muttprint/translations
|
||||
$(MAKE) -C doc/manual docdir=$(docdir) install
|
||||
- $(MAKE) -C doc/manpages mandir=$(mandir) install
|
||||
|
||||
uninstall:
|
||||
rm $(bindir)/muttprint
|
||||
|
|
|
@ -1,22 +1,13 @@
|
|||
--- muttprint.orig Sun Dec 15 20:14:03 2002
|
||||
+++ muttprint Sun Apr 6 16:28:56 2003
|
||||
@@ -193,8 +193,8 @@
|
||||
--- muttprint.orig Sat Apr 26 19:18:18 2003
|
||||
+++ muttprint Sat Apr 26 23:36:53 2003
|
||||
@@ -189,8 +189,8 @@
|
||||
|
||||
if ($Config{'PENGUIN'} eq "on") {
|
||||
$Config{'PENGUIN'} =
|
||||
- -r "$share_dir/penguin.eps"
|
||||
- ? "$share_dir/penguin.eps" : "off";
|
||||
+ -r "$share_dir/Beastie.eps"
|
||||
+ ? "$share_dir/Beastie.eps" : "off";
|
||||
my $sharedir = findCommonDir("share");
|
||||
- $Config{'PENGUIN'} = (-r "$sharedir/penguin.eps")
|
||||
- ? "$sharedir/penguin.eps"
|
||||
+ $Config{'PENGUIN'} = (-r "$sharedir/Beastie.eps")
|
||||
+ ? "$sharedir/Beastie.eps"
|
||||
: "off";
|
||||
}
|
||||
|
||||
ReadConfig ($Config{RCFILE});
|
||||
@@ -1532,7 +1532,7 @@
|
||||
##############################################################################
|
||||
|
||||
sub GetGeometryVersion {
|
||||
- my $tempfile = "/tmp/muttprint-geometry-ver";
|
||||
+ my $tempfile = "/tmp/muttprint-geometry-ver.$<";
|
||||
my $geometryVersion;
|
||||
|
||||
# temporary file exists
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- doc/manual/Makefile.orig Sat Feb 23 23:16:35 2002
|
||||
+++ doc/manual/Makefile Sat Feb 23 23:17:10 2002
|
||||
--- doc/manual/Makefile.orig Tue Mar 18 16:30:54 2003
|
||||
+++ doc/manual/Makefile Sat Apr 26 23:38:34 2003
|
||||
@@ -1,11 +1,7 @@
|
||||
#
|
||||
# This is the main makefile for documentation
|
||||
|
@ -11,5 +11,5 @@
|
|||
-MAKE = make
|
||||
+docdir = ${PREFIX}/share/doc
|
||||
|
||||
|
||||
|
||||
default:
|
||||
$(MAKE) -C de
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
--- doc/manpages/Makefile.orig Wed Sep 11 10:40:24 2002
|
||||
+++ doc/manpages/Makefile Wed Sep 11 20:32:04 2002
|
||||
@@ -4,14 +4,14 @@
|
||||
--- doc/manpages/Makefile.orig Sat Apr 26 19:17:56 2003
|
||||
+++ doc/manpages/Makefile Sat Apr 26 23:40:24 2003
|
||||
@@ -4,15 +4,6 @@
|
||||
|
||||
VERSION = 0.63a
|
||||
VERSION = 0.70
|
||||
POD2MAN = pod2man --section=1 --release=$(VERSION)
|
||||
-prefix = /usr
|
||||
-bindir = $(prefix)/bin
|
||||
|
@ -12,43 +12,28 @@
|
|||
-sharedir = $(prefix)/share
|
||||
-libdir = $(prefix)/lib
|
||||
-mandir = $(prefix)/share/man
|
||||
+#prefix = /usr
|
||||
+#bindir = $(prefix)/bin
|
||||
+#tempdir = /tmp
|
||||
+#sysconfdir = /etc
|
||||
+#docdir = /usr/share/doc/packages
|
||||
+#sharedir = $(prefix)/share
|
||||
+#libdir = $(prefix)/lib
|
||||
+#mandir = $(prefix)/share/man
|
||||
INSTALL = install -m 0644
|
||||
-INSTALL = install -m 0644
|
||||
gzip = gzip -f
|
||||
rm = rm
|
||||
|
||||
@@ -22,7 +22,7 @@
|
||||
TITLE_CS = "Krátký manuál Muttprintu"
|
||||
@@ -22,7 +13,7 @@
|
||||
TITLE_IT = "Breve manuale di Muttprint"
|
||||
|
||||
|
||||
-all: german english spanish italian czech
|
||||
-all: german english spanish italian
|
||||
+all: english
|
||||
german: de/muttprint.1.gz
|
||||
english: en/muttprint.1.gz
|
||||
italian: it/muttprint.1.gz
|
||||
@@ -111,13 +111,12 @@
|
||||
|
||||
########################### GENERAL ###################################
|
||||
|
||||
-install: de/muttprint.1.gz en/muttprint.1.gz es/muttprint.1.gz \
|
||||
- it/muttprint.1.gz cs/muttprint.1.gz
|
||||
@@ -103,10 +94,7 @@
|
||||
##install: de/muttprint.1.gz en/muttprint.1.gz es/muttprint.1.gz \
|
||||
## it/muttprint.1.gz
|
||||
install:
|
||||
- $(INSTALL) en/muttprint.1.gz $(mandir)/man1/
|
||||
- $(INSTALL) de/muttprint.1.gz $(mandir)/de/man1/
|
||||
- $(INSTALL) es/muttprint.1.gz $(mandir)/es/man1/
|
||||
- $(INSTALL) it/muttprint.1.gz $(mandir)/it/man1/
|
||||
- $(INSTALL) cs/muttprint.1.gz $(mandir)/cs/man1/
|
||||
+install: en/muttprint.1.gz
|
||||
+ ${BSD_INSTALL_MAN} en/muttprint.1.gz $(mandir)/man1/
|
||||
+# $(INSTALL) de/muttprint.1.gz $(mandir)/de/man1/
|
||||
+# $(INSTALL) es/muttprint.1.gz $(mandir)/es/man1/
|
||||
+# $(INSTALL) it/muttprint.1.gz $(mandir)/it/man1/
|
||||
+# $(INSTALL) cs/muttprint.1.gz $(mandir)/cs/man1/
|
||||
|
||||
uninstall:
|
||||
rm -f $(mandir)/man1/muttprint.1.gz
|
||||
|
|
|
@ -3,34 +3,40 @@ bin/muttprint
|
|||
%%PORTDOCS%%share/doc/muttprint/COPYING
|
||||
%%PORTDOCS%%share/doc/muttprint/INSTALL
|
||||
%%PORTDOCS%%share/doc/muttprint/README
|
||||
%%PORTDOCS%%share/doc/muttprint/README.es
|
||||
%%PORTDOCS%%share/doc/muttprint/README.Gnus
|
||||
%%PORTDOCS%%share/doc/muttprint/README.Latex
|
||||
%%PORTDOCS%%share/doc/muttprint/README.translations
|
||||
%%PORTDOCS%%share/doc/muttprint/manual-de/muttprint.html
|
||||
%%PORTDOCS%%share/doc/muttprint/manual-de/x15.html
|
||||
%%PORTDOCS%%share/doc/muttprint/manual-de/x23.html
|
||||
%%PORTDOCS%%share/doc/muttprint/manual-de/x192.html
|
||||
%%PORTDOCS%%share/doc/muttprint/manual-de/x669.html
|
||||
%%PORTDOCS%%share/doc/muttprint/manual-de/x196.html
|
||||
%%PORTDOCS%%share/doc/muttprint/manual-de/x697.html
|
||||
%%PORTDOCS%%share/doc/muttprint/manual-de.pdf
|
||||
%%PORTDOCS%%share/doc/muttprint/manual-en/muttprint.html
|
||||
%%PORTDOCS%%share/doc/muttprint/manual-en/x15.html
|
||||
%%PORTDOCS%%share/doc/muttprint/manual-en/x23.html
|
||||
%%PORTDOCS%%share/doc/muttprint/manual-en/x191.html
|
||||
%%PORTDOCS%%share/doc/muttprint/manual-en/x669.html
|
||||
%%PORTDOCS%%share/doc/muttprint/manual-en/x195.html
|
||||
%%PORTDOCS%%share/doc/muttprint/manual-en/x700.html
|
||||
%%PORTDOCS%%share/doc/muttprint/manual-en.pdf
|
||||
%%PORTDOCS%%share/doc/muttprint/manual-es/muttprint.html
|
||||
%%PORTDOCS%%share/doc/muttprint/manual-es/x15.html
|
||||
%%PORTDOCS%%share/doc/muttprint/manual-es/x23.html
|
||||
%%PORTDOCS%%share/doc/muttprint/manual-es/x189.html
|
||||
%%PORTDOCS%%share/doc/muttprint/manual-es/x620.html
|
||||
%%PORTDOCS%%share/doc/muttprint/manual-es/x191.html
|
||||
%%PORTDOCS%%share/doc/muttprint/manual-es/x650.html
|
||||
%%PORTDOCS%%share/doc/muttprint/manual-es.pdf
|
||||
%%PORTDOCS%%share/doc/muttprint/manual-it/muttprint.html
|
||||
%%PORTDOCS%%share/doc/muttprint/manual-it/x15.html
|
||||
%%PORTDOCS%%share/doc/muttprint/manual-it/x23.html
|
||||
%%PORTDOCS%%share/doc/muttprint/manual-it/x191.html
|
||||
%%PORTDOCS%%share/doc/muttprint/manual-it/x667.html
|
||||
%%PORTDOCS%%share/doc/muttprint/manual-it/x194.html
|
||||
%%PORTDOCS%%share/doc/muttprint/manual-it/x683.html
|
||||
%%PORTDOCS%%share/doc/muttprint/manual-it.pdf
|
||||
%%PORTDOCS%%share/doc/muttprint/sample-muttprintrc-cs
|
||||
%%PORTDOCS%%share/doc/muttprint/manual-sl/muttprint.html
|
||||
%%PORTDOCS%%share/doc/muttprint/manual-sl/x15.html
|
||||
%%PORTDOCS%%share/doc/muttprint/manual-sl/x195.html
|
||||
%%PORTDOCS%%share/doc/muttprint/manual-sl/x23.html
|
||||
%%PORTDOCS%%share/doc/muttprint/manual-sl/x700.html
|
||||
%%PORTDOCS%%share/doc/muttprint/manual-sl.pdf
|
||||
%%PORTDOCS%%share/doc/muttprint/sample-muttprintrc-de
|
||||
%%PORTDOCS%%share/doc/muttprint/sample-muttprintrc-en
|
||||
%%PORTDOCS%%share/doc/muttprint/sample-muttprintrc-es
|
||||
|
@ -38,20 +44,27 @@ bin/muttprint
|
|||
%%PORTDOCS%%share/doc/muttprint/sample-muttprintrc-it
|
||||
%%PORTDOCS%%share/doc/muttprint/sample-muttprintrc-si
|
||||
share/muttprint/BabyTuX.eps
|
||||
share/muttprint/BabyTuX.png
|
||||
share/muttprint/BabyTuX_color.eps
|
||||
share/muttprint/BabyTuX_color.png
|
||||
share/muttprint/Beastie.eps
|
||||
share/muttprint/Debian.eps
|
||||
share/muttprint/Debian.png
|
||||
share/muttprint/Debian_color.eps
|
||||
share/muttprint/Debian_color.png
|
||||
share/muttprint/README.pics
|
||||
share/muttprint/penguin.eps
|
||||
share/muttprint/penguin.jpg
|
||||
share/muttprint/translations/translation-cs.pl
|
||||
share/muttprint/translations/translation-de.pl
|
||||
share/muttprint/translations/translation-es.pl
|
||||
share/muttprint/translations/translation-example.pl
|
||||
share/muttprint/translations/translation-fr.pl
|
||||
share/muttprint/translations/translation-it.pl
|
||||
share/muttprint/translations/translation-pl.pl
|
||||
share/muttprint/translations/translation-ru.pl
|
||||
share/muttprint/translations/translation-sl.pl
|
||||
share/muttprint/translations/translation-sv.pl
|
||||
@dirrm share/muttprint/translations
|
||||
@dirrm share/muttprint
|
||||
%%PORTDOCS%%@dirrm share/doc/muttprint/manual-de
|
||||
%%PORTDOCS%%@dirrm share/doc/muttprint/manual-en
|
||||
%%PORTDOCS%%@dirrm share/doc/muttprint/manual-es
|
||||
%%PORTDOCS%%@dirrm share/doc/muttprint/manual-it
|
||||
%%PORTDOCS%%@dirrm share/doc/muttprint/manual-sl
|
||||
%%PORTDOCS%%@dirrm share/doc/muttprint
|
||||
|
|
Loading…
Reference in a new issue