- Update to version 20031003
PR: 57597 Submitted by: maintainer
This commit is contained in:
parent
415e830ec6
commit
c3998a5c67
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=90318
3 changed files with 14 additions and 49 deletions
|
@ -4,18 +4,18 @@
|
|||
#
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= ekg
|
||||
PORTVERSION= 1.3
|
||||
CATEGORIES= polish net
|
||||
MASTER_SITES= http://dev.null.pl/ekg/
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION}
|
||||
PORTNAME= ekg
|
||||
PORTVERSION= 1.3.20031003
|
||||
CATEGORIES= polish net
|
||||
MASTER_SITES= http://dev.null.pl/ekg/archive/
|
||||
DISTNAME= ${PORTNAME}-20031003
|
||||
|
||||
MAINTAINER= jacek@combit.com.pl
|
||||
COMMENT= Text-mode Gadu-Gadu client
|
||||
MAINTAINER= jacek@combit.com.pl
|
||||
COMMENT= Text-mode Gadu-Gadu client
|
||||
|
||||
USE_GMAKE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GNOME= gnomehack
|
||||
USE_GMAKE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GNOME= gnomehack
|
||||
CONFIGURE_ARGS+= --enable-shared \
|
||||
--disable-static \
|
||||
--enable-dynamic \
|
||||
|
@ -29,5 +29,8 @@ MANCOMPRESSED= no
|
|||
|
||||
post-install:
|
||||
${STRIP_CMD} ${PREFIX}/bin/ekg
|
||||
${RM} ${PREFIX}/lib/libgadu.so ${PREFIX}/lib/libgadu.so.2
|
||||
${MV} ${PREFIX}/lib/libgadu.so.2.13 ${PREFIX}/lib/libgadu.so.2
|
||||
${LN} -s ${PREFIX}/lib/libgadu.so.2 ${PREFIX}/lib/libgadu.so
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (ekg-1.3.tar.gz) = e59cddf8b4daed8b949da86f97f486fc
|
||||
MD5 (ekg-20031003.tar.gz) = 97de9587e97f21f69d75cdde64acc20d
|
||||
|
|
|
@ -1,38 +0,0 @@
|
|||
--- lib/Makefile.in Thu May 15 13:59:09 2003
|
||||
+++ lib/Makefile.in Thu Jul 17 15:33:55 2003
|
||||
@@ -8,7 +8,7 @@
|
||||
# increased with ABI changes
|
||||
VERSION_MAJOR=2
|
||||
# increased with API changes
|
||||
-VERSION_MINOR=13
|
||||
+#VERSION_MINOR=13
|
||||
|
||||
CC = @CC@
|
||||
CFLAGS = @CFLAGS_LIBGADU@ -I. -I.. -Wall
|
||||
@@ -27,7 +27,7 @@
|
||||
|
||||
SHAREDMM = libgadu.so
|
||||
SHAREDM = $(SHAREDMM).$(VERSION_MAJOR)
|
||||
-SHARED = $(SHAREDM).$(VERSION_MINOR)
|
||||
+SHARED = $(SHAREDMM).$(VERSION_MAJOR)
|
||||
STATIC = libgadu.a
|
||||
|
||||
all: @static@ @shared@
|
||||
@@ -57,7 +57,7 @@
|
||||
|
||||
$(SHARED): $(LOBJS)
|
||||
$(CC) -shared -Wl,-soname,libgadu.so.$(VERSION_MAJOR) -o $(SHARED) $(LOBJS) $(LIBS) -lc
|
||||
- $(LN_S) -f $(SHARED) $(SHAREDM)
|
||||
+# $(LN_S) -f $(SHARED) $(SHAREDM)
|
||||
$(LN_S) -f $(SHARED) $(SHAREDMM)
|
||||
|
||||
#
|
||||
@@ -82,7 +82,7 @@
|
||||
|
||||
install-shared: install-common @strip_libgadu_so@
|
||||
$(INSTALL) -m 755 $(SHARED) $(DESTDIR)$(libdir)
|
||||
- cd $(DESTDIR)$(libdir) && $(LN_S) -f $(SHARED) $(SHAREDM)
|
||||
+# cd $(DESTDIR)$(libdir) && $(LN_S) -f $(SHARED) $(SHAREDM)
|
||||
cd $(DESTDIR)$(libdir) && $(LN_S) -f $(SHARED) $(SHAREDMM)
|
||||
|
||||
install-static: install-common
|
Loading…
Reference in a new issue