Add libredblack 1.1.0
Library that provides the red-black balanced tree algorithm
This commit is contained in:
parent
c453eb1186
commit
c3c3d17a5c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=57727
7 changed files with 60 additions and 0 deletions
|
@ -262,6 +262,7 @@
|
|||
SUBDIR += libol
|
||||
SUBDIR += libole2
|
||||
SUBDIR += liboop
|
||||
SUBDIR += libredblack
|
||||
SUBDIR += libshhmsg
|
||||
SUBDIR += libshhopt
|
||||
SUBDIR += libsigc++
|
||||
|
|
22
devel/libredblack/Makefile
Normal file
22
devel/libredblack/Makefile
Normal file
|
@ -0,0 +1,22 @@
|
|||
# New ports collection makefile for: libredblack
|
||||
# Date created: 15 April 2002
|
||||
# Whom: smace@freebsd.org
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= libredblack
|
||||
PORTVERSION= 1.1.0
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
|
||||
MAINTAINER= smace@freebsd.org
|
||||
|
||||
MAN3= rbcloselist.3 rbdelete.3 rbdestroy.3 rbfind.3 rbinit.3 rblookup.3 \
|
||||
rbopenlist.3 rbreadlist.3 rbsearch.3 rbwalk.3
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
.include <bsd.port.mk>
|
1
devel/libredblack/distinfo
Normal file
1
devel/libredblack/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (libredblack-1.1.0.tar.gz) = e9f6c5a598afe99041d476c2c839fea1
|
25
devel/libredblack/files/patch-aa
Normal file
25
devel/libredblack/files/patch-aa
Normal file
|
@ -0,0 +1,25 @@
|
|||
--- ltmain.sh.orig Fri Mar 3 10:50:28 2000
|
||||
+++ ltmain.sh Mon Apr 15 12:52:12 2002
|
||||
@@ -1795,6 +1795,9 @@
|
||||
*-*-cygwin* | *-*-mingw* | *-*-os2* | *-*-beos*)
|
||||
# these systems don't actually have a c library (as such)!
|
||||
;;
|
||||
+ *-*-freebsd*)
|
||||
+ # FreeBSD doesn't need this...
|
||||
+ ;;
|
||||
*)
|
||||
# Add libc to deplibs on all other systems.
|
||||
deplibs="$deplibs -lc"
|
||||
@@ -3348,10 +3351,12 @@
|
||||
fi
|
||||
|
||||
# Install the pseudo-library for information purposes.
|
||||
+ if /usr/bin/false; then
|
||||
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
|
||||
instname="$dir/$name"i
|
||||
$show "$install_prog $instname $destdir/$name"
|
||||
$run eval "$install_prog $instname $destdir/$name" || exit $?
|
||||
+ fi
|
||||
|
||||
# Maybe install the static library, too.
|
||||
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
|
1
devel/libredblack/pkg-comment
Normal file
1
devel/libredblack/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
Library that provides the red-black balanced tree algorithm
|
6
devel/libredblack/pkg-descr
Normal file
6
devel/libredblack/pkg-descr
Normal file
|
@ -0,0 +1,6 @@
|
|||
This a small library that provides the red-black balanced tree algorithm
|
||||
|
||||
|
||||
23 May 2000
|
||||
Damian Ivereigh
|
||||
Cisco Systems Inc
|
4
devel/libredblack/pkg-plist
Normal file
4
devel/libredblack/pkg-plist
Normal file
|
@ -0,0 +1,4 @@
|
|||
lib/libredblack.a
|
||||
lib/libredblack.so
|
||||
lib/libredblack.so.2
|
||||
include/redblack.h
|
Loading…
Reference in a new issue