Initial import of gphoto version 19990511.

A universal digital camera picture control tool.

PR:		11892
Submitted by:	Anders Nordby <anders@fix.no>
This commit is contained in:
Steve Price 1999-06-06 17:22:13 +00:00
parent b1af1b1b5a
commit c3d3315fc1
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=19261
12 changed files with 326 additions and 0 deletions

27
graphics/gphoto/Makefile Normal file
View file

@ -0,0 +1,27 @@
# New ports collection makefile for: gphoto
# Version required: gphoto-19990511
# Date created: 26 May 1999
# Whom: Anders Nordby <anders@fix.no>
#
# $Id$
#
DISTNAME= gphoto-19990511
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.gphoto.org/projects/gphoto/pub/snap/ \
http://www.freenix.no/~anders/
EXTRACT_SUFX= .tgz
MAINTAINER= anders@fix.no
LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
gdk_imlib.4:${PORTSDIR}/graphics/imlib
RUN_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick
USE_GMAKE= yes
MAN1= gphoto.1
ALL_TARGET=
.include <bsd.port.mk>

1
graphics/gphoto/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (gphoto-19990511.tgz) = 3f38ead1d50bb39201ac84d8af8b5028

View file

@ -0,0 +1,61 @@
--- src/callbacks.c.orig Wed May 26 08:12:05 1999
+++ src/callbacks.c Wed May 26 08:15:40 1999
@@ -331,7 +331,9 @@
#ifdef linux
if (strncmp("/dev/ttyS", serial_port, 9) == 0) {
-#elif defined(__FreeBSD__) || defined(__NetBSD__)
+#elif defined(__FreeBSD__)
+ if (strncmp("/dev/ttyd0", serial_port, 9) == 0) {
+#elif defined(__NetBSD__)
if (strncmp("/dev/tty0", serial_port, 9) == 0) {
#else
if (strncmp("/dev/tty0", serial_port, 9) == 0) {
@@ -418,7 +420,10 @@
#ifdef linux
fprintf(conf, "/dev/ttyS0\n");
sprintf(serial_port, "/dev/ttyS0");
-#elif defined(__FreeBSD__) || defined(__NetBSD__)
+#elif defined(__FreeBSD__)
+ fprintf(conf, "/dev/ttyd0\n");
+ sprintf(serial_port, "/dev/ttyd0");
+#elif defined(__NetBSD__)
fprintf(conf, "/dev/tty00\n");
sprintf(serial_port, "/dev/tty00");
#endif
@@ -428,7 +433,10 @@
#ifdef linux
fprintf(conf, "/dev/ttyS1\n");
sprintf(serial_port, "/dev/ttyS1");
-#elif defined(__FreeBSD__) || defined(__NetBSD__)
+#elif defined(__FreeBSD__)
+ fprintf(conf, "/dev/ttyd1\n");
+ sprintf(serial_port, "/dev/ttyd1");
+#elif defined(__NetBSD__)
fprintf(conf, "/dev/tty01\n");
sprintf(serial_port, "/dev/tty01");
#endif
@@ -437,7 +445,10 @@
#ifdef linux
fprintf(conf, "/dev/ttyS2\n");
sprintf(serial_port, "/dev/ttyS2");
-#elif defined(__FreeBSD__) || defined(__NetBSD__)
+#elif defined(__FreeBSD__)
+ fprintf(conf, "/dev/ttyd2\n");
+ sprintf(serial_port, "/dev/ttyd2");
+#elif defined(__NetBSD__)
fprintf(conf, "/dev/tty02\n");
sprintf(serial_port, "/dev/tty02");
#endif
@@ -446,7 +457,10 @@
#ifdef linux
fprintf(conf, "/dev/ttyS3\n");
sprintf(serial_port, "/dev/ttyS3");
-#elif defined(__FreeBSD__) || defined(__NetBSD__)
+#elif defined(__FreeBSD__)
+ fprintf(conf, "/dev/ttyd3\n");
+ sprintf(serial_port, "/dev/ttyd3");
+#elif defined(__NetBSD__)
fprintf(conf, "/dev/tty03\n");
sprintf(serial_port, "/dev/tty03");
#endif

View file

@ -0,0 +1 @@
A universal digital camera picture control tool.

14
graphics/gphoto/pkg-descr Normal file
View file

@ -0,0 +1,14 @@
gPhoto is an universal, free GTK+ application that will allow
downloading, saving, and manipulation of images from several
different digital camera models, or from the local harddrive.
gPhoto has a basic command line interface, which is handy,
if you want to set up a web camera, and use gphoto in a
script, e.g. with Perl/PHP.
gPhoto sports a new HTML engine, that let's you create your
gallery "themes" (HTML with special tags), and publish images
to the web. A directory browse mode has also been implemented.
gPhoto supports a wide array of digital camera models. Visit
http://www.gphoto.org/cameras.php3 for an updated list.

59
graphics/gphoto/pkg-plist Normal file
View file

@ -0,0 +1,59 @@
bin/gphoto
doc/gphoto-0.3/AUTHORS
doc/gphoto-0.3/CREDITS
doc/gphoto-0.3/FAQ
doc/gphoto-0.3/MANUAL
doc/gphoto-0.3/NEWS
doc/gphoto-0.3/README
share/gphoto/drivers/libgphoto_casio_qv.so
share/gphoto/drivers/libgphoto_dir.so
share/gphoto/drivers/libgphoto_fuji.so
share/gphoto/drivers/libgphoto_kodak_dc2x.so
share/gphoto/drivers/libgphoto_konica_qm100.so
share/gphoto/drivers/libgphoto_philips.so
share/gphoto/drivers/libgphoto_photopc.so
share/gphoto/drivers/libgphoto_ricoh300z.so
share/gphoto/drivers/libgphoto_sony_dscf1.so
share/gphoto/gphoto/CSStheme/CVS/Entries
share/gphoto/gphoto/CSStheme/CVS/Repository
share/gphoto/gphoto/CSStheme/CVS/Root
share/gphoto/gphoto/CSStheme/index_bottom.html
share/gphoto/gphoto/CSStheme/index_top.html
share/gphoto/gphoto/CSStheme/mwcos
share/gphoto/gphoto/CSStheme/picture.html
share/gphoto/gphoto/CSStheme/styles.css
share/gphoto/gphoto/CSStheme/thumbnail.html
share/gphoto/gphoto/CSStheme/vh40.gif
share/gphoto/gphoto/Default/CVS/Entries
share/gphoto/gphoto/Default/CVS/Repository
share/gphoto/gphoto/Default/CVS/Root
share/gphoto/gphoto/Default/banner.gif
share/gphoto/gphoto/Default/index.gif
share/gphoto/gphoto/Default/index_bottom.html
share/gphoto/gphoto/Default/index_top.html
share/gphoto/gphoto/Default/next.gif
share/gphoto/gphoto/Default/picture.html
share/gphoto/gphoto/Default/previous.gif
share/gphoto/gphoto/Default/thumbnail.html
share/gphoto/gphoto/RedNGray/CVS/Entries
share/gphoto/gphoto/RedNGray/CVS/Repository
share/gphoto/gphoto/RedNGray/CVS/Root
share/gphoto/gphoto/RedNGray/backgrnd.gif
share/gphoto/gphoto/RedNGray/banner.gif
share/gphoto/gphoto/RedNGray/index.gif
share/gphoto/gphoto/RedNGray/index_bottom.html
share/gphoto/gphoto/RedNGray/index_top.html
share/gphoto/gphoto/RedNGray/next.gif
share/gphoto/gphoto/RedNGray/picture.html
share/gphoto/gphoto/RedNGray/previous.gif
share/gphoto/gphoto/RedNGray/thumbnail.html
@dirrm doc/gphoto-0.3
@dirrm share/gphoto/drivers
@dirrm share/gphoto/gphoto/CSStheme/CVS
@dirrm share/gphoto/gphoto/CSStheme
@dirrm share/gphoto/gphoto/Default/CVS
@dirrm share/gphoto/gphoto/Default
@dirrm share/gphoto/gphoto/RedNGray/CVS
@dirrm share/gphoto/gphoto/RedNGray
@dirrm share/gphoto/gphoto
@dirrm share/gphoto

27
graphics/gphoto2/Makefile Normal file
View file

@ -0,0 +1,27 @@
# New ports collection makefile for: gphoto
# Version required: gphoto-19990511
# Date created: 26 May 1999
# Whom: Anders Nordby <anders@fix.no>
#
# $Id$
#
DISTNAME= gphoto-19990511
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.gphoto.org/projects/gphoto/pub/snap/ \
http://www.freenix.no/~anders/
EXTRACT_SUFX= .tgz
MAINTAINER= anders@fix.no
LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
gdk_imlib.4:${PORTSDIR}/graphics/imlib
RUN_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick
USE_GMAKE= yes
MAN1= gphoto.1
ALL_TARGET=
.include <bsd.port.mk>

View file

@ -0,0 +1 @@
MD5 (gphoto-19990511.tgz) = 3f38ead1d50bb39201ac84d8af8b5028

View file

@ -0,0 +1,61 @@
--- src/callbacks.c.orig Wed May 26 08:12:05 1999
+++ src/callbacks.c Wed May 26 08:15:40 1999
@@ -331,7 +331,9 @@
#ifdef linux
if (strncmp("/dev/ttyS", serial_port, 9) == 0) {
-#elif defined(__FreeBSD__) || defined(__NetBSD__)
+#elif defined(__FreeBSD__)
+ if (strncmp("/dev/ttyd0", serial_port, 9) == 0) {
+#elif defined(__NetBSD__)
if (strncmp("/dev/tty0", serial_port, 9) == 0) {
#else
if (strncmp("/dev/tty0", serial_port, 9) == 0) {
@@ -418,7 +420,10 @@
#ifdef linux
fprintf(conf, "/dev/ttyS0\n");
sprintf(serial_port, "/dev/ttyS0");
-#elif defined(__FreeBSD__) || defined(__NetBSD__)
+#elif defined(__FreeBSD__)
+ fprintf(conf, "/dev/ttyd0\n");
+ sprintf(serial_port, "/dev/ttyd0");
+#elif defined(__NetBSD__)
fprintf(conf, "/dev/tty00\n");
sprintf(serial_port, "/dev/tty00");
#endif
@@ -428,7 +433,10 @@
#ifdef linux
fprintf(conf, "/dev/ttyS1\n");
sprintf(serial_port, "/dev/ttyS1");
-#elif defined(__FreeBSD__) || defined(__NetBSD__)
+#elif defined(__FreeBSD__)
+ fprintf(conf, "/dev/ttyd1\n");
+ sprintf(serial_port, "/dev/ttyd1");
+#elif defined(__NetBSD__)
fprintf(conf, "/dev/tty01\n");
sprintf(serial_port, "/dev/tty01");
#endif
@@ -437,7 +445,10 @@
#ifdef linux
fprintf(conf, "/dev/ttyS2\n");
sprintf(serial_port, "/dev/ttyS2");
-#elif defined(__FreeBSD__) || defined(__NetBSD__)
+#elif defined(__FreeBSD__)
+ fprintf(conf, "/dev/ttyd2\n");
+ sprintf(serial_port, "/dev/ttyd2");
+#elif defined(__NetBSD__)
fprintf(conf, "/dev/tty02\n");
sprintf(serial_port, "/dev/tty02");
#endif
@@ -446,7 +457,10 @@
#ifdef linux
fprintf(conf, "/dev/ttyS3\n");
sprintf(serial_port, "/dev/ttyS3");
-#elif defined(__FreeBSD__) || defined(__NetBSD__)
+#elif defined(__FreeBSD__)
+ fprintf(conf, "/dev/ttyd3\n");
+ sprintf(serial_port, "/dev/ttyd3");
+#elif defined(__NetBSD__)
fprintf(conf, "/dev/tty03\n");
sprintf(serial_port, "/dev/tty03");
#endif

View file

@ -0,0 +1 @@
A universal digital camera picture control tool.

View file

@ -0,0 +1,14 @@
gPhoto is an universal, free GTK+ application that will allow
downloading, saving, and manipulation of images from several
different digital camera models, or from the local harddrive.
gPhoto has a basic command line interface, which is handy,
if you want to set up a web camera, and use gphoto in a
script, e.g. with Perl/PHP.
gPhoto sports a new HTML engine, that let's you create your
gallery "themes" (HTML with special tags), and publish images
to the web. A directory browse mode has also been implemented.
gPhoto supports a wide array of digital camera models. Visit
http://www.gphoto.org/cameras.php3 for an updated list.

View file

@ -0,0 +1,59 @@
bin/gphoto
doc/gphoto-0.3/AUTHORS
doc/gphoto-0.3/CREDITS
doc/gphoto-0.3/FAQ
doc/gphoto-0.3/MANUAL
doc/gphoto-0.3/NEWS
doc/gphoto-0.3/README
share/gphoto/drivers/libgphoto_casio_qv.so
share/gphoto/drivers/libgphoto_dir.so
share/gphoto/drivers/libgphoto_fuji.so
share/gphoto/drivers/libgphoto_kodak_dc2x.so
share/gphoto/drivers/libgphoto_konica_qm100.so
share/gphoto/drivers/libgphoto_philips.so
share/gphoto/drivers/libgphoto_photopc.so
share/gphoto/drivers/libgphoto_ricoh300z.so
share/gphoto/drivers/libgphoto_sony_dscf1.so
share/gphoto/gphoto/CSStheme/CVS/Entries
share/gphoto/gphoto/CSStheme/CVS/Repository
share/gphoto/gphoto/CSStheme/CVS/Root
share/gphoto/gphoto/CSStheme/index_bottom.html
share/gphoto/gphoto/CSStheme/index_top.html
share/gphoto/gphoto/CSStheme/mwcos
share/gphoto/gphoto/CSStheme/picture.html
share/gphoto/gphoto/CSStheme/styles.css
share/gphoto/gphoto/CSStheme/thumbnail.html
share/gphoto/gphoto/CSStheme/vh40.gif
share/gphoto/gphoto/Default/CVS/Entries
share/gphoto/gphoto/Default/CVS/Repository
share/gphoto/gphoto/Default/CVS/Root
share/gphoto/gphoto/Default/banner.gif
share/gphoto/gphoto/Default/index.gif
share/gphoto/gphoto/Default/index_bottom.html
share/gphoto/gphoto/Default/index_top.html
share/gphoto/gphoto/Default/next.gif
share/gphoto/gphoto/Default/picture.html
share/gphoto/gphoto/Default/previous.gif
share/gphoto/gphoto/Default/thumbnail.html
share/gphoto/gphoto/RedNGray/CVS/Entries
share/gphoto/gphoto/RedNGray/CVS/Repository
share/gphoto/gphoto/RedNGray/CVS/Root
share/gphoto/gphoto/RedNGray/backgrnd.gif
share/gphoto/gphoto/RedNGray/banner.gif
share/gphoto/gphoto/RedNGray/index.gif
share/gphoto/gphoto/RedNGray/index_bottom.html
share/gphoto/gphoto/RedNGray/index_top.html
share/gphoto/gphoto/RedNGray/next.gif
share/gphoto/gphoto/RedNGray/picture.html
share/gphoto/gphoto/RedNGray/previous.gif
share/gphoto/gphoto/RedNGray/thumbnail.html
@dirrm doc/gphoto-0.3
@dirrm share/gphoto/drivers
@dirrm share/gphoto/gphoto/CSStheme/CVS
@dirrm share/gphoto/gphoto/CSStheme
@dirrm share/gphoto/gphoto/Default/CVS
@dirrm share/gphoto/gphoto/Default
@dirrm share/gphoto/gphoto/RedNGray/CVS
@dirrm share/gphoto/gphoto/RedNGray
@dirrm share/gphoto/gphoto
@dirrm share/gphoto