- Remove multimedia/flv2mpeg4 since it is abandoned upstream and has a buffer overflows

PR:		ports/153393
Submitted by:	Alex Kozlov <spam@rm-rf.kiev.ua> (maintainer)
This commit is contained in:
Wen Heping 2010-12-24 03:12:56 +00:00
parent 545ddd5702
commit c3eeaa0100
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=266826
6 changed files with 0 additions and 74 deletions

View file

@ -61,7 +61,6 @@
SUBDIR += ffmpeg-devel
SUBDIR += ffmpeg2theora
SUBDIR += ffmpegthumbnailer
SUBDIR += flv2mpeg4
SUBDIR += flvmeta
SUBDIR += flvstreamer
SUBDIR += flvtool++

View file

@ -1,43 +0,0 @@
# New ports collection makefile for: flv2mpeg4
# Date created: 22 August 2007
# Whom: spam@rm-rf.kiev.ua
#
# $FreeBSD$
#
PORTNAME= flv2mpeg4
DISTVERSION= 20061129
PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= http://src4.narod.ru/
MAINTAINER= spam@rm-rf.kiev.ua
COMMENT= Fast and less lossy FLV to MPEG4(AVI/MOV/MP4/MP3/3GP) converter
LIB_DEPENDS= avformat:${PORTSDIR}/multimedia/ffmpeg
USE_BZIP2= yes
MAKEFILE= ${FILESDIR}/Makefile.bsd
PLIST_FILES= bin/flv2mpeg4
WRKSRC= ${WRKDIR}/${PORTNAME}/src
SVNROOT= https://vixynet.svn.sourceforge.net/svnroot/vixynet
gen-dist:
@if [ ! -f ${LOCALBASE}/bin/svn ]; then \
${ECHO_CMD} "ERROR: You need to install devel/subversion for gen-dist target"; \
${FALSE}; \
fi
@if [ ! -f ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} ]; then \
${MKDIR} ${WRKDIR}/svn; \
cd ${WRKDIR}/svn && svn co ${SVNROOT} vixynet; \
cd ${WRKDIR}/svn/vixynet/trunk && \
${TAR} cfj ${_DISTDIR}${DISTFILES} flv2mpeg4; \
cd ${WRKDIR} && ${RM} -rf svn; \
cd ${.CURDIR} && ${MAKE} ${__softMAKEFLAGS} makesum; \
fi
.include <bsd.port.mk>

View file

@ -1,3 +0,0 @@
MD5 (flv2mpeg4-20061129.tar.bz2) = f757e1b0b2aa17db9551df32df39b1d9
SHA256 (flv2mpeg4-20061129.tar.bz2) = 84dee9767969b5166f1f72dc7e48370d621b048eb6f99250a4334354e16d1303
SIZE (flv2mpeg4-20061129.tar.bz2) = 154190

View file

@ -1,13 +0,0 @@
PREFIX?= /usr/local
BINDIR?= $(PREFIX)/bin
SRCS= avformat_writer.c dcprediction.c flv2mpeg4.c fetch.c flvdecoder.c\
m4vencode.c mp3header.c
LDADD+= -lpthread -lavformat -lavcodec -lavutil
CFLAGS+= -O2
CFLAGS+= -I/usr/local/include
LDADD+= -L/usr/local/lib
PROG= flv2mpeg4
NO_MAN= yes
.include <bsd.prog.mk>

View file

@ -1,10 +0,0 @@
Index: avformat_writer.h
@@ -28,7 +28,7 @@
#include <memory.h>
#include "type.h"
-#include "avformat.h" // libavformat is part of ffmpeg(http://ffmpeg.sf.net)
+#include "libavformat/avformat.h" // libavformat is part of ffmpeg(http://ffmpeg.sf.net)
#include "mp3header.h"
typedef struct _AVFWRITER

View file

@ -1,4 +0,0 @@
flv2mpeg4 allows you convert a Flash Video / FLV file (YouTube's videos,etc)
to MPEG4 (AVI/MOV/MP4/MP3/3GP) file online. It is using a compressed domain
transcoder technology (outline in Japanese). It converts FLV to MPEG4 faster
and less lossy than a typical transcoder.