Add poseidon 2.2.1, a popular UML CASE tool.

PR:		65303
Submitted by:	gerrit@beine-computer.de
Approved by:	pav (mentor).
This commit is contained in:
Thierry Thomas 2004-04-09 17:43:25 +00:00
parent 5b5c8879e6
commit c3ef36353e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=106586
6 changed files with 1613 additions and 0 deletions

View file

@ -109,6 +109,7 @@
SUBDIR += phpeclipse_phphelp
SUBDIR += phpeclipse_sql
SUBDIR += phpeclipse_tidy
SUBDIR += poseidon
SUBDIR += proguard
SUBDIR += sablevm
SUBDIR += shujit

55
java/poseidon/Makefile Normal file
View file

@ -0,0 +1,55 @@
# Ports collection makefile for: Poseidon
# Date created: February 28, 2004
# Whom: gerrit@beine-computer.de
#
# $FreeBSD$
#
PORTNAME= poseidonCE
PORTVERSION= 2.2.1
CATEGORIES= java
MASTER_SITES= # http://www.gentleware.com/products/download.php4
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} # Required to print the message
MAINTAINER= ports@freebsd.org
COMMENT= A popular UML CASE tool
USE_ZIP= yes
USE_JAVA= 1.4+
USE_REINPLACE= yes
NO_BUILD= yes
NO_PACKAGE= "Redistribution is not permitted"
NO_CDROM= ${NO_PACKAGE}
RESTRICTED= ${NO_PACKAGE}
.include <bsd.port.pre.mk>
.if !exists(${DISTDIR}/${DISTFILES})
ECHO_MSG=/usr/bin/printf
IGNORE= :\n\
Because of licensing restrictions, you must fetch the source distribution\n\
manually. Please access http://www.gentleware.com/products/download.php4\n\
with a web browser and load the \"ZIP for any Platform\" of the\n\
Community Edition.\n\
After download the file, place it into ${DISTDIR}.\n
.endif
post-patch:
@${REINPLACE_CMD} -e "s,%%JAVA_HOME%%,${JAVA_HOME}," ${WRKSRC}/bin/poseidon.sh
do-install:
@${MKDIR} ${DATADIR}/bin
@${MKDIR} ${DATADIR}/lib
${INSTALL_SCRIPT} ${WRKSRC}/bin/poseidon.sh ${DATADIR}/bin
${INSTALL_DATA} ${WRKSRC}/lib/*.jar ${DATADIR}/lib
${INSTALL_DATA} ${WRKSRC}/LICENSE.txt ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/license-keys.txt ${DATADIR}
.if !defined(NOPORTDOCS)
${CP} -r ${WRKSRC}/docs ${DATADIR}
${CP} -r ${WRKSRC}/examples ${DATADIR}
.endif
post-install:
${LN} -s ${DATADIR}/bin/poseidon.sh ${LOCALBASE}/bin/poseidon
.include <bsd.port.post.mk>

2
java/poseidon/distinfo Normal file
View file

@ -0,0 +1,2 @@
MD5 (poseidonCE-2.2.1.zip) = 9887813fffefc338704755ba22665f8e
SIZE (poseidonCE-2.2.1.zip) = 25756825

View file

@ -0,0 +1,30 @@
--- bin/poseidon.sh.orig Wed Mar 10 12:58:56 2004
+++ bin/poseidon.sh Fri Apr 9 00:12:53 2004
@@ -1,4 +1,7 @@
-#!/bin/bash
+#!/bin/sh
+
+JAVA_HOME=%%JAVA_HOME%%
+POSEIDONCE_HOME=$HOME/.poseidonCE
RealPath() {
cmd=`basename $0`
@@ -10,9 +13,9 @@
cd `dirname $link`
done
-
+
echo `pwd -P`/$cmd
-}
+}
if [ -z "$JAVA_HOME" ] ; then
echo "Could not find a JDK."
@@ -38,5 +41,5 @@
export CLASSPATH
-"$JAVACMD" -Xms64m -Xmx160m -Dposeidon.java.home="$JAVA_HOME" -Dposeidon.user.dir.PE="$POSEIDONPE_HOME" com.gentleware.poseidon.Poseidon $project
+"$JAVACMD" -Xms64m -Xmx160m -Dposeidon.java.home="$JAVA_HOME" -Dposeidon.user.dir.CE="$POSEIDONCE_HOME" com.gentleware.poseidon.Poseidon $project

12
java/poseidon/pkg-descr Normal file
View file

@ -0,0 +1,12 @@
Poseidon for UML is a professional UML CASE tool. With roots in the open source
project ArgoUML, it has evolved into a world-class modeling tool. Its superior
usability makes it the easiest tool to learn and work with.
With UML standards compliancy, it facilitates interoperability with other sets
of tools while maintaining investment security at an outstanding price-
performance ratio.
It is available in different editions to meet the needs of a wide range of
users.
WWW: http://www.gentleware.com/

1513
java/poseidon/pkg-plist Normal file

File diff suppressed because it is too large Load diff