Add ViewCVS, a Python version of Zeller's cvsweb. Cool!!

This commit is contained in:
Will Andrews 2000-07-03 00:34:20 +00:00
parent 7acea3ead6
commit c45597ab56
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=30092
15 changed files with 199 additions and 0 deletions

View file

@ -248,6 +248,7 @@
SUBDIR += tvision
SUBDIR += uclmmbase
SUBDIR += ups-debug
SUBDIR += viewcvs
SUBDIR += vtcl
SUBDIR += xmake
SUBDIR += xwpe

31
devel/viewcvs/Makefile Normal file
View file

@ -0,0 +1,31 @@
# New ports collection makefile for: groach
# Date created: Sun 02 Jul 2000
# Whom: will
#
# $FreeBSD$
#
PORTNAME= viewcvs
PORTVERSION= 0.5
CATEGORIES= devel python
MASTER_SITES= http://www.lyra.org/viewcvs/
MAINTAINER= ports@FreeBSD.org
BUILD_DEPENDS= python:${PORTSDIR}/lang/python
RUN_DEPENDS= python:${PORTSDIR}/lang/python
NO_BUILD= yes
pre-install:
${PERL} -pi -e "s:/usr/local/viewcvs:${PREFIX}/share/viewcvs:g" ${WRKSRC}/viewcvs-install
do-install:
(cd ${WRKSRC} && ${LOCALBASE}/bin/python ${WRKSRC}/viewcvs-install)
post-install:
@${ECHO}
@${CAT} ${PKGMESSAGE} | ${SED} -e "s:%%PREFIX%%:${PREFIX}:g"
@${ECHO}
.include <bsd.port.mk>

1
devel/viewcvs/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (viewcvs-0.5.tar.gz) = 19079897437148967c80f78763b20217

View file

@ -0,0 +1,17 @@
--- viewcvs-install Fri May 12 06:26:11 2000
+++ viewcvs-install.new Sun Jul 2 19:59:28 2000
@@ -159,10 +159,10 @@
print INFO_TEXT
## get the install path
- temp = raw_input("Installation Path [%s]: " % ROOT_DIR)
- temp = string.strip(temp)
- if len(temp):
- ROOT_DIR = temp
+ #temp = raw_input("Installation Path [%s]: " % ROOT_DIR)
+ #temp = string.strip(temp)
+ #if len(temp):
+ # ROOT_DIR = temp
## install the files
print

View file

@ -0,0 +1 @@
Python version of Zeller's cvsweb

11
devel/viewcvs/pkg-descr Normal file
View file

@ -0,0 +1,11 @@
ViewCVS was inspired by cvsweb (Zeller's version). ViewCVS
can browse directories, change logs, and specific revisions
of files. It can display diffs between versions and show
selections of files based on tags or branches. In addition,
ViewCVS has "annotation" or "blame" support, and the
beginnings of Bonsai-like query facilities.
WWW: http://www.lyra.org/viewcvs/
Author: Greg Stein <gstein@lyra.org>
- Will <andrews@technologist.com>

View file

@ -0,0 +1,5 @@
If you would like to set up ViewCVS in a usable manner, all
you need to do is modify the configuration file, located at
%%PREFIX%%/share/viewcvs/viewcvs.conf, to note where your
CVSROOT is, and then copy the actual CGI (located at
%%PREFIX%%/share/viewcvs/cgi/viewcvs.cgi) to your cgi-bin.

33
devel/viewcvs/pkg-plist Normal file
View file

@ -0,0 +1,33 @@
share/viewcvs/cgi/viewcvs.cgi
share/viewcvs/cgi/queryform.cgi
share/viewcvs/cgi/query.cgi
share/viewcvs/viewcvs.conf
share/viewcvs/lib/PyFontify.py
share/viewcvs/lib/PyFontify.pyc
share/viewcvs/lib/blame.py
share/viewcvs/lib/blame.pyc
share/viewcvs/lib/commit.py
share/viewcvs/lib/commit.pyc
share/viewcvs/lib/compat.py
share/viewcvs/lib/compat.pyc
share/viewcvs/lib/config.py
share/viewcvs/lib/config.pyc
share/viewcvs/lib/cvsdbapi.py
share/viewcvs/lib/cvsdbapi.pyc
share/viewcvs/lib/database.py
share/viewcvs/lib/database.pyc
share/viewcvs/lib/popen.py
share/viewcvs/lib/popen.pyc
share/viewcvs/lib/py2html.py
share/viewcvs/lib/py2html.pyc
share/viewcvs/lib/rlog.py
share/viewcvs/lib/rlog.pyc
share/viewcvs/loginfo-handler
share/viewcvs/cvsdbadmin
share/viewcvs/make-database
share/viewcvs/html-templates/queryformtemplate.html
share/viewcvs/html-templates/querytemplate.html
@dirrm share/viewcvs/html-templates
@dirrm share/viewcvs/lib
@dirrm share/viewcvs/cgi
@dirrm share/viewcvs

31
devel/viewvc/Makefile Normal file
View file

@ -0,0 +1,31 @@
# New ports collection makefile for: groach
# Date created: Sun 02 Jul 2000
# Whom: will
#
# $FreeBSD$
#
PORTNAME= viewcvs
PORTVERSION= 0.5
CATEGORIES= devel python
MASTER_SITES= http://www.lyra.org/viewcvs/
MAINTAINER= ports@FreeBSD.org
BUILD_DEPENDS= python:${PORTSDIR}/lang/python
RUN_DEPENDS= python:${PORTSDIR}/lang/python
NO_BUILD= yes
pre-install:
${PERL} -pi -e "s:/usr/local/viewcvs:${PREFIX}/share/viewcvs:g" ${WRKSRC}/viewcvs-install
do-install:
(cd ${WRKSRC} && ${LOCALBASE}/bin/python ${WRKSRC}/viewcvs-install)
post-install:
@${ECHO}
@${CAT} ${PKGMESSAGE} | ${SED} -e "s:%%PREFIX%%:${PREFIX}:g"
@${ECHO}
.include <bsd.port.mk>

1
devel/viewvc/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (viewcvs-0.5.tar.gz) = 19079897437148967c80f78763b20217

View file

@ -0,0 +1,17 @@
--- viewcvs-install Fri May 12 06:26:11 2000
+++ viewcvs-install.new Sun Jul 2 19:59:28 2000
@@ -159,10 +159,10 @@
print INFO_TEXT
## get the install path
- temp = raw_input("Installation Path [%s]: " % ROOT_DIR)
- temp = string.strip(temp)
- if len(temp):
- ROOT_DIR = temp
+ #temp = raw_input("Installation Path [%s]: " % ROOT_DIR)
+ #temp = string.strip(temp)
+ #if len(temp):
+ # ROOT_DIR = temp
## install the files
print

1
devel/viewvc/pkg-comment Normal file
View file

@ -0,0 +1 @@
Python version of Zeller's cvsweb

11
devel/viewvc/pkg-descr Normal file
View file

@ -0,0 +1,11 @@
ViewCVS was inspired by cvsweb (Zeller's version). ViewCVS
can browse directories, change logs, and specific revisions
of files. It can display diffs between versions and show
selections of files based on tags or branches. In addition,
ViewCVS has "annotation" or "blame" support, and the
beginnings of Bonsai-like query facilities.
WWW: http://www.lyra.org/viewcvs/
Author: Greg Stein <gstein@lyra.org>
- Will <andrews@technologist.com>

5
devel/viewvc/pkg-message Normal file
View file

@ -0,0 +1,5 @@
If you would like to set up ViewCVS in a usable manner, all
you need to do is modify the configuration file, located at
%%PREFIX%%/share/viewcvs/viewcvs.conf, to note where your
CVSROOT is, and then copy the actual CGI (located at
%%PREFIX%%/share/viewcvs/cgi/viewcvs.cgi) to your cgi-bin.

33
devel/viewvc/pkg-plist Normal file
View file

@ -0,0 +1,33 @@
share/viewcvs/cgi/viewcvs.cgi
share/viewcvs/cgi/queryform.cgi
share/viewcvs/cgi/query.cgi
share/viewcvs/viewcvs.conf
share/viewcvs/lib/PyFontify.py
share/viewcvs/lib/PyFontify.pyc
share/viewcvs/lib/blame.py
share/viewcvs/lib/blame.pyc
share/viewcvs/lib/commit.py
share/viewcvs/lib/commit.pyc
share/viewcvs/lib/compat.py
share/viewcvs/lib/compat.pyc
share/viewcvs/lib/config.py
share/viewcvs/lib/config.pyc
share/viewcvs/lib/cvsdbapi.py
share/viewcvs/lib/cvsdbapi.pyc
share/viewcvs/lib/database.py
share/viewcvs/lib/database.pyc
share/viewcvs/lib/popen.py
share/viewcvs/lib/popen.pyc
share/viewcvs/lib/py2html.py
share/viewcvs/lib/py2html.pyc
share/viewcvs/lib/rlog.py
share/viewcvs/lib/rlog.pyc
share/viewcvs/loginfo-handler
share/viewcvs/cvsdbadmin
share/viewcvs/make-database
share/viewcvs/html-templates/queryformtemplate.html
share/viewcvs/html-templates/querytemplate.html
@dirrm share/viewcvs/html-templates
@dirrm share/viewcvs/lib
@dirrm share/viewcvs/cgi
@dirrm share/viewcvs