devel/got: update to 0.54

User-visible changes:
- fix bugs where files skipped by 'got update' could not be updated again
- new 'gotadmin cleanup' command for removing unreferenced loose objects
- handle pack index files which lack a corresponding pack file
- make 'got add' always require the -I option in order to add ignored files
This commit is contained in:
Christian Weisgerber 2021-07-08 22:52:44 +02:00
parent 8577317159
commit c468a96d2f
5 changed files with 8 additions and 54 deletions

View file

@ -1,5 +1,5 @@
PORTNAME= got
PORTVERSION= 0.53
PORTVERSION= 0.54
CATEGORIES= devel
MASTER_SITES= https://gameoftrees.org/releases/

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1624457436
SHA256 (got-0.53.tar.gz) = 2401652e959457ddba67eef93a31b3dd6efea89198a3c02eebc964edb03961f3
SIZE (got-0.53.tar.gz) = 519143
TIMESTAMP = 1625775299
SHA256 (got-0.54.tar.gz) = c05585240d7ab8f3bbd30649bcb5595e3814e209c6141910344cdf464d06671b
SIZE (got-0.54.tar.gz) = 526945

View file

@ -11,42 +11,6 @@
*/
#define __dead __dead2
/*
* <sys/queue.h>
*/
#define SIMPLEQ_HEAD(name, type) \
STAILQ_HEAD(name, type)
#define SIMPLEQ_HEAD_INITIALIZER(head) \
STAILQ_HEAD_INITIALIZER(head)
#define SIMPLEQ_ENTRY(type) \
STAILQ_ENTRY(type)
#define SIMPLEQ_FIRST(head) \
STAILQ_FIRST(head)
#define SIMPLEQ_END(head) \
NULL
#define SIMPLEQ_EMPTY(head) \
STAILQ_EMPTY(head)
#define SIMPLEQ_NEXT(elm, field) \
STAILQ_NEXT(elm, field)
#define SIMPLEQ_FOREACH(var, head, field) \
STAILQ_FOREACH(var, head, field)
#define SIMPLEQ_FOREACH_SAFE(var, head, field, tvar) \
STAILQ_FOREACH_SAFE(var, head, field, tvar)
#define SIMPLEQ_INIT(head) \
STAILQ_INIT(head)
#define SIMPLEQ_INSERT_HEAD(head, elm, field) \
STAILQ_INSERT_HEAD(head, elm, field)
#define SIMPLEQ_INSERT_TAIL(head, elm, field) \
STAILQ_INSERT_TAIL(head, elm, field)
#define SIMPLEQ_INSERT_AFTER(head, listelm, elm, field) \
STAILQ_INSERT_AFTER(head, listelm, elm, field)
#define SIMPLEQ_REMOVE_HEAD(head, field) \
STAILQ_REMOVE_HEAD(head, field)
#define SIMPLEQ_REMOVE_AFTER(head, elm, field) \
STAILQ_REMOVE_AFTER(head, elm, field)
#define SIMPLEQ_CONCAT(head1, head2) \
STAILQ_CONCAT(head1, head2)
/*
* <fcntl.h>
*/

View file

@ -1,10 +0,0 @@
--- lib/repository_admin.c.orig 2021-06-23 15:24:57 UTC
+++ lib/repository_admin.c
@@ -22,6 +22,7 @@
#include <sys/wait.h>
#include <dirent.h>
+#include <endian.h>
#include <errno.h>
#include <fcntl.h>
#include <stdint.h>

View file

@ -1,8 +1,8 @@
--- regress/cmdline/Makefile.orig 2021-06-22 19:37:49 UTC
--- regress/cmdline/Makefile.orig 2021-07-03 20:38:45 UTC
+++ regress/cmdline/Makefile
@@ -83,4 +83,6 @@ tree:
pack:
./pack.sh -q -r "$(GOT_TEST_ROOT)"
@@ -87,4 +87,6 @@ cleanup:
./cleanup.sh -q -r "$(GOT_TEST_ROOT)"
-.include <bsd.regress.mk>
+regress: ${REGRESS_TARGETS} .PHONY .SILENT