net/unison251: Try to fix build failure due to race condition in Makefile
PR: 263067 MFH: 2022Q2
This commit is contained in:
parent
0524bb607c
commit
c46c155b02
1 changed files with 15 additions and 4 deletions
|
@ -1,6 +1,6 @@
|
|||
--- Makefile.OCaml.orig 2021-06-23 14:30:30 UTC
|
||||
--- Makefile.OCaml.orig 2021-12-18 15:04:56 UTC
|
||||
+++ Makefile.OCaml
|
||||
@@ -34,7 +34,11 @@ ifeq ($(shell uname),OpenBSD)
|
||||
@@ -34,7 +34,11 @@ ifeq ($(shell uname),NetBSD)
|
||||
else
|
||||
ifeq ($(shell uname),NetBSD)
|
||||
OSARCH=NetBSD
|
||||
|
@ -12,7 +12,7 @@
|
|||
ifeq ($(shell uname),Linux)
|
||||
OSARCH=Linux
|
||||
endif
|
||||
@@ -290,6 +294,11 @@ ifeq ($(OSARCH),Linux)
|
||||
@@ -301,6 +305,11 @@ endif
|
||||
INCLFLAGS+=-I fsmonitor -I fsmonitor/linux
|
||||
endif
|
||||
|
||||
|
@ -24,7 +24,18 @@
|
|||
ifeq ($(OSARCH),solaris)
|
||||
-include fsmonitor/solaris/Makefile src/fsmonitor/solaris/Makefile
|
||||
INCLFLAGS+=-I fsmonitor -I fsmonitor/solaris
|
||||
@@ -432,7 +441,7 @@ fswatch.cmi : ubase/prefs.cmi
|
||||
@@ -427,6 +436,10 @@ win32rc/unison.res.lib: win32rc/unison.res
|
||||
-$(RM) $@
|
||||
ocamllex $<
|
||||
|
||||
+compat%.cmi: compat%.mli
|
||||
+ @echo "$(CAMLC): $< ---> $@"
|
||||
+ $(CAMLC) $(CAMLFLAGS) $(COMPATCAMLFLAGS) -c $(CWD)/$<
|
||||
+
|
||||
%.cmi : %.mli
|
||||
@echo "$(CAMLC): $< ---> $@"
|
||||
$(CAMLC) $(CAMLFLAGS) $(COMPATCAMLFLAGS) -c $(CWD)/$<
|
||||
@@ -451,7 +464,7 @@ compat%.cmx: compat%.ml
|
||||
|
||||
%.o %.obj: %.c
|
||||
@echo "$(CAMLC): $< ---> $@"
|
||||
|
|
Loading…
Reference in a new issue