* security/libtomcrypt
- Update to 1.12 * math/libtommath - Update to 0.39 * math/tomsfastmath - Update to 0.09 PR: ports/98214 Submitted by: maintainer
This commit is contained in:
parent
060d89d7fb
commit
c48fc1ace2
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=164097
7 changed files with 37 additions and 30 deletions
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= libtommath
|
||||
PORTVERSION= 0.38
|
||||
PORTVERSION= 0.39
|
||||
CATEGORIES= math
|
||||
MASTER_SITES= http://math.libtomcrypt.com/files/
|
||||
DISTNAME= ltm-${PORTVERSION}
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (ltm-0.38.tar.bz2) = abbd3fd065f6e48f459e415079b985ba
|
||||
SHA256 (ltm-0.38.tar.bz2) = c4ef4a47146b8d3b642c4d64d02d77d7c428fd794482a4e998a0840b8c5a9d29
|
||||
SIZE (ltm-0.38.tar.bz2) = 1924687
|
||||
MD5 (ltm-0.39.tar.bz2) = 5f3c9287a6d65e2c3f6d47ad60797aeb
|
||||
SHA256 (ltm-0.39.tar.bz2) = 42ff44648c0a0407cef2132a6014431c2e3fb2910e5d5cd8b7ca0ac373465dce
|
||||
SIZE (ltm-0.39.tar.bz2) = 1978198
|
||||
|
|
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= tomsfastmath
|
||||
PORTVERSION= 0.08
|
||||
PORTVERSION= 0.09
|
||||
CATEGORIES= math
|
||||
MASTER_SITES= http://libtomcrypt.com/tfm/files/
|
||||
DISTNAME= tfm-${PORTVERSION}
|
||||
|
@ -22,13 +22,6 @@ ALL_TARGET= default
|
|||
|
||||
PLIST_FILES= include/tfm.h lib/libtfm.a
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
NOT_FOR_ARCHS= sparc64
|
||||
|
||||
.if ${ARCH} == "sparc64"
|
||||
BROKEN= Does not build on sparc64
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|
||' ${WRKSRC}/fp_montgomery_reduce.c
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (tfm-0.08.tar.bz2) = 681dc4452fb613e263619597bc537bca
|
||||
SHA256 (tfm-0.08.tar.bz2) = c0a929b41d50256022588ff22b43b3f8426699f2e32c8cc98103210d6d54f93b
|
||||
SIZE (tfm-0.08.tar.bz2) = 220282
|
||||
MD5 (tfm-0.09.tar.bz2) = cde07c65d08cadc3626f1476c75e1fb7
|
||||
SHA256 (tfm-0.09.tar.bz2) = 6ab39467a5be3911ec988539c9845e9c26da444fa59dc893110a0d52307fa9d9
|
||||
SIZE (tfm-0.09.tar.bz2) = 233815
|
||||
|
|
|
@ -1,15 +1,15 @@
|
|||
--- makefile.orig Mon Aug 1 12:34:18 2005
|
||||
+++ makefile Wed Aug 31 15:30:39 2005
|
||||
@@ -7,7 +7,7 @@
|
||||
--- makefile.orig Wed Apr 12 13:16:32 2006
|
||||
+++ makefile Wed Apr 12 13:16:48 2006
|
||||
@@ -11,7 +11,7 @@
|
||||
|
||||
ifndef IGNORE_SPEED
|
||||
|
||||
-CFLAGS += -O3 -funroll-all-loops
|
||||
+CFLAGS += -funroll-all-loops
|
||||
-CFLAGS += -O3 -funroll-loops
|
||||
+CFLAGS += -funroll-loops
|
||||
|
||||
#profiling
|
||||
#PROF=-pg -g
|
||||
@@ -49,11 +49,11 @@
|
||||
@@ -53,11 +53,11 @@
|
||||
HEADERS=tfm.h
|
||||
|
||||
ifndef LIBPATH
|
||||
|
|
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= libtomcrypt
|
||||
PORTVERSION= 1.10
|
||||
PORTVERSION= 1.12
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= http://libtomcrypt.com/files/
|
||||
DISTNAME= crypt-${PORTVERSION}
|
||||
|
@ -26,12 +26,13 @@ CFLAGS+= -I${PREFIX}/include
|
|||
|
||||
OPTIONS= DOCS "build documentation (depends on teTeX)" off \
|
||||
LIBTOMMATH "Use LibTomMath" on \
|
||||
TOMSFASTMATH "Use TomsFastMath" off
|
||||
TOMSFASTMATH "Use TomsFastMath" off \
|
||||
GMP "Use GMP" off
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if defined(WITHOUT_LIBTOMMATH) && defined(WITHOUT_TOMSFASTMATH)
|
||||
IGNORE= you must choose either LibTomMath or TomsFastMath (or both)
|
||||
.if defined(WITHOUT_LIBTOMMATH) && !defined(WITH_TOMSFASTMATH) && !defined(WITH_GMP)
|
||||
IGNORE= you must choose at least LibTomMath, TomsFastMath, or GMP (or all three)
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_LIBTOMMATH)
|
||||
|
@ -44,6 +45,11 @@ BUILD_DEPENDS+= ${LOCALBASE}/include/tfm.h:${PORTSDIR}/math/tomsfastmath
|
|||
CFLAGS+= -DTFM_DESC
|
||||
.endif
|
||||
|
||||
.if defined(WITH_GMP)
|
||||
BUILD_DEPENDS+= ${LOCALBASE}/include/gmp.h:${PORTSDIR}/math/libgmp4
|
||||
CFLAGS+= -DGMP_DESC
|
||||
.endif
|
||||
|
||||
.if defined(WITH_DOCS)
|
||||
BUILD_DEPENDS+= latex:${PORTSDIR}/print/teTeX
|
||||
.else
|
||||
|
@ -62,5 +68,13 @@ test: build
|
|||
|
||||
@${ECHO_MSG} "Testing with -DUSE_LTM..."
|
||||
(cd ${WRKSRC} && CFLAGS="${CFLAGS} -DUSE_LTM" EXTRALIBS="-L${PREFIX}/lib -ltommath" ${GMAKE} test && ${WRKSRC}/test)
|
||||
|
||||
@${ECHO_MSG} "Cleaning up test binary..."
|
||||
@${RM} ${WRKSRC}/test
|
||||
@${RM} ${WRKSRC}/demos/test.o
|
||||
|
||||
@${ECHO_MSG} "Testing with -DUSE_GMP..."
|
||||
(cd ${WRKSRC} && CFLAGS="${CFLAGS} -DUSE_GMP" EXTRALIBS="-L${PREFIX}/lib -lgmp" ${GMAKE} test && ${WRKSRC}/test)
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (crypt-1.10.tar.bz2) = 8da42847a5ac43e82965121c9e26e525
|
||||
SHA256 (crypt-1.10.tar.bz2) = 3115f8d91956ae8e05a19d74e6d2d2321e5e466a6daf69a4c43c2aa48334308d
|
||||
SIZE (crypt-1.10.tar.bz2) = 1324351
|
||||
MD5 (crypt-1.12.tar.bz2) = 0a018c0a84deea104bbc21d566f142fc
|
||||
SHA256 (crypt-1.12.tar.bz2) = 3001f79f26d3e70ae52e3f752c506aec1159c5efdcc43ca970cbfc7904c50907
|
||||
SIZE (crypt-1.12.tar.bz2) = 1393191
|
||||
|
|
Loading…
Reference in a new issue