o Add support for 7-Zip .cb7 comic book archive extension WITH_7ZIP
option which defaults to on o Bump PORTREVISION o Take over maintainership PR: 130235 Approved by: maintainer (previous)
This commit is contained in:
parent
d3d49b9c54
commit
c4adff48e4
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=226232
3 changed files with 33 additions and 3 deletions
|
@ -7,11 +7,11 @@
|
|||
|
||||
PORTNAME= qcomicbook
|
||||
PORTVERSION= 0.4.0
|
||||
PORTREVISION= 4
|
||||
PORTREVISION= 5
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://linux.bydg.org/~yogin/qcomicbook/
|
||||
|
||||
MAINTAINER= makc@issp.ac.ru
|
||||
MAINTAINER= lioux@FreeBSD.org
|
||||
COMMENT= QT-based comic book archive viewer
|
||||
|
||||
RUN_DEPENDS= unzip:${PORTSDIR}/archivers/unzip \
|
||||
|
@ -30,4 +30,13 @@ DESKTOP_ENTRIES="QComicBook" "Comic Book Viewer" \
|
|||
"${DATADIR}/${PORTNAME}.png" \
|
||||
"qcomicbook" "" false
|
||||
|
||||
.include <bsd.port.mk>
|
||||
OPTIONS= 7ZIP "Enable support for 7-Zip (.cb7) comic book archives" on
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
# 7-Zip (.cb7) support
|
||||
.if !defined(WITHOUT_7ZIP)
|
||||
RUN_DEPENDS+= 7z:${PORTSDIR}/archivers/p7zip
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
11
graphics/qcomicbook/files/patch-help__qcomicbook.1
Normal file
11
graphics/qcomicbook/files/patch-help__qcomicbook.1
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- ./help/qcomicbook.1.orig 2009-01-06 01:06:54.000000000 -0200
|
||||
+++ ./help/qcomicbook.1 2009-01-06 01:07:40.000000000 -0200
|
||||
@@ -10,7 +10,7 @@
|
||||
QComicBook is a viewer for comic book archives containing jpeg/png/xpm/gif images, which aims at convenience and simplicity.
|
||||
.PP
|
||||
Features include:
|
||||
- \- automatic decompression of zip (cbz), rar (cbr), ace (cba), targzipped (cbg) and tarbzip2ped (cbb) archives
|
||||
+ \- automatic decompression of zip (cbz), rar (cbr), ace (cba), 7-Zip (cb7), targzipped (cbg) and tarbzip2ped (cbb) archives
|
||||
\- full\-screen mode
|
||||
\- two\-pages viewing
|
||||
\- page scaling
|
10
graphics/qcomicbook/files/patch-src__imgarchivesink.cpp
Normal file
10
graphics/qcomicbook/files/patch-src__imgarchivesink.cpp
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- ./src/imgarchivesink.cpp.orig 2009-01-06 01:05:14.000000000 -0200
|
||||
+++ ./src/imgarchivesink.cpp 2009-01-06 01:06:26.000000000 -0200
|
||||
@@ -471,6 +471,7 @@
|
||||
inf.type = SEVENZIP_ARCHIVE;
|
||||
inf.name = "7z";
|
||||
inf.extensions.append(".7z");
|
||||
+ inf.extensions.append(".cb7");
|
||||
if (which("7z") != QString::null)
|
||||
{
|
||||
inf.extractopts.append("7z");
|
Loading…
Reference in a new issue