Milton is an open source application that lets you Just Paint.

WWW: https://www.miltonpaint.com/
This commit is contained in:
Alexey Dokuchaev 2019-03-19 18:42:59 +00:00
parent 77e50dc0ec
commit c54e9cf6f6
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=496288
10 changed files with 146 additions and 0 deletions

View file

@ -553,6 +553,7 @@
SUBDIR += metacam
SUBDIR += metapixel
SUBDIR += mhgui
SUBDIR += milton
SUBDIR += minder
SUBDIR += ming
SUBDIR += mirage

32
graphics/milton/Makefile Normal file
View file

@ -0,0 +1,32 @@
# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
# $FreeBSD$
PORTNAME= milton
PORTVERSION= 1.6.0
DISTVERSIONPREFIX= v
CATEGORIES= graphics
MAINTAINER= danfe@FreeBSD.org
COMMENT= Infinite-canvas paint program
LICENSE= MIT
USE_GITHUB= yes
GH_ACCOUNT= serge-rgb
USES= cmake gl gnome
USE_GL= gl
USE_GNOME= gtk20
USE_SDL= sdl2
PLIST_FILES= bin/milton
post-patch:
@${REINPLACE_CMD} -e 's:__linux__:__${OPSYS}__:' \
${WRKSRC}/src/easytab.h
do-install:
${INSTALL_PROGRAM} ${INSTALL_WRKSRC}/Milton \
${STAGEDIR}${PREFIX}/bin/milton
.include <bsd.port.mk>

3
graphics/milton/distinfo Normal file
View file

@ -0,0 +1,3 @@
TIMESTAMP = 1552623103
SHA256 (serge-rgb-milton-v1.6.0_GH0.tar.gz) = 0c3b6e1774678af1efa7c4018d2a2281838c0e748c6e594d059d49eae57c3638
SIZE (serge-rgb-milton-v1.6.0_GH0.tar.gz) = 12056633

View file

@ -0,0 +1,46 @@
--- CMakeLists.txt.orig 2019-03-15 04:11:43 UTC
+++ CMakeLists.txt
@@ -41,7 +41,7 @@ else()
endif()
set(CMAKE_CXX_FLAGS_DEBUG "-g")
-set(CMAKE_CXX_FLAGS_RELEASE "-O3")
+#set(CMAKE_CXX_FLAGS_RELEASE "-O3")
message(STATUS "Building ${CMAKE_BUILD_TYPE}")
@@ -71,13 +71,14 @@ if(UNIX)
${UnixCFlags})
endif()
-if(${CMAKE_SYSTEM_NAME} STREQUAL "Linux")
+if(${CMAKE_SYSTEM_NAME} STREQUAL "FreeBSD")
find_package(OpenGL REQUIRED)
find_package(GTK2 2.6 REQUIRED gtk)
find_package(X11 REQUIRED)
find_library(XINPUT_LIBRARY libXi.so)
find_package(Threads REQUIRED)
+ find_package(SDL2 REQUIRED)
if(XINPUT_LIBRARY STREQUAL "XINPUT_LIBRARY-NOTFOUND")
message(FATAL_ERROR "Could not find libXi.so")
@@ -98,7 +99,7 @@ if(${CMAKE_SYSTEM_NAME} STREQUAL "Linux")
target_include_directories(Milton PRIVATE
${GTK2_INCLUDE_DIRS}
${X11_INCLUDE_DIR}
- ${SDL2DIR}/build/linux64/include/SDL2
+ ${SDL2_INCLUDE_DIRS}
${OPENGL_INCLUDE_DIR}
)
@@ -107,8 +108,7 @@ if(${CMAKE_SYSTEM_NAME} STREQUAL "Linux")
${X11_LIBRARIES}
${OPENGL_LIBRARIES}
${XINPUT_LIBRARY}
- ${SDL2DIR}/build/linux64/lib/libSDL2maind.a
- ${SDL2DIR}/build/linux64/lib/libSDL2d.a
+ ${SDL2_LIBRARIES}
${CMAKE_THREAD_LIBS_INIT}
${CMAKE_DL_LIBS}
)

View file

@ -0,0 +1,11 @@
--- src/platform.h.orig 2019-03-15 04:11:43 UTC
+++ src/platform.h
@@ -197,7 +197,7 @@ float perf_count_to_sec(u64 counter);
#if defined(_WIN32)
#include "platform_windows.h"
-#elif defined(__linux__) || defined(__MACH__)
+#elif defined(__linux__) || defined(__MACH__) || defined(__FreeBSD__)
#include "platform_unix.h"
#endif

View file

@ -0,0 +1,11 @@
--- src/platform_unix.h.orig 2019-03-15 04:11:43 UTC
+++ src/platform_unix.h
@@ -1,7 +1,7 @@
// Copyright (c) 2015 Sergio Gonzalez. All rights reserved.
// License: https://github.com/serge-rgb/milton#license
-#ifdef __linux__
+#if defined(__linux__) || defined(__FreeBSD__)
#ifndef _GNU_SOURCE
#define _GNU_SOURCE // To get MAP_ANONYMOUS on linux
#endif

View file

@ -0,0 +1,11 @@
--- src/system_includes.h.orig 2019-03-15 04:11:43 UTC
+++ src/system_includes.h
@@ -48,7 +48,7 @@
#include "gl.h"
-#elif defined(__linux__)
+#elif defined(__linux__) || defined(__FreeBSD__)
#include "gl.h"

View file

@ -0,0 +1,11 @@
--- src/tiny_jpeg.h.orig 2019-03-15 04:11:43 UTC
+++ src/tiny_jpeg.h
@@ -217,7 +217,7 @@ static uint8_t tjei_g_output_buffer[TJEI_BUFFER_SIZE];
#ifdef _WIN32
#define tje_log(msg) OutputDebugStringA(msg)
-#elif defined(__linux__) || defined(__MACH__)
+#elif defined(__linux__) || defined(__MACH__) || defined(__FreeBSD__)
#define tje_log(msg) puts(msg)
#endif

View file

@ -0,0 +1,11 @@
--- src/unity.cc.orig 2019-03-15 04:11:43 UTC
+++ src/unity.cc
@@ -18,7 +18,7 @@
#if defined(_WIN32)
#include "platform_windows.cc"
-#elif defined(__linux__)
+#elif defined(__linux__) || defined(__FreeBSD__)
#include "platform_unix.cc"
#include "platform_linux.cc"
#elif defined(__MACH__)

View file

@ -0,0 +1,9 @@
Milton is an open source application that lets you Just Paint.
There are no pixels, you can paint with (almost) infinite detail.
It feels raster-based but it works with vectors. It is not an image
editor. It is not a vector graphics editor. It is a program that
lets you draw, sketch, and paint. There is no save button, your
work is persistent with unlimited undo.
WWW: https://www.miltonpaint.com/