Update to 1.9.0
PR: 203245 Submitted by: tkato432 yahoo com Sponsored by: Absolight
This commit is contained in:
parent
d83450a133
commit
c56a413160
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=410580
5 changed files with 89 additions and 22 deletions
|
@ -2,10 +2,10 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= hatari
|
||||
PORTVERSION= 1.8.0
|
||||
PORTREVISION= 4
|
||||
PORTVERSION= 1.9.0
|
||||
CATEGORIES= emulators
|
||||
MASTER_SITES= http://download.tuxfamily.org/hatari/${PORTVERSION}/
|
||||
MASTER_SITES= http://download.tuxfamily.org/hatari/%SUBDIR%/
|
||||
MASTER_SITE_SUBDIR= ${PORTVERSION}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Atari ST emulator
|
||||
|
@ -16,14 +16,27 @@ LICENSE_FILE= ${WRKSRC}/gpl.txt
|
|||
LIB_DEPENDS= libportaudio.so:${PORTSDIR}/audio/portaudio \
|
||||
libpng.so:${PORTSDIR}/graphics/png
|
||||
|
||||
USES= cmake readline tar:bzip2
|
||||
USES= cmake desktop-file-utils python readline shared-mime-info \
|
||||
shebangfix tar:bzip2
|
||||
SHEBANG_FILES= tools/atari-convert-dir.py
|
||||
python_OLD_CMD= /usr/bin/python2
|
||||
USE_GNOME= pygtk2
|
||||
USE_SDL= sdl
|
||||
CMAKE_ARGS= -DCMAKE_C_FLAGS_RELEASE:STRING="-DNDEBUG" \
|
||||
-DETCDIR:STRING="${PREFIX}/etc" \
|
||||
-DMANDIR:STRING="man/man1"
|
||||
CMAKE_ARGS= -DETCDIR:PATH="${PREFIX}/etc" \
|
||||
-DMANDIR:PATH="man/man1" \
|
||||
-DREADLINE_FOUND:BOOL=ON
|
||||
INSTALLS_ICONS= yes
|
||||
|
||||
OPTIONS_DEFINE= DOCS
|
||||
OPTIONS_DEFINE= DEBUG DOCS SDL2 WINUAE
|
||||
|
||||
DEBUG_CFLAGS_OFF= -DNDEBUG
|
||||
SDL2_DESC= Use SDL2 libraries instead of SDL 1.2
|
||||
SDL2_USES= iconv
|
||||
SDL2_USE= sdl=sdl2
|
||||
SDL2_USE_OFF= sdl=sdl
|
||||
SDL2_CMAKE_ON= -DENABLE_SDL2:BOOL=ON
|
||||
SDL2_CFLAGS= -I${ICONV_INCLUDE_PATH}
|
||||
WINUAE_DESC= Build with WinUAE CPU core (experimental)
|
||||
WINUAE_CMAKE_ON= -DENABLE_WINUAE_CPU:BOOL=ON
|
||||
|
||||
post-patch:
|
||||
.for i in doc/hatari.1 doc/fr/hatari.1 tools/hconsole/hconsole.1
|
||||
|
@ -31,15 +44,12 @@ post-patch:
|
|||
's|^/etc/hatari.cfg .*|${PREFIX}/etc/hatari.cfg| ; \
|
||||
s|/usr/share|${PREFIX}/share|' ${WRKSRC}/${i}
|
||||
.endfor
|
||||
@${REINPLACE_CMD} -e '/DESTINATION/s|/icons/.*)|/pixmaps)|' \
|
||||
${WRKSRC}/python-ui/CMakeLists.txt
|
||||
|
||||
post-build:
|
||||
@cd ${WRKSRC}/doc/fr && ${GZIP_CMD} -c ${PORTNAME}.1 > ${PORTNAME}.1.gz
|
||||
@${REINPLACE_CMD} -e \
|
||||
's|-Wno-maybe-uninitialized||' ${WRKSRC}/src/cpu/CMakeLists.txt
|
||||
|
||||
post-install:
|
||||
@${MKDIR} ${STAGEDIR}${MANPREFIX}/man/fr/man1
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/fr/${PORTNAME}.1.gz ${STAGEDIR}${MANPREFIX}/man/fr/man1
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/fr/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/fr/man1
|
||||
|
||||
post-install-DOCS-on:
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}/fr
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (hatari-1.8.0.tar.bz2) = 7ecf486ba578e3b4d7a3d3e86ef3e879d5e5611b39c2504e38ccafdaacb5ffeb
|
||||
SIZE (hatari-1.8.0.tar.bz2) = 1985358
|
||||
SHA256 (hatari-1.9.0.tar.bz2) = b2b56e6cbe7f8769a5e8b1d96599f392d9351b44cacf959da6905da06d30e992
|
||||
SIZE (hatari-1.9.0.tar.bz2) = 2379016
|
||||
|
|
24
emulators/hatari/files/patch-share_CMakeLists.txt
Normal file
24
emulators/hatari/files/patch-share_CMakeLists.txt
Normal file
|
@ -0,0 +1,24 @@
|
|||
--- share/CMakeLists.txt.orig 2015-09-10 21:16:03 UTC
|
||||
+++ share/CMakeLists.txt
|
||||
@@ -5,8 +5,8 @@ foreach(size 32x32 48x48 64x64 128x128 2
|
||||
install(FILES icons/hicolor/${size}/mimetypes/application-x-st-disk-image.png
|
||||
DESTINATION ${ICONDIR}/${size}/mimetypes)
|
||||
foreach(type vnd.msa vnd.fastcopy x-stx)
|
||||
- install(CODE "execute_process(COMMAND ln -sf application-x-st-disk-image.png
|
||||
- ${CMAKE_INSTALL_PREFIX}/${ICONDIR}/${size}/mimetypes/application-${type}-disk-image.png)
|
||||
+ install(CODE "execute_process(COMMAND ${CMAKE_COMMAND} -E create_symlink application-x-st-disk-image.png application-${type}-disk-image.png
|
||||
+ WORKING_DIRECTORY \$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/${ICONDIR}/${size}/mimetypes)
|
||||
")
|
||||
endforeach()
|
||||
endforeach()
|
||||
@@ -16,8 +16,8 @@ install(FILES icons/hicolor/scalable/app
|
||||
install(FILES icons/hicolor/scalable/mimetypes/application-x-st-disk-image.svg
|
||||
DESTINATION ${ICONDIR}/scalable/mimetypes)
|
||||
foreach(type vnd.msa vnd.fastcopy x-stx)
|
||||
- install(CODE "execute_process(COMMAND ln -sf application-x-st-disk-image.svg
|
||||
- ${CMAKE_INSTALL_PREFIX}/${ICONDIR}/scalable/mimetypes/application-${type}-disk-image.svg)
|
||||
+ install(CODE "execute_process(COMMAND ${CMAKE_COMMAND} -E create_symlink application-x-st-disk-image.svg application-${type}-disk-image.svg
|
||||
+ WORKING_DIRECTORY \$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/${ICONDIR}/scalable/mimetypes)
|
||||
")
|
||||
endforeach()
|
||||
install(FILES mime/packages/hatari.xml DESTINATION share/mime/packages)
|
|
@ -1,5 +1,5 @@
|
|||
Hatari is an Atari ST emulator. It tries to emulate the hardware of a ST
|
||||
as close as possible so that it is able to run most of the old ST games
|
||||
and demos.
|
||||
Hatari is an emulator for the Atari ST, STE, TT and Falcon computers. It
|
||||
tries to emulate the hardware of a ST as close as possible so that it is
|
||||
able to run most of the old ST games and demos.
|
||||
|
||||
WWW: http://hatari.tuxfamily.org/
|
||||
|
|
|
@ -1,3 +1,4 @@
|
|||
bin/atari-convert-dir
|
||||
bin/atari-hd-image
|
||||
bin/gst2ascii
|
||||
bin/hatari
|
||||
|
@ -6,6 +7,7 @@ bin/hatariui
|
|||
bin/hmsa
|
||||
bin/zip2st
|
||||
man/fr/man1/hatari.1.gz
|
||||
man/man1/atari-convert-dir.1.gz
|
||||
man/man1/atari-hd-image.1.gz
|
||||
man/man1/gst2ascii.1.gz
|
||||
man/man1/hatari.1.gz
|
||||
|
@ -14,6 +16,7 @@ man/man1/hatariui.1.gz
|
|||
man/man1/hconsole.1.gz
|
||||
man/man1/hmsa.1.gz
|
||||
man/man1/zip2st.1.gz
|
||||
share/applications/hatari.desktop
|
||||
share/applications/hatariui.desktop
|
||||
%%PORTDOCS%%%%DOCSDIR%%/authors.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/compatibility.html
|
||||
|
@ -50,7 +53,7 @@ share/applications/hatariui.desktop
|
|||
%%DATADIR%%/hatariui/debugui.py
|
||||
%%DATADIR%%/hatariui/dialogs.py
|
||||
%%DATADIR%%/hatariui/hatari-icon.png
|
||||
%%DATADIR%%/hatariui/hatari.png
|
||||
%%DATADIR%%/hatariui/hatari-logo.png
|
||||
%%DATADIR%%/hatariui/hatari.py
|
||||
%%DATADIR%%/hatariui/hatariui.py
|
||||
%%DATADIR%%/hatariui/release-notes.txt
|
||||
|
@ -61,4 +64,34 @@ share/applications/hatariui.desktop
|
|||
%%DATADIR%%/hconsole/hconsole.py
|
||||
%%DATADIR%%/hconsole/release-notes.txt
|
||||
%%DATADIR%%/tos.img
|
||||
share/pixmaps/hatari-icon.png
|
||||
share/icons/hicolor/128x128/apps/hatari.png
|
||||
share/icons/hicolor/128x128/mimetypes/application-vnd.fastcopy-disk-image.png
|
||||
share/icons/hicolor/128x128/mimetypes/application-vnd.msa-disk-image.png
|
||||
share/icons/hicolor/128x128/mimetypes/application-x-st-disk-image.png
|
||||
share/icons/hicolor/128x128/mimetypes/application-x-stx-disk-image.png
|
||||
share/icons/hicolor/256x256/apps/hatari.png
|
||||
share/icons/hicolor/256x256/mimetypes/application-vnd.fastcopy-disk-image.png
|
||||
share/icons/hicolor/256x256/mimetypes/application-vnd.msa-disk-image.png
|
||||
share/icons/hicolor/256x256/mimetypes/application-x-st-disk-image.png
|
||||
share/icons/hicolor/256x256/mimetypes/application-x-stx-disk-image.png
|
||||
share/icons/hicolor/32x32/apps/hatari.png
|
||||
share/icons/hicolor/32x32/mimetypes/application-vnd.fastcopy-disk-image.png
|
||||
share/icons/hicolor/32x32/mimetypes/application-vnd.msa-disk-image.png
|
||||
share/icons/hicolor/32x32/mimetypes/application-x-st-disk-image.png
|
||||
share/icons/hicolor/32x32/mimetypes/application-x-stx-disk-image.png
|
||||
share/icons/hicolor/48x48/apps/hatari.png
|
||||
share/icons/hicolor/48x48/mimetypes/application-vnd.fastcopy-disk-image.png
|
||||
share/icons/hicolor/48x48/mimetypes/application-vnd.msa-disk-image.png
|
||||
share/icons/hicolor/48x48/mimetypes/application-x-st-disk-image.png
|
||||
share/icons/hicolor/48x48/mimetypes/application-x-stx-disk-image.png
|
||||
share/icons/hicolor/64x64/apps/hatari.png
|
||||
share/icons/hicolor/64x64/mimetypes/application-vnd.fastcopy-disk-image.png
|
||||
share/icons/hicolor/64x64/mimetypes/application-vnd.msa-disk-image.png
|
||||
share/icons/hicolor/64x64/mimetypes/application-x-st-disk-image.png
|
||||
share/icons/hicolor/64x64/mimetypes/application-x-stx-disk-image.png
|
||||
share/icons/hicolor/scalable/apps/hatari.svg
|
||||
share/icons/hicolor/scalable/mimetypes/application-vnd.fastcopy-disk-image.svg
|
||||
share/icons/hicolor/scalable/mimetypes/application-vnd.msa-disk-image.svg
|
||||
share/icons/hicolor/scalable/mimetypes/application-x-st-disk-image.svg
|
||||
share/icons/hicolor/scalable/mimetypes/application-x-stx-disk-image.svg
|
||||
share/mime/packages/hatari.xml
|
||||
|
|
Loading…
Reference in a new issue