Update to 1.1.90

This commit is contained in:
Tilman Keskinoz 2003-10-27 18:26:34 +00:00
parent 527ef92c33
commit c570ee8e92
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=92332
6 changed files with 9 additions and 56 deletions

View file

@ -6,8 +6,7 @@
#
PORTNAME= newscache
PORTVERSION= 1.1.12
PORTREVISION= 1
PORTVERSION= 1.1.90
CATEGORIES= news
MASTER_SITES= http://www.hstraub.at/linux/downloads/src/ \
http://www.infosys.tuwien.ac.at/NewsCache/download/
@ -18,16 +17,18 @@ COMMENT= NewsCache is a free cache server for USENET News
LIB_DEPENDS= socket[+][+].1:${PORTSDIR}/net/libsocket++
USE_AUTOHEADER= yes
USE_AUTOMAKE_VER= 15
USE_GMAKE= yes
CONFIGURE_ENV= CPPFLAGS="${CFLAGS} -I${LOCALBASE}/include" LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
MAKE_ENV= LIBS="-lsocket++"
USE_GETOPT_LONG= yes
AUTOMAKE_ARGS= --add-missing
CONFIGURE_ENV= CPPFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
MAN5= newscache.conf.5
MAN8= newscache.8 newscacheclean.8 updatenews.8
INFO= NewsCache
post-patch:
cd ${WRKSRC}; ./autogen
cd ${WRKSRC}; ${ACLOCAL}
.include <bsd.port.mk>

View file

@ -1 +1 @@
MD5 (NewsCache-1.1.12.tar.gz) = 13248be94403aad9c9495e6c5efa1cb2
MD5 (NewsCache-1.1.90.tar.gz) = 0c15eab599f901161c117e2f40562b7f

View file

@ -1,20 +0,0 @@
--- NServer-0.9.1/Article.cc.orig Sun Apr 6 18:09:33 2003
+++ NServer-0.9.1/Article.cc Sun Apr 6 18:10:44 2003
@@ -93,7 +93,7 @@
}
}
-string Article::getfield(const char *ifld, int Full = 0) const
+string Article::getfield(const char *ifld, int Full) const
{
string rfld;
const char *p, *fld;
@@ -214,7 +214,7 @@
_ctext = _text.c_str();
}
-ostream & Article::write(ostream & os, int flags = Head | Body)
+ostream & Article::write(ostream & os, int flags)
{
const char *p, *q;

View file

@ -1,10 +0,0 @@
--- NServer-0.9.1/NServer.h.orig Mon Aug 4 13:19:19 2003
+++ NServer-0.9.1/NServer.h Mon Aug 4 13:19:52 2003
@@ -243,6 +243,7 @@
RServer():NServer() {
_ServerList = NULL;
_CurrentServer = NULL;
+ _pServerStream = NULL;
} void init(MPList * serverlist);
/**

View file

@ -1,19 +0,0 @@
--- configure.in.orig Sun Apr 6 18:49:34 2003
+++ configure.in Sun Apr 6 18:50:31 2003
@@ -220,14 +220,14 @@
LIBS="-lsocket++ $LIBS"
AC_TRY_LINK([#include <socket++/sockinet.h>], [iosockinet sio; sio.rdbuf()->setname("Test");],
libsocket_found=yes ,)
-if eval "test $libsocket_found == 'yes'"; then
+if eval "test x$libsocket_found = xyes"; then
AC_MSG_RESULT(yes)
else
AC_MSG_RESULT(no)
LIBS=$OLDLIBS
fi
-if eval "test $libsocket_found == 'no'"; then
+if eval "test x$libsocket_found = xno"; then
AC_MSG_ERROR(No libsocket++ Library found!)
fi

View file

@ -1,4 +1,5 @@
bin/updatenews
etc/newscache.conf-dist
etc/newscache.auth-dist
sbin/newscache
sbin/newscacheclean