- Update to version 1.12.3

- Conditionalize dependency on `devel/libexecinfo'
- Try to detect SSE2 support
- Convert to USES=qmake and stafigy
- Improve grammar in port description while here

Approved by:	maintainer (implicit)
This commit is contained in:
Alexey Dokuchaev 2013-10-31 15:30:04 +00:00
parent ff86bdb0ba
commit c5854fe3e1
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=332256
8 changed files with 325 additions and 79 deletions

View file

@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= ugene
DISTVERSION= 1.11.4
DISTVERSION= 1.12.3
CATEGORIES= biology
MASTER_SITES= http://ugene.unipro.ru/downloads/
@ -11,41 +11,54 @@ COMMENT= Free, open-source, cross-platform bioinformatics toolkit
LICENSE= GPLv2
LIB_DEPENDS= execinfo:${PORTSDIR}/devel/libexecinfo
.if !exists(/usr/include/execinfo.h)
LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo
.endif
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
USES= qmake
USE_GL= glu
USE_QT4= gui webkit xml svg linguist_build moc_build qmake_build \
qtestlib_build rcc_build uic_build imageformats_run
USE_XORG= xtst
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
MAN1= ${PORTNAME}.1
MANCOMPRESSED= yes
QMAKE_ARGS= INSTALL_PREFIX=${PREFIX} UGENE_INSTALL_DATA=${DATADIR} \
INSTALL_MANDIR=${MAN1PREFIX}/man
ALL_TARGET= release
NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${OSVERSION} > 1000054
CXXFLAGS+= -std=c++11
.endif
.if ${ARCH} == "amd64"
# need to manually tell the build we are on x64
CARCH= CONFIG+=x64
# XXX: need to manually tell the build we are on x64
QMAKE_ARGS+= CONFIG+=x64
PLIST_SUB= NOX64="@comment "
.else
PLIST_SUB= NOX64=""
.endif
# yes, bash is required, stuff will not execute with sh
.if ${MACHINE_CPU:Msse2}
QMAKE_ARGS+= UGENE_SSE2_DETECTED=1
.endif
post-patch:
# yes, bash is required, stuff will not execute with sh
@${REINPLACE_CMD} -e 's|/bin/bash|/usr/bin/env bash|' \
${WRKSRC}/src/gen_bin_script.cmd \
${WRKSRC}/installer/_common_data/ugene
# remove BOM from files and non-latin comments; gcc 4.2 does not like them
@${REINPLACE_CMD} -e '1s|^[^/]*|| ; /lose sequence view,/d' \
${WRKSRC}/src/plugins/GUITestBase/src/tests/common_scenarios/smith_waterman_dialog/GTTestsSWDialog.cpp \
${WRKSRC}/src/plugins/GUITestBase/src/tests/common_scenarios/repeat_finder/GTTestsRepeatFinder.cpp
do-configure:
@cd ${CONFIGURE_WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${QMAKE} \
PREFIX=${PREFIX} INSTALL_PREFIX=${PREFIX} \
INSTALL_MANDIR=${MAN1PREFIX}/man ${CARCH} \
UGENE_INSTALL_DATA=${DATADIR} -r ${PORTNAME}.pro
post-configure:
@${REINPLACE_CMD} -e '/^LFLAGS/s,-pthread,-lexecinfo &,' \
${WRKSRC}/src/ugenecl/Makefile.Release \
${WRKSRC}/src/ugeneui/Makefile.Release
.include <bsd.port.post.mk>

View file

@ -1,2 +1,2 @@
SHA256 (ugene-1.11.4.tar.gz) = 5b9b914e7ef5a3d3658f3346cccdb5cd6583b03db3b7bed7e163cb5cfd5663fa
SIZE (ugene-1.11.4.tar.gz) = 14761290
SHA256 (ugene-1.12.3.tar.gz) = 6642ec6ef5110b50b38c9620be4a98101d9a7b325a61a202ee7e0f2c67d45496
SIZE (ugene-1.12.3.tar.gz) = 17611949

View file

@ -0,0 +1,91 @@
--- src/corelibs/U2Gui/src/util/ProjectTreeController.cpp.orig 2013-10-08 15:07:58.000000000 +0800
+++ src/corelibs/U2Gui/src/util/ProjectTreeController.cpp 2013-10-30 19:47:27.000000000 +0800
@@ -448,7 +448,7 @@ void ProjectTreeController::sl_onCloseEd
QMessageBox::critical(0, "Error", tr("Duplicate object names are not allowed"));
return;
- } else if (newName.contains(invalidCharactersRegExp) != NULL) {
+ } else if (newName.contains(invalidCharactersRegExp) != false) {
QMessageBox::critical(0, "Error", tr("The name can't contain any of the following characters: %1").arg(invalidCharacters));
return;
}
--- src/corelibs/U2Private/src/CrashHandler.cpp.orig 2013-10-08 15:07:59.000000000 +0800
+++ src/corelibs/U2Private/src/CrashHandler.cpp 2013-10-30 19:18:30.000000000 +0800
@@ -349,7 +349,7 @@ void CrashHandler::setupHandler() {
#define SA_FLAGS (SA_ONSTACK | SA_SIGINFO)
stack_t sigstk;
- sigstk.ss_sp = malloc(SIGSTKSZ * 2);
+ sigstk.ss_sp = static_cast<char *>(malloc(SIGSTKSZ * 2));
sigstk.ss_size = SIGSTKSZ * 2;
sigstk.ss_flags = 0;
if (sigaltstack(&sigstk,0) < 0) {
--- src/plugins/biostruct3d_view/src/MolecularSurfaceRenderer.cpp.orig 2013-10-08 15:07:39.000000000 +0800
+++ src/plugins/biostruct3d_view/src/MolecularSurfaceRenderer.cpp 2013-10-30 21:42:54.000000000 +0800
@@ -80,9 +80,21 @@ void DotsRenderer::drawSurface( Molecula
glBegin(GL_POINTS);
foreach(const Face& face, surface.getFaces()) {
float vct[3][3] = {
- {face.v[0].x,face.v[0].y,face.v[0].z},
- {face.v[1].x,face.v[1].y,face.v[1].z},
- {face.v[2].x,face.v[2].y,face.v[2].z},
+ {
+ static_cast<float>(face.v[0].x),
+ static_cast<float>(face.v[0].y),
+ static_cast<float>(face.v[0].z),
+ },
+ {
+ static_cast<float>(face.v[1].x),
+ static_cast<float>(face.v[1].y),
+ static_cast<float>(face.v[1].z),
+ },
+ {
+ static_cast<float>(face.v[2].x),
+ static_cast<float>(face.v[2].y),
+ static_cast<float>(face.v[2].z),
+ },
};
glVertex3fv(vct[0]);
glVertex3fv(vct[1]);
--- src/plugins/expert_discovery/src/ExpertDiscoveryTreeWidgetsCtrl.cpp.orig 2013-10-08 15:07:42.000000000 +0800
+++ src/plugins/expert_discovery/src/ExpertDiscoveryTreeWidgetsCtrl.cpp 2013-10-30 22:02:40.000000000 +0800
@@ -198,7 +198,7 @@ void EDProjectTree::updateSequenceBase(E
void EDProjectTree::sl_propChanged(EDProjectItem* item, const EDPIProperty* prop, QString newVal){
switch (item->getType()) {
case PIT_CS_FOLDER:
- if (prop->getName().compare("Name", Qt::CaseInsensitive) == NULL) {
+ if (prop->getName().compare("Name", Qt::CaseInsensitive) == 0) {
EDPICSDirectory* pPI = dynamic_cast<EDPICSDirectory*>(item);
CSFolder* pFolder = findFolder(pPI);
const CSFolder* pParentFolder = pFolder->getParentFolder();
--- src/plugins/test_runner/src/TestViewReporter.h.orig 2013-10-08 15:07:45.000000000 +0800
+++ src/plugins/test_runner/src/TestViewReporter.h 2013-10-30 21:50:12.000000000 +0800
@@ -44,7 +44,7 @@ namespace U2 {
public:
- TestViewReporter(TestViewController* parent,QTreeWidget* tree=NULL,int runTime=NULL);
+ TestViewReporter(TestViewController* parent,QTreeWidget* tree=NULL,int runTime=0);
QString getReportText() {return curReportText;}
bool saveAs(const QString url,const QString data);
@@ -52,7 +52,7 @@ namespace U2 {
virtual void setupViewMenu(QMenu* n);
private:
- const QString prepareHTMLText(QTreeWidget* tree=NULL,int runTime=NULL);
+ const QString prepareHTMLText(QTreeWidget* tree=NULL,int runTime=0);
const QString getHTMLNoTests();
const QString getHTMLHead();
--- src/plugins_3rdparty/ball/src/source/COMMON/version.cpp.orig 2013-10-08 15:07:47.000000000 +0800
+++ src/plugins_3rdparty/ball/src/source/COMMON/version.cpp 2013-10-30 21:20:22.000000000 +0800
@@ -12,7 +12,7 @@ namespace BALL
{
const char* VersionInfo::getVersion() throw()
{
- return BALL_RELEASE_STRING " ("__DATE__", " __TIME__ ")";
+ return BALL_RELEASE_STRING " (" __DATE__ ", " __TIME__ ")";
}
int VersionInfo::getMinorRevision() throw(Exception::InvalidFormat)

View file

@ -0,0 +1,34 @@
commit 23699acca083589be9dc3b6e8e5c5d09f654648d
Author: marina.kolpakova <marina.kolpakova@itseez.com>
Date: Mon Oct 8 02:37:22 2012 +0400
fix for bug 2264
fix compilation OpenCV with cxx11 under Ubuntu with clang and gcc 4.7
diff --git a/modules/ts/include/opencv2/ts/ts_gtest.h b/modules/ts/include/opencv2/ts/ts_gtest.h
index f98f71b..42eb608 100644
--- src/libs_3rdparty/gtest/src/gtest/internal/gtest-port.h.orig
+++ src/libs_3rdparty/gtest/src/gtest/internal/gtest-port.h
@@ -1654,7 +1654,21 @@ inline bool operator!=(const GTEST_10_TUPLE_(T)& t,
# undef _TR1_FUNCTIONAL // Allows the user to #include
// <tr1/functional> if he chooses to.
# else
+# if defined (__cplusplus) && __cplusplus > 199711L
+# include <tuple>
+namespace std {
+ namespace tr1 {
+ using std::tuple;
+ using std::tuple_element;
+ using std::get;
+ using std::tuple_size;
+ using std::make_tuple;
+ }
+}
+# else
# include <tr1/tuple> // NOLINT
+# endif
+
# endif // !GTEST_HAS_RTTI && GTEST_GCC_VER_ < 40302
# else

View file

@ -1,20 +0,0 @@
--- ./src/corelibs/U2Private/src/CrashHandler.cpp.orig 2012-10-30 15:36:22.000000000 +0100
+++ ./src/corelibs/U2Private/src/CrashHandler.cpp 2012-10-30 15:47:47.000000000 +0100
@@ -253,7 +253,7 @@
}
//handler = AddVectoredExceptionHandler(1, CrashHandlerFunc);
-#elif defined( Q_OS_MAC)
+#elif defined( Q_OS_MAC ) || defined ( Q_OS_FREEBSD )
return; //TODO: implement crash hander for MAC OS
#else
stack_t sigstk;
@@ -284,7 +284,7 @@
void CrashHandler::runMonitorProcess(const QString &exceptionType) {
QString path = QCoreApplication::applicationDirPath() + "/ugenem";
-#ifndef Q_OS_WIN
+#if !defined ( Q_OS_WIN ) && !defined ( Q_OS_FREEBSD )
char pid_buf[30];
sprintf(pid_buf, "%d", getpid());
char name_buf[512];

View file

@ -1,30 +0,0 @@
--- ./src/plugins_3rdparty/umuscle/src/muscle/intmath.cpp.orig 2012-12-26 17:43:44.000000000 +0800
+++ ./src/plugins_3rdparty/umuscle/src/muscle/intmath.cpp 2013-02-25 17:25:06.000000000 +0800
@@ -9,13 +9,6 @@
return (PROB) pow(2.0, (double) Score/INTSCALE);
}
-static const double log2e = log2(exp(1.0));
-
-double lnTolog2(double ln)
- {
- return ln*log2e;
- }
-
double log2(double x)
{
if (0 == x)
@@ -27,6 +20,13 @@
return log(x)*dInvLn2;
}
+static const double log2e = log2(exp(1.0));
+
+double lnTolog2(double ln)
+ {
+ return ln*log2e;
+ }
+
SCORE ProbToScore(PROB Prob)
{
if (0.0 == Prob)

View file

@ -1,12 +1,12 @@
Unipro UGENE is a multiplatform open-source software with the main goal of
Unipro UGENE is multiplatform, open-source software with the main goal of
assisting molecular biologists without much expertise in bioinformatics to
manage, analyze and visualize their data. UGENE integrates widely used
bioinformatics tools within a common user interface.
manage, analyze, and visualize their data. UGENE integrates widely used
bioinformatics tools within one common user interface.
The toolkit supports multiple biological data formats and allows the
UGENE toolkit supports multiple biological data formats and allows the
retrieval of data from remote data sources. It provides visualization
modules for biological objects such as annotated genome sequences, Next
Generation Sequencing (NGS) assembly data, multiple sequence alignments,
phylogenetic trees and 3D structures.
phylogenetic trees, and 3D structures.
WWW: http://ugene.unipro.ru/

View file

@ -10,13 +10,28 @@ lib/ugene/libU2Remote.so
lib/ugene/libU2Test.so
lib/ugene/libU2View.so
lib/ugene/libgtest.so
lib/ugene/libgtest.so.1
lib/ugene/libgtest.so.1.0
lib/ugene/libgtest.so.1.0.0
lib/ugene/libugenedb.so
lib/ugene/libugenedb.so.1
lib/ugene/libugenedb.so.1.0
lib/ugene/libugenedb.so.1.0.0
lib/ugene/plugins/libbrowser_support.so
lib/ugene/plugins/liblinkdata_support.so
lib/ugene/plugins/libvariants.so
lib/ugene/plugins/linkdata_support.license
lib/ugene/plugins/linkdata_support.plugin
lib/ugene/plugins/variants.license
lib/ugene/plugins/variants.plugin
lib/ugene/plugins/CoreTests.license
lib/ugene/plugins/CoreTests.plugin
lib/ugene/plugins/GUITestBase.license
lib/ugene/plugins/GUITestBase.plugin
lib/ugene/plugins/annotator.license
lib/ugene/plugins/annotator.plugin
lib/ugene/plugins/browser_support.license
lib/ugene/plugins/browser_support.plugin
lib/ugene/plugins/api_tests.license
lib/ugene/plugins/api_tests.plugin
lib/ugene/plugins/ball.license
@ -133,6 +148,7 @@ lib/ugene/ugene
lib/ugene/ugenecl
lib/ugene/ugenem
lib/ugene/ugeneui
man/man1/ugene.1.gz
share/applications/ugene.desktop
share/pixmaps/ugene.png
share/pixmaps/ugene.xpm
@ -177,21 +193,20 @@ share/pixmaps/ugene.xpm
%%DATADIR%%/back_translation/Yeast/Saccharomyces_cerevisiae_(baker's_yeast).cut
%%DATADIR%%/back_translation/tables.xml
%%DATADIR%%/biostruct3d_plugin/BioStruct3DLinks.txt
%%DATADIR%%/cmdline/align-clustalo.uwl
%%DATADIR%%/cmdline/align-clustalw.uwl
%%DATADIR%%/cmdline/align-kalign.uwl
%%DATADIR%%/cmdline/align-mafft.uwl
%%DATADIR%%/cmdline/align-tcoffee.uwl
%%DATADIR%%/cmdline/align.uwl
%%DATADIR%%/cmdline/bowtie-build.uwl
%%DATADIR%%/cmdline/bowtie.uwl
%%DATADIR%%/cmdline/convert-msa.uwl
%%DATADIR%%/cmdline/convert-seq.uwl
%%DATADIR%%/cmdline/extract-sequence.uwl
%%DATADIR%%/cmdline/fetch-sequence.uwl
%%DATADIR%%/cmdline/fetch.uwl
%%DATADIR%%/cmdline/find-orfs.uwl
%%DATADIR%%/cmdline/find-repeats.uwl
%%DATADIR%%/cmdline/find-sw.uwl
%%DATADIR%%/cmdline/gene-by-gene.uwl
%%DATADIR%%/cmdline/generate-dna.uwl
%%DATADIR%%/cmdline/hmm2-build.uwl
%%DATADIR%%/cmdline/hmm2-search.uwl
@ -207,8 +222,7 @@ share/pixmaps/ugene.xpm
%%DATADIR%%/cmdline/revcompl.uwl
%%DATADIR%%/cmdline/sitecon-build.uwl
%%DATADIR%%/cmdline/sitecon-search.uwl
%%DATADIR%%/enzymes/rebase_v003_all.bairoch.gz
%%DATADIR%%/enzymes/rebase_v003_t2_com.bairoch.gz
%%DATADIR%%/enzymes/2013_08_01.bairoch.gz
%%DATADIR%%/license
%%DATADIR%%/position_weight_matrix/JASPAR/all_jaspar.csv
%%DATADIR%%/position_weight_matrix/JASPAR/fungi/MA0265.1.pfm
@ -389,6 +403,131 @@ share/pixmaps/ugene.xpm
%%DATADIR%%/position_weight_matrix/JASPAR/fungi/MA0440.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/fungi/MA0441.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/fungi/matrix_list.txt
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0010.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0011.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0012.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0013.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0015.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0016.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0022.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0023.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0026.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA00445.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0049.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0085.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0086.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0094.2.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0126.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0165.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0166.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0167.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0168.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0169.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0170.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0171.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0172.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0173.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0174.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0175.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0176.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0177.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0178.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0179.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0180.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0181.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0182.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0183.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0184.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0185.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0186.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0187.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0188.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0189.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0190.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0191.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0192.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0193.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0194.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0195.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0196.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0197.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0198.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0199.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0200.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0201.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0202.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0203.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0204.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0205.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0206.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0207.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0208.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0209.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0210.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0211.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0212.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0213.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0214.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0215.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0216.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0217.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0218.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0219.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0220.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0221.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0222.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0223.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0224.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0225.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0226.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0227.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0228.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0229.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0230.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0231.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0232.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0233.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0234.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0235.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0236.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0237.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0238.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0239.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0240.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0241.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0242.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0243.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0244.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0245.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0246.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0247.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0248.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0249.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0250.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0251.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0252.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0253.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0254.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0255.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0256.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0257.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0443.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0444.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0446.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0447.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0448.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0449.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0450.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0451.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0452.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0453.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0454.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0455.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0456.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0457.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0458.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0459.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/MA0460.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/insects/matrix_list.txt
%%DATADIR%%/position_weight_matrix/JASPAR/nematodes/MA0260.1.pfm
%%DATADIR%%/position_weight_matrix/JASPAR/nematodes/MA0261.1.pfm
@ -834,8 +973,6 @@ share/pixmaps/ugene.xpm
%%DATADIR%%/query_samples/RepeatsWithORF.uql
%%DATADIR%%/query_samples/SimpleGene.uql
%%DATADIR%%/samples/ABIF/A01.abi
%%DATADIR%%/samples/ACE/BL060C3.ace
%%DATADIR%%/samples/ACE/K26.ace
%%DATADIR%%/samples/Assembly/chrM.fa
%%DATADIR%%/samples/Assembly/chrM.sam
%%DATADIR%%/samples/Assembly/chrM.sorted.bam
@ -1058,7 +1195,9 @@ share/pixmaps/ugene.xpm
%%DATADIR%%/workflow_samples/Conversions/msa2clustal.uwl
%%DATADIR%%/workflow_samples/Conversions/query2alignment.uwl
%%DATADIR%%/workflow_samples/Conversions/seq2gen.uwl
%%DATADIR%%/workflow_samples/Custom elements/script-create-alignment.uwl
%%DATADIR%%/workflow_samples/Custom elements/script-dump-sequence-info.uwl
%%DATADIR%%/workflow_samples/Custom elements/script-linkdata-fetch-seq.uwl
%%DATADIR%%/workflow_samples/Custom elements/script-quality-filter.uwl
%%DATADIR%%/workflow_samples/Data marking/annotation_marker.uwl
%%DATADIR%%/workflow_samples/Data marking/length_marker.uwl
@ -1067,12 +1206,32 @@ share/pixmaps/ugene.xpm
%%DATADIR%%/workflow_samples/Data merging/tfbs.uwl
%%DATADIR%%/workflow_samples/HMMER/build-test-HMM.uwl
%%DATADIR%%/workflow_samples/HMMER/searchHMM.uwl
%%DATADIR%%/workflow_samples/NGS/call_variants.uwl
%%DATADIR%%/workflow_samples/NGS/cistrome/chip_seq.uwl
%%DATADIR%%/workflow_samples/NGS/cistrome/chip_seq_with_control.uwl
%%DATADIR%%/workflow_samples/NGS/cistrome.uwl
%%DATADIR%%/workflow_samples/NGS/tuxedo/tuxedo_main.uwl
%%DATADIR%%/workflow_samples/NGS/tuxedo/tuxedo_main_paired.uwl
%%DATADIR%%/workflow_samples/NGS/tuxedo/tuxedo_multiple_dataset.uwl
%%DATADIR%%/workflow_samples/NGS/tuxedo/tuxedo_multiple_dataset_paired.uwl
%%DATADIR%%/workflow_samples/NGS/tuxedo/tuxedo_single_dataset.uwl
%%DATADIR%%/workflow_samples/NGS/tuxedo/tuxedo_single_dataset_paired.uwl
%%DATADIR%%/workflow_samples/NGS/tuxedo.uwl
%%DATADIR%%/workflow_samples/Scenarios/filter_matched.uwl
%%DATADIR%%/workflow_samples/Scenarios/find_sequences.uwl
%%DATADIR%%/workflow_samples/Scenarios/gene_by_gene_report.uwl
%%DATADIR%%/workflow_samples/Scenarios/merge_sequence_annotation.uwl
%%DATADIR%%/workflow_samples/Transcriptomics/SearchTFBS.uwl
%%DATADIR%%/workflow_samples/users/CreateAlignment.usa
%%DATADIR%%/workflow_samples/users/Dump sequence info.usa
%%DATADIR%%/workflow_samples/users/LinkData Fetch.usa
%%DATADIR%%/workflow_samples/users/QualityFilter.usa
@dirrm %%DATADIR%%/workflow_samples/users
@dirrm %%DATADIR%%/workflow_samples/Transcriptomics
@dirrm %%DATADIR%%/workflow_samples/Scenarios
@dirrm %%DATADIR%%/workflow_samples/NGS/tuxedo
@dirrm %%DATADIR%%/workflow_samples/NGS/cistrome
@dirrm %%DATADIR%%/workflow_samples/NGS
@dirrm %%DATADIR%%/workflow_samples/HMMER
@dirrm %%DATADIR%%/workflow_samples/Data merging
@dirrm %%DATADIR%%/workflow_samples/Data marking
@ -1100,7 +1259,6 @@ share/pixmaps/ugene.xpm
@dirrm %%DATADIR%%/samples/EMBL
@dirrm %%DATADIR%%/samples/CLUSTALW
@dirrm %%DATADIR%%/samples/Assembly
@dirrm %%DATADIR%%/samples/ACE
@dirrm %%DATADIR%%/samples/ABIF
@dirrm %%DATADIR%%/samples
@dirrm %%DATADIR%%/query_samples