x11/libfm-qt: Update to 0.12.0
PR: 223213 Submitted by: Olivier Duchateau <duchateau.olivier@gmail.com>
This commit is contained in:
parent
d6dc159bdf
commit
c58ec31cab
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=452993
5 changed files with 65 additions and 27 deletions
|
@ -2,10 +2,9 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= libfm-qt
|
||||
PORTVERSION= 0.11.2
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 0.12.0
|
||||
CATEGORIES= x11
|
||||
MASTER_SITES= LXQT/${PORTNAME}
|
||||
MASTER_SITES= LXQT
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Qt port of libfm
|
||||
|
@ -13,14 +12,18 @@ COMMENT= Qt port of libfm
|
|||
LICENSE= LGPL21+
|
||||
|
||||
LIB_DEPENDS= libfm.so:x11/libfm \
|
||||
libmenu-cache.so:x11/menu-cache
|
||||
libmenu-cache.so:x11/menu-cache \
|
||||
libexif.so:graphics/libexif
|
||||
|
||||
USES= cmake:outsource compiler:c++11-lib gettext-runtime lxqt pkgconfig \
|
||||
tar:xz
|
||||
shared-mime-info tar:xz
|
||||
USE_QT5= buildtools_build qmake_build core gui linguisttools widgets \
|
||||
x11extras
|
||||
USE_GNOME= glib20
|
||||
USE_XORG= xcb
|
||||
USE_LXQT= buildtools
|
||||
|
||||
post-install:
|
||||
${RM} -Rf ${STAGEDIR}${PREFIX}/include/${PORTNAME}/tests/
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1482350725
|
||||
SHA256 (lxqt/libfm-qt-0.11.2.tar.xz) = d6154760fd89eea9c4f87acce4c8c692852229ed8d5bbaf25f4a8517024f74fd
|
||||
SIZE (lxqt/libfm-qt-0.11.2.tar.xz) = 130456
|
||||
TIMESTAMP = 1508756298
|
||||
SHA256 (lxqt/libfm-qt-0.12.0.tar.xz) = a2cc4fc811aff6a83507e41770152cb01ea564668a33f4c878c7132a42b4f693
|
||||
SIZE (lxqt/libfm-qt-0.12.0.tar.xz) = 181924
|
||||
|
|
15
x11/libfm-qt/files/patch-src_core_thumbnailjob.cpp
Normal file
15
x11/libfm-qt/files/patch-src_core_thumbnailjob.cpp
Normal file
|
@ -0,0 +1,15 @@
|
|||
--- src/core/thumbnailjob.cpp.orig 2017-10-21 18:56:43 UTC
|
||||
+++ src/core/thumbnailjob.cpp
|
||||
@@ -83,7 +83,12 @@ QImage ThumbnailJob::loadForFile(const s
|
||||
// calculate md5 hash for the uri of the original file
|
||||
g_checksum_update(md5Calc_, reinterpret_cast<const unsigned char*>(uri.get()), -1);
|
||||
memcpy(thumbnailName, g_checksum_get_string(md5Calc_), 32);
|
||||
+#if defined(Q_OS_LINUX)
|
||||
mempcpy(thumbnailName + 32, ".png", 5);
|
||||
+#else
|
||||
+ memcpy(thumbnailName + 32, ".png", 5);
|
||||
+ thumbnailName + 5;
|
||||
+#endif
|
||||
g_checksum_reset(md5Calc_); // reset the checksum calculator for next use
|
||||
|
||||
QString thumbnailFilename = thumbnailDir;
|
|
@ -1,4 +1,4 @@
|
|||
A Qt port of the libfm - a library providing components to build
|
||||
desktop file managers.
|
||||
|
||||
WWW: http://lxqt.org/
|
||||
WWW: https://github.com/lxde/libfm-qt
|
||||
|
|
|
@ -5,37 +5,62 @@ include/libfm-qt/appmenuview.h
|
|||
include/libfm-qt/appmenuview_p.h
|
||||
include/libfm-qt/archiver.h
|
||||
include/libfm-qt/bookmarkaction.h
|
||||
include/libfm-qt/bookmarks.h
|
||||
include/libfm-qt/browsehistory.h
|
||||
include/libfm-qt/cachedfoldermodel.h
|
||||
include/libfm-qt/colorbutton.h
|
||||
include/libfm-qt/config.h
|
||||
include/libfm-qt/core/bookmarks.h
|
||||
include/libfm-qt/core/compat_p.h
|
||||
include/libfm-qt/core/copyjob.h
|
||||
include/libfm-qt/core/cstrptr.h
|
||||
include/libfm-qt/core/deletejob.h
|
||||
include/libfm-qt/core/dirlistjob.h
|
||||
include/libfm-qt/core/filechangeattrjob.h
|
||||
include/libfm-qt/core/fileinfo.h
|
||||
include/libfm-qt/core/fileinfo_p.h
|
||||
include/libfm-qt/core/fileinfojob.h
|
||||
include/libfm-qt/core/filelinkjob.h
|
||||
include/libfm-qt/core/filemonitor.h
|
||||
include/libfm-qt/core/fileoperationjob.h
|
||||
include/libfm-qt/core/filepath.h
|
||||
include/libfm-qt/core/filesysteminfojob.h
|
||||
include/libfm-qt/core/folder.h
|
||||
include/libfm-qt/core/gioptrs.h
|
||||
include/libfm-qt/core/gobjectptr.h
|
||||
include/libfm-qt/core/iconinfo.h
|
||||
include/libfm-qt/core/iconinfo_p.h
|
||||
include/libfm-qt/core/job.h
|
||||
include/libfm-qt/core/job_p.h
|
||||
include/libfm-qt/core/mimetype.h
|
||||
include/libfm-qt/core/terminal.h
|
||||
include/libfm-qt/core/thumbnailer.h
|
||||
include/libfm-qt/core/thumbnailjob.h
|
||||
include/libfm-qt/core/totalsizejob.h
|
||||
include/libfm-qt/core/trashjob.h
|
||||
include/libfm-qt/core/untrashjob.h
|
||||
include/libfm-qt/core/userinfocache.h
|
||||
include/libfm-qt/core/volumemanager.h
|
||||
include/libfm-qt/createnewmenu.h
|
||||
include/libfm-qt/customaction_p.h
|
||||
include/libfm-qt/deepcountjob.h
|
||||
include/libfm-qt/dirlistjob.h
|
||||
include/libfm-qt/customactions/fileaction.h
|
||||
include/libfm-qt/customactions/fileactioncondition.h
|
||||
include/libfm-qt/customactions/fileactionprofile.h
|
||||
include/libfm-qt/dirtreemodel.h
|
||||
include/libfm-qt/dirtreemodelitem.h
|
||||
include/libfm-qt/dirtreeview.h
|
||||
include/libfm-qt/dndactionmenu.h
|
||||
include/libfm-qt/dnddest.h
|
||||
include/libfm-qt/dummymonitor.h
|
||||
include/libfm-qt/editbookmarksdialog.h
|
||||
include/libfm-qt/execfiledialog_p.h
|
||||
include/libfm-qt/file.h
|
||||
include/libfm-qt/fileinfo.h
|
||||
include/libfm-qt/fileinfojob.h
|
||||
include/libfm-qt/filedialog.h
|
||||
include/libfm-qt/filelauncher.h
|
||||
include/libfm-qt/filemenu.h
|
||||
include/libfm-qt/filemenu_p.h
|
||||
include/libfm-qt/fileoperation.h
|
||||
include/libfm-qt/fileoperationdialog.h
|
||||
include/libfm-qt/fileopsjob.h
|
||||
include/libfm-qt/filepropsdialog.h
|
||||
include/libfm-qt/filesearchdialog.h
|
||||
include/libfm-qt/fm-qt_export.h
|
||||
include/libfm-qt/fm-search.h
|
||||
include/libfm-qt/folder.h
|
||||
include/libfm-qt/folderconfig.h
|
||||
include/libfm-qt/folderitemdelegate.h
|
||||
include/libfm-qt/foldermenu.h
|
||||
|
@ -44,17 +69,12 @@ include/libfm-qt/foldermodelitem.h
|
|||
include/libfm-qt/folderview.h
|
||||
include/libfm-qt/folderview_p.h
|
||||
include/libfm-qt/fontbutton.h
|
||||
include/libfm-qt/icon.h
|
||||
include/libfm-qt/icontheme.h
|
||||
include/libfm-qt/job.h
|
||||
include/libfm-qt/libfmqt.h
|
||||
include/libfm-qt/libfmqtglobals.h
|
||||
include/libfm-qt/list.h
|
||||
include/libfm-qt/mimetype.h
|
||||
include/libfm-qt/mountoperation.h
|
||||
include/libfm-qt/mountoperationpassworddialog_p.h
|
||||
include/libfm-qt/mountoperationquestiondialog_p.h
|
||||
include/libfm-qt/navhistory.h
|
||||
include/libfm-qt/path.h
|
||||
include/libfm-qt/pathbar.h
|
||||
include/libfm-qt/pathbar_p.h
|
||||
|
@ -67,9 +87,6 @@ include/libfm-qt/proxyfoldermodel.h
|
|||
include/libfm-qt/renamedialog.h
|
||||
include/libfm-qt/sidepane.h
|
||||
include/libfm-qt/templates.h
|
||||
include/libfm-qt/terminal.h
|
||||
include/libfm-qt/thumbnailer.h
|
||||
include/libfm-qt/thumbnailloader.h
|
||||
include/libfm-qt/utilities.h
|
||||
include/libfm-qt/utilities_p.h
|
||||
include/libfm-qt/utils.h
|
||||
|
@ -82,3 +99,6 @@ share/cmake/fm-qt/fm-qt-config-version.cmake
|
|||
share/cmake/fm-qt/fm-qt-config.cmake
|
||||
share/cmake/fm-qt/fm-qt-targets-%%CMAKE_BUILD_TYPE%%.cmake
|
||||
share/cmake/fm-qt/fm-qt-targets.cmake
|
||||
%%DATADIR%%/archivers.list
|
||||
%%DATADIR%%/terminals.list
|
||||
share/mime/packages/libfm-qt-mimetypes.xml
|
||||
|
|
Loading…
Reference in a new issue