- Add BUILD_DEPENDS/RUN_DEPENDS to devel/pkgconfig
- Support CFLAGS properly - Fix pkg-plist - Do not install useless .la file PR: 36551 Submitted by: KATO Tsuguru <tkato@prontomail.com> Approved by: maintainer
This commit is contained in:
parent
1e5de1c84f
commit
c58f52df89
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=57007
3 changed files with 31 additions and 9 deletions
|
@ -7,15 +7,22 @@
|
|||
|
||||
PORTNAME= libexif
|
||||
PORTVERSION= 0.5.0
|
||||
PORTREVISION=
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR=libexif
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
|
||||
MAINTAINER= pschmied@qwest.net
|
||||
|
||||
INSTALLS_SHLIB= yes
|
||||
HAS_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= # Intentionally blank
|
||||
BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
|
||||
RUN_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
post-patch:
|
||||
@${PERL} -pi -e 's|-g -Wall||g' ${WRKSRC}/configure
|
||||
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${PERL} -pi -e \
|
||||
's|\$$\(libdir\)/pkgconfig|\$$\(prefix\)/libdata/pkgconfig|g'
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
15
graphics/libexif/files/patch-ltmain.sh
Normal file
15
graphics/libexif/files/patch-ltmain.sh
Normal file
|
@ -0,0 +1,15 @@
|
|||
--- ltmain.sh.orig Thu Jan 10 04:26:41 2002
|
||||
+++ ltmain.sh Sun Mar 31 04:02:01 2002
|
||||
@@ -4247,10 +4247,12 @@
|
||||
fi
|
||||
|
||||
# Install the pseudo-library for information purposes.
|
||||
+ if /usr/bin/false; then
|
||||
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
|
||||
instname="$dir/$name"i
|
||||
$show "$install_prog $instname $destdir/$name"
|
||||
$run eval "$install_prog $instname $destdir/$name" || exit $?
|
||||
+ fi
|
||||
|
||||
# Maybe install the static library, too.
|
||||
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
|
|
@ -1,7 +1,3 @@
|
|||
lib/libexif.so.5
|
||||
lib/libexif.so
|
||||
lib/libexif.la
|
||||
lib/libexif.a
|
||||
include/libexif/exif-byte-order.h
|
||||
include/libexif/exif-content.h
|
||||
include/libexif/exif-data.h
|
||||
|
@ -10,4 +6,8 @@ include/libexif/exif-format.h
|
|||
include/libexif/exif-result.h
|
||||
include/libexif/exif-tag.h
|
||||
include/libexif/exif-utils.h
|
||||
lib/libexif.a
|
||||
lib/libexif.so
|
||||
lib/libexif.so.5
|
||||
libdata/pkgconfig/libexif.pc
|
||||
@dirrm include/libexif
|
||||
|
|
Loading…
Reference in a new issue