YAGF is a graphical interface for the cuneiform text recognition
program on the Linux platform. With YAGF you can scan images via XSane, perform images preprocessing and recognize texts using cuneiform from a single command centre. YAGF also makes it easy to scan and recognize several images sequentially. WWW: http://symmetrica.net/cuneiform-linux/yagf-en.html
This commit is contained in:
parent
c0180be414
commit
c5b97e5775
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=241401
7 changed files with 91 additions and 0 deletions
|
@ -955,6 +955,7 @@
|
|||
SUBDIR += xwpick
|
||||
SUBDIR += xzgv
|
||||
SUBDIR += yafray
|
||||
SUBDIR += yagf
|
||||
SUBDIR += yap
|
||||
SUBDIR += zgv
|
||||
SUBDIR += zimg
|
||||
|
|
34
graphics/yagf/Makefile
Normal file
34
graphics/yagf/Makefile
Normal file
|
@ -0,0 +1,34 @@
|
|||
# New ports collection makefile for: graphics/yagf
|
||||
# Date created: 2009-09-11
|
||||
# Whom: bsam
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= yagf
|
||||
PORTVERSION= 0.8.1
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://symmetrica.net/cuneiform-linux/
|
||||
|
||||
MAINTAINER= bsam@FreeBSD.org
|
||||
COMMENT= Graphical interface for the cuneiform OCR program
|
||||
|
||||
LIB_DEPENDS= aspell:${PORTSDIR}/textproc/aspell
|
||||
|
||||
ONLY_FOR_ARCHS= i386 amd64
|
||||
|
||||
USE_CMAKE= yes
|
||||
USE_LDCONFIG= yes
|
||||
USE_GNOME= pkgconfig
|
||||
INSTALLS_ICONS= yes
|
||||
USE_QT_VER= 4
|
||||
QT_COMPONENTS= corelib gui imageformats linguist moc qmake rcc uic
|
||||
|
||||
CPPFLAGS+= -I${LOCALBASE}/include
|
||||
CFLAGS+= -I${LOCALBASE}/include
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
.if ${OSVERSION}<700000
|
||||
IGNORE= does not compile at 6.x
|
||||
.endif
|
||||
.include <bsd.port.post.mk>
|
3
graphics/yagf/distinfo
Normal file
3
graphics/yagf/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
MD5 (yagf-0.8.1.tar.gz) = 72558252cba34003d26ea31fba24ca67
|
||||
SHA256 (yagf-0.8.1.tar.gz) = f520629cf36e346bfa032a12fd6a84b14ab7d48d5e86d1fd3340d94cbb7f4f03
|
||||
SIZE (yagf-0.8.1.tar.gz) = 189938
|
18
graphics/yagf/files/patch-CMakeLists.txt
Normal file
18
graphics/yagf/files/patch-CMakeLists.txt
Normal file
|
@ -0,0 +1,18 @@
|
|||
--- CMakeLists.txt.orig 2009-08-16 20:54:20.000000000 +0400
|
||||
+++ CMakeLists.txt 2009-09-14 13:09:48.000000000 +0400
|
||||
@@ -25,12 +25,12 @@
|
||||
#QT4_CREATE_TRANSLATION(yagf_ru.qm src/mainform.cpp ${MOC_SRCS} ${UI_HEADERS} src/yagf_ru.ts)
|
||||
#set(CMAKE_INSTALL_PREFIX /usr/)
|
||||
if (NOT DEFINED ${CMAKE_INSTALL_PREFIX})
|
||||
-set(CPACK_INSTALL_PREFIX /usr/)
|
||||
-set (CMAKE_INSTALL_PREFIX /usr/)
|
||||
+set(CPACK_INSTALL_PREFIX ${PREFIX})
|
||||
+set(CMAKE_INSTALL_PREFIX ${PREFIX})
|
||||
endif()
|
||||
install_targets(/bin/ yagf)
|
||||
if (CMAKE_SIZEOF_VOID_P EQUAL 8)
|
||||
- set (LIB_PATH_SUFFIX 64)
|
||||
+ set (LIB_PATH_SUFFIX "")
|
||||
set_property (GLOBAL PROPERTY FIND_LIBRARY_USE_LIB64_PATHS TRUE)
|
||||
endif(CMAKE_SIZEOF_VOID_P EQUAL 8)
|
||||
install_targets(/lib${LIB_PATH_SUFFIX}/yagf xspreload)
|
11
graphics/yagf/files/patch-src-FileChannel.cpp
Normal file
11
graphics/yagf/files/patch-src-FileChannel.cpp
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- src/FileChannel.cpp.orig 2009-09-12 13:08:28.000000000 +0400
|
||||
+++ src/FileChannel.cpp 2009-09-12 13:08:41.000000000 +0400
|
||||
@@ -248,7 +248,7 @@
|
||||
|
||||
QString FileChannel::errorString()
|
||||
{
|
||||
- strcpy(lastErrorString, strerror_r(errno, lastErrorString, 0));
|
||||
+ strcpy(lastErrorString, strerror(errno));
|
||||
return QString(trUtf8(lastErrorString));
|
||||
}
|
||||
|
7
graphics/yagf/pkg-descr
Normal file
7
graphics/yagf/pkg-descr
Normal file
|
@ -0,0 +1,7 @@
|
|||
YAGF is a graphical interface for the cuneiform text recognition
|
||||
program on the Linux platform. With YAGF you can scan images via
|
||||
XSane, perform images preprocessing and recognize texts using
|
||||
cuneiform from a single command centre. YAGF also makes it easy to
|
||||
scan and recognize several images sequentially.
|
||||
|
||||
WWW: http://symmetrica.net/cuneiform-linux/yagf-en.html
|
17
graphics/yagf/pkg-plist
Normal file
17
graphics/yagf/pkg-plist
Normal file
|
@ -0,0 +1,17 @@
|
|||
bin/yagf
|
||||
lib/yagf/libxspreload.so
|
||||
share/applications/YAGF.desktop
|
||||
share/icons/hicolor/96x96/apps/yagf.png
|
||||
share/pixmaps/yagf.png
|
||||
share/yagf/translations/yagf_lt.qm
|
||||
share/yagf/translations/yagf_ru.qm
|
||||
@comment those are yagf directories
|
||||
@dirrm lib/yagf
|
||||
@dirrm share/yagf/translations
|
||||
@dirrm share/yagf
|
||||
@comment those are shared directories
|
||||
@dirrmtry share/applications
|
||||
@dirrmtry share/icons/hicolor/96x96/apps
|
||||
@dirrmtry share/icons/hicolor/96x96
|
||||
@dirrmtry share/icons/hicolor
|
||||
@dirrmtry share/icons
|
Loading…
Reference in a new issue