Add QT Linguist - a tool for generating translations of various strings

used in internationalized Qt programs. This is pre-release version.
This commit is contained in:
Maxim Sobolev 2000-10-31 14:50:43 +00:00
parent b0d5c11d3c
commit c5ddda521a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=34495
7 changed files with 160 additions and 0 deletions

View file

@ -146,6 +146,7 @@
SUBDIR += libunicode SUBDIR += libunicode
SUBDIR += libxalloc SUBDIR += libxalloc
SUBDIR += lincvs SUBDIR += lincvs
SUBDIR += linguist
SUBDIR += linux_devtools SUBDIR += linux_devtools
SUBDIR += linux_kdump SUBDIR += linux_kdump
SUBDIR += linuxthreads SUBDIR += linuxthreads

42
devel/linguist/Makefile Normal file
View file

@ -0,0 +1,42 @@
# New ports collection makefile for: linguist
# Date created: 31 October 2000
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= linguist
PORTVERSION= 0.0
CATEGORIES= devel
MASTER_SITES= ftp://ftp.trolltech.com/qt/pre-releases/
DISTNAME= ${PORTNAME}-pre
MAINTAINER= sobomax@FreeBSD.org
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_QT2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
HAS_CONFIGURE= yes
CONFIGURE_ENV= TMAKEPATH="${LOCALBASE}/share/tmake/freebsd-g++" \
QTDIR="${X11BASE}"
MAKE_ENV= TMAKEPATH="${LOCALBASE}/share/tmake/freebsd-g++" \
QTDIR="${X11BASE}" \
MOC="${X11BASE}/bin/moc2"
MAKE_ARGS= -e
post-configure:
@${PERL} -pi -e 's|\$\(SUBDIRS\):.*tmake_all|\$\(SUBDIRS\):|' \
${WRKSRC}/Makefile
@find ${WRKSRC} -name "Makefile" -type f | xargs ${PERL} -pi -e \
's|TARGET.*=.*\$\(QTDIR\)/bin/|TARGET=|'
do-install:
.for file in linguist lrelease lupdate qm2ts
${INSTALL_PROGRAM} ${WRKSRC}/${file}/${file} ${PREFIX}/bin
.endfor
${MKDIR} ${PREFIX}/share/doc/linguist
${INSTALL_MAN} ${WRKSRC}/linguist/tutorial/doc/html/* ${PREFIX}/share/doc/linguist
.include <bsd.port.mk>

1
devel/linguist/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (linguist-pre.tar.gz) = 6ea8e653a409efd0ebce39060e7d808f

View file

@ -0,0 +1,59 @@
--- configure 2000/10/31 13:01:21 1.1
+++ configure 2000/10/31 13:03:15
@@ -9,7 +9,7 @@
exit -1
fi
-if [ ! -f "$TMAKEPATH/../../bin/tmake" ]
+if [ ! -f "$TMAKEPATH/../../../bin/tmake" ]
then
echo "*******************************************************************************"
echo " The tmake utility was not found. This package requires a correctly"
@@ -20,21 +20,21 @@
echo "Creating Makefiles..."
-$TMAKEPATH/../../bin/tmake -o Makefile *.pro 2> /dev/null
+$TMAKEPATH/../../../bin/tmake -o Makefile *.pro 2> /dev/null
cd linguist
-$TMAKEPATH/../../bin/tmake -o Makefile *.pro 2> /dev/null
+$TMAKEPATH/../../../bin/tmake -o Makefile *.pro 2> /dev/null
cd tutorial/tt1
-$TMAKEPATH/../../bin/tmake -o Makefile *.pro 2> /dev/null
+$TMAKEPATH/../../../bin/tmake -o Makefile *.pro 2> /dev/null
cd ../tt2
-$TMAKEPATH/../../bin/tmake -o Makefile *.pro 2> /dev/null
+$TMAKEPATH/../../../bin/tmake -o Makefile *.pro 2> /dev/null
cd ../tt3
-$TMAKEPATH/../../bin/tmake -o Makefile *.pro 2> /dev/null
+$TMAKEPATH/../../../bin/tmake -o Makefile *.pro 2> /dev/null
cd ../../../lrelease
-$TMAKEPATH/../../bin/tmake -o Makefile *.pro 2> /dev/null
+$TMAKEPATH/../../../bin/tmake -o Makefile *.pro 2> /dev/null
cd ../lupdate
-$TMAKEPATH/../../bin/tmake -o Makefile *.pro 2> /dev/null
+$TMAKEPATH/../../../bin/tmake -o Makefile *.pro 2> /dev/null
cd ../qm2ts
-$TMAKEPATH/../../bin/tmake -o Makefile *.pro 2> /dev/null
+$TMAKEPATH/../../../bin/tmake -o Makefile *.pro 2> /dev/null
cd ..
if [ -z "$QTDIR" ]
@@ -46,7 +46,7 @@
exit -1
fi
-if [ ! -f "$QTDIR/lib/libqt.so.2.2.1" -a ! -f "$QTDIR/lib/libqt.a" ]
+if [ ! -f "$QTDIR/lib/libqt2.so.4" -a ! -f "$QTDIR/lib/libqt2.a" ]
then
echo "*******************************************************************************"
echo " The Qt 2.2.1 Library was not found. This package requires a correctly set up"
@@ -55,7 +55,7 @@
exit -1
fi
-if [ ! -f "$QTDIR/bin/moc" ]
+if [ ! -f "$QTDIR/bin/moc2" ]
then
echo "*******************************************************************************"
echo " The moc meta object compiler was not found. This package requires a"

View file

@ -0,0 +1 @@
A tool for generating translations of strings used in i10'ed Qt programs

16
devel/linguist/pkg-descr Normal file
View file

@ -0,0 +1,16 @@
Qt Linguist, localization tool, allows users to seamlessly convert Qt-based
programs from one language to another, simply and intelligently. Qt Linguist
helps with the translation of all visible text in a program, to and from any
language supported by Unicode and the target platforms. A key feature in Qt
Linguist is a specialized editing tool, with many features to help the
translators be more productive and get better results. Qt Linguist will work
with both Qt/Windows and Qt for UNIX.
Qt Linguist also includes a pre-installed intelligent database of multi-lingual
terms to assist in the translation process. Once new translations are made, the
database saves the terms for later re-use. This provides translators a tool
that greatly increases work efficiency as they continue to use the product.
Qt Linguist is distributed under BSD-style license.
WWW: http://www.trolltech.com/company/announce/linguistpre.html

40
devel/linguist/pkg-plist Normal file
View file

@ -0,0 +1,40 @@
bin/linguist
bin/lrelease
bin/lupdate
bin/qm2ts
share/doc/linguist/examples.html
share/doc/linguist/index
share/doc/linguist/propertyindex
share/doc/linguist/titleindex
share/doc/linguist/tt1-main-cpp.html
share/doc/linguist/tt1-tt1-pro.html
share/doc/linguist/tt1.html
share/doc/linguist/tt1_en.png
share/doc/linguist/tt1_la.png
share/doc/linguist/tt2-arrowpad-cpp.html
share/doc/linguist/tt2-arrowpad-h.html
share/doc/linguist/tt2-main-cpp.html
share/doc/linguist/tt2-mainwindow-cpp.html
share/doc/linguist/tt2-mainwindow-h.html
share/doc/linguist/tt2-tt2-pro.html
share/doc/linguist/tt2.html
share/doc/linguist/tt2_en.png
share/doc/linguist/tt2_fr.png
share/doc/linguist/tt2_nl.png
share/doc/linguist/tt3-main-cpp.html
share/doc/linguist/tt3-mainwindow-cpp.html
share/doc/linguist/tt3-mainwindow-h.html
share/doc/linguist/tt3-printpanel-cpp.html
share/doc/linguist/tt3-printpanel-h.html
share/doc/linguist/tt3-tt3-pro.html
share/doc/linguist/tt3-tt3_pt-ts.html
share/doc/linguist/tt3.html
share/doc/linguist/tt3_10_en.png
share/doc/linguist/tt3_10_pt_bad.png
share/doc/linguist/tt3_10_pt_good.png
share/doc/linguist/tt3_11_about_pt.png
share/doc/linguist/tt3_11_en.png
share/doc/linguist/tt3_11_pt.png
share/doc/linguist/ttutorial.html
share/doc/linguist/whatsthis
@dirrm share/doc/linguist