- Add LICENSE

- Simplify patching
- Cosmetic fixes
- Switch to options helpers
This commit is contained in:
Dmitry Marakasov 2016-11-14 09:00:17 +00:00
parent 4ee2188dce
commit c5dfcfc323
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=426094
2 changed files with 15 additions and 9 deletions

View file

@ -9,21 +9,27 @@ MASTER_SITES= LOCAL/nox
MAINTAINER= ports@FreeBSD.org
COMMENT= Simple zapping tool for the Linux DVB S2 API
LICENSE= GPLv2+
BUILD_DEPENDS= ${LOCALBASE}/include/linux/dvb/frontend.h:multimedia/v4l_compat
USES= gmake tar:bzip2
PATCH_STRIP= -p1
USE_CSTD= gnu89
MAKE_ARGS= INCLUDE=-I"${LOCALBASE}/include"
MAKE_ARGS+= CC="${CC}"
MAKE_ARGS+= CXX="${CXX}"
MAKE_ARGS= INCLUDE=-I"${LOCALBASE}/include" \
CC="${CC}" \
CXX="${CXX}"
WRKSRC= ${WRKDIR}/szap-s2-e34f73b254db
PORTDOCS= README
PLIST_FILES= bin/szap-s2
OPTIONS_DEFINE= DOCS
do-install:
(cd ${WRKSRC} && ${INSTALL_PROGRAM} szap-s2 ${STAGEDIR}/${PREFIX}/bin)
${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR})
${INSTALL_PROGRAM} ${WRKSRC}/szap-s2 ${STAGEDIR}/${PREFIX}/bin
do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>

View file

@ -1,5 +1,5 @@
--- a/szap-s2.c
+++ b/szap-s2.c
--- szap-s2.c.orig 2010-01-29 22:54:19 UTC
+++ szap-s2.c
@@ -206,6 +206,7 @@ static char *usage_str =
" -i : run interactively, allowing you to type in channel names\n"
" -p : add pat and pmt to TS recording (implies -r)\n"