- Update to 2.36
This commit is contained in:
parent
dda6583cc3
commit
c6029b28bc
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=249489
14 changed files with 69 additions and 190 deletions
|
@ -6,11 +6,10 @@
|
|||
#
|
||||
|
||||
PORTNAME= glui
|
||||
PORTVERSION= 2.1
|
||||
PORTREVISION= 5
|
||||
PORTVERSION= 2.36
|
||||
CATEGORIES= devel graphics
|
||||
MASTER_SITES= http://www.cs.unc.edu/~rademach/glui/src/release/
|
||||
DISTNAME= glui_v2_1_beta
|
||||
MASTER_SITES= SF/${PORTNAME}/Source/${PORTVERSION}
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= GLUT-based C++ user interface library
|
||||
|
@ -19,21 +18,18 @@ USE_GL= glut
|
|||
USE_GMAKE= yes
|
||||
USE_XORG= xmu xext x11 xi
|
||||
MAKEFILE= makefile
|
||||
ALL_TARGET= # empty
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's:/unc/walk/lib/sgi_irix:${PREFIX}/lib:g; \
|
||||
s:/unc/walk/include:${PREFIX}/include:g; \
|
||||
s:^CFLAGS:#&:; s:^CC=:CC?=gcc #:; \
|
||||
s:^libs =:&${PTHREAD_LIBS}:' ${WRKSRC}/makefile
|
||||
@${MKDIR} ${WRKSRC}/lib ${WRKSRC}/bin
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME}/src
|
||||
|
||||
PLIST_FILES= include/glui.h lib/libglui.a
|
||||
PORTDOCS= *
|
||||
|
||||
do-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/glui.h ${PREFIX}/include
|
||||
${INSTALL_DATA} ${WRKSRC}/lib/libglui.a ${PREFIX}/lib
|
||||
${INSTALL_DATA} ${WRKSRC}/include/GL/glui.h ${PREFIX}/include/
|
||||
${INSTALL_DATA} ${WRKSRC}/lib/libglui.a ${PREFIX}/lib/
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${PREFIX}/share/doc/glui
|
||||
${INSTALL_DATA} ${WRKSRC}/glui_manual.pdf ${PREFIX}/share/doc/glui
|
||||
${MKDIR} ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/glui_manual.pdf ${DOCSDIR}/
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (glui_v2_1_beta.tar.gz) = e8ab926ac22f3fbfe3c82f541b924496
|
||||
SHA256 (glui_v2_1_beta.tar.gz) = 164bc82150812de2af5d00d4af2866193e3396c997a6a21a45afb67aa6c714a6
|
||||
SIZE (glui_v2_1_beta.tar.gz) = 289333
|
||||
MD5 (glui-2.36.tgz) = 9e8d506af9a9428dac09e8cd7bda7c1e
|
||||
SHA256 (glui-2.36.tgz) = c1ef5e83cf338e225ce849f948170cd681c99661a5c2158b4074515926702787
|
||||
SIZE (glui-2.36.tgz) = 562956
|
||||
|
|
|
@ -1,32 +0,0 @@
|
|||
--- algebra3.cpp.orig Fri Jul 9 22:38:46 1999
|
||||
+++ algebra3.cpp Tue Sep 25 21:50:30 2001
|
||||
@@ -505,8 +505,7 @@
|
||||
{ return a*d; }
|
||||
|
||||
vec4 operator * (const mat4& a, const vec4& v) {
|
||||
- #define ROWCOL(i) a.v[i].n[0]*v.n[VX] + a.v[i].n[1]*v.n[VY] \
|
||||
- + a.v[i].n[2]*v.n[VZ] + a.v[i].n[3]*v.n[VW]
|
||||
+ #define ROWCOL(i) a.v[i].n[0]*v.n[VX] + a.v[i].n[1]*v.n[VY] + a.v[i].n[2]*v.n[VZ] + a.v[i].n[3]*v.n[VW]
|
||||
return vec4(ROWCOL(0), ROWCOL(1), ROWCOL(2), ROWCOL(3));
|
||||
#undef ROWCOL
|
||||
}
|
||||
@@ -680,8 +679,7 @@
|
||||
{ return mat3(a.v[0] - b.v[0], a.v[1] - b.v[1], a.v[2] - b.v[2]); }
|
||||
|
||||
mat3 operator * (mat3& a, mat3& b) {
|
||||
- #define ROWCOL(i, j) \
|
||||
- a.v[i].n[0]*b.v[0][j] + a.v[i].n[1]*b.v[1][j] + a.v[i].n[2]*b.v[2][j]
|
||||
+ #define ROWCOL(i, j) a.v[i].n[0]*b.v[0][j] + a.v[i].n[1]*b.v[1][j] + a.v[i].n[2]*b.v[2][j]
|
||||
return mat3(vec3(ROWCOL(0,0), ROWCOL(0,1), ROWCOL(0,2)),
|
||||
vec3(ROWCOL(1,0), ROWCOL(1,1), ROWCOL(1,2)),
|
||||
vec3(ROWCOL(2,0), ROWCOL(2,1), ROWCOL(2,2)));
|
||||
@@ -895,8 +893,7 @@
|
||||
{ return mat4(a.v[0] - b.v[0], a.v[1] - b.v[1], a.v[2] - b.v[2], a.v[3] - b.v[3]); }
|
||||
|
||||
mat4 operator * (mat4& a, mat4& b) {
|
||||
- #define ROWCOL(i, j) a.v[i].n[0]*b.v[0][j] + a.v[i].n[1]*b.v[1][j] + \
|
||||
- a.v[i].n[2]*b.v[2][j] + a.v[i].n[3]*b.v[3][j]
|
||||
+ #define ROWCOL(i, j) a.v[i].n[0]*b.v[0][j] + a.v[i].n[1]*b.v[1][j] + a.v[i].n[2]*b.v[2][j] + a.v[i].n[3]*b.v[3][j]
|
||||
return mat4(
|
||||
vec4(ROWCOL(0,0), ROWCOL(0,1), ROWCOL(0,2), ROWCOL(0,3)),
|
||||
vec4(ROWCOL(1,0), ROWCOL(1,1), ROWCOL(1,2), ROWCOL(1,3)),
|
|
@ -1,12 +0,0 @@
|
|||
--- stdinc.h.orig Fri Jul 9 22:38:46 1999
|
||||
+++ stdinc.h Tue Sep 25 21:50:32 2001
|
||||
@@ -99,8 +99,7 @@
|
||||
|
||||
/************ check if a 2D point lies within a 2D box ***************/
|
||||
#ifndef PT_IN_BOX
|
||||
-#define PT_IN_BOX( x, y, lo_x, hi_x, lo_y, hi_y ) \
|
||||
-( IN_BOUNDS(x,lo_x,hi_x) AND IN_BOUNDS(y,lo_y,hi_y) )
|
||||
+#define PT_IN_BOX( x, y, lo_x, hi_x, lo_y, hi_y ) ( IN_BOUNDS(x,lo_x,hi_x) AND IN_BOUNDS(y,lo_y,hi_y) )
|
||||
#endif
|
||||
|
||||
/****** check if value lies on proper side of another value *****/
|
|
@ -1,19 +0,0 @@
|
|||
--- example1.cpp.orig Sat Oct 5 12:36:47 2002
|
||||
+++ example1.cpp Sat Oct 5 12:37:20 2002
|
||||
@@ -85,7 +85,7 @@
|
||||
|
||||
/**************************************** main() ********************/
|
||||
|
||||
-void main(int argc, char* argv[])
|
||||
+int main(int argc, char* argv[])
|
||||
{
|
||||
/****************************************/
|
||||
/* Initialize GLUT and create window */
|
||||
@@ -136,6 +136,7 @@
|
||||
GLUI_Master.set_glutIdleFunc( myGlutIdle );
|
||||
|
||||
glutMainLoop();
|
||||
+ return 0;
|
||||
}
|
||||
|
||||
|
|
@ -1,17 +0,0 @@
|
|||
--- example2.cpp.orig Sat Oct 5 12:37:42 2002
|
||||
+++ example2.cpp Sat Oct 5 12:38:06 2002
|
||||
@@ -181,7 +181,7 @@
|
||||
|
||||
/**************************************** main() ********************/
|
||||
|
||||
-void main(int argc, char* argv[])
|
||||
+int main(int argc, char* argv[])
|
||||
{
|
||||
/****************************************/
|
||||
/* Initialize GLUT and create window */
|
||||
@@ -244,4 +244,5 @@
|
||||
GLUI_Master.set_glutIdleFunc( myGlutIdle );
|
||||
|
||||
glutMainLoop();
|
||||
+ return 0;
|
||||
}
|
|
@ -1,18 +0,0 @@
|
|||
--- example3.cpp.orig Sat Oct 5 12:42:22 2002
|
||||
+++ example3.cpp Sat Oct 5 12:42:39 2002
|
||||
@@ -263,7 +263,7 @@
|
||||
|
||||
/**************************************** main() ********************/
|
||||
|
||||
-void main(int argc, char* argv[])
|
||||
+int main(int argc, char* argv[])
|
||||
{
|
||||
/****************************************/
|
||||
/* Initialize GLUT and create window */
|
||||
@@ -392,5 +392,6 @@
|
||||
|
||||
/**** Regular GLUT main loop ****/
|
||||
glutMainLoop();
|
||||
+ return 0;
|
||||
}
|
||||
|
|
@ -1,18 +0,0 @@
|
|||
--- example4.cpp.orig Sat Oct 5 12:38:51 2002
|
||||
+++ example4.cpp Sat Oct 5 12:39:16 2002
|
||||
@@ -253,7 +253,7 @@
|
||||
|
||||
/**************************************** main() ********************/
|
||||
|
||||
-void main(int argc, char* argv[])
|
||||
+int main(int argc, char* argv[])
|
||||
{
|
||||
/****************************************/
|
||||
/* Initialize GLUT and create window */
|
||||
@@ -371,5 +371,6 @@
|
||||
/**** Regular GLUT main loop ****/
|
||||
|
||||
glutMainLoop();
|
||||
+ return 0;
|
||||
}
|
||||
|
|
@ -1,18 +0,0 @@
|
|||
--- example5.cpp.orig Sat Oct 5 12:39:00 2002
|
||||
+++ example5.cpp Sat Oct 5 12:39:35 2002
|
||||
@@ -310,7 +310,7 @@
|
||||
|
||||
/**************************************** main() ********************/
|
||||
|
||||
-void main(int argc, char* argv[])
|
||||
+int main(int argc, char* argv[])
|
||||
{
|
||||
/****************************************/
|
||||
/* Initialize GLUT and create window */
|
||||
@@ -478,5 +478,6 @@
|
||||
/**** Regular GLUT main loop ****/
|
||||
|
||||
glutMainLoop();
|
||||
+ return 0;
|
||||
}
|
||||
|
|
@ -1,30 +0,0 @@
|
|||
--- glui.h.orig Sat Oct 5 12:33:27 2002
|
||||
+++ glui.h Sat Oct 5 12:34:09 2002
|
||||
@@ -295,8 +295,8 @@
|
||||
parent_node= child_head = child_tail = next_sibling = prev_sibling = NULL;
|
||||
};
|
||||
|
||||
- friend GLUI_Rollout;
|
||||
- friend GLUI_Main;
|
||||
+ friend class GLUI_Rollout;
|
||||
+ friend class GLUI_Main;
|
||||
};
|
||||
|
||||
|
||||
@@ -559,11 +559,11 @@
|
||||
|
||||
/********** Friend classes *************/
|
||||
|
||||
- friend GLUI_Control;
|
||||
- friend GLUI_Rotation;
|
||||
- friend GLUI_Translation;
|
||||
- friend GLUI;
|
||||
- friend GLUI_Master_Object;
|
||||
+ friend class GLUI_Control;
|
||||
+ friend class GLUI_Rotation;
|
||||
+ friend class GLUI_Translation;
|
||||
+ friend class GLUI;
|
||||
+ friend class GLUI_Master_Object;
|
||||
|
||||
|
||||
/********** Misc functions *************/
|
24
devel/glui/files/patch-glui_list.cpp
Normal file
24
devel/glui/files/patch-glui_list.cpp
Normal file
|
@ -0,0 +1,24 @@
|
|||
--- glui_list.cpp.orig 2007-11-04 08:19:40.000000000 +0300
|
||||
+++ glui_list.cpp 2010-02-08 19:59:12.000000000 +0300
|
||||
@@ -30,7 +30,7 @@
|
||||
|
||||
#include "glui_internal_control.h"
|
||||
#include <cmath>
|
||||
-#include <sys/timeb.h>
|
||||
+#include <sys/time.h>
|
||||
|
||||
/****************************** GLUI_List::GLUI_List() **********/
|
||||
|
||||
@@ -100,9 +100,9 @@
|
||||
{
|
||||
int tmp_line;
|
||||
unsigned long int ms;
|
||||
- timeb time;
|
||||
- ftime(&time);
|
||||
- ms = time.millitm + (time.time)*1000;
|
||||
+ struct timeval tv;
|
||||
+ gettimeofday(&tv, NULL);
|
||||
+ ms = tv.tv_usec/100 + (tv.tv_sec)*1000;
|
||||
|
||||
tmp_line = find_line( local_x-x_abs, local_y-y_abs-5 );
|
||||
if ( tmp_line == -1 ) {
|
27
devel/glui/files/patch-makefile
Normal file
27
devel/glui/files/patch-makefile
Normal file
|
@ -0,0 +1,27 @@
|
|||
--- makefile.orig 2007-08-21 07:59:54.000000000 +0400
|
||||
+++ makefile 2010-02-08 19:56:05.000000000 +0300
|
||||
@@ -9,12 +9,7 @@
|
||||
OPTS=-O0
|
||||
#OPTS=-O2
|
||||
|
||||
-UNAME = $(shell uname)
|
||||
-
|
||||
-ifeq ($(UNAME), Linux)
|
||||
-CXX = g++
|
||||
-CPPFLAGS += $(OPTS) -Wall -pedantic
|
||||
-endif
|
||||
+CPPFLAGS = $(CXXFLAGS) -Wall -pedantic
|
||||
|
||||
#######################################
|
||||
|
||||
@@ -35,8 +30,8 @@
|
||||
# CPPFLAGS += -I/usr/X11R6/include -DGLUI_FREEGLUT
|
||||
|
||||
# (3) GLUT
|
||||
-LIBGLUT = -L/usr/X11R6/lib -lglut
|
||||
-CPPFLAGS += -I/usr/X11R6/include
|
||||
+LIBGLUT = -L${LOCALBASE}/lib -lglut
|
||||
+CPPFLAGS += -I${LOCALBASE}/include
|
||||
|
||||
#######################################
|
||||
|
|
@ -1,7 +1,7 @@
|
|||
GLUI is a GLUT-based C++ user interface library which provides
|
||||
controls such as buttons, check boxes, radio buttons, and spinners to
|
||||
OpenGL applications. It is window-system independent, relying on GLUT
|
||||
to handle all system-dependent issues, such as window and mouse
|
||||
management.
|
||||
controls such as buttons, check boxes, radio buttons, and spinners
|
||||
to OpenGL applications. It is window-system independent, relying
|
||||
on GLUT to handle all system-dependent issues, such as window and
|
||||
mouse management.
|
||||
|
||||
WWW: http://www.cs.unc.edu/~rademach/glui/
|
||||
|
|
|
@ -1,4 +0,0 @@
|
|||
include/glui.h
|
||||
lib/libglui.a
|
||||
%%PORTDOCS%%share/doc/glui/glui_manual.pdf
|
||||
%%PORTDOCS%%@dirrm share/doc/glui
|
Loading…
Reference in a new issue