Picviz is a parallel coordinates plotter which enables easy scripting from
various input (tcpdump, syslog, iptables logs, apache logs, etc..) to visualize your data and discover interesting results quickly. Picviz helps you to create, automate and understand parallel coordinates plots. Its primary goal is to graph data in order to be able to quickly analyze problems and find correlations among variables. With security analysis in mind, the program has been designed to be very flexible, able to graph millions of events. The language is designed to be close to the graphviz graph description language. WWW: http://www.wallinfire.net/picviz PR: 128705 Submitted by: Tim Hemel <ports at timit dot nl>
This commit is contained in:
parent
6fa5598319
commit
c6084df974
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=222732
9 changed files with 174 additions and 0 deletions
|
@ -603,6 +603,7 @@
|
|||
SUBDIR += phplot
|
||||
SUBDIR += phpsview
|
||||
SUBDIR += picturebook
|
||||
SUBDIR += picviz
|
||||
SUBDIR += piddle
|
||||
SUBDIR += pixelize
|
||||
SUBDIR += pixen
|
||||
|
|
26
graphics/picviz/Makefile
Normal file
26
graphics/picviz/Makefile
Normal file
|
@ -0,0 +1,26 @@
|
|||
# New ports collection makefile for: picviz
|
||||
# Date created: 08 Nov 2008
|
||||
# Whom: Tim Hemel
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= picviz
|
||||
PORTVERSION= 0.4
|
||||
CATEGORIES= graphics security
|
||||
MASTER_SITES= http://www.wallinfire.net/picviz/attachment/wiki/ReleasesDownload/
|
||||
DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}?format=raw
|
||||
|
||||
MAINTAINER= ports@timit.nl
|
||||
COMMENT= Parallel coordinates plotter
|
||||
|
||||
LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre \
|
||||
cairo.2:${PORTSDIR}/graphics/cairo
|
||||
|
||||
USE_CMAKE= yes
|
||||
USE_LDCONFIG= yes
|
||||
USE_BISON= build
|
||||
|
||||
MAN1= pcv.1
|
||||
|
||||
.include <bsd.port.mk>
|
3
graphics/picviz/distinfo
Normal file
3
graphics/picviz/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
MD5 (picviz-0.4.tar.gz?format=raw) = 92aecf1465a278095611d01fb4e86d28
|
||||
SHA256 (picviz-0.4.tar.gz?format=raw) = 57a65bf942350904c72c6710cebdebe20c9dea315b865c5ba6128503b70624f2
|
||||
SIZE (picviz-0.4.tar.gz?format=raw) = 1587160
|
8
graphics/picviz/files/patch-doc-CMakeLists.txt
Normal file
8
graphics/picviz/files/patch-doc-CMakeLists.txt
Normal file
|
@ -0,0 +1,8 @@
|
|||
--- doc/CMakeLists.txt.orig 2008-10-27 14:39:31.000000000 +0300
|
||||
+++ doc/CMakeLists.txt 2008-11-10 01:56:33.000000000 +0300
|
||||
@@ -1,4 +1,4 @@
|
||||
set(manpages pcv.1)
|
||||
|
||||
-install(FILES ${manpages} DESTINATION ${CMAKE_INSTALL_PREFIX}/share/man/${MAN_DIR}/man1)
|
||||
+install(FILES ${manpages} DESTINATION ${CMAKE_INSTALL_PREFIX}/man/man1)
|
||||
|
27
graphics/picviz/files/patch-src-libpicviz-CMakeLists.txt
Normal file
27
graphics/picviz/files/patch-src-libpicviz-CMakeLists.txt
Normal file
|
@ -0,0 +1,27 @@
|
|||
--- src/libpicviz/CMakeLists.txt.orig 2008-10-27 14:39:31.000000000 +0300
|
||||
+++ src/libpicviz/CMakeLists.txt 2008-11-10 02:00:01.000000000 +0300
|
||||
@@ -1,7 +1,7 @@
|
||||
add_subdirectory(plugins)
|
||||
#add_subdirectory(bindings)
|
||||
|
||||
-include_directories(${picviz_SOURCE_DIR}/src/libpicviz/include ${picviz_SOURCE_DIR}/src/libpicviz/parser ${picviz_SOURCE_DIR}/src/libpicviz/props)
|
||||
+include_directories(${picviz_SOURCE_DIR}/src/libpicviz/include ${picviz_SOURCE_DIR}/src/libpicviz/parser ${picviz_SOURCE_DIR}/src/libpicviz/props ${PCRE_INCLUDE_DIR})
|
||||
|
||||
#set(CMAKE_SHARED_LINKER_FLAGS "-lm -lfl -ly")
|
||||
configure_file(
|
||||
@@ -26,7 +26,7 @@
|
||||
|
||||
set_target_properties(picviz PROPERTIES SOVERSION 1)
|
||||
|
||||
-target_link_libraries(picviz "-lm -ldl")
|
||||
+target_link_libraries(picviz "-lm")
|
||||
|
||||
install(TARGETS picviz LIBRARY DESTINATION ${LIB_INSTALL_DIR})
|
||||
INSTALL(FILES
|
||||
@@ -55,5 +55,5 @@
|
||||
PERMISSIONS OWNER_READ GROUP_READ WORLD_READ)
|
||||
|
||||
INSTALL(FILES ${picviz_BINARY_DIR}/src/libpicviz/picviz.pc
|
||||
- DESTINATION ${LIB_INSTALL_DIR}/pkgconfig/ )
|
||||
+ DESTINATION ${CMAKE_INSTALL_PREFIX}/libdata/pkgconfig/ )
|
||||
|
51
graphics/picviz/files/patch-src-libpicviz-parser-lexer.l
Normal file
51
graphics/picviz/files/patch-src-libpicviz-parser-lexer.l
Normal file
|
@ -0,0 +1,51 @@
|
|||
--- src/libpicviz/parser/lexer.l.orig 2008-10-27 12:39:31.000000000 +0100
|
||||
+++ src/libpicviz/parser/lexer.l 2008-11-08 17:11:55.000000000 +0100
|
||||
@@ -19,7 +19,27 @@
|
||||
static char *realfile;
|
||||
|
||||
void yyerror (char *s);
|
||||
+
|
||||
+#ifdef __FreeBSD__
|
||||
+char* strndup(const char* string, size_t n)
|
||||
+{
|
||||
+ char* copy_string = 0;
|
||||
+
|
||||
+ if(0 == string || 0 == n)
|
||||
+ return 0;
|
||||
+
|
||||
+ copy_string = (char*) malloc(n + 1);
|
||||
+ if(0 == copy_string)
|
||||
+ return 0;
|
||||
+
|
||||
+ memcpy(copy_string, string, n);
|
||||
+ *(copy_string + n) = '\0';
|
||||
+
|
||||
+ return copy_string;
|
||||
+}
|
||||
+#else
|
||||
char * strndup (const char *s, size_t n);
|
||||
+#endif
|
||||
|
||||
#define MAX_INCLUDE_DEPTH 10
|
||||
YY_BUFFER_STATE includes[MAX_INCLUDE_DEPTH];
|
||||
@@ -48,7 +68,20 @@
|
||||
return str;
|
||||
}
|
||||
|
||||
+void yyset_lineno(int line_number) {
|
||||
+ yylineno = line_number;
|
||||
+}
|
||||
+
|
||||
+int yyget_lineno() {
|
||||
+ return yylineno;
|
||||
+}
|
||||
+
|
||||
+char * yyget_text() {
|
||||
+ return yytext;
|
||||
+}
|
||||
+
|
||||
%}
|
||||
+%option yylineno
|
||||
%option noyywrap
|
||||
|
||||
SECTION (header|engine|axes|data)
|
10
graphics/picviz/files/patch-src-libpicviz-values-mapping.c
Normal file
10
graphics/picviz/files/patch-src-libpicviz-values-mapping.c
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- src/libpicviz/values-mapping.c.orig 2008-11-08 16:07:44.000000000 +0100
|
||||
+++ src/libpicviz/values-mapping.c 2008-11-08 16:08:33.000000000 +0100
|
||||
@@ -24,6 +24,7 @@
|
||||
#include <sys/socket.h>
|
||||
#include <netdb.h>
|
||||
#include <ctype.h>
|
||||
+#include <netinet/in.h>
|
||||
|
||||
|
||||
#if defined(__linux__) && ! defined(__USE_XOPEN)
|
15
graphics/picviz/pkg-descr
Normal file
15
graphics/picviz/pkg-descr
Normal file
|
@ -0,0 +1,15 @@
|
|||
Picviz is a parallel coordinates plotter which enables easy scripting from
|
||||
various input (tcpdump, syslog, iptables logs, apache logs, etc..) to visualize
|
||||
your data and discover interesting results quickly.
|
||||
|
||||
Picviz helps you to create, automate and understand parallel coordinates plots.
|
||||
|
||||
Its primary goal is to graph data in order to be able to quickly analyze
|
||||
problems and find correlations among variables. With security analysis in mind,
|
||||
the program has been designed to be very flexible, able to graph millions of
|
||||
events.
|
||||
|
||||
The language is designed to be close to the graphviz graph description
|
||||
language.
|
||||
|
||||
WWW: http://www.wallinfire.net/picviz
|
33
graphics/picviz/pkg-plist
Normal file
33
graphics/picviz/pkg-plist
Normal file
|
@ -0,0 +1,33 @@
|
|||
bin/pcv
|
||||
include/picviz/axis.h
|
||||
include/picviz/common.h
|
||||
include/picviz/correlation.h
|
||||
include/picviz/debug.h
|
||||
include/picviz/defaults.h
|
||||
include/picviz/draw.h
|
||||
include/picviz/engine.h
|
||||
include/picviz/filter.h
|
||||
include/picviz/image.h
|
||||
include/picviz/learn.h
|
||||
include/picviz/line.h
|
||||
include/picviz/linuxlist.h
|
||||
include/picviz/pcimage.h
|
||||
include/picviz/picviz-pcre.h
|
||||
include/picviz/picviz.h
|
||||
include/picviz/plugins.h
|
||||
include/picviz/properties.h
|
||||
include/picviz/render.h
|
||||
include/picviz/types.h
|
||||
include/picviz/values-mapping.h
|
||||
include/picviz/variable.h
|
||||
lib/libpicviz.so
|
||||
lib/libpicviz.so.1
|
||||
lib/picviz/libpicvizoutcsv.so
|
||||
lib/picviz/libpicvizoutdebug.so
|
||||
lib/picviz/libpicvizoutpngcairo.so
|
||||
lib/picviz/libpicvizoutsvg.so
|
||||
lib/picviz/libpicvizrendebug.so
|
||||
lib/picviz/libpicvizrenheatline.so
|
||||
libdata/pkgconfig/picviz.pc
|
||||
@dirrm lib/picviz
|
||||
@dirrm include/picviz
|
Loading…
Reference in a new issue