science/py-h5py: Update to 2.7.1

Additional port changes:
* Changed to DISTVERSION
* Grouped USExx
* Added USE_PYTHON=concurrent (for docs, examples)
* Removed patching (in post-patch and files/)
* Added stripping
* Updated WWW

Approved by:	tcberner (mentor, implicit)
This commit is contained in:
Yuri Victorovich 2018-02-25 01:24:18 +00:00
parent 2615879be7
commit c61d2c3b30
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=462889
4 changed files with 11 additions and 25 deletions

View file

@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= h5py
PORTVERSION= 2.7.0
DISTVERSION= 2.7.1
CATEGORIES= science python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@ -19,10 +19,9 @@ LIB_DEPENDS= libhdf5.so:science/hdf5
RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${FLAVOR}
USE_GITHUB= yes
USES= python
USE_PYTHON= autoplist distutils cython
USE_GITHUB= yes
USE_PYTHON= distutils cython autoplist concurrent
PORTDOCS= *
PORTEXAMPLES= multiprocessing_example.py swmr_multiprocess.py \
@ -30,9 +29,6 @@ PORTEXAMPLES= multiprocessing_example.py swmr_multiprocess.py \
OPTIONS_DEFINE= DOCS EXAMPLES
post-patch:
${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|' ${WRKSRC}/setup_build.py
do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.rst ${STAGEDIR}${DOCSDIR}
@ -42,7 +38,10 @@ do-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${PORTEXAMPLES:S|^|${WRKSRC}/examples/|} ${STAGEDIR}${EXAMPLESDIR}
post-install:
@${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/h5py/*.so
do-test:
cd ${WRKSRC} && ${PYTHON_CMD} ${PYSETUP} test
@cd ${WRKSRC} && ${PYTHON_CMD} ${PYSETUP} test
.include <bsd.port.mk>

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1496507199
SHA256 (h5py-h5py-2.7.0_GH0.tar.gz) = fff3a878c6adfa1b4f5c30b558a295d52dd4fee9174128c626ef416dec1b536b
SIZE (h5py-h5py-2.7.0_GH0.tar.gz) = 265122
TIMESTAMP = 1519520436
SHA256 (h5py-h5py-2.7.1_GH0.tar.gz) = 55bdefda47c49973ec24384097d18eb5f84797c057aaf0bf0b6b0f7860ad43e7
SIZE (h5py-h5py-2.7.1_GH0.tar.gz) = 268457

View file

@ -1,13 +0,0 @@
--- setup_build.py.orig 2017-06-03 16:40:14 UTC
+++ setup_build.py
@@ -49,8 +49,8 @@ if sys.platform.startswith('win'):
('H5_BUILT_AS_DYNAMIC_LIB', None)
])
else:
- COMPILER_SETTINGS['include_dirs'].extend(['/opt/local/include''/usr/local/include'])
- COMPILER_SETTINGS['library_dirs'].extend(['/opt/local/include''/usr/local/include'])
+ COMPILER_SETTINGS['include_dirs'].extend(['%%PREFIX%%/include'])
+ COMPILER_SETTINGS['library_dirs'].extend(['%%PREFIX%%/lib'])
class h5py_build_ext(build_ext):

View file

@ -9,4 +9,4 @@ to the existing HDF5 API and abstractions, so that Python programs can
easily deal with HDF5 files and exchange data with other HDF5-aware
applications.
WWW: http://h5py.alfven.org
WWW: https://www.h5py.org