Contribute a port of SGB, the Stanford Graphbase by Donald E. Knuth, which

is a workbench for combinatorial computing and provides standard sets of
data that can be used for benchmark tests of competing methods.

Reviewed by:	obrien
This commit is contained in:
Gerald Pfeifer 2003-05-04 15:33:32 +00:00
parent d96f3b1ef3
commit c62f34b607
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=80110
6 changed files with 98 additions and 0 deletions

View file

@ -846,6 +846,7 @@
SUBDIR += semantic
SUBDIR += semantic-emacs20
SUBDIR += sfio
SUBDIR += sgb
SUBDIR += sh-rtems-binutils
SUBDIR += sh-rtems-g77
SUBDIR += sh-rtems-gcc

23
devel/sgb/Makefile Normal file
View file

@ -0,0 +1,23 @@
# New ports collection makefile for: sgb
# Date created: 2003-02-05
# Whom: Gerald Pfeifer <gerald@freebsd.org>
#
# $FreeBSD$
#
PORTNAME= sgb
PORTVERSION= 20020425
CATEGORIES= devel
MASTER_SITES= ftp://labrea.stanford.edu/pub/sgb/
DISTNAME= sgb
MAINTAINER= gerald@FreeBSD.org
COMMENT= The Stanford GraphBase: A Platform for Combinatorial Computing
BUILD_DEPENDS= ctangle:${PORTSDIR}/devel/cweb
USE_REINPLACE= yes
NO_WRKSUBDIR= yes
ALL_TARGET= lib tests
.include <bsd.port.mk>

1
devel/sgb/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (sgb.tar.gz) = 1a4143754aeb5913785aaa7d6b9931ff

View file

@ -0,0 +1,30 @@
--- Makefile.orig Mon Dec 27 23:27:24 1999
+++ Makefile Fri May 2 14:43:29 2003
@@ -8,22 +8,22 @@
# current directory. (Not recommended for serious users.)
# Change SGBDIR to the directory where all GraphBase files will go:
-SGBDIR = /usr/local/sgb
+SGBDIR = ${PREFIX}
# Change DATADIR to the directory where GraphBase data files will go:
-DATADIR = $(SGBDIR)/data
+DATADIR = $(SGBDIR)/lib/sgb
# Change INCLUDEDIR to the directory where GraphBase header files will go:
INCLUDEDIR = $(SGBDIR)/include
# Change LIBDIR to the directory where GraphBase library routines will go:
-LIBDIR = /usr/local/lib
+LIBDIR = $(SGBDIR)/lib
# Change BINDIR to the directory where installdemos will put demo programs:
-BINDIR = /usr/local/bin
+BINDIR = $(SGBDIR)/bin
# Change CWEBINPUTS to the directory where CWEB include files will go:
-CWEBINPUTS = /usr/local/lib/cweb
+CWEBINPUTS = $(SGBDIR)/lib/cweb
# SHORTCUT: Uncomment these lines, for single-directory installation:
#DATADIR = .

8
devel/sgb/pkg-descr Normal file
View file

@ -0,0 +1,8 @@
A workbench for combinatorial computing, and standard sets of data that
can be used for benchmark tests of competing methods by Donald Knuth.
Also includes demonstration programs and games that make use of the data.
WWW: http://www-cs-faculty.stanford.edu/~knuth/sgb.html
- Gerald Pfeifer
gerald@FreeBSD.org

35
devel/sgb/pkg-plist Normal file
View file

@ -0,0 +1,35 @@
include/gb_flip.h
include/gb_save.h
include/gb_dijk.h
include/gb_words.h
include/gb_roget.h
include/gb_rand.h
include/gb_raman.h
include/gb_plane.h
include/gb_miles.h
include/gb_lisa.h
include/gb_gates.h
include/gb_games.h
include/gb_econ.h
include/gb_books.h
include/gb_basic.h
include/gb_sort.h
include/gb_io.h
include/gb_graph.h
include/Makefile
lib/libgb.a
lib/cweb/gb_types.w
lib/cweb/boilerplate.w
lib/sgb/anna.dat
lib/sgb/david.dat
lib/sgb/econ.dat
lib/sgb/games.dat
lib/sgb/homer.dat
lib/sgb/huck.dat
lib/sgb/jean.dat
lib/sgb/lisa.dat
lib/sgb/miles.dat
lib/sgb/roget.dat
lib/sgb/words.dat
@dirrm lib/cweb
@dirrm lib/sgb