Update to v1.1.
Submitted by: greg@greg.rim.or.jp (Kensaku Masuda) PR: ports/16600 # I don't like to use directory ${PREFIX}/docs. But it seems it is # difficult to move it to somewhere.
This commit is contained in:
parent
145cf70f67
commit
c6e27288e4
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=25644
10 changed files with 223 additions and 85 deletions
|
@ -1,47 +1,42 @@
|
|||
# New ports collection makefile for: apache mod_jserv
|
||||
# Version required: 1.0
|
||||
# Version required: 1.1
|
||||
# Date created: 1999/05/29
|
||||
# Whom: Kensaku Masuda <greg@greg.rim.or.jp>
|
||||
#
|
||||
# $FreeBSD$
|
||||
|
||||
DISTNAME= Apache_JServ_1.0
|
||||
PKGNAME= apache-jserv-1.0
|
||||
DISTNAME= ApacheJServ-1.1
|
||||
PKGNAME= apache-jserv-1.1
|
||||
CATEGORIES= www java
|
||||
MASTER_SITES= http://java.apache.org/jserv/dist/
|
||||
|
||||
MAINTAINER= greg@greg.rim.or.jp
|
||||
|
||||
BUILD_DEPENDS= ${PREFIX}/jdk1.1.8/bin/javac:${PORTSDIR}/java/jdk\
|
||||
${PREFIX}/sbin/apachectl:${PORTSDIR}/www/apache13\
|
||||
${PREFIX}/share/java/classes/jsdk.jar:${PORTSDIR}/java/jsdk
|
||||
RUN_DEPENDS= ${PREFIX}/jdk1.1.8/bin/java:${PORTSDIR}/java/jdk\
|
||||
${PREFIX}/sbin/apachectl:${PORTSDIR}/www/apache13\
|
||||
${PREFIX}/share/java/classes/jsdk.jar:${PORTSDIR}/java/jsdk
|
||||
BUILD_DEPENDS= ${LOCALBASE}/jdk1.1.8/bin/javac:${PORTSDIR}/java/jdk\
|
||||
${LOCALBASE}/sbin/apachectl:${PORTSDIR}/www/apache13\
|
||||
${LOCALBASE}/share/java/classes/jsdk.jar:${PORTSDIR}/java/jsdk
|
||||
RUN_DEPENDS= ${LOCALBASE}/jdk1.1.8/bin/java:${PORTSDIR}/java/jdk\
|
||||
${LOCALBASE}/sbin/apachectl:${PORTSDIR}/www/apache13\
|
||||
${LOCALBASE}/share/java/classes/jsdk.jar:${PORTSDIR}/java/jsdk
|
||||
|
||||
WRKSRC= ${WRKDIR}/ApacheJServ-1.0
|
||||
USE_LIBTOOL= yes
|
||||
CONFIGURE_TARGET=
|
||||
USE_GMAKE= yes
|
||||
CONFIGURE_ENV= MAKE=${LOCALBASE}/bin/${GMAKE}
|
||||
CONFIGURE_ARGS= --prefix=${PREFIX}\
|
||||
--libexecdir=${PREFIX}/libexec/apache\
|
||||
--libdir=${PREFIX}/libexec/apache\
|
||||
--libexecdir=${LOCALBASE}/libexec/apache\
|
||||
--libdir=${LOCALBASE}/libexec/apache\
|
||||
--with-logdir=/var/log\
|
||||
--sysconfdir=${PREFIX}/etc/apache\
|
||||
--with-jdk-home=${PREFIX}/jdk1.1.8\
|
||||
--with-jsdk=${PREFIX}/share/java/classes/jsdk.jar\
|
||||
--with-apache-install=${PREFIX}\
|
||||
--with-java=${PREFIX}/jdk1.1.8/bin/java\
|
||||
--with-javac=${PREFIX}/jdk1.1.8/bin/javac\
|
||||
--with-jdk-home=${LOCALBASE}/jdk1.1.8\
|
||||
--with-JSDK=${LOCALBASE}/share/java/classes/jsdk.jar\
|
||||
--with-java=${LOCALBASE}/jdk1.1.8/bin/java\
|
||||
--with-javac=${LOCALBASE}/jdk1.1.8/bin/javac\
|
||||
--with-servlets=${PREFIX}/share/java/servlets\
|
||||
--with-gnu-ld\
|
||||
--enable-compressed-jar
|
||||
--enable-compressed-jar\
|
||||
--enable-EAPI
|
||||
|
||||
post-install:
|
||||
@(cd ${WRKSRC}/conf;\
|
||||
${INSTALL_DATA} httpd.conf \
|
||||
${PREFIX}/etc/apache/jserv.conf.default;\
|
||||
${INSTALL_DATA} jserv.properties \
|
||||
${PREFIX}/etc/apache/jserv.properties.default; \
|
||||
${INSTALL_DATA} zone.properties \
|
||||
${PREFIX}/etc/apache/zone.properties.default)
|
||||
@${CAT} ${PKGDIR}/MESSAGE
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (Apache_JServ_1.0.tar.gz) = 772027454979e53a51c5ceefe3860ed6
|
||||
MD5 (ApacheJServ-1.1.tar.gz) = 0a34cc05670dd44eac1a5d6f785ab5af
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
--- docs/Makefile.in.orig Sat Jun 12 05:47:51 1999
|
||||
+++ docs/Makefile.in Sat Jun 26 23:45:33 1999
|
||||
@@ -87,7 +87,7 @@
|
||||
--- docs/Makefile.in.orig Wed Jan 26 18:21:50 2000
|
||||
+++ docs/Makefile.in Wed Jan 26 18:22:14 2000
|
||||
@@ -115,7 +115,7 @@
|
||||
|
||||
DOCFILES = $(strip $(shell ls $(EXTRA_DIST)))
|
||||
|
||||
-docdir = ${prefix}/docs
|
||||
+docdir = ${prefix}/share/doc/mod_jserv
|
||||
doc_DATA = $(DOCFILES)
|
||||
mkinstalldirs = $(SHELL) $(top_srcdir)/src/scripts/build/unix/mkinstalldirs
|
||||
CONFIG_CLEAN_FILES =
|
||||
DIST_COMMON = Makefile.am Makefile.in
|
||||
|
|
|
@ -1,35 +1,11 @@
|
|||
--- conf/httpd.conf.in.orig Sat Jun 12 05:38:46 1999
|
||||
+++ conf/httpd.conf.in Thu Jul 1 00:07:44 1999
|
||||
@@ -6,7 +6,7 @@
|
||||
# Note: this file should be appended to or included in httpd.conf
|
||||
|
||||
# Tell Apache on win32 to load the Apache JServ communication module
|
||||
-#LoadModule jserv_module modules/ApacheModuleJServ.dll
|
||||
+LoadModule jserv_module libexec/apache/mod_jserv.so
|
||||
|
||||
<IfModule mod_jserv.c>
|
||||
|
||||
@@ -19,13 +19,13 @@
|
||||
# In manual mode this directive is ignored
|
||||
# Syntax: ApJServProperties [filename]
|
||||
# Default: "./conf/jserv.properties"
|
||||
-ApJServProperties ./conf/jserv.properties
|
||||
+ApJServProperties etc/apache/jserv.properties
|
||||
|
||||
# Log file for this module operation relative to Apache root directory.
|
||||
# Syntax: ApJServLogFile [filename]
|
||||
--- conf/jserv.conf.in.orig Wed Jan 26 18:37:20 2000
|
||||
+++ conf/jserv.conf.in Wed Jan 26 18:38:36 2000
|
||||
@@ -40,7 +40,7 @@
|
||||
# Syntax: ApJServLogFile [filename]
|
||||
# Default: "./logs/mod_jserv.log"
|
||||
# Note: when set to "DISABLED", the log will be redirected to Apache error log
|
||||
-ApJServLogFile ./logs/mod_jserv.log
|
||||
-ApJServLogFile @JSERV_LOG@/mod_jserv.log
|
||||
+ApJServLogFile /var/log/mod_jserv.log
|
||||
|
||||
# Log Level for this module
|
||||
# Syntax: ApJServLogLevel [debug|info|notice|warn|error|crit|alert|emerg]
|
||||
@@ -99,6 +99,7 @@
|
||||
#ApJServAction .jsp /servlets/nl.nmg.jsp.JSPServlet
|
||||
#ApJServAction .gsp /servlets/com.bitmechanics.gsp.GspServlet
|
||||
#ApJServAction .jhtml /servlets/org.apache.servlet.ssi.SSI
|
||||
+# Uncomment if you use Cocoon.
|
||||
#ApJServAction .xml /servlets/org.apache.cocoon.Cocoon
|
||||
|
||||
# Enable the Apache JServ status handler with the URL of
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
--- conf/jserv.properties.in.orig Sat Jun 12 05:38:46 1999
|
||||
+++ conf/jserv.properties.in Tue Jun 29 23:02:02 1999
|
||||
@@ -52,8 +52,15 @@
|
||||
# Note: the classes you want to be automatically reloaded upon modification
|
||||
--- conf/jserv.properties.in.orig Wed Jan 26 18:26:31 2000
|
||||
+++ conf/jserv.properties.in Wed Jan 26 18:28:44 2000
|
||||
@@ -53,8 +53,15 @@
|
||||
# MUST NOT be in this classpath or the classpath of the shell
|
||||
# you start the Apache from.
|
||||
#
|
||||
-wrapper.classpath=@JSERV_CLASSES@
|
||||
+wrapper.classpath=@libexecdir@/ApacheJServ.jar
|
||||
wrapper.classpath=@JSDK_CLASSES@
|
||||
|
@ -16,8 +16,8 @@
|
|||
+#wrapper.classpath=@prefix@/share/java/classes/lotusxsl.jar
|
||||
|
||||
# An environment name with value passed to the JVM
|
||||
# Syntax: wrapper.env=[name]=[value]
|
||||
@@ -94,7 +101,7 @@
|
||||
# Syntax: wrapper.env=[name]=[value] (String)
|
||||
@@ -117,7 +124,7 @@
|
||||
# Syntax: [servlet zone name as on the zones list].properties=[full path to configFile] (String)
|
||||
# Default: NONE
|
||||
# Note: if the file could not be opened, try using absolute paths.
|
||||
|
@ -25,8 +25,8 @@
|
|||
+root.properties=@sysconfdir@/zone.properties
|
||||
|
||||
#
|
||||
# Security parameters
|
||||
@@ -177,7 +184,7 @@
|
||||
# Thread Pool parameters
|
||||
@@ -247,7 +254,7 @@
|
||||
# Syntax: log.file=[log path and filename] (String)
|
||||
# Default: NONE
|
||||
# Note: if the file could not be opened, try using absolute paths.
|
||||
|
|
|
@ -1,15 +1,15 @@
|
|||
--- conf/zone.properties.in~ Fri Feb 19 13:09:29 1999
|
||||
+++ conf/zone.properties.in Tue Jun 29 23:04:05 1999
|
||||
--- conf/zone.properties.in.orig Wed Jan 26 18:30:38 2000
|
||||
+++ conf/zone.properties.in Wed Jan 26 18:31:53 2000
|
||||
@@ -23,6 +23,8 @@
|
||||
# here.
|
||||
|
||||
repositories=
|
||||
repositories=@JSERV_REPO@
|
||||
+# Uncomment if you use Cocoon.
|
||||
+#repositories=@prefix@/share/java/classes/Cocoon.jar
|
||||
|
||||
# Classloader parameters
|
||||
#########################
|
||||
@@ -133,6 +135,8 @@
|
||||
@@ -141,6 +143,8 @@
|
||||
# Syntax: servlet.[classname].initArgs=[name]=[value],[name]=[value],...
|
||||
# Default: NONE
|
||||
# servlet.org.fool.Dummy.initArgs=message=I'm a dummy servlet
|
||||
|
|
30
www/apache-jserv/files/patch-af
Normal file
30
www/apache-jserv/files/patch-af
Normal file
|
@ -0,0 +1,30 @@
|
|||
--- src/java/org/apache/java/lang/AdaptiveClassLoader.java.orig Tue Feb 8 18:37:01 2000
|
||||
+++ src/java/org/apache/java/lang/AdaptiveClassLoader.java Tue Feb 8 20:33:18 2000
|
||||
@@ -661,7 +661,18 @@
|
||||
ZipEntry entry = zipfile.getEntry(name);
|
||||
|
||||
if (entry != null) {
|
||||
- return zipfile.getInputStream(entry);
|
||||
+ InputStream stream = zipfile.getInputStream(entry);
|
||||
+ byte data[] = new byte[(int)entry.getSize()];
|
||||
+ for(int i = 0 ; i < data.length ;) {
|
||||
+ int size = stream.read(data, i, data.length - i);
|
||||
+ if(size < 0) {
|
||||
+ stream.close();
|
||||
+ return null;
|
||||
+ }
|
||||
+ i += size;
|
||||
+ }
|
||||
+ stream.close();
|
||||
+ return new ByteArrayInputStream(data);;
|
||||
} else {
|
||||
return null;
|
||||
}
|
||||
@@ -671,6 +682,7 @@
|
||||
if ( zipfile != null ) {
|
||||
try {
|
||||
zipfile.close();
|
||||
+ zipfile = null;
|
||||
} catch ( IOException ignored ) {
|
||||
}
|
||||
}
|
31
www/apache-jserv/files/patch-ag
Normal file
31
www/apache-jserv/files/patch-ag
Normal file
|
@ -0,0 +1,31 @@
|
|||
--- src/java/org/apache/jserv/JServConnection.java.orig Wed Feb 9 00:05:03 2000
|
||||
+++ src/java/org/apache/jserv/JServConnection.java Wed Feb 9 00:15:59 2000
|
||||
@@ -1062,6 +1062,14 @@
|
||||
* known.
|
||||
*/
|
||||
public String getRemoteUser() {
|
||||
+ String type = getAuthType();
|
||||
+ if(type == null) {
|
||||
+ return (String) env_vars.get("REMOTE_USER");
|
||||
+ } else if(type.equalsIgnoreCase("SSL")) {
|
||||
+ String name = (String)env_vars.get("SSL_CLIENT_DN");
|
||||
+ name = name.replace('/', ',');
|
||||
+ return name.substring(1);
|
||||
+ }
|
||||
return (String) env_vars.get("REMOTE_USER");
|
||||
}
|
||||
|
||||
@@ -1072,7 +1080,12 @@
|
||||
* @return this request's authentication scheme, or null if none.
|
||||
*/
|
||||
public String getAuthType() {
|
||||
- return (String) env_vars.get("AUTH_TYPE");
|
||||
+ String temp = (String) env_vars.get("SSL_CLIENT_DN");
|
||||
+ if(temp != null && temp.equals("") == false) {
|
||||
+ return "SSL";
|
||||
+ } else {
|
||||
+ return (String) env_vars.get("AUTH_TYPE");
|
||||
+ }
|
||||
}
|
||||
|
||||
/**
|
|
@ -1,7 +1,5 @@
|
|||
To activate mod_jserv:
|
||||
|
||||
o Copy jserv.conf.default, jserv.properties.default and
|
||||
zone.properties.default in ${PREFIX}/etc/apache to jserv.conf,
|
||||
jserv.properties and zone.properties.
|
||||
o Touch /var/log/jserv.log with write permission for owner of httpd.
|
||||
o Add "Include etc/apache/jserv.conf" into httpd.conf to activate mod_jserv.
|
||||
o Add "Include etc/apache/jserv/jserv.conf" into httpd.conf to activate mod_jserv.
|
||||
|
||||
|
|
|
@ -1,13 +1,14 @@
|
|||
etc/apache/jserv.conf.default
|
||||
etc/apache/jserv.properties.default
|
||||
etc/apache/zone.properties.default
|
||||
libexec/apache/libjserv.a
|
||||
libexec/apache/libjserv.so
|
||||
libexec/apache/libjserv.so.0
|
||||
libexec/apache/mod_jserv.so
|
||||
etc/apache/jserv/jserv.conf
|
||||
etc/apache/jserv/jserv.properties
|
||||
etc/apache/jserv/zone.properties
|
||||
libexec/apache/ApacheJServ.jar
|
||||
libexec/apache/mod_jserv.so
|
||||
share/java/servlets/Hello.class
|
||||
share/java/servlets/Hello.java
|
||||
share/java/servlets/IsItWorking.class
|
||||
share/java/servlets/IsItWorking.java
|
||||
share/doc/mod_jserv/FAQ.html
|
||||
share/doc/mod_jserv/api/index.html
|
||||
share/doc/mod_jserv/STATUS.txt
|
||||
share/doc/mod_jserv/bugs.html
|
||||
share/doc/mod_jserv/changes.html
|
||||
share/doc/mod_jserv/contributing.html
|
||||
|
@ -26,13 +27,13 @@ share/doc/mod_jserv/images/lbprod001.gif
|
|||
share/doc/mod_jserv/images/lbprod002.gif
|
||||
share/doc/mod_jserv/images/lbshm001.gif
|
||||
share/doc/mod_jserv/index.html
|
||||
share/doc/mod_jserv/license.html
|
||||
share/doc/mod_jserv/install/howto.security.html
|
||||
share/doc/mod_jserv/install/howto.servlets.html
|
||||
share/doc/mod_jserv/install/howto.status.html
|
||||
share/doc/mod_jserv/install/howto.unix_install.html
|
||||
share/doc/mod_jserv/install/howto.win32_install.html
|
||||
share/doc/mod_jserv/install/index.html
|
||||
share/doc/mod_jserv/license.html
|
||||
share/doc/mod_jserv/modules.html
|
||||
share/doc/mod_jserv/operation.html
|
||||
share/doc/mod_jserv/protocol/AJPv1.html
|
||||
|
@ -42,8 +43,115 @@ share/doc/mod_jserv/protocol/AJPv21.html
|
|||
share/doc/mod_jserv/security.html
|
||||
share/doc/mod_jserv/sendbug.html
|
||||
share/doc/mod_jserv/support.html
|
||||
share/doc/mod_jserv/upgrade.html
|
||||
share/doc/mod_jserv/y2k.html
|
||||
share/doc/mod_jserv/zones.html
|
||||
docs/api/org/apache/java/io/SimpleFileFilter.html
|
||||
docs/api/org/apache/java/io/package-tree.html
|
||||
docs/api/org/apache/java/io/package-frame.html
|
||||
docs/api/org/apache/java/io/Logger.html
|
||||
docs/api/org/apache/java/io/LogRecord.html
|
||||
docs/api/org/apache/java/io/LogWriter.html
|
||||
docs/api/org/apache/java/io/LogWriter.Agent.html
|
||||
docs/api/org/apache/java/io/ReadFullyInputStream.html
|
||||
docs/api/org/apache/java/io/package-summary.html
|
||||
docs/api/org/apache/java/lang/TimeoutException.html
|
||||
docs/api/org/apache/java/lang/package-tree.html
|
||||
docs/api/org/apache/java/lang/package-frame.html
|
||||
docs/api/org/apache/java/lang/Stoppable.html
|
||||
docs/api/org/apache/java/lang/AdaptiveClassLoader.html
|
||||
docs/api/org/apache/java/lang/AdaptiveClassLoader.ClassCacheEntry.html
|
||||
docs/api/org/apache/java/lang/Bytes.html
|
||||
docs/api/org/apache/java/lang/Lock.html
|
||||
docs/api/org/apache/java/lang/Semaphore.html
|
||||
docs/api/org/apache/java/lang/package-summary.html
|
||||
docs/api/org/apache/java/net/package-summary.html
|
||||
docs/api/org/apache/java/net/package-tree.html
|
||||
docs/api/org/apache/java/net/package-frame.html
|
||||
docs/api/org/apache/java/net/AuthenticatedServerSocket.html
|
||||
docs/api/org/apache/java/net/AuthenticatedSocket.html
|
||||
docs/api/org/apache/java/net/AuthenticationException.html
|
||||
docs/api/org/apache/java/recycle/pool/package-summary.html
|
||||
docs/api/org/apache/java/recycle/pool/package-tree.html
|
||||
docs/api/org/apache/java/recycle/pool/package-frame.html
|
||||
docs/api/org/apache/java/recycle/pool/Worker.html
|
||||
docs/api/org/apache/java/recycle/pool/WorkerContainer.html
|
||||
docs/api/org/apache/java/recycle/pool/WorkerPool.html
|
||||
docs/api/org/apache/java/recycle/package-tree.html
|
||||
docs/api/org/apache/java/recycle/package-frame.html
|
||||
docs/api/org/apache/java/recycle/Controller.html
|
||||
docs/api/org/apache/java/recycle/Recyclable.html
|
||||
docs/api/org/apache/java/recycle/RecycleBin.html
|
||||
docs/api/org/apache/java/recycle/AdaptiveController.html
|
||||
docs/api/org/apache/java/recycle/Container.html
|
||||
docs/api/org/apache/java/recycle/ControlledContainer.html
|
||||
docs/api/org/apache/java/recycle/ControllerFactory.html
|
||||
docs/api/org/apache/java/recycle/DefaultController.html
|
||||
docs/api/org/apache/java/recycle/GaussianController.html
|
||||
docs/api/org/apache/java/recycle/LimitedContainer.html
|
||||
docs/api/org/apache/java/recycle/MinMaxController.html
|
||||
docs/api/org/apache/java/recycle/RecycleBinIsEmpty.html
|
||||
docs/api/org/apache/java/recycle/package-summary.html
|
||||
docs/api/org/apache/java/recycle/RecycleBinIsFull.html
|
||||
docs/api/org/apache/java/security/package-summary.html
|
||||
docs/api/org/apache/java/security/package-tree.html
|
||||
docs/api/org/apache/java/security/package-frame.html
|
||||
docs/api/org/apache/java/security/MD5.html
|
||||
docs/api/org/apache/java/security/MessageDigest.html
|
||||
docs/api/org/apache/java/util/SimpleQueue.html
|
||||
docs/api/org/apache/java/util/package-tree.html
|
||||
docs/api/org/apache/java/util/package-frame.html
|
||||
docs/api/org/apache/java/util/Configurations.html
|
||||
docs/api/org/apache/java/util/ConfigurationsRepository.html
|
||||
docs/api/org/apache/java/util/ExtendedProperties.html
|
||||
docs/api/org/apache/java/util/ExtendedProperties.PropertiesReader.html
|
||||
docs/api/org/apache/java/util/ExtendedProperties.PropertiesTokenizer.html
|
||||
docs/api/org/apache/java/util/package-summary.html
|
||||
docs/api/org/apache/jserv/JServUtils.html
|
||||
docs/api/org/apache/jserv/package-tree.html
|
||||
docs/api/org/apache/jserv/package-frame.html
|
||||
docs/api/org/apache/jserv/JServDefs.html
|
||||
docs/api/org/apache/jserv/JServLogChannels.html
|
||||
docs/api/org/apache/jserv/JServSendError.html
|
||||
docs/api/org/apache/jserv/Ajpv12InputStream.html
|
||||
docs/api/org/apache/jserv/JServ.html
|
||||
docs/api/org/apache/jserv/JServConnection.html
|
||||
docs/api/org/apache/jserv/JServConnection.JServInputStream.html
|
||||
docs/api/org/apache/jserv/JServConnection.JServOutputStream.html
|
||||
docs/api/org/apache/jserv/JServContext.html
|
||||
docs/api/org/apache/jserv/JServLog.html
|
||||
docs/api/org/apache/jserv/JServServletManager.html
|
||||
docs/api/org/apache/jserv/JServSession.html
|
||||
docs/api/org/apache/jserv/JServSTMStore.html
|
||||
docs/api/org/apache/jserv/JServServletManager.ACLObjectInputStream.html
|
||||
docs/api/org/apache/jserv/package-summary.html
|
||||
docs/api/stylesheet.css
|
||||
docs/api/serialized-form.html
|
||||
docs/api/packages.html
|
||||
docs/api/overview-tree.html
|
||||
docs/api/overview-summary.html
|
||||
docs/api/package-list
|
||||
docs/api/index.html
|
||||
docs/api/index-all.html
|
||||
docs/api/help-doc.html
|
||||
docs/api/deprecated-list.html
|
||||
docs/api/allclasses-frame.html
|
||||
docs/api/overview-frame.html
|
||||
@dirrm docs/api/org/apache/java/io
|
||||
@dirrm docs/api/org/apache/java/lang
|
||||
@dirrm docs/api/org/apache/java/net
|
||||
@dirrm docs/api/org/apache/java/recycle/pool
|
||||
@dirrm docs/api/org/apache/java/recycle
|
||||
@dirrm docs/api/org/apache/java/security
|
||||
@dirrm docs/api/org/apache/java/util
|
||||
@dirrm docs/api/org/apache/java
|
||||
@dirrm docs/api/org/apache/jserv
|
||||
@dirrm docs/api/org/apache
|
||||
@dirrm docs/api/org
|
||||
@dirrm docs/api
|
||||
@dirrm docs
|
||||
@dirrm etc/apache/jserv
|
||||
@dirrm share/java/servlets
|
||||
@dirrm share/doc/mod_jserv/api
|
||||
@dirrm share/doc/mod_jserv/future
|
||||
@dirrm share/doc/mod_jserv/images
|
||||
|
|
Loading…
Reference in a new issue