- Update to 0.8.2
- Pass maintainership to submitter PR: 135205 Submitted by: Yi-Jheng Lin <yzlin@cs.nctu.edu.tw>
This commit is contained in:
parent
eab2748f1b
commit
c6fa4af61c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=235234
8 changed files with 11 additions and 145 deletions
|
@ -6,14 +6,15 @@
|
|||
#
|
||||
|
||||
PORTNAME= htop
|
||||
PORTVERSION= 0.8.1
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 0.8.2
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= SF
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
MAINTAINER= yzlin@cs.nctu.edu.tw
|
||||
COMMENT= A better top(1) - interactive process viewer
|
||||
|
||||
OPTIONS= LSOF "Enable lsof support" On
|
||||
|
||||
NOT_FOR_ARCHS= sparc64
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
|
@ -31,6 +32,10 @@ MAN1= htop.1
|
|||
LIB_DEPENDS+= ncursesw.5:${PORTSDIR}/devel/ncurses
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_LSOF)
|
||||
RUN_DEPENDS+= lsof:${PORTSDIR}/sysutils/lsof
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's:/usr/bin/python:${LOCALBASE}/bin/python:' ${WRKSRC}/scripts/MakeHeader.py
|
||||
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (htop-0.8.1.tar.gz) = f0b259ca29175656de48bf0fa0a2e619
|
||||
SHA256 (htop-0.8.1.tar.gz) = 25ae28202fa4b782ed0e1298d3feee407bdeb56eaf9c652d0a6f9dbf22125d28
|
||||
SIZE (htop-0.8.1.tar.gz) = 414870
|
||||
MD5 (htop-0.8.2.tar.gz) = 78c2382dc4ff0cf5a29a5c3bc1e556ec
|
||||
SHA256 (htop-0.8.2.tar.gz) = 8e77ad7dbf6333ed158dcd3ab16da346ded680fd50a1c258e3a6771e4ca1c707
|
||||
SIZE (htop-0.8.2.tar.gz) = 418756
|
||||
|
|
|
@ -1,18 +0,0 @@
|
|||
--- Makefile.am.orig 2008-07-16 11:16:00.000000000 +0800
|
||||
+++ Makefile.am 2008-07-16 11:16:14.000000000 +0800
|
||||
@@ -1,5 +1,5 @@
|
||||
|
||||
-SUBDIRS = plpa-1.1
|
||||
+SUBDIRS =
|
||||
|
||||
bin_PROGRAMS = htop
|
||||
dist_man_MANS = htop.1
|
||||
@@ -34,7 +34,7 @@
|
||||
|
||||
BUILT_SOURCES = $(myhtopheaders)
|
||||
htop_SOURCES = $(myhtopheaders) $(myhtopsources) config.h debug.h
|
||||
-htop_LDADD = $(top_builddir)/plpa-1.1/src/libplpa_included.la
|
||||
+htop_LDADD =
|
||||
|
||||
profile:
|
||||
$(MAKE) all CFLAGS="-pg -O2"
|
|
@ -1,28 +0,0 @@
|
|||
--- Process.c.orig 2008-03-15 02:35:05.000000000 +0800
|
||||
+++ Process.c 2008-07-16 12:51:24.000000000 +0800
|
||||
@@ -28,7 +28,9 @@
|
||||
#include <pwd.h>
|
||||
#include <sched.h>
|
||||
|
||||
+#if 0
|
||||
#include <plpa.h>
|
||||
+#endif
|
||||
|
||||
// This works only with glibc 2.1+. On earlier versions
|
||||
// the behavior is similar to have a hardcoded page size.
|
||||
@@ -478,6 +480,7 @@
|
||||
return (err == 0);
|
||||
}
|
||||
|
||||
+#if 0
|
||||
unsigned long Process_getAffinity(Process* this) {
|
||||
unsigned long mask = 0;
|
||||
plpa_sched_getaffinity(this->pid, sizeof(unsigned long), (plpa_cpu_set_t*) &mask);
|
||||
@@ -487,6 +490,7 @@
|
||||
bool Process_setAffinity(Process* this, unsigned long mask) {
|
||||
return (plpa_sched_setaffinity(this->pid, sizeof(unsigned long), (plpa_cpu_set_t*) &mask) == 0);
|
||||
}
|
||||
+#endif
|
||||
|
||||
void Process_sendSignal(Process* this, int signal) {
|
||||
kill(this->pid, signal);
|
|
@ -1,24 +0,0 @@
|
|||
--- Process.h.orig 2008-03-15 02:42:15.000000000 +0800
|
||||
+++ Process.h 2008-07-16 12:52:37.000000000 +0800
|
||||
@@ -31,7 +31,9 @@
|
||||
#include <pwd.h>
|
||||
#include <sched.h>
|
||||
|
||||
+#if 0
|
||||
#include <plpa.h>
|
||||
+#endif
|
||||
|
||||
// This works only with glibc 2.1+. On earlier versions
|
||||
// the behavior is similar to have a hardcoded page size.
|
||||
@@ -166,9 +168,11 @@
|
||||
|
||||
bool Process_setPriority(Process* this, int priority);
|
||||
|
||||
+#if 0
|
||||
unsigned long Process_getAffinity(Process* this);
|
||||
|
||||
bool Process_setAffinity(Process* this, unsigned long mask);
|
||||
+#endif
|
||||
|
||||
void Process_sendSignal(Process* this, int signal);
|
||||
|
|
@ -1,14 +0,0 @@
|
|||
--- ProcessList.c.orig 2009-03-21 23:21:46.000000000 +0800
|
||||
+++ ProcessList.c 2009-03-21 23:22:04.000000000 +0800
|
||||
@@ -563,9 +563,8 @@
|
||||
process->pid = pid;
|
||||
}
|
||||
}
|
||||
- if (parent) {
|
||||
- process->tgid = parent->pid;
|
||||
- }
|
||||
+
|
||||
+ process->tgid = parent ? parent->pid : pid;
|
||||
|
||||
if (showUserlandThreads && (!parent || pid != parent->pid)) {
|
||||
char subdirname[MAX_NAME+1];
|
|
@ -1,14 +0,0 @@
|
|||
--- configure.ac.orig 2008-07-16 10:48:24.000000000 +0800
|
||||
+++ configure.ac 2008-07-16 10:48:36.000000000 +0800
|
||||
@@ -84,11 +84,5 @@
|
||||
AC_CHECK_FILE($PROCDIR/stat,,AC_MSG_ERROR(Cannot find /proc/stat. Make sure you have a Linux-compatible /proc filesystem mounted. See the file README for help.))
|
||||
AC_CHECK_FILE($PROCDIR/meminfo,,AC_MSG_ERROR(Cannot find /proc/meminfo. Make sure you have a Linux-compatible /proc filesystem mounted. See the file README for help.))
|
||||
|
||||
-PLPA_INCLUDED(plpa-1.1)
|
||||
-PLPA_INIT(plpa_happy=yes, plpa_happy=no)
|
||||
-if test "x$plpa_happy" = xno; then
|
||||
- AC_MSG_ERROR([Failed to initialize PLPA.])
|
||||
-fi
|
||||
-
|
||||
AC_CONFIG_FILES([Makefile])
|
||||
AC_OUTPUT
|
|
@ -1,41 +0,0 @@
|
|||
--- htop.c.orig 2008-04-27 13:56:38.000000000 +0800
|
||||
+++ htop.c 2008-07-16 12:54:44.000000000 +0800
|
||||
@@ -110,9 +110,11 @@
|
||||
mvaddstr(15, 0, " F9 k: kill process/tagged processes P: sort by CPU%");
|
||||
mvaddstr(16, 0, " + [ F7: lower priority (+ nice) M: sort by MEM%");
|
||||
mvaddstr(17, 0, " - ] F8: higher priority (root only) T: sort by TIME");
|
||||
+#if 0
|
||||
if (pl->processorCount > 1)
|
||||
mvaddstr(18, 0, " a: set CPU affinity F4 I: invert sort order");
|
||||
else
|
||||
+#endif
|
||||
mvaddstr(18, 0, " F4 I: invert sort order");
|
||||
mvaddstr(19, 0, " F2 S: setup F6 >: select sort column");
|
||||
mvaddstr(20, 0, " F1 h: show this help screen");
|
||||
@@ -129,8 +131,10 @@
|
||||
mvaddstr(16, 0, " + [ F7"); mvaddstr(16,40, " M");
|
||||
mvaddstr(17, 0, " - ] F8"); mvaddstr(17,40, " T");
|
||||
mvaddstr(18,40, " F4 I");
|
||||
+#if 0
|
||||
if (pl->processorCount > 1)
|
||||
mvaddstr(18, 0, " a:");
|
||||
+#endif
|
||||
mvaddstr(19, 0, " F2 S"); mvaddstr(19,40, " F6 >");
|
||||
mvaddstr(20, 0, " F1 h");
|
||||
mvaddstr(21, 0, " F10 q"); mvaddstr(21,40, " s");
|
||||
@@ -625,6 +629,7 @@
|
||||
refreshTimeout = 0;
|
||||
break;
|
||||
}
|
||||
+#if 0
|
||||
case 'a':
|
||||
{
|
||||
if (pl->processorCount == 1)
|
||||
@@ -660,6 +665,7 @@
|
||||
refreshTimeout = 0;
|
||||
break;
|
||||
}
|
||||
+#endif
|
||||
case KEY_F(10):
|
||||
case 'q':
|
||||
quit = 1;
|
Loading…
Reference in a new issue