Update to 2.23

Use our own getopt instead of bundled version.

ChangeLog: https://feh.finalrewind.org/archive/2.23/
This commit is contained in:
Niclas Zeising 2017-12-31 11:08:25 +00:00
parent c45b599df9
commit c6fd70aef1
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=457683
4 changed files with 28 additions and 8 deletions

View file

@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= feh
PORTVERSION= 2.22.2
PORTVERSION= 2.23
CATEGORIES= graphics
MASTER_SITES= http://feh.finalrewind.org/ \
LOCAL/uqs
@ -22,7 +22,7 @@ USES= cpe desktop-file-utils gmake perl5 shebangfix tar:bzip2
CPE_VENDOR= daniel_friesel
USE_PERL5= run
CPPFLAGS+= -I${LOCALBASE}/include -std=c99
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
MAKE_ENV+= LDFLAGS="${LDFLAGS}"

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1510336682
SHA256 (feh-2.22.2.tar.bz2) = 05a81fbe0997f6274c7617efc351647be38e5244c2624bd203459025c9a68ecd
SIZE (feh-2.22.2.tar.bz2) = 2129840
TIMESTAMP = 1514713644
SHA256 (feh-2.23.tar.bz2) = 16df3cb813526a549e854aa82f80bcb299b9e83dd687ab4216a84e86f61722a1
SIZE (feh-2.23.tar.bz2) = 2130344

View file

@ -1,6 +1,6 @@
--- config.mk.orig 2015-05-24 09:46:21 UTC
--- config.mk.orig 2017-12-28 18:28:35 UTC
+++ config.mk
@@ -6,12 +6,12 @@ PREFIX ?= /usr/local
@@ -22,12 +22,12 @@ endif
# Directories for manuals, executables, docs, data, etc.
main_dir = ${DESTDIR}${PREFIX}
@ -13,5 +13,14 @@
-example_dir = ${main_dir}/share/doc/feh/examples
+example_dir = ${main_dir}/share/examples/feh
desktop_dir = ${main_dir}/share/applications
icon_dir = ${ICON_PREFIX}/hicolor
48_icon_dir = ${icon_dir}/48x48/apps
@@ -38,7 +38,7 @@ CFLAGS ?= -g -O2
CFLAGS += -Wall -Wextra -pedantic
# default CFLAGS
# Settings for glibc >= 2.19 - may need to be adjusted for other systems
-CFLAGS += -std=c11 -D_POSIX_C_SOURCE=200809L -D_XOPEN_SOURCE=500
+CFLAGS += -std=c11
ifeq (${curl},1)
CFLAGS += -DHAVE_LIBCURL

View file

@ -0,0 +1,11 @@
--- src/Makefile.orig 2017-12-28 18:28:35 UTC
+++ src/Makefile
@@ -5,8 +5,6 @@ TARGETS = \
events.c \
feh_png.c \
filelist.c \
- getopt.c \
- getopt1.c \
gib_hash.c \
gib_imlib.c \
gib_list.c \