net-mgmt/lldpd: update 0.9.2 -> 0.9.4
- Fix lldpd(8) in post-patch to show correct lldpd config file/directory path. - Apply extra patches taken from upstream right after 0.9.4 was released: * Fix build issues with 9.3's older cpp not supporting mutiple files as input. (likely Tier 2 archs with GCC 4.2 too) * Fix a regression which was caused by importing/adding support for new OpenBSD ifmediareq changes* and the use of typeof in 0.9.4 lldpd (0.9.3) * Do not rely on support of constructors for liblldpctl. * Always log to stderr (even in addition to syslog). * `lldpcli watch` accepts a limit on the number of received events. * `lldpcli -f {xml,json} watch` should work now. * Consider `veth` interfaces as physical interfaces. lldpd (0.9.4) * Make lldpd accepts a `-p` option to specify the PID file. * Ability to change multicast MAC address to two additional values to reach customer bridges. * lldpcli will now display chassis TTL when detailed view is enabled. * Fix setting of local value for port ID. * Fix compilation with BSD make. * Ensure lldpcli returns an error code on invalid commands. PR: 210390 Submitted by: Mathieu Simon <freebsd@simweb.ch> (maintainer)
This commit is contained in:
parent
ec49f97c71
commit
c739808f3c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=417507
5 changed files with 57 additions and 3 deletions
|
@ -2,7 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= lldpd
|
||||
PORTVERSION= 0.9.2
|
||||
PORTVERSION= 0.9.4
|
||||
CATEGORIES= net-mgmt
|
||||
MASTER_SITES= http://media.luffy.cx/files/${PORTNAME}/ \
|
||||
http://mirror.1labs.ch/${PORTNAME}/
|
||||
|
@ -54,6 +54,9 @@ JSON_USES= pkgconfig
|
|||
SNMP_LIB_DEPENDS= libnetsnmp.so:net-mgmt/net-snmp
|
||||
XML_LIB_DEPENDS= libxml2.so:textproc/libxml2
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|/etc|${PREFIX}|g' ${WRKSRC}/src/daemon/lldpd.8.in
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA} ${FILESDIR}/README.bsd ${STAGEDIR}${DOCSDIR}
|
||||
|
||||
|
|
|
@ -1,2 +1,3 @@
|
|||
SHA256 (lldpd-0.9.2.tar.gz) = 6054f29d41faf32186a22331853a299c87f4419b4332df4a564f76a139305a32
|
||||
SIZE (lldpd-0.9.2.tar.gz) = 1600648
|
||||
TIMESTAMP = 1466250111
|
||||
SHA256 (lldpd-0.9.4.tar.gz) = eb1f5beff2ff5c13c5e0342b5b9da815ed4a63866262445e1168a79ee65c9079
|
||||
SIZE (lldpd-0.9.4.tar.gz) = 1604103
|
||||
|
|
11
net-mgmt/lldpd/files/patch-configure.ac
Normal file
11
net-mgmt/lldpd/files/patch-configure.ac
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- configure.ac.orig 2016-06-10 06:11:26 UTC
|
||||
+++ configure.ac
|
||||
@@ -90,6 +90,8 @@ AX_CFLAGS_GCC_OPTION([-Wno-sign-compare]
|
||||
AX_LDFLAGS_OPTION([-Wl,-z,relro], [LLDP_LDFLAGS])
|
||||
AX_LDFLAGS_OPTION([-Wl,-z,now], [LLDP_LDFLAGS])
|
||||
|
||||
+AC_C_TYPEOF
|
||||
+
|
||||
# Hardening
|
||||
AC_ARG_ENABLE([hardening],
|
||||
[AS_HELP_STRING([--enable-hardening],
|
14
net-mgmt/lldpd/files/patch-src_daemon_interfaces-bsd.c
Normal file
14
net-mgmt/lldpd/files/patch-src_daemon_interfaces-bsd.c
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- src/daemon/interfaces-bsd.c.orig 2016-06-13 06:38:49 UTC
|
||||
+++ src/daemon/interfaces-bsd.c
|
||||
@@ -470,7 +470,11 @@ ifbsd_macphy(struct lldpd *cfg,
|
||||
{
|
||||
#ifdef ENABLE_DOT3
|
||||
struct ifmediareq ifmr = {};
|
||||
+#ifdef HAVE_TYPEOF
|
||||
typeof(ifmr.ifm_ulist[0]) media_list[32] = {};
|
||||
+#else
|
||||
+ int media_list[32] = {};
|
||||
+#endif
|
||||
ifmr.ifm_ulist = media_list;
|
||||
ifmr.ifm_count = 32;
|
||||
struct lldpd_port *port = &hardware->h_lport;
|
25
net-mgmt/lldpd/files/patch-src_lib_Makefile.in
Normal file
25
net-mgmt/lldpd/files/patch-src_lib_Makefile.in
Normal file
|
@ -0,0 +1,25 @@
|
|||
--- src/lib/Makefile.in.orig 2016-06-17 17:20:00 UTC
|
||||
+++ src/lib/Makefile.in
|
||||
@@ -895,8 +895,9 @@ uninstall-am: uninstall-includeHEADERS u
|
||||
|
||||
|
||||
atom-glue.c: $(ATOM_FILES) Makefile
|
||||
- $(AM_V_GEN)($(CPP) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
|
||||
- $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) $(ATOM_FILES:%=$(srcdir)/%) | \
|
||||
+ $(AM_V_GEN)(for f in $(ATOM_FILES:%=$(srcdir)/%); do \
|
||||
+ $(CPP) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
|
||||
+ $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) $$f; done | \
|
||||
$(SED) -n 's+^void init_atom_builder_\([^(]*\)().*, \([0-9]*\)).*+\2 \1+p' | \
|
||||
sort | \
|
||||
$(AWK) '{ atoms[$$2] = 1 } \
|
||||
@@ -905,8 +906,9 @@ atom-glue.c: $(ATOM_FILES) Makefile
|
||||
print " static int init = 0; if (init) return; init++;"; \
|
||||
for (atom in atoms) { print " init_atom_builder_"atom"();" } \
|
||||
print "}"; }' && \
|
||||
+ for f in $(ATOM_FILES:%=$(srcdir)/%); do \
|
||||
$(CPP) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
|
||||
- $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) $(ATOM_FILES:%=$(srcdir)/%) | \
|
||||
+ $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) $$f; done | \
|
||||
$(SED) -n 's+^void init_atom_map_\([^(]*\)().*, \([0-9]*\)).*+\2 \1+p' | \
|
||||
sort -n | \
|
||||
$(AWK) '{ atoms[$$2] = 1 } \
|
Loading…
Reference in a new issue