science/cgnslib: rename unitconv to unitconv.sh, thus avoiding the conflict with

XCrySDen.
This commit is contained in:
Thierry Thomas 2020-12-26 11:48:36 +00:00
parent 83f3113caa
commit c7653b87ed
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=559285
5 changed files with 32 additions and 4 deletions

View file

@ -4,6 +4,7 @@
PORTNAME= cgnslib
PORTVERSION= 4.1.2
DISTVERSIONPREFIX= v
PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= science
@ -22,8 +23,6 @@ GH_PROJECT= CGNS
USE_LDCONFIG= yes
MAKE_JOBS_UNSAFE= yes
CONFLICTS_INSTALL= xcrysden-1.* # bin/unitconv
TEST_TARGET= test
FFLAGS+= -std=legacy

View file

@ -0,0 +1,15 @@
--- src/cgnstools/cgnscalc/CMakeLists.txt.orig 2020-08-18 19:44:35 UTC
+++ src/cgnstools/cgnscalc/CMakeLists.txt
@@ -77,10 +77,10 @@ else (WIN32)
cgnscalc.sh
DESTINATION bin
RENAME cgnscalc)
+ # Do not install as unitconv to avoid a conflicy with XCrySDen
install(PROGRAMS
unitconv.sh
- DESTINATION bin
- RENAME unitconv)
+ DESTINATION bin)
install(FILES
cgnscalc.tcl
unitconv.tcl

View file

@ -0,0 +1,14 @@
--- src/cgnstools/cgnscalc/Makefile.unix.orig 2020-08-18 19:44:35 UTC
+++ src/cgnstools/cgnscalc/Makefile.unix
@@ -45,8 +45,9 @@ install-prog :
@echo "installing cgnscalc shell scripts to $(BIN_INSTALL_DIR)"
@$(INSTALL_PROG) cgnscalc.sh $(BIN_INSTALL_DIR)/cgnscalc
@chmod +x $(BIN_INSTALL_DIR)/cgnscalc
- @$(INSTALL_PROG) unitconv.sh $(BIN_INSTALL_DIR)/unitconv
- @chmod +x $(BIN_INSTALL_DIR)/unitconv
+ # Do not install as unitconv to avoid a conflicy with XCrySDen
+ @$(INSTALL_PROG) unitconv.sh $(BIN_INSTALL_DIR)/unitconv.sh
+ @chmod +x $(BIN_INSTALL_DIR)/unitconv.sh
@if [ ! -f $(EXE_INSTALL_DIR)/cgconfig ] ; then \
echo "installing configuration file to $(EXE_INSTALL_DIR)"; \
$(INSTALL_DATA) ../cgconfig $(EXE_INSTALL_DIR)/cgconfig; \

View file

@ -26,7 +26,7 @@
%%TOOLS%%bin/cgnstools/update_ngon
%%TOOLS%%bin/cgnstools/vgrid_to_cgns
%%TOOLS%%bin/cgnsview
%%TOOLS%%bin/unitconv
%%TOOLS%%bin/unitconv.sh
bin/cgnscheck
bin/cgnscompress
bin/cgnsconvert

View file

@ -24,7 +24,7 @@ USES= fortran gl gmake localbase:ldflags tcl tk xorg
USE_GL= gl glu
USE_XORG= x11 xmu
CONFLICTS_INSTALL= cgnslib-4.* # bin/unitconv
CONFLICTS_INSTALL= cgnslib-4.1.2,1 # bin/unitconv
MAKE_ARGS= prefix=${STAGEDIR}${PREFIX}