multimedia/umplayer: cleanup

- Add LICENSE.
- Add USES=desktop-file-utils.
- Replace linguist_build with linguisttools_build.
- Strip binary.
- Regenerate patch with 'make makepatch'.

PR:                  201474
Submitted by:        s3erios@gmail.com
This commit is contained in:
Philip M. Gollucci 2015-07-15 20:58:57 +00:00
parent a88759d8a1
commit c76ffd1bea
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=392221
2 changed files with 12 additions and 6 deletions

View file

@ -3,18 +3,21 @@
PORTNAME= umplayer
DISTVERSION= 0.97
PORTREVISION= 2
PORTREVISION= 3
CATEGORIES= multimedia audio kde
MASTER_SITES= LOCAL/wen
MAINTAINER= lichray@gmail.com
COMMENT= Modern front-end for MPlayer (fork of SMPlayer)
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/Copying.txt
RUN_DEPENDS= mplayer:${PORTSDIR}/multimedia/mplayer
USES= gmake qmake tar:xz
USES= desktop-file-utils gmake qmake tar:xz
USE_QT4= gui network xml moc_build rcc_build uic_build \
linguist_build
linguisttools_build
INSTALLS_ICONS= yes
MAKE_ARGS+= PREFIX=${PREFIX} DESTDIR=${STAGEDIR}
QMAKE_ARGS+= "DEFINES+=NO_DEBUG_ON_CONSOLE"
@ -39,4 +42,7 @@ post-patch:
${WRKSRC}/Makefile
.endif
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
.include <bsd.port.mk>

View file

@ -1,6 +1,6 @@
--- ./src/umplayer.cpp.orig 2011-03-29 07:43:57.000000000 -0500
+++ ./src/umplayer.cpp 2011-06-03 01:07:11.292091723 -0500
@@ -443,13 +443,13 @@ void UMPlayer::showInfo() {
--- src/umplayer.cpp.orig 2011-09-13 08:33:08 UTC
+++ src/umplayer.cpp
@@ -447,13 +447,13 @@ void UMPlayer::showInfo() {
.arg(umplayerVersion())
#ifdef Q_OS_LINUX
.arg("Linux")