Add bsflite , a lightweight command line AIM client.
PR: 81877 Submitted by: Emanuel Haupt <ehaupt@critical.ch>
This commit is contained in:
parent
696ec71898
commit
c7a6f12d72
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=136881
13 changed files with 169 additions and 0 deletions
29
net-im/bsflite/Makefile
Normal file
29
net-im/bsflite/Makefile
Normal file
|
@ -0,0 +1,29 @@
|
|||
# New ports collection makefile for: bsflite
|
||||
# Date created: 3 June 2005
|
||||
# Whom: Emanuel Haupt <ehaupt@critical.ch>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= bsflite
|
||||
DISTVERSION= 0.80
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
|
||||
MASTER_SITE_SUBDIR=bsflite
|
||||
|
||||
MAINTAINER= ehaupt@critical.ch
|
||||
COMMENT= A lightweight command line AIM client
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/bsflite ${PREFIX}/bin
|
||||
${MKDIR} ${EXAMPLESDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/config-example ${EXAMPLESDIR}
|
||||
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${DOCSDIR}
|
||||
.for f in COPYING ChangeLog README
|
||||
${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
|
||||
.endfor
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
2
net-im/bsflite/distinfo
Normal file
2
net-im/bsflite/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
MD5 (bsflite-0.80.tar.gz) = 31589a230e4ccfaae1225d080d3b7d6d
|
||||
SIZE (bsflite-0.80.tar.gz) = 50529
|
19
net-im/bsflite/files/patch-Makefile
Normal file
19
net-im/bsflite/files/patch-Makefile
Normal file
|
@ -0,0 +1,19 @@
|
|||
--- Makefile.orig Mon Jun 6 02:49:25 2005
|
||||
+++ Makefile Mon Jun 6 02:49:41 2005
|
||||
@@ -2,7 +2,6 @@
|
||||
#EXEC=bsflite.exe
|
||||
#CC=i386-pc-msdosdjgpp-gcc
|
||||
#CC=mingw32-gcc
|
||||
-CC=gcc
|
||||
#
|
||||
# Remove -DTIMESTAMPS to remove timestamps on messages/events
|
||||
#
|
||||
@@ -18,7 +17,7 @@
|
||||
# Add -DBELL_ON_INCOMING to sound an alert when a message
|
||||
# comes in.
|
||||
#
|
||||
-CFLAGS=-O -DTIMESTAMPS
|
||||
+CFLAGS+=-DTIMESTAMPS
|
||||
#CFLAGS+=-I/usr/local/djgpp/watt/inc
|
||||
#
|
||||
# Add -lsocket -lnsl for Solaris
|
18
net-im/bsflite/files/patch-imcomm::Makefile
Normal file
18
net-im/bsflite/files/patch-imcomm::Makefile
Normal file
|
@ -0,0 +1,18 @@
|
|||
--- imcomm/Makefile.orig Mon Jun 6 02:49:47 2005
|
||||
+++ imcomm/Makefile Mon Jun 6 02:50:17 2005
|
||||
@@ -1,15 +1,11 @@
|
||||
EXEC=test
|
||||
#AR=i386-pc-msdosdjgpp-ar
|
||||
#AR=mingw32-ar
|
||||
-AR=ar
|
||||
#RANLIB=i386-pc-msdosdjgpp-ranlib
|
||||
#RANLIB=mingw32-ranlib
|
||||
-RANLIB=ranlib
|
||||
LIB=libimcomm.a
|
||||
#CC=i386-pc-msdosdjgpp-gcc
|
||||
#CC=mingw32-gcc
|
||||
-CC=gcc
|
||||
-CFLAGS=-O
|
||||
RM=rm -f
|
||||
#CFLAGS+=-I/usr/local/djgpp/watt/inc
|
||||
#
|
9
net-im/bsflite/pkg-descr
Normal file
9
net-im/bsflite/pkg-descr
Normal file
|
@ -0,0 +1,9 @@
|
|||
BSFlite is a small and minimalistic client for AIM service. Instead of having a
|
||||
full screen console interface, BSFlite employs a command line interface that
|
||||
allows your fingers to do all of the work without needlessly sifting through
|
||||
windows.
|
||||
|
||||
WWW: http://bsflite.sourceforge.net/
|
||||
|
||||
- ehaupt
|
||||
ehaupt@critical.ch
|
7
net-im/bsflite/pkg-plist
Normal file
7
net-im/bsflite/pkg-plist
Normal file
|
@ -0,0 +1,7 @@
|
|||
bin/bsflite
|
||||
%%EXAMPLESDIR%%/config-example
|
||||
%%PORTDOCS%%%%DOCSDIR%%/COPYING
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README
|
||||
@dirrm %%EXAMPLESDIR%%
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
|
@ -55,6 +55,7 @@
|
|||
SUBDIR += bounce
|
||||
SUBDIR += brutecopy
|
||||
SUBDIR += bsdproxy
|
||||
SUBDIR += bsflite
|
||||
SUBDIR += btqueue
|
||||
SUBDIR += c3270
|
||||
SUBDIR += cacti
|
||||
|
|
29
net/bsflite/Makefile
Normal file
29
net/bsflite/Makefile
Normal file
|
@ -0,0 +1,29 @@
|
|||
# New ports collection makefile for: bsflite
|
||||
# Date created: 3 June 2005
|
||||
# Whom: Emanuel Haupt <ehaupt@critical.ch>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= bsflite
|
||||
DISTVERSION= 0.80
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
|
||||
MASTER_SITE_SUBDIR=bsflite
|
||||
|
||||
MAINTAINER= ehaupt@critical.ch
|
||||
COMMENT= A lightweight command line AIM client
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/bsflite ${PREFIX}/bin
|
||||
${MKDIR} ${EXAMPLESDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/config-example ${EXAMPLESDIR}
|
||||
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${DOCSDIR}
|
||||
.for f in COPYING ChangeLog README
|
||||
${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
|
||||
.endfor
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
2
net/bsflite/distinfo
Normal file
2
net/bsflite/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
MD5 (bsflite-0.80.tar.gz) = 31589a230e4ccfaae1225d080d3b7d6d
|
||||
SIZE (bsflite-0.80.tar.gz) = 50529
|
19
net/bsflite/files/patch-Makefile
Normal file
19
net/bsflite/files/patch-Makefile
Normal file
|
@ -0,0 +1,19 @@
|
|||
--- Makefile.orig Mon Jun 6 02:49:25 2005
|
||||
+++ Makefile Mon Jun 6 02:49:41 2005
|
||||
@@ -2,7 +2,6 @@
|
||||
#EXEC=bsflite.exe
|
||||
#CC=i386-pc-msdosdjgpp-gcc
|
||||
#CC=mingw32-gcc
|
||||
-CC=gcc
|
||||
#
|
||||
# Remove -DTIMESTAMPS to remove timestamps on messages/events
|
||||
#
|
||||
@@ -18,7 +17,7 @@
|
||||
# Add -DBELL_ON_INCOMING to sound an alert when a message
|
||||
# comes in.
|
||||
#
|
||||
-CFLAGS=-O -DTIMESTAMPS
|
||||
+CFLAGS+=-DTIMESTAMPS
|
||||
#CFLAGS+=-I/usr/local/djgpp/watt/inc
|
||||
#
|
||||
# Add -lsocket -lnsl for Solaris
|
18
net/bsflite/files/patch-imcomm::Makefile
Normal file
18
net/bsflite/files/patch-imcomm::Makefile
Normal file
|
@ -0,0 +1,18 @@
|
|||
--- imcomm/Makefile.orig Mon Jun 6 02:49:47 2005
|
||||
+++ imcomm/Makefile Mon Jun 6 02:50:17 2005
|
||||
@@ -1,15 +1,11 @@
|
||||
EXEC=test
|
||||
#AR=i386-pc-msdosdjgpp-ar
|
||||
#AR=mingw32-ar
|
||||
-AR=ar
|
||||
#RANLIB=i386-pc-msdosdjgpp-ranlib
|
||||
#RANLIB=mingw32-ranlib
|
||||
-RANLIB=ranlib
|
||||
LIB=libimcomm.a
|
||||
#CC=i386-pc-msdosdjgpp-gcc
|
||||
#CC=mingw32-gcc
|
||||
-CC=gcc
|
||||
-CFLAGS=-O
|
||||
RM=rm -f
|
||||
#CFLAGS+=-I/usr/local/djgpp/watt/inc
|
||||
#
|
9
net/bsflite/pkg-descr
Normal file
9
net/bsflite/pkg-descr
Normal file
|
@ -0,0 +1,9 @@
|
|||
BSFlite is a small and minimalistic client for AIM service. Instead of having a
|
||||
full screen console interface, BSFlite employs a command line interface that
|
||||
allows your fingers to do all of the work without needlessly sifting through
|
||||
windows.
|
||||
|
||||
WWW: http://bsflite.sourceforge.net/
|
||||
|
||||
- ehaupt
|
||||
ehaupt@critical.ch
|
7
net/bsflite/pkg-plist
Normal file
7
net/bsflite/pkg-plist
Normal file
|
@ -0,0 +1,7 @@
|
|||
bin/bsflite
|
||||
%%EXAMPLESDIR%%/config-example
|
||||
%%PORTDOCS%%%%DOCSDIR%%/COPYING
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README
|
||||
@dirrm %%EXAMPLESDIR%%
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
Loading…
Reference in a new issue