Update to 1.3.11. For a list of what's changed, checkout:
http://galeon.sourceforge.net/news/index.php#66
This commit is contained in:
parent
2fde8e3f3d
commit
c7acf589a7
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=96166
6 changed files with 19 additions and 63 deletions
|
@ -6,10 +6,10 @@
|
|||
#
|
||||
|
||||
PORTNAME= galeon2
|
||||
PORTVERSION= 1.3.10
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 1.3.11
|
||||
CATEGORIES= www gnome
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
|
||||
http://osdn.dl.sourceforge.net/sourceforge/galeon/
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME:S/2$//}
|
||||
DISTNAME= ${PORTNAME:S/2$//}-${PORTVERSION}
|
||||
|
||||
|
@ -32,7 +32,7 @@ HEADERS_SUFX=
|
|||
.if ${WITH_MOZILLA}=="mozilla-devel-gtk2"
|
||||
MOZILLA= ${WITH_MOZILLA}
|
||||
HEADERS_SUFX= -devel
|
||||
MOZ_CONFIGURE_ARGS= --with-mozilla-snapshot="trunk"
|
||||
MOZ_CONFIGURE_ARGS= --with-mozilla-snapshot="1.6b"
|
||||
.else
|
||||
MOZILLA= mozilla-gtk2
|
||||
HEADERS_SUFX=
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (galeon-1.3.10.tar.bz2) = 1707493228c2174e8ecd856789506ecd
|
||||
MD5 (galeon-1.3.11.tar.bz2) = 3992745759ef886270905d481742faa3
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- bookmarks/xbel.c.orig Tue Oct 28 00:27:13 2003
|
||||
+++ bookmarks/xbel.c Tue Oct 28 00:27:28 2003
|
||||
@@ -1065,7 +1065,7 @@
|
||||
xbel_save_galeon_metadata_remove_metadata (xmlNodePtr node)
|
||||
{
|
||||
xmlNodePtr infoNode;
|
||||
- xmlNodePtr metaNode;;
|
||||
+ xmlNodePtr metaNode;
|
||||
xmlNodePtr first_info = NULL;
|
||||
xmlNodePtr found = NULL;
|
||||
|
|
@ -1,10 +1,10 @@
|
|||
--- src/Makefile.in.orig Sun Aug 17 15:00:55 2003
|
||||
+++ src/Makefile.in Sun Aug 17 15:01:50 2003
|
||||
@@ -205,6 +205,7 @@
|
||||
--- src/Makefile.in.orig Thu Dec 18 15:12:38 2003
|
||||
+++ src/Makefile.in Thu Dec 18 15:13:13 2003
|
||||
@@ -206,6 +206,7 @@
|
||||
-I$(top_srcdir)/bookmarks \
|
||||
$(GALEON_DEPENDENCY_CFLAGS) \
|
||||
-DSHARE_DIR=\"$(pkgdatadir)\" \
|
||||
-DDATADIR=\""$(datadir)"\" \
|
||||
+ -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" \
|
||||
-DG_DISABLE_DEPRECATED \
|
||||
-DGDK_DISABLE_DEPRECATED \
|
||||
-DGTK_DISABLE_DEPRECATED \
|
||||
-DDATADIR=\""$(datadir)"\"
|
||||
|
||||
|
||||
|
|
|
@ -1,37 +0,0 @@
|
|||
--- src/galeon-shell.c.orig Mon Oct 13 17:56:13 2003
|
||||
+++ src/galeon-shell.c Tue Nov 4 23:07:54 2003
|
||||
@@ -186,6 +186,7 @@
|
||||
if (gs->priv->automation_factory == NULL)
|
||||
{
|
||||
GtkWidget *dialog;
|
||||
+ char *text;
|
||||
|
||||
dialog = hig_alert_new (NULL,
|
||||
GTK_DIALOG_MODAL,
|
||||
@@ -195,7 +196,7 @@
|
||||
GTK_STOCK_OK,
|
||||
GTK_RESPONSE_OK,
|
||||
NULL);
|
||||
- char * text = g_strdup_printf (_("Bonobo couldn't locate the file %s."),
|
||||
+ text = g_strdup_printf (_("Bonobo couldn't locate the file %s."),
|
||||
"<tt>\"GNOME_Galeon_Automation.server\"</tt>");
|
||||
hig_alert_set_secondary_printf (HIG_ALERT (dialog), "%s\n\n%s", text,
|
||||
_("Usually this is an indication of an incomplete installation. "
|
||||
@@ -283,8 +284,6 @@
|
||||
gb_bookmark_set_check_save (gs->priv->bookmark_set);
|
||||
g_object_unref (G_OBJECT (gs->priv->bookmark_set));
|
||||
|
||||
- g_free (gs->priv);
|
||||
-
|
||||
G_OBJECT_CLASS (parent_class)->finalize (object);
|
||||
|
||||
#ifdef DEBUG_MARCO
|
||||
@@ -295,6 +294,8 @@
|
||||
{
|
||||
bonobo_object_unref (gs->priv->automation_factory);
|
||||
}
|
||||
+
|
||||
+ g_free (gs->priv);
|
||||
|
||||
bonobo_main_quit ();
|
||||
|
|
@ -9,6 +9,7 @@ etc/gconf/gconf.xml.defaults/apps/galeon/Advanced/Persistent/%gconf.xml
|
|||
etc/gconf/gconf.xml.defaults/apps/galeon/Advanced/Security/%gconf.xml
|
||||
etc/gconf/gconf.xml.defaults/apps/galeon/Browsing/%gconf.xml
|
||||
etc/gconf/gconf.xml.defaults/apps/galeon/Browsing/Bookmarks/%gconf.xml
|
||||
etc/gconf/gconf.xml.defaults/apps/galeon/Browsing/Bookmarks/Editor/%gconf.xml
|
||||
etc/gconf/gconf.xml.defaults/apps/galeon/Browsing/Find/%gconf.xml
|
||||
etc/gconf/gconf.xml.defaults/apps/galeon/Browsing/General/%gconf.xml
|
||||
etc/gconf/gconf.xml.defaults/apps/galeon/Browsing/History/%gconf.xml
|
||||
|
@ -33,6 +34,7 @@ etc/gconf/gconf.xml.defaults/schemas/apps/galeon/Advanced/Persistent/%gconf.xml
|
|||
etc/gconf/gconf.xml.defaults/schemas/apps/galeon/Advanced/Security/%gconf.xml
|
||||
etc/gconf/gconf.xml.defaults/schemas/apps/galeon/Browsing/%gconf.xml
|
||||
etc/gconf/gconf.xml.defaults/schemas/apps/galeon/Browsing/Bookmarks/%gconf.xml
|
||||
etc/gconf/gconf.xml.defaults/schemas/apps/galeon/Browsing/Bookmarks/Editor/%gconf.xml
|
||||
etc/gconf/gconf.xml.defaults/schemas/apps/galeon/Browsing/Find/%gconf.xml
|
||||
etc/gconf/gconf.xml.defaults/schemas/apps/galeon/Browsing/General/%gconf.xml
|
||||
etc/gconf/gconf.xml.defaults/schemas/apps/galeon/Browsing/History/%gconf.xml
|
||||
|
@ -56,11 +58,8 @@ libdata/bonobo/servers/GNOME_Galeon_Automation.server
|
|||
libdata/bonobo/servers/GNOME_Galeon_NautilusView.server
|
||||
share/gnome/applications/galeon.desktop
|
||||
share/gnome/galeon/FAQ.html
|
||||
share/gnome/galeon/Insecure.png
|
||||
share/gnome/galeon/Secure.png
|
||||
share/gnome/galeon/about_logo.png
|
||||
share/gnome/galeon/autoscroll.xpm
|
||||
share/gnome/galeon/blocked.png
|
||||
share/gnome/galeon/bookmarks-editor-small.glade
|
||||
share/gnome/galeon/bookmarks-editor.glade
|
||||
share/gnome/galeon/bookmarks-find.glade
|
||||
|
@ -80,6 +79,8 @@ share/gnome/galeon/galeon-folder-open.png
|
|||
share/gnome/galeon/galeon-folder.png
|
||||
share/gnome/galeon/galeon-fullscreen.png
|
||||
share/gnome/galeon/galeon-history.png
|
||||
share/gnome/galeon/galeon-insecure.png
|
||||
share/gnome/galeon/galeon-popup-blocked.png
|
||||
share/gnome/galeon/galeon-prefs-fonts.png
|
||||
share/gnome/galeon/galeon-prefs-general.png
|
||||
share/gnome/galeon/galeon-prefs-language.png
|
||||
|
@ -88,6 +89,7 @@ share/gnome/galeon/galeon-prefs-network.png
|
|||
share/gnome/galeon/galeon-prefs-privacy.png
|
||||
share/gnome/galeon/galeon-prefs-tabs.png
|
||||
share/gnome/galeon/galeon-prefs-web-content.png
|
||||
share/gnome/galeon/galeon-secure.png
|
||||
share/gnome/galeon/galeon-send-link.png
|
||||
share/gnome/galeon/galeon-separator.png
|
||||
share/gnome/galeon/galeon-tab-loading.gif
|
||||
|
@ -276,6 +278,7 @@ share/locale/zh_TW/LC_MESSAGES/galeon-2.0.mo
|
|||
@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/galeon/Browsing/History
|
||||
@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/galeon/Browsing/General
|
||||
@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/galeon/Browsing/Find
|
||||
@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/galeon/Browsing/Bookmarks/Editor
|
||||
@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/galeon/Browsing/Bookmarks
|
||||
@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/galeon/Browsing
|
||||
@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/galeon/Advanced/Security
|
||||
|
@ -300,6 +303,7 @@ share/locale/zh_TW/LC_MESSAGES/galeon-2.0.mo
|
|||
@dirrm etc/gconf/gconf.xml.defaults/apps/galeon/Browsing/History
|
||||
@dirrm etc/gconf/gconf.xml.defaults/apps/galeon/Browsing/General
|
||||
@dirrm etc/gconf/gconf.xml.defaults/apps/galeon/Browsing/Find
|
||||
@dirrm etc/gconf/gconf.xml.defaults/apps/galeon/Browsing/Bookmarks/Editor
|
||||
@dirrm etc/gconf/gconf.xml.defaults/apps/galeon/Browsing/Bookmarks
|
||||
@dirrm etc/gconf/gconf.xml.defaults/apps/galeon/Browsing
|
||||
@dirrm etc/gconf/gconf.xml.defaults/apps/galeon/Advanced/Security
|
||||
|
|
Loading…
Reference in a new issue