- Update to version 6.0, add one more LICENSE [1]
- Add USES=desktop-file-utils, port installs desktop file - Add INSTALL_ICONS=yes, icons are installed PR: 198622 [1] Submitted by: Kevin Zheng <kevinz5000@gmail.com> (maintainer) [1]
This commit is contained in:
parent
742dae6da0
commit
c7cca7df81
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=381436
4 changed files with 30 additions and 20 deletions
|
@ -2,17 +2,16 @@
|
||||||
# $FreeBSD$
|
# $FreeBSD$
|
||||||
|
|
||||||
PORTNAME= openclonk
|
PORTNAME= openclonk
|
||||||
PORTVERSION= 5.1
|
PORTVERSION= 6.0
|
||||||
DISTVERSIONPREFIX= 5.
|
|
||||||
DISTVERSIONSUFFIX= -src
|
DISTVERSIONSUFFIX= -src
|
||||||
PORTREVISION= 2
|
|
||||||
CATEGORIES= games
|
CATEGORIES= games
|
||||||
MASTER_SITES= http://www.openclonk.org/builds/release/${DISTVERSIONPREFIX}${DISTVERSION}/
|
MASTER_SITES= http://www.openclonk.org/builds/release/${DISTVERSION}/
|
||||||
|
|
||||||
MAINTAINER= kevinz5000@gmail.com
|
MAINTAINER= kevinz5000@gmail.com
|
||||||
COMMENT= Multiplayer action game involving small and nimble humanoids
|
COMMENT= Multiplayer action game involving small and nimble humanoids
|
||||||
|
|
||||||
LICENSE= ISCL
|
LICENSE= ISCL CC0-1.0
|
||||||
|
LICENSE_COMB= dual
|
||||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||||
|
|
||||||
LIB_DEPENDS= libboost_thread.so:${PORTSDIR}/devel/boost-libs \
|
LIB_DEPENDS= libboost_thread.so:${PORTSDIR}/devel/boost-libs \
|
||||||
|
@ -22,13 +21,14 @@ LIB_DEPENDS= libboost_thread.so:${PORTSDIR}/devel/boost-libs \
|
||||||
libpng.so:${PORTSDIR}/graphics/png \
|
libpng.so:${PORTSDIR}/graphics/png \
|
||||||
libvorbis.so:${PORTSDIR}/audio/libvorbis
|
libvorbis.so:${PORTSDIR}/audio/libvorbis
|
||||||
|
|
||||||
USES= compiler:c++11-lib cmake iconv pkgconfig tar:bzip2
|
USES= compiler:c++11-lib cmake desktop-file-utils iconv pkgconfig tar:bzip2
|
||||||
USE_GL= glew
|
USE_GL= glew
|
||||||
USE_GNOME= gtk20
|
USE_GNOME= gtk20
|
||||||
USE_SDL= sdl mixer
|
USE_SDL= sdl mixer
|
||||||
USE_XORG= x11 xpm
|
USE_XORG= x11 xpm
|
||||||
|
INSTALLS_ICONS= yes
|
||||||
|
|
||||||
WRKSRC= ${WRKDIR}/openclonk-release-${DISTVERSIONPREFIX}${DISTVERSION}-src
|
WRKSRC= ${WRKDIR}/openclonk-release-${DISTVERSION}-src
|
||||||
|
|
||||||
.include <bsd.port.pre.mk>
|
.include <bsd.port.pre.mk>
|
||||||
|
|
||||||
|
|
|
@ -1,2 +1,2 @@
|
||||||
SHA256 (openclonk-5.5.1-src.tar.bz2) = c038d6dc2ef9a3d7966b18ba6147b9dd136f353dfaa5796455f9917b79255743
|
SHA256 (openclonk-6.0-src.tar.bz2) = 89271011c14a239c3000f057c12699c2ce1242187d41c4d2f6fd11b1d46a0248
|
||||||
SIZE (openclonk-5.5.1-src.tar.bz2) = 65383438
|
SIZE (openclonk-6.0-src.tar.bz2) = 68762594
|
||||||
|
|
21
games/openclonk/files/patch-CMakeLists.txt
Normal file
21
games/openclonk/files/patch-CMakeLists.txt
Normal file
|
@ -0,0 +1,21 @@
|
||||||
|
--- CMakeLists.txt.orig 2015-03-15 19:33:38 UTC
|
||||||
|
+++ CMakeLists.txt
|
||||||
|
@@ -912,7 +912,6 @@ if(USE_SDL_MAINLOOP OR (Audio_TK STREQUA
|
||||||
|
find_package(SDL)
|
||||||
|
SET(HAVE_SDL ${SDL_FOUND})
|
||||||
|
include_directories(${SDL_INCLUDE_DIR})
|
||||||
|
- target_link_libraries(openclonk ${SDL_LIBRARY})
|
||||||
|
endif()
|
||||||
|
|
||||||
|
############################################################################
|
||||||
|
@@ -1094,6 +1093,10 @@ target_link_libraries(openclonk
|
||||||
|
libmisc
|
||||||
|
)
|
||||||
|
|
||||||
|
+if (SDL_FOUND)
|
||||||
|
+ target_link_libraries(openclonk ${SDL_LIBRARY})
|
||||||
|
+endif()
|
||||||
|
+
|
||||||
|
if(Audio_FOUND)
|
||||||
|
target_link_libraries(openclonk ${Audio_LIBRARIES})
|
||||||
|
include_directories(${Audio_INCLUDE_DIRS})
|
|
@ -1,11 +0,0 @@
|
||||||
--- src/platform/StdSync.h.orig 2014-10-05 17:22:07.000000000 +0400
|
|
||||||
+++ src/platform/StdSync.h 2014-11-27 18:14:51.000000000 +0300
|
|
||||||
@@ -135,7 +135,7 @@
|
|
||||||
{
|
|
||||||
// Use pthread_cond_wait or pthread_cond_timedwait depending on wait length. Check return value.
|
|
||||||
// Note this will temporarily unlock the mutex, so no deadlock should occur.
|
|
||||||
- timespec ts = { iMillis / 1000, (iMillis % 1000) * 1000000 };
|
|
||||||
+ timespec ts = { static_cast<time_t>(iMillis / 1000), static_cast<long>(iMillis % 1000) * 1000000 };
|
|
||||||
if (0 != (iMillis != INFINITE ? pthread_cond_timedwait(&cond, &mutex, &ts) : pthread_cond_wait(&cond, &mutex)))
|
|
||||||
{
|
|
||||||
pthread_mutex_unlock(&mutex);
|
|
Loading…
Reference in a new issue