print/py-fontbakery: Update to 0.9.0
- Add FONTVAL, FONTWERK, GOOGLEFONTS, ISO15008, NOTOFONTS, SHAPING and UFO_SOURCES options - Remove FREETYPE option Changes: https://github.com/googlefonts/fontbakery/releases
This commit is contained in:
parent
302ceadbd1
commit
c7dd00af82
3 changed files with 62 additions and 36 deletions
|
@ -1,5 +1,5 @@
|
|||
PORTNAME= fontbakery
|
||||
PORTVERSION= 0.8.13
|
||||
PORTVERSION= 0.9.0
|
||||
DISTVERSIONPREFIX= v
|
||||
CATEGORIES= print python
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
@ -13,33 +13,20 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
|
|||
|
||||
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=6.2:devel/py-setuptools_scm@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}axisregistry>=0.3.0:x11-fonts/py-axisregistry@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}beautifulsoup>=0:www/py-beautifulsoup@${PY_FLAVOR} \
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}babelfont>=0:x11-fonts/py-babelfont@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}beziers>=0.5.0:graphics/py-beziers@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}cmarkgfm>=0:textproc/py-cmarkgfm@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}collidoscope>=0.5.2:print/py-collidoscope@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}defcon>=0:x11-fonts/py-defcon@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}dehinter>=3.1.0:print/py-dehinter@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}font-v>=0:print/py-font-v@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}fonttools>=4.36.0:print/py-fonttools@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}gflanguages>=0.3.0:x11-fonts/py-gflanguages@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}glyphsets>=0.5.0:print/py-glyphsets@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}lxml>=0:devel/py-lxml@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}fonttools>=4.39.0:print/py-fonttools@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}freetype-py>=0:print/py-freetype-py@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}munkres>=0:math/py-munkres@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}opentype-sanitizer>=7.1.9:x11-fonts/py-opentype-sanitizer@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}opentypespec>=0:x11-fonts/py-opentypespec@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}packaging>=0:devel/py-packaging@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}pip-api>=0:devel/py-pip-api@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}protobuf>=3.7.0,1:devel/py-protobuf@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}yaml>=0:devel/py-yaml@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}rich>=0:textproc/py-rich@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}stringbrewer>=0:devel/py-stringbrewer@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}toml>=0:textproc/py-toml@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}ufo2ft>=2.25.2:x11-fonts/py-ufo2ft@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}ufolint>=0:x11-fonts/py-ufolint@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}unicodedata2>=0:devel/py-unicodedata2@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}vharfbuzz>=0.2.0:print/py-vharfbuzz@${PY_FLAVOR}
|
||||
${PYTHON_PKGNAMEPREFIX}toml>=0:textproc/py-toml@${PY_FLAVOR}
|
||||
|
||||
USES= python
|
||||
USE_PYTHON= autoplist concurrent distutils
|
||||
|
@ -49,9 +36,39 @@ NO_ARCH= yes
|
|||
GH_ACCOUNT= googlefonts
|
||||
USE_GITHUB= yes
|
||||
|
||||
OPTIONS_DEFINE= FREETYPE
|
||||
OPTIONS_DEFINE= FONTVAL FONTWERK GOOGLEFONTS ISO15008 NOTOFONTS SHAPING UFO_SOURCES
|
||||
OPTIONS_DEFAULT=FONTVAL FONTWERK GOOGLEFONTS ISO15008 NOTOFONTS SHAPING UFO_SOURCES
|
||||
FONTVAL_DESC= Checks for Font Validator
|
||||
FONTWERK_DESC= Checks for Fontwerk.com
|
||||
FONTWERK_IMPLIES= GOOGLEFONTS
|
||||
GOOGLEFONTS_DESC= Checks for Google Fonts
|
||||
GOOGLEFONTS_IMPLIES= SHAPING UFO_SOURCES
|
||||
ISO15008_DESC= Checks for suitability for in-car displays (ISO 15008)
|
||||
NOTOFONTS_DESC= Checks for Noto fonts
|
||||
NOTOFONTS_IMPLIES= GOOGLEFONTS
|
||||
SHAPING_DESC= Checks for shaping
|
||||
UFO_SOURCES_DESC= Checks for UFO sources
|
||||
|
||||
FREETYPE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}freetype-py>=0:print/py-freetype-py@${PY_FLAVOR}
|
||||
FONTVAL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lxml>=0:devel/py-lxml@${PY_FLAVOR}
|
||||
GOOGLEFONTS_RUN_DEPENDS=${PYTHON_PKGNAMEPREFIX}axisregistry>=0.3.0:x11-fonts/py-axisregistry@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}beautifulsoup>=0:www/py-beautifulsoup@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}dehinter>=3.1.0:print/py-dehinter@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}font-v>=0:print/py-font-v@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}fonttools>=4.39.0:print/py-fonttools@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}gflanguages>=0.3.0:x11-fonts/py-gflanguages@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}glyphsets>=0.5.0:print/py-glyphsets@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}protobuf>=3.7.0,1:devel/py-protobuf@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}vharfbuzz>=0.2.0:print/py-vharfbuzz@${PY_FLAVOR}
|
||||
ISO15008_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}uharfbuzz>=0:print/py-uharfbuzz@${PY_FLAVOR}
|
||||
SHAPING_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}collidoscope>=0.5.2:print/py-collidoscope@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}shaperglot>=0.2.0:x11-fonts/py-shaperglot@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}stringbrewer>=0:devel/py-stringbrewer@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}ufo2ft>=2.25.2:x11-fonts/py-ufo2ft@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}vharfbuzz>=0.2.0:print/py-vharfbuzz@${PY_FLAVOR}
|
||||
UFO_SOURCES_RUN_DEPENDS=${PYTHON_PKGNAMEPREFIX}defcon>=0:x11-fonts/py-defcon@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}fonttools>=4.39.0:print/py-fonttools@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}ufo2ft>=2.25.2:x11-fonts/py-ufo2ft@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}ufolint>=0:x11-fonts/py-ufolint@${PY_FLAVOR}
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|%%PORTVERSION%%|${PORTVERSION}|' ${WRKSRC}/setup.py
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1685995470
|
||||
SHA256 (googlefonts-fontbakery-v0.8.13_GH0.tar.gz) = 8ded27527873a04f9b0eb527f2bbf0adbcd9cec4fb72c6d4692068bc35ebf8ac
|
||||
SIZE (googlefonts-fontbakery-v0.8.13_GH0.tar.gz) = 46414525
|
||||
TIMESTAMP = 1695143355
|
||||
SHA256 (googlefonts-fontbakery-v0.9.0_GH0.tar.gz) = f05094545172eaa4c4700adddca31f6c78da4c4bb0516adc20b04d7d8a8186e6
|
||||
SIZE (googlefonts-fontbakery-v0.9.0_GH0.tar.gz) = 47185543
|
||||
|
|
|
@ -1,20 +1,29 @@
|
|||
--- setup.py.orig 2023-06-01 00:42:56 UTC
|
||||
--- setup.py.orig 2023-09-12 12:07:05 UTC
|
||||
+++ setup.py
|
||||
@@ -23,7 +23,7 @@ except IOError:
|
||||
@@ -55,7 +55,7 @@ googlefonts_extras = (
|
||||
"gflanguages>=0.3.0", # 0.3.0 had an api simplification/update
|
||||
# (see https://github.com/googlefonts/gflanguages/pull/7)
|
||||
"glyphsets>=0.5.0",
|
||||
- "protobuf>=3.7.0, <4", # 3.7.0 fixed a bug on parsing some METADATA.pb files.
|
||||
+ "protobuf>=3.7.0", # 3.7.0 fixed a bug on parsing some METADATA.pb files.
|
||||
# We cannot use v4 because our protobuf files have been compiled with v3.
|
||||
# (see https://github.com/fonttools/fontbakery/issues/2200)
|
||||
f"vharfbuzz{VHARFBUZZ_VERSION}",
|
||||
@@ -96,7 +96,7 @@ all_extras = set(
|
||||
|
||||
setup(
|
||||
name="fontbakery",
|
||||
- use_scm_version={"write_to": "Lib/fontbakery/_version.py"},
|
||||
+ use_scm_version={"fallback_version": "%%PORTVERSION%%", "write_to": "Lib/fontbakery/_version.py"},
|
||||
url='https://github.com/googlefonts/fontbakery/',
|
||||
description='Well designed Font QA tool, written in Python 3',
|
||||
url="https://github.com/fonttools/fontbakery/",
|
||||
description="A font quality assurance tool for everyone",
|
||||
long_description=readme,
|
||||
@@ -83,7 +83,7 @@ setup(
|
||||
'pip-api', # needed for checking Font Bakery's version
|
||||
# 3.7.0 fixed a bug on parsing some METADATA.pb files.
|
||||
# We cannot use v4 because our protobuf files have been compiled with v3.
|
||||
- 'protobuf>=3.7.0, <4',
|
||||
+ 'protobuf>=3.7.0',
|
||||
# (see https://github.com/googlefonts/fontbakery/issues/2200)
|
||||
'PyYAML',
|
||||
'requests',
|
||||
@@ -148,7 +148,7 @@ setup(
|
||||
# core dependencies
|
||||
"babelfont",
|
||||
f"fontTools{FONTTOOLS_VERSION}",
|
||||
- "freetype-py!=2.4.0", # Avoiding 2.4.0 due to seg-fault described at
|
||||
+ "freetype-py", # Avoiding 2.4.0 due to seg-fault described at
|
||||
# https://github.com/fonttools/fontbakery/issues/4143
|
||||
"opentypespec",
|
||||
"opentype-sanitizer>=7.1.9", # 7.1.9 fixes caret value format = 3 bug
|
||||
|
|
Loading…
Reference in a new issue