- Fix build on DragonFly

- Strip binary
This commit is contained in:
Dmitry Marakasov 2015-04-01 14:10:44 +00:00
parent 113296853a
commit c801b56286
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=382915
3 changed files with 23 additions and 1 deletions

View file

@ -3,7 +3,7 @@
PORTNAME= einstein
PORTVERSION= 2.0
PORTREVISION= 9
PORTREVISION= 10
CATEGORIES= games
MASTER_SITES= http://games.flowix.com/files/einstein/
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
@ -20,4 +20,7 @@ post-patch:
-e "s,@@PREFIX@@,${PREFIX}," \
${WRKSRC}/Makefile
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/einstein
.include <bsd.port.mk>

View file

@ -0,0 +1,10 @@
--- convert.h.orig 2005-08-14 06:40:58.000000000 +0400
+++ convert.h 2015-03-27 02:57:05.826432000 +0300
@@ -5,6 +5,7 @@
#include <iostream>
#include <sstream>
#include <string>
+#include <typeinfo>
#include "exceptions.h"
#include "unicode.h"

View file

@ -0,0 +1,9 @@
--- unicode.cpp.orig 2005-08-14 06:40:58.000000000 +0400
+++ unicode.cpp 2015-03-27 02:57:47.513365000 +0300
@@ -1,5 +1,6 @@
#include <wchar.h>
#include <stdlib.h>
+#include <string.h>
#ifdef WIN32
#include <windows.h>
#endif