astro/boinc-setiathome-enhanced: Project is switching, use astro/boinc-setiathome-v7 instead
This commit is contained in:
Rene Ladan 2013-10-21 20:25:23 +00:00
parent 40e14aa23a
commit c8223c167a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=331188
17 changed files with 1 additions and 328 deletions

1
MOVED
View file

@ -5135,3 +5135,4 @@ devel/rubygem-ruby-debug-ide||2013-10-21|Has expired: Does not work with Ruby 1.
devel/rubygem-ruby-debug||2013-10-21|Has expired: Does not work with Ruby 1.9
japanese/gorua||2013-10-21|Has expired: Does not work with Ruby 1.9
x11-toolkits/ruby-gtk||2013-10-21|Has expired: Does not work with Ruby 1.9
astro/boinc-setiathome-enhanced|astro/boinc-setiathome-v7|2013-10-21|Removed: Project is switching, use astro/boinc-setiathome-v7 instead; broken on 10.0

View file

@ -8,7 +8,6 @@
SUBDIR += accrete
SUBDIR += astrometry
SUBDIR += boinc-astropulse
SUBDIR += boinc-setiathome-enhanced
SUBDIR += boinc-setiathome-v7
SUBDIR += celestia
SUBDIR += celestia-gnome

View file

@ -1,118 +0,0 @@
# Created by: rene
# $FreeBSD$
PORTNAME= boinc-setiathome-enhanced
PORTVERSION= 6.12
PORTREVISION= 7
CATEGORIES= astro
MASTER_SITES= ftp://rene-ladan.nl/pub/distfiles/
DISTNAME= setiathome-svn-1008
MAINTAINER= rene@FreeBSD.org
COMMENT= Setiathome Enhanced for BOINC
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
DEPRECATED= Project is switching, use astro/boinc-setiathome-v7 instead
BUILD_DEPENDS= ${LOCALBASE}/include/fftw3.h:${PORTSDIR}/math/fftw3
RUN_DEPENDS= boinc_client:${PORTSDIR}/net/boinc-client
LIB_DEPENDS= libfftw3f.so:${PORTSDIR}/math/fftw3-float
USES= gmake pkgconfig
USE_XZ= yes
USE_AUTOTOOLS= autoconf:env automake:env
GNU_CONFIGURE= yes
USE_GCC= any
NEED_ROOT= yes
CFLAGS+= -O2 -I${LOCALBASE}/include/boinc -I${LOCALBASE}/include \
-L${LOCALBASE}/lib
.if defined(CPUTYPE)
CFLAGS+= -march=${CPUTYPE}
.endif
# these must match settings in ${PORTSDIR}/net/boinc-client/Makefile
BOINC_CLIENT_USER?= boinc
BOINC_CLIENT_GROUP?= nobody
BOINC_CLIENT_HOME?= /var/db/boinc
OPTIONS_DEFINE= X11
X11_DESC= Build screensaver (requires net/boinc-client with X11)
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MX11}
LIB_DEPENDS+= libjpeg.so:${PORTSDIR}/graphics/jpeg
USE_GL= gl glu glut
USE_XORG= ice sm x11 xau xcb xext xi xdamage xdmcp xfixes xmu xt xxf86vm
BUILD_DEPENDS+= ${LOCALBASE}/lib/libboinc_graphics2.a:${PORTSDIR}/net/boinc-client
PLIST_SUB+= X11=""
CONFLICTS= boinc-setiathome-v7-[0-9]*
.else
BUILD_DEPENDS+= ${LOCALBASE}/include/boinc/std_fixes.h:${PORTSDIR}/net/boinc-client
CONFIGURE_ARGS+= --disable-graphics
PLIST_SUB+= X11="@comment "
.endif
.if ${ARCH} == i386 || ${ARCH} == amd64
# comment out if world is built with clang and port with gcc
CFLAGS+= -mtune=native
.endif
.if !empty(MACHINE_CPU:Maltivec)
CONFIGURE_ARGS+= --enable-altivec
.endif
CONFIGURE_ENV+= BOINCDIR="${NONEXISTENT}"
CONFIGURE_ARGS+= --disable-static-client --disable-server \
--disable-tests \
--with-boinc-platform=${ARCH}-portbld-freebsd
SETI_SITE= setiathome.berkeley.edu
SETI_BINARY= setiathome-${PORTVERSION:S/.0/./}.${ARCH}-portbld-freebsd
SUB_FILES= pkg-deinstall pkg-install pkg-message
SUB_LIST= SETI_BINARY=${SETI_BINARY} \
SETI_SITE=${SETI_SITE} \
SETI_VERSION=${PORTVERSION:S/.//} \
BOINC_CLIENT_HOME=${BOINC_CLIENT_HOME} \
BOINC_CLIENT_USER=${BOINC_CLIENT_USER} \
BOINC_CLIENT_GROUP=${BOINC_CLIENT_GROUP}
PLIST_SUB+= SETI_BINARY=${SETI_BINARY} \
SETI_SITE=${SETI_SITE} \
BOINC_CLIENT_HOME=${BOINC_CLIENT_HOME} \
PREFIX=${PREFIX}
# str_replace.h is included in newer versions of net/boinc-client,
# but it is not needed on FreeBSD
post-patch:
${REINPLACE_CMD} -E -e "s|#include \"str_replace.h\"||" \
${WRKSRC}/client/main.cpp \
${WRKSRC}/client/sah_gfx.cpp \
${WRKSRC}/client/seti.cpp \
${WRKSRC}/client/timecvt.cpp \
${WRKSRC}/db/xml_util.cpp
pre-configure:
(cd ${WRKSRC} ; ./_autosetup)
do-install:
${INSTALL} -d -o ${BOINC_CLIENT_USER} -g ${BOINC_CLIENT_GROUP} \
${STAGEDIR}${BOINC_CLIENT_HOME}/projects
${INSTALL} -d -o ${BOINC_CLIENT_USER} -g ${BOINC_CLIENT_GROUP} \
${STAGEDIR}${BOINC_CLIENT_HOME}/projects/${SETI_SITE}
${INSTALL_PROGRAM} -o ${BOINC_CLIENT_USER} -g ${BOINC_CLIENT_GROUP} \
${WRKSRC}/client/${SETI_BINARY} \
${STAGEDIR}${BOINC_CLIENT_HOME}/projects/${SETI_SITE}/
.if ${PORT_OPTIONS:MX11}
${INSTALL_PROGRAM} -o ${BOINC_CLIENT_USER} -g ${BOINC_CLIENT_GROUP} \
${WRKSRC}/client/seti_graphics \
${STAGEDIR}${BOINC_CLIENT_HOME}/projects/${SETI_SITE}/
.endif
.include <bsd.port.mk>

View file

@ -1,2 +0,0 @@
SHA256 (setiathome-svn-1008.tar.xz) = bde909b6922e94abe9b454e81b5c84dffb0fef64bf60ed3dbe4121f87fe31d6e
SIZE (setiathome-svn-1008.tar.xz) = 1771116

View file

@ -1,11 +0,0 @@
--- client/Makefile.am.orig 2009-09-23 01:50:50.000000000 +0200
+++ client/Makefile.am 2011-12-04 17:19:18.000000000 +0100
@@ -165,7 +165,7 @@
seti_boinc-analyzeFuncs_altivec.o: vector/analyzeFuncs_altivec.cpp
if $(CXX) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
$(CPPFLAGS) $(seti_boinc_CXXFLAGS) $(CXXFLAGS) -DUSE_ALTIVEC \
- -MT $@ -MD -MP -MF "$(DEPDIR)/$*.Tpo" -faltivec \
+ -MT $@ -MD -MP -MF "$(DEPDIR)/$*.Tpo" -maltivec -mabi=altivec \
-c -o $@ $<; then mv -f "$(DEPDIR)/$*.Tpo" "$(DEPDIR)/$*.Po"; \
else rm -f "$(DEPDIR)/$*.Tpo"; exit 1; fi
seti_boinc-analyzeFuncs_vector.o: vector/analyzeFuncs_vector.cpp

View file

@ -1,10 +0,0 @@
--- client/analyzeFuncs.cpp.orig 2008-07-31 02:02:10.000000000 +0200
+++ client/analyzeFuncs.cpp 2013-08-06 18:48:46.000000000 +0200
@@ -415,7 +415,6 @@
fftlen = ChirpFftPairs[icfft].FftLen;
chirprate = ChirpFftPairs[icfft].ChirpRate;
chirprateind = ChirpFftPairs[icfft].ChirpRateInd;
- boinc_fpops_cumulative((SETUP_FLOPS+analysis_state.FLOP_counter)*LOAD_STORE_ADJUSTMENT);
// boinc_worker_timer();
#ifdef DEBUG
double ptime=static_cast<double>((unsigned)clock())/CLOCKS_PER_SEC+

View file

@ -1,11 +0,0 @@
--- client/seti.h.orig 2009-01-26 18:01:09.000000000 +0100
+++ client/seti.h 2013-08-06 18:48:50.000000000 +0200
@@ -35,8 +35,6 @@
#include <vector>
#include "boinc_api.h"
-#define boinc_fpops_cumulative(x) boinc_ops_cumulative(x,0)
-
extern APP_INIT_DATA app_init_data;
#include "analyze.h"

View file

@ -1,10 +0,0 @@
--- client/vector/analyzeFuncs_sse.cpp.orig 2008-08-19 21:24:46.000000000 +0200
+++ client/vector/analyzeFuncs_sse.cpp 2012-04-19 12:51:10.000000000 +0200
@@ -32,6 +32,7 @@
// This file is empty is __i386__ is not defined
#include "sah_config.h"
#include <vector>
+#include <math.h>
#if defined(__i386__) || defined(__x86_64__)

View file

@ -1,19 +0,0 @@
--- ./client/vector/analyzeFuncs_vector.cpp.orig 2009-07-14 21:02:10.000000000 +0200
+++ ./client/vector/analyzeFuncs_vector.cpp 2013-09-23 19:16:42.000000000 +0200
@@ -86,13 +86,12 @@
#include <sys/sysctl.h>
#endif
+using namespace std;
-#ifdef HAVE___ISNAN
-#define isnotnan(x) (!__isnan(x))
-#elif defined(HAVE__ISNAN)
+#if defined(HAVE__ISNAN)
#define isnotnan(x) (!_isnan(x))
#elif defined(HAVE_ISNAN)
-#define isnotnam(x) (!isnan(x))
+#define isnotnan(x) (!isnan(x))
#else
#define isnotnan(x) ((x) == (x))
#endif

View file

@ -1,18 +0,0 @@
--- client/worker.cpp.orig 2008-07-31 02:02:10.000000000 +0200
+++ client/worker.cpp 2013-08-06 18:48:48.000000000 +0200
@@ -153,7 +153,6 @@
retval = seti_do_work();
if (retval) SETIERROR(retval,"from seti_do_work() in worker()");
- boinc_fpops_cumulative((SETUP_FLOPS+analysis_state.FLOP_counter)*LOAD_STORE_ADJUSTMENT);
boinc_finish(retval);
}
catch (seti_error e) {
@@ -165,7 +164,6 @@
remaining=0;
boinc_fraction_done(progress);
checkpoint(true); // force a checkpoint
- boinc_fpops_cumulative((SETUP_FLOPS+analysis_state.FLOP_counter)*LOAD_STORE_ADJUSTMENT);
boinc_finish(0);
exit(0); // an overflow is not an app error
} else {

View file

@ -1,22 +0,0 @@
--- configure.ac.orig 2010-09-29 22:47:20.000000000 +0200
+++ configure.ac 2011-02-28 08:36:17.000000000 +0100
@@ -5,17 +5,10 @@
AC_PREREQ(2.57)
AC_INIT(setiathome_enhanced, 6.12, ports@setiathome.ssl.berkeley.edu)
-svnrev="`svn info | grep Revision:`"
-if test -n "${svnrev}" ; then
- AC_REVISION("${svnrev}")
- AC_DEFINE_UNQUOTED(SVN_REV,"${svnrev}",
+AC_REVISION([$Revision: 1008 $])
+AC_DEFINE(SVN_REV,"$Revision: 1008 $",
[Define to be the subversion revision number])
-else
- AC_REVISION([$Revision: 316 $])
- AC_DEFINE(SVN_REV,"$Revision: 316 $",
- [Define to be the subversion revision number])
-fi
AC_CANONICAL_TARGET
AM_INIT_AUTOMAKE(dist-zip)

View file

@ -1,11 +0,0 @@
--- m4/sah_check_boinc.m4.orig 2008-09-09 18:55:19.000000000 +0200
+++ m4/sah_check_boinc.m4 2011-03-13 16:24:18.000000000 +0100
@@ -30,7 +30,7 @@
cd $thisdir
break
else
- if $FIND $boinc_dir -name "std_fixes.h" >& /dev/null
+ if $FIND $boinc_dir -name "std_fixes.h" > /dev/null
then
BOINCDIR=`$FIND $boinc_dir -name "std_fixes.h" -print | $HEAD -1 | sed 's/\/std_fixes.h//'`
cd $BOINCDIR/..

View file

@ -1,26 +0,0 @@
#!/bin/sh
# $FreeBSD$
if [ "$2" != "POST-DEINSTALL" ]; then
exit 0
fi
F=%%BOINC_CLIENT_HOME%%/projects/%%SETI_SITE%%/app_info.xml
echo Removing setiathome_enhanced lines from $F
l=`grep -n "<name>setiathome_enhanced</name>" $F | cut -f 1 -d :`
if [ $? -ne 0 ]; then
echo $F is corrupt
exit 1
fi
l1=$(($l-1))
l2=$(($l+13))
sed -i.bak "${l1},${l2}d" $F # sed wants the braces
rm $F.bak
l=`wc -l $F | cut -f 1 -d / | sed 's/ //g'`
if [ $l -eq 2 ]; then
echo Removing empty $F
rm $F
fi

View file

@ -1,39 +0,0 @@
#!/bin/sh
# $FreeBSD$
if [ "$2" != "POST-INSTALL" ]; then
exit 0
fi
F=%%BOINC_CLIENT_HOME%%/projects/%%SETI_SITE%%/app_info.xml
if [ ! -f $F ]; then
echo Creating new $F
echo "<app_info>" > $F
echo "</app_info>" >> $F
chown %%BOINC_CLIENT_USER%%:%%BOINC_CLIENT_GROUP%% $F
fi
echo Adding setiathome_enhanced lines to $F
ed - $F <<EOF
1a
<app>
<name>setiathome_enhanced</name>
</app>
<file_info>
<name>%%SETI_BINARY%%</name>
<executable/>
</file_info>
<app_version>
<app_name>setiathome_enhanced</app_name>
<version_num>%%SETI_VERSION%%</version_num>
<file_ref>
<file_name>%%SETI_BINARY%%</file_name>
<main_program/>
</file_ref>
</app_version>
.
w
q
EOF

View file

@ -1,16 +0,0 @@
*****************************************************************************
ATTACHING PROJECT
Just run boinc_gui (if installed), choose Attach, and follow instructions.
Project URL is %%SETI_SITE%%
MANUAL INSTALLATION
*) If this is your first time in any BOINC project, create a new account at
http://%%SETI_SITE%%/create_account_form.php
*) Or get your account key at http://%%SETI_SITE%%/get_passwd.php
*) Attach to the project:
cd %%BOINC_CLIENT_HOME%%
boinccmd --project_attach %%SETI_SITE%% <account key>
*****************************************************************************

View file

@ -1,9 +0,0 @@
SETI - Search for Extra-Terrestrial Intelligence -- Enhanced version
Use your unused CPU cycles to aid in computations analyzing radio
telescope information for possible signs of extra-terrestrial intelligence.
The port automatically optimizes for the host CPU using the CPUTYPE
variable in /etc/make.conf
WWW: http://setiathome.berkeley.edu/

View file

@ -1,5 +0,0 @@
@cwd %%BOINC_CLIENT_HOME%%/projects
%%SETI_SITE%%/%%SETI_BINARY%%
%%X11%%%%SETI_SITE%%/seti_graphics
@dirrmtry %%SETI_SITE%%
@cwd %%PREFIX%%