proftpd is a highly configurable ftp daemon.
PR: ports/5588 Submitted by: Stephane Legrand <stephane@lituus.fr>
This commit is contained in:
parent
4f7b6a5a0d
commit
c832199dd9
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=9700
12 changed files with 264 additions and 0 deletions
48
ftp/proftpd-devel/Makefile
Normal file
48
ftp/proftpd-devel/Makefile
Normal file
|
@ -0,0 +1,48 @@
|
|||
# New ports collection makefile for: proftpd
|
||||
# Version required: 1.0.0
|
||||
# Date created: 26 January 1998
|
||||
# Whom: Stephane Legrand
|
||||
#
|
||||
# $Id$
|
||||
#
|
||||
|
||||
DISTNAME= proftpd-1.0.0
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= ftp://ftp.proftpd.org/distrib/
|
||||
|
||||
MAINTAINER= stephane@lituus.fr
|
||||
|
||||
MAN1= ftpwho.1 ftpcount.1
|
||||
MAN8= proftpd.8 ftpshut.8
|
||||
|
||||
USE_GMAKE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= CFLAGS="${CFLAGS}"
|
||||
|
||||
#
|
||||
# Ugly but "configure --prefix=..." doesn't seem work :(
|
||||
# So, do a "sed" to set prefix to $PREFIX
|
||||
#
|
||||
# Ugly again, do a "sed" to set the config dir to ${PREFIX}/etc
|
||||
#
|
||||
|
||||
pre-build:
|
||||
${SED} -e "s:^prefix=\/usr:prefix=${PREFIX}:" < ${WRKSRC}/Makefile > ${WRKSRC}/Makefile.tmp
|
||||
${MV} ${WRKSRC}/Makefile.tmp ${WRKSRC}/Makefile
|
||||
|
||||
${SED} -e "s:^etcdir=\/etc:etcdir=${PREFIX}\/etc:" < ${WRKSRC}/Makefile > ${WRKSRC}/Makefile.tmp
|
||||
${MV} ${WRKSRC}/Makefile.tmp ${WRKSRC}/Makefile
|
||||
|
||||
${SED} -e "s:^libexecdir=\/libexec:libexecdir=${PREFIX}\/libexec:" < ${WRKSRC}/Makefile > ${WRKSRC}/Makefile.tmp
|
||||
${MV} ${WRKSRC}/Makefile.tmp ${WRKSRC}/Makefile
|
||||
|
||||
${SED} -e 's:\/etc\/proftpd\.conf:${PREFIX}\/etc\/proftpd.conf:' < ${WRKSRC}/config.h > ${WRKSRC}/config.h.tmp
|
||||
${MV} ${WRKSRC}/config.h.tmp ${WRKSRC}/config.h
|
||||
|
||||
post-install:
|
||||
strip ${PREFIX}/bin/ftpcount
|
||||
strip ${PREFIX}/bin/ftpwho
|
||||
strip ${PREFIX}/libexec/proftpd
|
||||
strip ${PREFIX}/sbin/ftpshut
|
||||
|
||||
.include <bsd.port.mk>
|
1
ftp/proftpd-devel/distinfo
Normal file
1
ftp/proftpd-devel/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (proftpd-1.0.0.tar.gz) = 736719658018ef370aa88d3e52ef021d
|
63
ftp/proftpd-devel/files/patch-aa
Normal file
63
ftp/proftpd-devel/files/patch-aa
Normal file
|
@ -0,0 +1,63 @@
|
|||
--- sample-configurations/basic.conf.orig Tue Nov 18 02:23:12 1997
|
||||
+++ sample-configurations/basic.conf Mon Jan 26 22:45:53 1998
|
||||
@@ -1,3 +1,8 @@
|
||||
+#
|
||||
+# To have more informations about Proftpd configuration
|
||||
+# look at : http://www.proftpd.org/
|
||||
+#
|
||||
+
|
||||
# This is a basic ProFTPD configuration file (rename it to
|
||||
# 'proftpd.conf' for actual use. It establishes a single server
|
||||
# and a single anonymous login. It assumes that you have a user/group
|
||||
@@ -23,24 +28,31 @@
|
||||
AllowOverwrite on
|
||||
</Directory>
|
||||
|
||||
-# A basic anonymous configuration, no upload directories.
|
||||
-<Anonymous ~ftp>
|
||||
- User ftp
|
||||
- Group ftp
|
||||
- # We want clients to be able to login with "anonymous" as well as "ftp"
|
||||
- UserAlias anonymous ftp
|
||||
-
|
||||
- # Limit the maximum number of anonymous logins
|
||||
- MaxClients 10
|
||||
-
|
||||
- # We want 'welcome.msg' displayed at login, and '.message' displayed
|
||||
- # in each newly chdired directory.
|
||||
- DisplayLogin welcome.msg
|
||||
- DisplayFirstChdir .message
|
||||
-
|
||||
- # Limit WRITE everywhere in the anonymous chroot
|
||||
- <Limit WRITE>
|
||||
- DenyAll
|
||||
- </Limit>
|
||||
|
||||
-</Anonymous>
|
||||
+#########################################################################
|
||||
+# #
|
||||
+# Uncomment lines with only one # to allow basic anonymous access #
|
||||
+# #
|
||||
+#########################################################################
|
||||
+
|
||||
+### A basic anonymous configuration, no upload directories.
|
||||
+# <Anonymous ~ftp>
|
||||
+# User ftp
|
||||
+# Group ftp
|
||||
+ ### We want clients to be able to login with "anonymous" as well as "ftp"
|
||||
+ # UserAlias anonymous ftp
|
||||
+
|
||||
+ ### Limit the maximum number of anonymous logins
|
||||
+ # MaxClients 10
|
||||
+
|
||||
+ ### We want 'welcome.msg' displayed at login, and '.message' displayed
|
||||
+ ### in each newly chdired directory.
|
||||
+ # DisplayLogin welcome.msg
|
||||
+ # DisplayFirstChdir .message
|
||||
+
|
||||
+ ### Limit WRITE everywhere in the anonymous chroot
|
||||
+ # <Limit WRITE>
|
||||
+ # DenyAll
|
||||
+ # </Limit>
|
||||
+
|
||||
+# </Anonymous>
|
1
ftp/proftpd-devel/pkg-comment
Normal file
1
ftp/proftpd-devel/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
Highly configurable ftp daemon.
|
10
ftp/proftpd-devel/pkg-descr
Normal file
10
ftp/proftpd-devel/pkg-descr
Normal file
|
@ -0,0 +1,10 @@
|
|||
ProFTPD is a highly configurable ftp daemon for unix
|
||||
and unix-like operating systems. ProFTPD is designed
|
||||
to be somewhat of a "drop-in" replacement for wu-ftpd.
|
||||
|
||||
Full online documentation is available at
|
||||
http://www.proftpd.org/, including a server
|
||||
configuration directive reference manual.
|
||||
|
||||
- Stephane Legrand
|
||||
stephane@lituus.fr
|
9
ftp/proftpd-devel/pkg-plist
Normal file
9
ftp/proftpd-devel/pkg-plist
Normal file
|
@ -0,0 +1,9 @@
|
|||
bin/ftpcount
|
||||
bin/ftpwho
|
||||
etc/proftpd.conf
|
||||
libexec/proftpd
|
||||
sbin/ftpshut
|
||||
man/man8/proftpd.8.gz
|
||||
man/man8/ftpshut.8.gz
|
||||
man/man1/ftpwho.1.gz
|
||||
man/man1/ftpcount.1.gz
|
48
ftp/proftpd/Makefile
Normal file
48
ftp/proftpd/Makefile
Normal file
|
@ -0,0 +1,48 @@
|
|||
# New ports collection makefile for: proftpd
|
||||
# Version required: 1.0.0
|
||||
# Date created: 26 January 1998
|
||||
# Whom: Stephane Legrand
|
||||
#
|
||||
# $Id$
|
||||
#
|
||||
|
||||
DISTNAME= proftpd-1.0.0
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= ftp://ftp.proftpd.org/distrib/
|
||||
|
||||
MAINTAINER= stephane@lituus.fr
|
||||
|
||||
MAN1= ftpwho.1 ftpcount.1
|
||||
MAN8= proftpd.8 ftpshut.8
|
||||
|
||||
USE_GMAKE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= CFLAGS="${CFLAGS}"
|
||||
|
||||
#
|
||||
# Ugly but "configure --prefix=..." doesn't seem work :(
|
||||
# So, do a "sed" to set prefix to $PREFIX
|
||||
#
|
||||
# Ugly again, do a "sed" to set the config dir to ${PREFIX}/etc
|
||||
#
|
||||
|
||||
pre-build:
|
||||
${SED} -e "s:^prefix=\/usr:prefix=${PREFIX}:" < ${WRKSRC}/Makefile > ${WRKSRC}/Makefile.tmp
|
||||
${MV} ${WRKSRC}/Makefile.tmp ${WRKSRC}/Makefile
|
||||
|
||||
${SED} -e "s:^etcdir=\/etc:etcdir=${PREFIX}\/etc:" < ${WRKSRC}/Makefile > ${WRKSRC}/Makefile.tmp
|
||||
${MV} ${WRKSRC}/Makefile.tmp ${WRKSRC}/Makefile
|
||||
|
||||
${SED} -e "s:^libexecdir=\/libexec:libexecdir=${PREFIX}\/libexec:" < ${WRKSRC}/Makefile > ${WRKSRC}/Makefile.tmp
|
||||
${MV} ${WRKSRC}/Makefile.tmp ${WRKSRC}/Makefile
|
||||
|
||||
${SED} -e 's:\/etc\/proftpd\.conf:${PREFIX}\/etc\/proftpd.conf:' < ${WRKSRC}/config.h > ${WRKSRC}/config.h.tmp
|
||||
${MV} ${WRKSRC}/config.h.tmp ${WRKSRC}/config.h
|
||||
|
||||
post-install:
|
||||
strip ${PREFIX}/bin/ftpcount
|
||||
strip ${PREFIX}/bin/ftpwho
|
||||
strip ${PREFIX}/libexec/proftpd
|
||||
strip ${PREFIX}/sbin/ftpshut
|
||||
|
||||
.include <bsd.port.mk>
|
1
ftp/proftpd/distinfo
Normal file
1
ftp/proftpd/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (proftpd-1.0.0.tar.gz) = 736719658018ef370aa88d3e52ef021d
|
63
ftp/proftpd/files/patch-aa
Normal file
63
ftp/proftpd/files/patch-aa
Normal file
|
@ -0,0 +1,63 @@
|
|||
--- sample-configurations/basic.conf.orig Tue Nov 18 02:23:12 1997
|
||||
+++ sample-configurations/basic.conf Mon Jan 26 22:45:53 1998
|
||||
@@ -1,3 +1,8 @@
|
||||
+#
|
||||
+# To have more informations about Proftpd configuration
|
||||
+# look at : http://www.proftpd.org/
|
||||
+#
|
||||
+
|
||||
# This is a basic ProFTPD configuration file (rename it to
|
||||
# 'proftpd.conf' for actual use. It establishes a single server
|
||||
# and a single anonymous login. It assumes that you have a user/group
|
||||
@@ -23,24 +28,31 @@
|
||||
AllowOverwrite on
|
||||
</Directory>
|
||||
|
||||
-# A basic anonymous configuration, no upload directories.
|
||||
-<Anonymous ~ftp>
|
||||
- User ftp
|
||||
- Group ftp
|
||||
- # We want clients to be able to login with "anonymous" as well as "ftp"
|
||||
- UserAlias anonymous ftp
|
||||
-
|
||||
- # Limit the maximum number of anonymous logins
|
||||
- MaxClients 10
|
||||
-
|
||||
- # We want 'welcome.msg' displayed at login, and '.message' displayed
|
||||
- # in each newly chdired directory.
|
||||
- DisplayLogin welcome.msg
|
||||
- DisplayFirstChdir .message
|
||||
-
|
||||
- # Limit WRITE everywhere in the anonymous chroot
|
||||
- <Limit WRITE>
|
||||
- DenyAll
|
||||
- </Limit>
|
||||
|
||||
-</Anonymous>
|
||||
+#########################################################################
|
||||
+# #
|
||||
+# Uncomment lines with only one # to allow basic anonymous access #
|
||||
+# #
|
||||
+#########################################################################
|
||||
+
|
||||
+### A basic anonymous configuration, no upload directories.
|
||||
+# <Anonymous ~ftp>
|
||||
+# User ftp
|
||||
+# Group ftp
|
||||
+ ### We want clients to be able to login with "anonymous" as well as "ftp"
|
||||
+ # UserAlias anonymous ftp
|
||||
+
|
||||
+ ### Limit the maximum number of anonymous logins
|
||||
+ # MaxClients 10
|
||||
+
|
||||
+ ### We want 'welcome.msg' displayed at login, and '.message' displayed
|
||||
+ ### in each newly chdired directory.
|
||||
+ # DisplayLogin welcome.msg
|
||||
+ # DisplayFirstChdir .message
|
||||
+
|
||||
+ ### Limit WRITE everywhere in the anonymous chroot
|
||||
+ # <Limit WRITE>
|
||||
+ # DenyAll
|
||||
+ # </Limit>
|
||||
+
|
||||
+# </Anonymous>
|
1
ftp/proftpd/pkg-comment
Normal file
1
ftp/proftpd/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
Highly configurable ftp daemon.
|
10
ftp/proftpd/pkg-descr
Normal file
10
ftp/proftpd/pkg-descr
Normal file
|
@ -0,0 +1,10 @@
|
|||
ProFTPD is a highly configurable ftp daemon for unix
|
||||
and unix-like operating systems. ProFTPD is designed
|
||||
to be somewhat of a "drop-in" replacement for wu-ftpd.
|
||||
|
||||
Full online documentation is available at
|
||||
http://www.proftpd.org/, including a server
|
||||
configuration directive reference manual.
|
||||
|
||||
- Stephane Legrand
|
||||
stephane@lituus.fr
|
9
ftp/proftpd/pkg-plist
Normal file
9
ftp/proftpd/pkg-plist
Normal file
|
@ -0,0 +1,9 @@
|
|||
bin/ftpcount
|
||||
bin/ftpwho
|
||||
etc/proftpd.conf
|
||||
libexec/proftpd
|
||||
sbin/ftpshut
|
||||
man/man8/proftpd.8.gz
|
||||
man/man8/ftpshut.8.gz
|
||||
man/man1/ftpwho.1.gz
|
||||
man/man1/ftpcount.1.gz
|
Loading…
Reference in a new issue