update firefox-esr to 78.8.0 (rc2)
Release Notes (soon): https://www.mozilla.org/en-US/firefox/78.8.0/releasenotes/ Removed patches applied upstream, massaged patches where surrounding code changed. MFH: 2021Q1 (when GA)
This commit is contained in:
parent
6dd47cc228
commit
c86570612a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=565791
6 changed files with 7 additions and 178 deletions
|
@ -2,8 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= firefox
|
||||
DISTVERSION= 78.7.1
|
||||
PORTREVISION= 1
|
||||
DISTVERSION= 78.8.0
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}esr/source \
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1612510531
|
||||
SHA256 (firefox-78.7.1esr.source.tar.xz) = 5042783e2cf94d21dd990d2083800f05bc32f8ba65532a715c7be3cb7716b837
|
||||
SIZE (firefox-78.7.1esr.source.tar.xz) = 334417504
|
||||
TIMESTAMP = 1613560530
|
||||
SHA256 (firefox-78.8.0esr.source.tar.xz) = 1cf2dfdee2e31fd0a5ecced6275a33fa11bee1d2a7c65e23350b26992584a110
|
||||
SIZE (firefox-78.8.0esr.source.tar.xz) = 330937116
|
||||
|
|
|
@ -8,11 +8,11 @@ index 75c2c5e435e35..4d8c09c02759b 100644
|
|||
@@ -37,7 +37,7 @@ pref("extensions.webextOptionalPermissionPrompts", true);
|
||||
// Preferences for AMO integration
|
||||
pref("extensions.getAddons.cache.enabled", true);
|
||||
pref("extensions.getAddons.get.url", "https://services.addons.mozilla.org/api/v3/addons/search/?guid=%IDS%&lang=%LOCALE%");
|
||||
pref("extensions.getAddons.get.url", "https://services.addons.mozilla.org/api/v4/addons/search/?guid=%IDS%&lang=%LOCALE%");
|
||||
-pref("extensions.getAddons.search.browseURL", "https://addons.mozilla.org/%LOCALE%/firefox/search?q=%TERMS%&platform=%OS%&appver=%VERSION%");
|
||||
+pref("extensions.getAddons.search.browseURL", "https://addons.mozilla.org/%LOCALE%/firefox/search?q=%TERMS%&platform=Linux&appver=%VERSION%");
|
||||
pref("extensions.getAddons.link.url", "https://addons.mozilla.org/%LOCALE%/firefox/");
|
||||
pref("extensions.getAddons.langpacks.url", "https://services.addons.mozilla.org/api/v3/addons/language-tools/?app=firefox&type=language&appversion=%VERSION%");
|
||||
pref("extensions.getAddons.langpacks.url", "https://services.addons.mozilla.org/api/v4/addons/language-tools/?app=firefox&type=language&appversion=%VERSION%");
|
||||
pref("extensions.getAddons.discovery.api_url", "https://services.addons.mozilla.org/api/v4/discovery/?lang=%LOCALE%&edition=%DISTRIBUTION%");
|
||||
@@ -168,8 +168,8 @@ pref("app.update.staging.enabled", true);
|
||||
// .. etc ..
|
||||
|
|
|
@ -7,7 +7,7 @@ index 855214a..1e91d51 100644
|
|||
@imports(_from='mozbuild.pythonutil', _import='python_executable_version')
|
||||
@imports(_from='six', _import='ensure_text')
|
||||
+@imports(_from='__builtin__', _import='KeyError')
|
||||
def virtualenv_python3(env_python, build_env, mozconfig, help):
|
||||
def virtualenv_python3(env_python, virtualenv_name, build_env, mozconfig, help):
|
||||
# Avoid re-executing python when running configure --help.
|
||||
if help:
|
||||
@@ -283,6 +284,12 @@ def virtualenv_python3(env_python, build_env, mozconfi
|
||||
|
|
|
@ -1,73 +0,0 @@
|
|||
|
||||
# HG changeset patch
|
||||
# User Emilio Cobos Álvarez <emilio@crisal.io>
|
||||
# Date 1609006565 0
|
||||
# Node ID 0e8f444683cb9c4079d3b2250f32f986043ea582
|
||||
# Parent 55097a5cf353f1b2a2228820bdf26bb69a1372a0
|
||||
Bug 1684261 - Fix build with rust nightly. r=jrmuizel, a=RyanVM
|
||||
|
||||
Fixes errors like:
|
||||
|
||||
dependency (nix) specification is ambiguous. Only one of `branch`, `tag` or `rev` is allowed.
|
||||
|
||||
I've left the most specific dependency, but for wgpu the rev is not
|
||||
right, so I've kept the branch which effectively preserves behavior.
|
||||
|
||||
Differential Revision: https://phabricator.services.mozilla.com/D100485
|
||||
|
||||
diff --git a/.cargo/config.in b/.cargo/config.in
|
||||
--- .cargo/config.in
|
||||
+++ .cargo/config.in
|
||||
@@ -1,16 +1,16 @@
|
||||
# This file contains vendoring instructions for cargo.
|
||||
# It was generated by `mach vendor rust`.
|
||||
# Please do not edit.
|
||||
|
||||
[source."https://github.com/shravanrn/nix/"]
|
||||
-branch = "r0.13.1"
|
||||
git = "https://github.com/shravanrn/nix/"
|
||||
replace-with = "vendored-sources"
|
||||
+rev = "4af6c367603869a30fddb5ffb0aba2b9477ba92e"
|
||||
|
||||
[source."https://github.com/mozilla/rkv"]
|
||||
git = "https://github.com/mozilla/rkv"
|
||||
replace-with = "vendored-sources"
|
||||
rev = "e3c3388e6632cf55e08d773b32e58b1cab9b2731"
|
||||
|
||||
[source."https://github.com/mozilla/neqo"]
|
||||
git = "https://github.com/mozilla/neqo"
|
||||
diff --git a/Cargo.lock b/Cargo.lock
|
||||
--- Cargo.lock
|
||||
+++ Cargo.lock
|
||||
@@ -3195,17 +3195,17 @@ source = "registry+https://github.com/ru
|
||||
checksum = "0cdc457076c78ab54d5e0d6fa7c47981757f1e34dc39ff92787f217dede586c4"
|
||||
dependencies = [
|
||||
"unreachable",
|
||||
]
|
||||
|
||||
[[package]]
|
||||
name = "nix"
|
||||
version = "0.13.1"
|
||||
-source = "git+https://github.com/shravanrn/nix/?branch=r0.13.1#4af6c367603869a30fddb5ffb0aba2b9477ba92e"
|
||||
+source = "git+https://github.com/shravanrn/nix/?rev=4af6c367603869a30fddb5ffb0aba2b9477ba92e#4af6c367603869a30fddb5ffb0aba2b9477ba92e"
|
||||
dependencies = [
|
||||
"bitflags",
|
||||
"cc",
|
||||
"cfg-if",
|
||||
"libc",
|
||||
"void",
|
||||
]
|
||||
|
||||
--- Cargo.toml
|
||||
+++ Cargo.toml
|
||||
@@ -68,8 +68,8 @@ panic = "abort"
|
||||
libudev-sys = { path = "dom/webauthn/libudev-sys" }
|
||||
packed_simd = { git = "https://github.com/hsivonen/packed_simd", rev="0917fe780032a6bbb23d71be545f9c1834128d75" }
|
||||
rlbox_lucet_sandbox = { git = "https://github.com/PLSysSec/rlbox_lucet_sandbox/", rev="d510da5999a744c563b0acd18056069d1698273f" }
|
||||
-nix = { git = "https://github.com/shravanrn/nix/", branch = "r0.13.1", rev="4af6c367603869a30fddb5ffb0aba2b9477ba92e" }
|
||||
-spirv_cross = { git = "https://github.com/kvark/spirv_cross", branch = "wgpu3", rev = "20191ad2f370afd6d247edcb9ff9da32d3bedb9c" }
|
||||
+nix = { git = "https://github.com/shravanrn/nix/", rev="4af6c367603869a30fddb5ffb0aba2b9477ba92e" }
|
||||
+spirv_cross = { git = "https://github.com/kvark/spirv_cross", branch = "wgpu3" }
|
||||
# failure's backtrace feature might break our builds, see bug 1608157.
|
||||
failure = { git = "https://github.com/badboy/failure", rev = "64af847bc5fdcb6d2438bec8a6030812a80519a5" }
|
||||
failure_derive = { git = "https://github.com/badboy/failure", rev = "64af847bc5fdcb6d2438bec8a6030812a80519a5" }
|
|
@ -1,97 +0,0 @@
|
|||
|
||||
# HG changeset patch
|
||||
# User Cameron Kaiser <spectre@floodgap.com>
|
||||
# Date 1612231460 0
|
||||
# Node ID 579a66fd796690fb752485215b2edaa6167ebf16
|
||||
# Parent a00504e040bfd34d01c74d478beb9d308ec085be
|
||||
Bug 1690152 - on ppc64 properly skip parameter slots if we overflow GPRs while still having FPRs to burn. r=tcampbell
|
||||
|
||||
Differential Revision: https://phabricator.services.mozilla.com/D103724
|
||||
|
||||
diff --git a/xpcom/reflect/xptcall/md/unix/xptcinvoke_ppc64_linux.cpp b/xpcom/reflect/xptcall/md/unix/xptcinvoke_ppc64_linux.cpp
|
||||
--- xpcom/reflect/xptcall/md/unix/xptcinvoke_ppc64_linux.cpp
|
||||
+++ xpcom/reflect/xptcall/md/unix/xptcinvoke_ppc64_linux.cpp
|
||||
@@ -86,27 +86,37 @@ extern "C" void invoke_copy_to_stack(uin
|
||||
case nsXPTType::T_WCHAR: value = s->val.wc; break;
|
||||
default: value = (uint64_t) s->val.p; break;
|
||||
}
|
||||
}
|
||||
|
||||
if (!s->IsIndirect() && s->type == nsXPTType::T_DOUBLE) {
|
||||
if (nr_fpr < FPR_COUNT) {
|
||||
fpregs[nr_fpr++] = s->val.d;
|
||||
- nr_gpr++;
|
||||
+ // Even if we have enough FPRs, still skip space in
|
||||
+ // the parameter area if we ran out of placeholder GPRs.
|
||||
+ if (nr_gpr < GPR_COUNT) {
|
||||
+ nr_gpr++;
|
||||
+ } else {
|
||||
+ d++;
|
||||
+ }
|
||||
} else {
|
||||
*((double *)d) = s->val.d;
|
||||
d++;
|
||||
}
|
||||
}
|
||||
else if (!s->IsIndirect() && s->type == nsXPTType::T_FLOAT) {
|
||||
if (nr_fpr < FPR_COUNT) {
|
||||
// Single-precision floats are passed in FPRs too.
|
||||
fpregs[nr_fpr++] = s->val.f;
|
||||
- nr_gpr++;
|
||||
+ if (nr_gpr < GPR_COUNT) {
|
||||
+ nr_gpr++;
|
||||
+ } else {
|
||||
+ d++;
|
||||
+ }
|
||||
} else {
|
||||
#ifdef __LITTLE_ENDIAN__
|
||||
*((float *)d) = s->val.f;
|
||||
#else
|
||||
// Big endian needs adjustment to point to the least
|
||||
// significant word.
|
||||
float* p = (float*)d;
|
||||
p++;
|
||||
diff --git a/xpcom/reflect/xptcall/md/unix/xptcstubs_ppc64_linux.cpp b/xpcom/reflect/xptcall/md/unix/xptcstubs_ppc64_linux.cpp
|
||||
--- xpcom/reflect/xptcall/md/unix/xptcstubs_ppc64_linux.cpp
|
||||
+++ xpcom/reflect/xptcall/md/unix/xptcstubs_ppc64_linux.cpp
|
||||
@@ -98,27 +98,37 @@ PrepareAndDispatch(nsXPTCStubBase * self
|
||||
nr_gpr++;
|
||||
else
|
||||
ap++;
|
||||
}
|
||||
|
||||
if (!param.IsOut() && type == nsXPTType::T_DOUBLE) {
|
||||
if (nr_fpr < FPR_COUNT) {
|
||||
dp->val.d = fpregs[nr_fpr++];
|
||||
- nr_gpr++;
|
||||
+ // Even if we have enough FPRs, still skip space in
|
||||
+ // the parameter area if we ran out of placeholder GPRs.
|
||||
+ if (nr_gpr < GPR_COUNT) {
|
||||
+ nr_gpr++;
|
||||
+ } else {
|
||||
+ ap++;
|
||||
+ }
|
||||
} else {
|
||||
dp->val.d = *(double*)ap++;
|
||||
}
|
||||
continue;
|
||||
}
|
||||
if (!param.IsOut() && type == nsXPTType::T_FLOAT) {
|
||||
if (nr_fpr < FPR_COUNT) {
|
||||
// Single-precision floats are passed in FPRs too.
|
||||
dp->val.f = (float)fpregs[nr_fpr++];
|
||||
- nr_gpr++;
|
||||
+ if (nr_gpr < GPR_COUNT) {
|
||||
+ nr_gpr++;
|
||||
+ } else {
|
||||
+ ap++;
|
||||
+ }
|
||||
} else {
|
||||
#ifdef __LITTLE_ENDIAN__
|
||||
dp->val.f = *(float*)ap++;
|
||||
#else
|
||||
// Big endian needs adjustment to point to the least
|
||||
// significant word.
|
||||
float* p = (float*)ap;
|
||||
p++;
|
||||
|
Loading…
Reference in a new issue