Standalone library to control various widely available Freescale's mpc8xx

based boards. This code was derived from mpcbdm patch by Frank Przybylski.

This allows using this code separately from gdb, for example, to load
firmware to the board, or retrive information about it.

The package includes example "mpc8xx" program, that displays information
about connected board using libmpcbdm library.

The schematic of adapter itself can be found at project homepage.

Author:	Erwin Rol <erwin@muffin.org>
WWW:	http://libmpc8xx.sourceforge.net/

PR:		ports/99406
Submitted by:	Stanislav Sedov <stas at fonon.realnet>
This commit is contained in:
Ion-Mihai Tetcu 2006-07-08 23:49:15 +00:00
parent 88ec828a31
commit c8757290e8
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=167237
8 changed files with 104 additions and 0 deletions

View file

@ -526,6 +526,7 @@
SUBDIR += libmba
SUBDIR += libmcve
SUBDIR += libmimedir
SUBDIR += libmpcbdm
SUBDIR += libmtrie
SUBDIR += libnaji
SUBDIR += libnotify

30
devel/libmpcbdm/Makefile Normal file
View file

@ -0,0 +1,30 @@
# New ports collection makefile for: libmpcbdm
# Date created: 2006-06-24
# Whom: Stanislav Sedov <stas@fonon.realnet>
#
# $FreeBSD$
#
PORTNAME= libmpcbdm
PORTVERSION= 0.0.3
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://mbsd.msk.ru/dist/
MASTER_SITE_SUBDIR= libmpc8xx
DISTNAME= mpc8xx-${PORTVERSION}
MAINTAINER= ssedov@mbsd.msk.ru
COMMENT= Standalone library to control various mpc8xx boards
WRKSRC= ${WRKDIR}/libmpc8xx
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
ONLY_FOR_ARCHS= i386
post-install:
@${MKDIR} ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/Flash.dev ${DATADIR}
.include <bsd.port.mk>

3
devel/libmpcbdm/distinfo Normal file
View file

@ -0,0 +1,3 @@
MD5 (mpc8xx-0.0.3.tar.gz) = 9384db55fd34f0c58240432790ea30bb
SHA256 (mpc8xx-0.0.3.tar.gz) = aa5ba81a3a339c990811e8c64d7e74bade212604c57472ea553e7839319f0aa6
SIZE (mpc8xx-0.0.3.tar.gz) = 229848

View file

@ -0,0 +1,12 @@
--- example/main.c.orig Sat Jun 24 13:15:08 2006
+++ example/main.c Sat Jun 24 13:15:44 2006
@@ -50,7 +50,8 @@
power_on = atoi( argv[3] );
mpc8xx_set_print_function( print );
- mpc8xx_bdm_init( lpt_port, adapter_version, power_on );
+ if (mpc8xx_bdm_init( lpt_port, adapter_version, power_on ) == -1)
+ exit(1);
mpc8xx_bdm_reset();

View file

@ -0,0 +1,20 @@
+++ libmpc8xx/lptbdm.c.orig Sat Jun 24 12:47:47 2006
--- libmpc8xx/lptbdm.c Sat Jun 24 12:50:21 2006
@@ -22,7 +22,7 @@
#include <unistd.h>
#include <sys/types.h>
#include <string.h>
-#include <sys/io.h>
+#include <machine/sysarch.h>
#include <time.h>
static int lptbdm_read( void );
@@ -252,7 +252,7 @@
}
}
- nResult = ioperm( lptbdm_port.DATAAddr, 3, 1 );
+ nResult = i386_set_ioperm( lptbdm_port.DATAAddr, 3, 1 );
seteuid( getuid() );

View file

@ -0,0 +1,10 @@
--- libmpc8xx/mpc8xxflash.c.orig Sat Jun 24 12:55:50 2006
+++ libmpc8xx/mpc8xxflash.c Sat Jun 24 12:55:57 2006
@@ -14,7 +14,6 @@
#include <stdio.h>
#include <string.h>
-#include <malloc.h>
#include <ctype.h>
#include <stdlib.h>

13
devel/libmpcbdm/pkg-descr Normal file
View file

@ -0,0 +1,13 @@
Standalone library to control various widely available Freescale's mpc8xx
based boards. This code was derived from mpcbdm patch by Frank Przybylski.
This allows using this code separately from gdb, for example, to load
firmware to the board, or retrive information about it.
The package includes example "mpc8xx" program, that displays information
about connected board using libmpcbdm library.
The schematic of adapter itself can be found at project homepage.
Author: Erwin Rol <erwin@muffin.org>
WWW: http://libmpc8xx.sourceforge.net/

15
devel/libmpcbdm/pkg-plist Normal file
View file

@ -0,0 +1,15 @@
bin/mpc8xx
include/mpc8xx.h
include/mpc8xx/lptbdm.h
include/mpc8xx/mpc8xxbdm.h
include/mpc8xx/mpc8xxflash.h
include/mpc8xx/mpc8xxmem.h
include/mpc8xx/mpc8xxmisc.h
include/mpc8xx/mpc8xxspr.h
include/mpc8xx/mpc8xxtarget.h
lib/libmpc8xx.la
lib/libmpc8xx.so
lib/libmpc8xx.so.0
%%DATADIR%%/Flash.dev
@dirrm %%DATADIR%%
@dirrm include/mpc8xx