finance/alkimia: Update to 8.1.1

This commit is contained in:
Jason E. Hale 2022-05-06 12:57:03 -04:00
parent 812daaca0f
commit c8c89adb91
5 changed files with 31 additions and 52 deletions

View file

@ -1,5 +1,5 @@
PORTNAME= alkimia
PORTVERSION= 8.1.0
PORTVERSION= 8.1.1
CATEGORIES= finance kde
MASTER_SITES= KDE/stable/${PORTNAME}/${PORTVERSION}
@ -16,16 +16,17 @@ RUN_DEPENDS= p5-Date-Manip>=0:devel/p5-Date-Manip \
p5-libwww>=0:www/p5-libwww
USES= cmake compiler:c++11-lang kde:5 pathfix perl5 qt:5 \
shebangfix tar:xz
shebangfix tar:xz xorg
USE_LDCONFIG= yes
USE_KDE= attica auth codecs completion config configwidgets coreaddons \
i18n iconthemes jobwidgets kio newstuff service sonnet \
i18n iconthemes jobwidgets kio newstuff service solid sonnet \
textwidgets widgetsaddons windowsystem xmlgui ecm_build
USE_PERL5= run
USE_QT= concurrent core dbus declarative gui network widgets xml \
buildtools_build qmake_build
USE_XORG= x11
CMAKE_OFF= BUILD_DOXYGEN_DOCS
CMAKE_ON= CMAKE_DISABLE_FIND_PACKAGE_Doxygen
PLIST_SUB= VER=${PORTVERSION:R}
SHEBANG_FILES= src/financequote.pl
@ -58,7 +59,7 @@ TOOLS_DESC= Build tools
TOOLS_CMAKE_BOOL= BUILD_TOOLS
WEBENGINE_DESC= Qt Web Engine support
WEBENGINE_USE= QT=webengine
WEBENGINE_USE= QT=location,printsupport,webchannel,webengine
WEBENGINE_CMAKE_BOOL= BUILD_WITH_WEBENGINE
WEBKIT_DESC= Qt WebKit support

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1615051962
SHA256 (alkimia-8.1.0.tar.xz) = 916807352707b0490cdd9ca65682eff73b00ca523029bda6fe7a2749a1bc927c
SIZE (alkimia-8.1.0.tar.xz) = 230804
TIMESTAMP = 1651762698
SHA256 (alkimia-8.1.1.tar.xz) = 957adc63c0be54dd433e3268a37323be5456e5ab84ece27f73a1616a92db86d5
SIZE (alkimia-8.1.1.tar.xz) = 252332

View file

@ -1,20 +1,20 @@
Make tests conditional
--- CMakeLists.txt.orig 2021-01-21 22:50:19 UTC
--- CMakeLists.txt.orig 2022-05-05 15:16:34 UTC
+++ CMakeLists.txt
@@ -37,7 +37,7 @@ include(FeatureSummary)
# check for PkgConfig, Qt and MPIR/GMP
find_package(PkgConfig)
if(BUILD_QT4)
- find_package(Qt4 REQUIRED COMPONENTS QtCore QtGui QtDBus QtTest QtWebKit QtDeclarative)
+ find_package(Qt4 REQUIRED COMPONENTS QtCore QtGui QtDBus QtWebKit QtDeclarative)
set(QT_USE_LIBSPREFIX Qt4::Qt)
set(ALKIMIA_LIB_SUFFIX "")
set(ALKIMIA_INCLUDE_SUFFIX "Qt4")
@@ -107,7 +107,6 @@ else()
@@ -75,7 +75,7 @@ if(BUILD_QT4)
set(QT_NETWORK_COMPONENT)
endif()
- find_package(Qt4 REQUIRED COMPONENTS QtCore QtGui QtDBus ${QT_NETWORK_COMPONENT} QtTest ${QT_BROWSER_COMPONENT} QtDeclarative)
+ find_package(Qt4 REQUIRED COMPONENTS QtCore QtGui QtDBus ${QT_NETWORK_COMPONENT} ${QT_BROWSER_COMPONENT} QtDeclarative)
set(_kde4_uninstall_rule_created 1)
find_package(KDE4 REQUIRED)
if(NOT BUILD_WITH_QTNETWORK)
@@ -150,7 +150,6 @@ else()
find_package(Qt5 REQUIRED COMPONENTS
Core
${QT_NETWORK_COMPONENT}
- Test
${QT_BROWSER_COMPONENT}
Qml

View file

@ -1,32 +0,0 @@
Fix build when both the WEBKIT and WEBENGINE options are set to OFF.
/wrkdirs/usr/ports/finance/alkimia/work/alkimia-8.1.0/tools/onlinequoteseditor/mainwindow.cpp:52:28: error: member access into incomplete type 'const QUrl'
d->urlLine->setText(url.toString());
^
/usr/local/include/qt5/QtCore/qmetatype.h:2089:1: note: forward declaration of 'QUrl'
QT_FOR_EACH_STATIC_CORE_CLASS(QT_FORWARD_DECLARE_STATIC_TYPES_ITER)
^
/usr/local/include/qt5/QtCore/qmetatype.h:121:17: note: expanded from macro 'QT_FOR_EACH_STATIC_CORE_CLASS'
F(QUrl, 17, QUrl) \
^
/wrkdirs/usr/ports/finance/alkimia/work/alkimia-8.1.0/tools/onlinequoteseditor/mainwindow.cpp:57:63: error: 'QUrl' is an incomplete type
AlkOnlineQuotesProfileManager::instance().webPage()->load(QUrl(d->urlLine->text()), d->quotesWidget->acceptLanguage());
^
/usr/local/include/qt5/QtCore/qmetatype.h:2089:1: note: forward declaration of 'QUrl'
QT_FOR_EACH_STATIC_CORE_CLASS(QT_FORWARD_DECLARE_STATIC_TYPES_ITER)
^
/usr/local/include/qt5/QtCore/qmetatype.h:121:17: note: expanded from macro 'QT_FOR_EACH_STATIC_CORE_CLASS'
F(QUrl, 17, QUrl) \
^
2 errors generated.
--- src/alkwebpage.h.orig 2021-03-10 18:46:11 UTC
+++ src/alkwebpage.h
@@ -83,6 +83,7 @@ class ALK_EXPORT AlkWebPage : public QWebView (private
#else
+#include <QUrl>
#include <QWidget>
/**

View file

@ -17,7 +17,7 @@ lib/cmake/LibAlkimia5-%%VER%%/LibAlkimia5Targets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/LibAlkimia5-%%VER%%/LibAlkimia5Targets.cmake
lib/libalkimia5.so
lib/libalkimia5.so.8
lib/libalkimia5.so.8.1.0
lib/libalkimia5.so.8.1.1
%%QT_QMLDIR%%/org/kde/alkimia/libqmlalkimia.so
%%QT_QMLDIR%%/org/kde/alkimia/qmldir
libdata/pkgconfig/libalkimia5.pc
@ -32,6 +32,7 @@ libdata/pkgconfig/libalkimia5.pc
share/knsrcfiles/alkimia-quotes.knsrc
share/knsrcfiles/kmymoney-quotes.knsrc
share/knsrcfiles/skrooge-quotes.knsrc
%%PLASMA%%share/kservices5/plasma-applet-org.wincak.foreigncurrencies2.desktop
share/locale/ca/LC_MESSAGES/alkimia.mo
share/locale/ca/LC_MESSAGES/onlinequoteseditor.mo
share/locale/ca/LC_MESSAGES/plasma_applet_onlinequote.mo
@ -74,6 +75,10 @@ share/locale/gl/LC_MESSAGES/alkimia.mo
share/locale/gl/LC_MESSAGES/onlinequoteseditor.mo
share/locale/gl/LC_MESSAGES/plasma_applet_onlinequote.mo
share/locale/gl/LC_MESSAGES/plasma_applet_org.wincak.foreigncurrencies2.mo
share/locale/hu/LC_MESSAGES/alkimia.mo
share/locale/hu/LC_MESSAGES/onlinequoteseditor.mo
share/locale/hu/LC_MESSAGES/plasma_applet_onlinequote.mo
share/locale/hu/LC_MESSAGES/plasma_applet_org.wincak.foreigncurrencies2.mo
share/locale/ia/LC_MESSAGES/alkimia.mo
share/locale/ia/LC_MESSAGES/onlinequoteseditor.mo
share/locale/ia/LC_MESSAGES/plasma_applet_onlinequote.mo
@ -114,6 +119,10 @@ share/locale/sk/LC_MESSAGES/alkimia.mo
share/locale/sk/LC_MESSAGES/onlinequoteseditor.mo
share/locale/sk/LC_MESSAGES/plasma_applet_onlinequote.mo
share/locale/sk/LC_MESSAGES/plasma_applet_org.wincak.foreigncurrencies2.mo
share/locale/sl/LC_MESSAGES/alkimia.mo
share/locale/sl/LC_MESSAGES/onlinequoteseditor.mo
share/locale/sl/LC_MESSAGES/plasma_applet_onlinequote.mo
share/locale/sl/LC_MESSAGES/plasma_applet_org.wincak.foreigncurrencies2.mo
share/locale/sv/LC_MESSAGES/alkimia.mo
share/locale/sv/LC_MESSAGES/onlinequoteseditor.mo
share/locale/sv/LC_MESSAGES/plasma_applet_onlinequote.mo
@ -130,6 +139,7 @@ share/locale/zh_TW/LC_MESSAGES/alkimia.mo
share/locale/zh_TW/LC_MESSAGES/onlinequoteseditor.mo
share/locale/zh_TW/LC_MESSAGES/plasma_applet_onlinequote.mo
share/locale/zh_TW/LC_MESSAGES/plasma_applet_org.wincak.foreigncurrencies2.mo
%%TOOLS%%share/metainfo/org.kde.onlinequoteseditor5.appdata.xml
%%PLASMA%%share/metainfo/org.wincak.foreigncurrencies2.appdata.xml
%%PLASMA%%share/plasma/plasmoids/org.wincak.foreigncurrencies2/LICENSE
%%PLASMA%%share/plasma/plasmoids/org.wincak.foreigncurrencies2/README