Apply linespace patch (taoka).

Apply dired.el patch (yoichi).

Submitted by:	taoka, yoichi
This commit is contained in:
Shigeyuki Fukushima 2001-12-07 12:37:34 +00:00
parent 5ac324ca84
commit c8d0e74359
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=51175
3 changed files with 44 additions and 3 deletions

View file

@ -6,15 +6,22 @@
#
PORTNAME= emacs
PORTVERSION= 20.7
PORTVERSION= ${EMACS_VER}
PORTREVISION= 1
CATEGORIES+= editors ipv6
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= emacs
PATCH_SITES= ${MASTER_SITE_LOCAL}
PATCH_SITE_SUBDIR= shige/emacs
PATCHFILES= emacs-20.7-linespace-patch.gz
PATCH_DIST_STRIP= -p1
MAINTAINER= ports@FreeBSD.org
USE_AUTOCONF= yes
USE_GMAKE= yes
EMACS_VER= 20.7
CONFIGURE_TARGET= ${MACHINE_ARCH}--freebsd
.if defined(WITHOUT_X11)
CONFIGURE_ARGS= --with-x=no --with-pop
@ -22,13 +29,27 @@ CONFIGURE_ARGS= --with-x=no --with-pop
CONFIGURE_ARGS= --with-x-toolkit --with-pop
USE_XLIB= yes
.endif
CONFIGURE_ARGS+= --with-line-space
MAKE_ENV= INSTALL_SCRIPT="${INSTALL_SCRIPT}"
MAN1= emacs.1 etags.1 ctags.1
PLIST_SUB= EMACS_VER=20.7 EMACS_ARCH=${CONFIGURE_TARGET}
#WRKSRC= ${WRKDIR}/emacs-20.7
PLIST_SUB= EMACS_VER=${EMACS_VER} EMACS_ARCH=${CONFIGURE_TARGET}
RECOMPILE_ELS= dired.el startup.el
pre-build:
${RM} -rf ${WRKSRC}/info/*
post-build:
# to rebuild emacs because startup.elc should be updated
@(cd ${WRKSRC}/lisp; \
${WRKSRC}/src/emacs -batch -q -no-init-file \
-f batch-byte-compile ${RECOMPILE_ELS} ; \
)
@${RM} -f ${WRKSRC}/src/emacs ${WRKSRC}/src/emacs-${EMACS_VER}*
@(cd ${BUILD_WRKSRC}; \
${SETENV} ${MAKE_ENV} \
${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET} ;\
)
.include <bsd.port.mk>

View file

@ -1 +1,2 @@
MD5 (emacs-20.7.tar.gz) = c732cf5e668d4ac67d9418ecb103ecf5
MD5 (emacs-20.7-linespace-patch.gz) = 01b6e4480f5801dcfb202ca96f8ad886

View file

@ -0,0 +1,19 @@
--- lisp/dired.el.orig Tue Nov 30 00:04:12 1999
+++ lisp/dired.el Wed Dec 5 03:15:14 2001
@@ -1375,6 +1375,7 @@
;; weiand: changed: year potentially unaligned
;;old s "\\(" HH:MM "\\|" s yyyy "\\|" yyyy s "\\)"))
s "\\(" HH:MM "\\|" s "?" yyyy "\\|" yyyy s "\\)"))
+ (freebsd-ja (concat s mm "/" dd s "\\(" HH:MM "\\|" s yyyy "\\)"))
(japanese (concat mm k s dd k s "\\(" s HH:MM "\\|" yyyy k "\\)")))
;; The "[0-9]" below requires the previous column to end in a digit.
;; This avoids recognizing `1 may 1997' as a date in the line:
@@ -1382,7 +1383,7 @@
;; The ".*" below finds the last match if there are multiple matches.
;; This avoids recognizing `jservice 10 1024' as a date in the line:
;; drwxr-xr-x 3 jservice 10 1024 Jul 2 1997 esg-host
- (concat ".*[0-9]" s "\\(" western "\\|" japanese "\\)" s))
+ (concat ".*[0-9]" s "\\(" western "\\|" japanese "\\|" freebsd-ja "\\)" s))
"Regular expression to match up to the file name in a directory listing.
The default value is designed to recognize dates and times
regardless of the language.")