www/tinyproxy: update 1.8.3 -> 1.8.4

- new WWW

PR:		207051
Changes:	https://github.com/tinyproxy/tinyproxy/releases
Submitted by:	jason.mann+freebsd@gmail.com
Approved by:	sunpoet (maintainer timeout)
This commit is contained in:
Kurt Jaeger 2016-11-22 17:58:54 +00:00
parent 8dbda492b0
commit c8d1ddf6c0
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=426834
9 changed files with 62 additions and 98 deletions

View file

@ -2,18 +2,17 @@
# $FreeBSD$
PORTNAME= tinyproxy
PORTVERSION= 1.8.3
PORTREVISION= 1
PORTVERSION= 1.8.4
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= https://banu.com/pub/tinyproxy/${PORTVERSION:R}/ \
LOCAL/sunpoet
MAINTAINER= sunpoet@FreeBSD.org
MAINTAINER= jason.mann+freebsd-ports@gmail.com
COMMENT= Small, efficient HTTP proxy server
LICENSE= GPLv2 GPLv3
LICENSE_COMB= dual
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
USE_GITHUB= yes
OPTIONS_DEFINE= REVERSE TRANSPARENT XHEADER
REVERSE_DESC= Reverse proxy support
@ -24,19 +23,19 @@ CONFIGURE_ARGS= --bindir=${PREFIX}/sbin \
--program-transform-name=""
GNU_CONFIGURE= yes
USE_RC_SUBR= ${PORTNAME}
USES= gmake
USES= autoreconf gmake
REVERSE_CONFIGURE_ENABLE= reverse
TRANSPARENT_CONFIGURE_ENABLE= transparent
XHEADER_CONFIGURE_ENABLE= xtinyproxy
post-patch:
@${REINPLACE_CMD} -e 's|-O2||' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|tinyproxy/tinyproxy|tinyproxy|g; s|/etc/tinyproxy|${PREFIX}&|' \
${WRKSRC}/docs/man5/tinyproxy.conf.txt.in \
${WRKSRC}/docs/man8/tinyproxy.txt.in \
${WRKSRC}/etc/tinyproxy.conf.in
@${REINPLACE_CMD} -e '/\/usr\/share\/tinyproxy/d' ${WRKSRC}/etc/tinyproxy.conf.in
@${REINPLACE_CMD} -e 's/^#LogFile/LogFile/; s/^#PidFile/PidFile/' ${WRKSRC}/etc/tinyproxy.conf.in
post-install:
${INSTALL_DATA} ${WRKSRC}/etc/tinyproxy.conf ${STAGEDIR}${PREFIX}/etc/tinyproxy.conf.sample

View file

@ -1,2 +1,3 @@
SHA256 (tinyproxy-1.8.3.tar.gz) = 682416c8f0f733a8106c87bb395c631222569751fe4617bc381d0499b0f0c017
SIZE (tinyproxy-1.8.3.tar.gz) = 266744
TIMESTAMP = 1479837510
SHA256 (tinyproxy-tinyproxy-1.8.4_GH0.tar.gz) = 1999c88c43e31ff4cb5e8379b76776a65fa3d326eea868cb5f88ef58a8f631de
SIZE (tinyproxy-tinyproxy-1.8.4_GH0.tar.gz) = 124634

View file

@ -0,0 +1,10 @@
--- Makefile.am.orig 2014-12-13 00:57:23 UTC
+++ Makefile.am
@@ -2,7 +2,6 @@ SUBDIRS = \
src \
data \
etc \
- docs \
m4macros \
tests

View file

@ -1,10 +0,0 @@
--- Makefile.in.orig 2011-08-16 12:27:58 UTC
+++ Makefile.in
@@ -222,7 +222,6 @@ SUBDIRS = \
src \
data \
etc \
- docs \
m4macros \
tests

View file

@ -1,47 +0,0 @@
--- configure.orig 2011-08-16 12:27:59 UTC
+++ configure
@@ -3626,13 +3626,13 @@ if test "$ac_test_CFLAGS" = set; then
CFLAGS=$ac_save_CFLAGS
elif test $ac_cv_prog_cc_g = yes; then
if test "$GCC" = yes; then
- CFLAGS="-g -O2"
+ CFLAGS="-g "
else
CFLAGS="-g"
fi
else
if test "$GCC" = yes; then
- CFLAGS="-O2"
+ CFLAGS=""
else
CFLAGS=
fi
@@ -4889,13 +4889,13 @@ if test "$ac_test_CFLAGS" = set; then
CFLAGS=$ac_save_CFLAGS
elif test $ac_cv_prog_cc_g = yes; then
if test "$GCC" = yes; then
- CFLAGS="-g -O2"
+ CFLAGS="-g "
else
CFLAGS="-g"
fi
else
if test "$GCC" = yes; then
- CFLAGS="-O2"
+ CFLAGS=""
else
CFLAGS=
fi
@@ -6865,11 +6865,7 @@ else
HAVE_A2X_FALSE=
fi
-if test x"$A2X" = x"no"; then
- as_fn_error $? "Test for asciidoc failed. See the file 'INSTALL' for help." "$LINENO" 5
-fi
-
-ac_config_files="$ac_config_files Makefile src/Makefile data/Makefile data/templates/Makefile etc/Makefile docs/Makefile docs/man5/Makefile docs/man5/tinyproxy.conf.txt docs/man8/Makefile docs/man8/tinyproxy.txt m4macros/Makefile tests/Makefile tests/scripts/Makefile"
+ac_config_files="$ac_config_files Makefile src/Makefile data/Makefile data/templates/Makefile etc/Makefile m4macros/Makefile tests/Makefile tests/scripts/Makefile"
cat >confcache <<\_ACEOF

View file

@ -0,0 +1,27 @@
--- configure.ac.orig 2014-12-13 00:57:23 UTC
+++ configure.ac
@@ -284,24 +284,12 @@ AC_SUBST(CPPFLAGS)
AC_SUBST(LIBS)
AC_SUBST(ADDITIONAL_OBJECTS)
-# Check for asciidoc
-AC_PATH_PROG(A2X, a2x, no)
-AM_CONDITIONAL(HAVE_A2X, test "x$A2X" != "xno")
-if test x"$A2X" = x"no"; then
- AC_MSG_ERROR([Test for asciidoc failed. See the file 'INSTALL' for help.])
-fi
-
AC_CONFIG_FILES([
Makefile
src/Makefile
data/Makefile
data/templates/Makefile
etc/Makefile
-docs/Makefile
-docs/man5/Makefile
-docs/man5/tinyproxy.conf.txt
-docs/man8/Makefile
-docs/man8/tinyproxy.txt
m4macros/Makefile
tests/Makefile
tests/scripts/Makefile

View file

@ -1,15 +0,0 @@
--- etc/Makefile.in.orig 2011-08-16 12:27:58 UTC
+++ etc/Makefile.in
@@ -248,8 +248,10 @@ install-sysconfDATA: $(sysconf_DATA)
echo "$$d$$p"; \
done | $(am__base_list) | \
while read files; do \
- echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(sysconfdir)'"; \
- $(INSTALL_DATA) $$files "$(DESTDIR)$(sysconfdir)" || exit $$?; \
+ nfile="$$files.sample"; \
+ cp $$files $$nfile; \
+ echo " $(INSTALL_DATA) $$nfile '$(DESTDIR)$(sysconfdir)'"; \
+ $(INSTALL_DATA) $$nfile "$(DESTDIR)$(sysconfdir)" || exit $$?; \
done
uninstall-sysconfDATA:

View file

@ -1,6 +1,6 @@
--- src/main.c.orig 2011-08-16 12:14:34 UTC
--- src/main.c.orig 2014-12-13 00:57:23 UTC
+++ src/main.c
@@ -407,12 +407,9 @@ main (int argc, char **argv)
@@ -417,12 +417,9 @@ main (int argc, char **argv)
exit (EX_OSERR);
}
@ -10,16 +10,16 @@
- else
- log_message (LOG_WARNING,
- "Not running as root, so not changing UID/GID.");
+ /*To get this to run correctly on FreeBSD, we must
+ ceate the PID and log files before we drop privileges.
+ Other ideas are welcome */
+ /* To get this to run correctly on FreeBSD, we must
+ create the PID and log files before we drop privileges.
+ Other ideas are welcome */
/* Create log file after we drop privileges */
if (setup_logging ()) {
@@ -427,6 +424,13 @@ main (int argc, char **argv)
exit (EX_OSERR);
@@ -438,6 +435,13 @@ main (int argc, char **argv)
}
}
+ /* Switch to a different user if we're running as root */
+ if (geteuid () == 0)
+ change_user (argv[0]);
@ -27,6 +27,6 @@
+ log_message (LOG_WARNING,
+ "Not running as root, so not changing UID/GID.");
+
if (child_pool_create () < 0) {
fprintf (stderr,
"%s: Could not create the pool of children.\n",

View file

@ -1,11 +1,10 @@
tinyproxy is a GPLed, lightweight HTTP proxy. Designed from the ground up to be
fast and yet small, it is an ideal solution for sites where a full-featured
HTTP proxy is required, but the system resources required to run a more
demanding HTTP proxy are unavailable. tinyproxy is fully compatible with all
existing web browsers, and has a number of useful features including
anonymous mode.
Tinyproxy is a light-weight HTTP/HTTPS proxy daemon for POSIX
operating systems. Designed from the ground up to be fast and yet
small, it is an ideal solution for use cases such as embedded
deployments where a full featured HTTP proxy is required, but the
system resources for a larger proxy are unavailable.
Note that tinyproxy requires configuration to run in anonymizing
mode. See tinyproxy.conf.sample for detail.
WWW: https://banu.com/tinyproxy/
WWW: https://tinyproxy.github.io/