- Fix building with -CURRENT
- Pass CFLAGS to the make - While here, fix portlint warnings Reported by: pkg-fallout
This commit is contained in:
parent
7679ec76b0
commit
c8dc31818c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=548254
5 changed files with 18 additions and 14 deletions
|
@ -3,7 +3,7 @@
|
|||
|
||||
PORTNAME= eukleides
|
||||
PORTVERSION= 1.5.4
|
||||
PORTREVISION= 5
|
||||
PORTREVISION= 6
|
||||
CATEGORIES= math
|
||||
MASTER_SITES= http://www.eukleides.org/files/
|
||||
|
||||
|
@ -16,10 +16,13 @@ LICENSE_FILE= ${WRKSRC}/COPYING
|
|||
RUN_DEPENDS= pstoedit:graphics/pstoedit \
|
||||
getopt>=0:misc/getopt
|
||||
|
||||
USE_TEX= latex
|
||||
USES= bison gettext iconv gmake readline:port tar:bzip2
|
||||
USE_TEX= latex
|
||||
INSTALL_TARGET= install PREFIX=${STAGEDIR}${PREFIX}
|
||||
|
||||
# Fix build with clang11
|
||||
CFLAGS+= -fcommon
|
||||
|
||||
PORTDOCS= de.pdf fr.pdf
|
||||
PORTEXAMPLES= greenwich.euk sundial.euk vonkoch.euk
|
||||
|
||||
|
@ -38,7 +41,8 @@ post-patch:
|
|||
-e "s|%%PREFIX%%|${PREFIX}|g" \
|
||||
-e "s|%%LOCALBASE%%|${LOCALBASE}|g" \
|
||||
-e "s|%%EXAMPLESDIR%%|\$${PREFIX}/${EXAMPLESDIR_REL}|g" \
|
||||
-e "s|%%DOCSDIR%%|\$${PREFIX}/${DOCSDIR_REL}|g"
|
||||
-e "s|%%DOCSDIR%%|\$${PREFIX}/${DOCSDIR_REL}|g" \
|
||||
-e "s|%%CFLAGS%%|${CFLAGS}|g"
|
||||
@${GREP} -lFR "gcc" ${WRKSRC} |${XARGS} ${REINPLACE_CMD} \
|
||||
-e "s|gcc|${CC}|g"
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- bash/euktoeps.orig
|
||||
--- bash/euktoeps.orig 2010-04-27 06:31:00 UTC
|
||||
+++ bash/euktoeps
|
||||
@@ -31,7 +31,7 @@
|
||||
@@ -31,7 +31,7 @@ USAGE
|
||||
exit $1
|
||||
}
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- build/Makefile.orig
|
||||
--- build/Makefile.orig 2010-04-27 06:31:00 UTC
|
||||
+++ build/Makefile
|
||||
@@ -12,12 +12,12 @@
|
||||
@@ -12,12 +12,12 @@ LFLAGS = -8
|
||||
YACC = bison
|
||||
YFLAGS = -d
|
||||
CC = gcc
|
||||
|
@ -9,8 +9,9 @@
|
|||
ifneq ($(strip $(LOCALES)),)
|
||||
MOFLAGS = -DMO_DIR=\"$(MO_DIR)\"
|
||||
endif
|
||||
CFLAGS = -Wall -D__$(BINARY)__ $(IFLAGS) $(MOFLAGS)
|
||||
-CFLAGS = -Wall -D__$(BINARY)__ $(IFLAGS) $(MOFLAGS)
|
||||
-LDFLAGS = -lncurses -lreadline -lm
|
||||
+CFLAGS = -Wall -D__$(BINARY)__ $(IFLAGS) $(MOFLAGS) %%CFLAGS%%
|
||||
+LDFLAGS = -lncurses -lreadline -lm "-L%%LOCALBASE%%/lib" -lintl
|
||||
VPATH = $(COMMON_DIR):$(MAIN_DIR):$(BUILD_DIR)
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
--- doc/eukleides.texi.orig
|
||||
--- doc/eukleides.texi.orig 2010-04-27 06:31:00 UTC
|
||||
+++ doc/eukleides.texi
|
||||
@@ -6,12 +6,14 @@
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- man/Makefile.orig
|
||||
--- man/Makefile.orig 2010-04-27 06:31:00 UTC
|
||||
+++ man/Makefile
|
||||
@@ -3,13 +3,10 @@
|
||||
@@ -3,12 +3,9 @@
|
||||
|
||||
include ../Config
|
||||
|
||||
|
@ -8,10 +8,9 @@
|
|||
+MAN_PAGES := $(wildcard *.1)
|
||||
|
||||
man: $(MAN_PAGES)
|
||||
|
||||
-
|
||||
-%.1.gz: %.1
|
||||
- @gzip -c $< > $@
|
||||
-
|
||||
|
||||
install: $(MAN_PAGES)
|
||||
@install -d $(MAN_DIR)
|
||||
@install -m 0644 $^ $(MAN_DIR)
|
||||
|
|
Loading…
Reference in a new issue