Update to scare-1.3.5 and add a "test" target.

This commit is contained in:
Peter Pentchev 2007-01-21 21:38:30 +00:00
parent 68171b1938
commit c9171663d5
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=182920
6 changed files with 21 additions and 24 deletions

View file

@ -6,7 +6,7 @@
#
PORTNAME= scare
PORTVERSION= 1.3.4
PORTVERSION= 1.3.5
CATEGORIES= games
MASTER_SITES= ftp://ftp.ifarchive.org/if-archive/programming/adrift/ \
http://www.geocities.com/legion_if/
@ -42,6 +42,9 @@ EXTRA_PATCHES= ${FILESDIR}/no-xglk.patch
PLIST_FILES= ${BINFILES:S,^,bin/,}
do-install:
${INSTALL_PROGRAM} ${BINFILES:S,^,${WRKSRC}/,} ${PREFIX}/bin/
${INSTALL_PROGRAM} ${BINFILES:S,^,${WRKSRC}/source/,} ${PREFIX}/bin/
test: build
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check
.include <bsd.port.post.mk>

View file

@ -1,3 +1,3 @@
MD5 (scare-1.3.4.zip) = 82fc641ba6a92b933f9bd53f4963b9b9
SHA256 (scare-1.3.4.zip) = fa93cb5f8cd35facad027d08ac898c569b4b60aecac038acacb7b7e6fb9218b1
SIZE (scare-1.3.4.zip) = 633157
MD5 (scare-1.3.5.zip) = 1f26a09440f2fc180ac6435c47a0a6e5
SHA256 (scare-1.3.5.zip) = 8b65d60591b6db6618ce35ef027e4d2c51fda1362b1d74632e74f62571ac8722
SIZE (scare-1.3.5.zip) = 1305393

View file

@ -1,6 +1,6 @@
--- Makefile Fri Feb 4 22:09:46 2005
+++ Makefile.noglk Fri Feb 4 22:09:33 2005
@@ -68,8 +68,9 @@
--- source/Makefile Sun Jan 21 23:18:36 2007
+++ source/Makefile.noglk Sun Jan 21 23:21:08 2007
@@ -73,8 +73,9 @@
# If your make can't handle sinclude or -include, and you're not building
# for Glk, comment out the include line.
GLKPATH = $(GLKDIR)/$(GLK)

View file

@ -1,5 +1,5 @@
--- Makefile.orig Tue Sep 26 21:47:00 2006
+++ Makefile Tue Sep 26 21:49:23 2006
--- source/Makefile.old Sun Jan 21 23:16:03 2007
+++ source/Makefile Sun Jan 21 23:18:36 2007
@@ -26,18 +26,19 @@
#
@ -11,7 +11,7 @@
+CC ?= gcc
+DEBUG ?=
+CEXTRA ?=
+CFLAGS ?= -O2 -D__NO_STRING_INLINES -fPIC -ansi -D_STRICT_ANSI_ -Wall -W \
+CFLAGS ?= -O2 -D__NO_STRING_INLINES -fPIC -ansi -D_STRICT_ANSI_ -Wall -W \
-pedantic -Wshadow -Wpointer-arith -Wstrict-prototypes \
-Wmissing-prototypes -Wmissing-declarations -Wredundant-decls \
-Wwrite-strings -Wundef -Wbad-function-cast -Waggregate-return \
@ -21,28 +21,22 @@
-LDEXTRA =
-LDFLAGS = $(DEBUG) $(LDEXTRA)
+ $(DEBUG)
+CFLAGS += $(CEXTRA)
+CFLAGS += $(CEXTRA)
+LDLIBS ?=
+LDEXTRA ?=
+LDFLAGS ?= $(DEBUG) $(LDEXTRA)
# Generic compiler and linker flags.
#CC = cc
@@ -79,12 +80,12 @@
@@ -79,9 +80,9 @@
SHELL = /bin/sh
# Miscellaneous tools, overridable by the command line.
-ZIP = zip
-UNZIP = unzip
-RM = rm
-LN = ln
-TAR = tar
-TEST = test
+ZIP ?= zip
+UNZIP ?= unzip
+RM ?= rm
+LN ?= ln
+TAR ?= tar
+TEST ?= test
# SCARE objects and headers.

View file

@ -1,5 +1,5 @@
--- os_glk.c.orig Tue Sep 26 21:50:17 2006
+++ os_glk.c Tue Sep 26 21:55:13 2006
--- source/os_glk.c.orig Tue Sep 26 21:50:17 2006
+++ source/os_glk.c Tue Sep 26 21:55:13 2006
@@ -1110,6 +1110,8 @@
&& gsclinux_graphics_enabled && glk_gestalt (gestalt_Graphics, 0))
{

View file

@ -1,5 +1,5 @@
--- Makefile.orig Tue Sep 26 22:15:12 2006
+++ Makefile Tue Sep 26 22:17:36 2006
--- source/Makefile Sun Jan 21 23:22:38 2007
+++ source/Makefile.xglk Sun Jan 21 23:23:11 2007
@@ -73,7 +73,7 @@
# If your make can't handle sinclude or -include, and you're not building
# for Glk, comment out the include line.
@ -9,7 +9,7 @@
GLKLIBS = -L$(GLKPATH) $(GLKLIB) $(LINKLIBS)
# Always use the Bourne shell.
@@ -127,7 +127,7 @@
@@ -134,7 +134,7 @@
os_glk.o: os_glk.c $(HEADERS)
$(CC) $(GLKARCH) $(CFLAGS) -Wno-write-strings \