Update to 2.2.

PR:		211103
Reported by:	Iblis Lin
Sponsored by:	Absolight
This commit is contained in:
Mathieu Arnold 2016-07-18 13:23:16 +00:00
parent 76bcdcaac4
commit c91da906e6
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=418701
4 changed files with 15 additions and 44 deletions

View file

@ -2,11 +2,10 @@
# $FreeBSD$
PORTNAME= tmux
PORTVERSION= 2.1
PORTREVISION= 1
PORTVERSION= 2.2
CATEGORIES= sysutils
MASTER_SITES= https://github.com/tmux/tmux/releases/download/${PORTVERSION}/ \
SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION:S/a$//}
MASTER_SITES= https://github.com/tmux/tmux/releases/download/${PORTVERSION}/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= mat@FreeBSD.org
COMMENT= Terminal Multiplexer
@ -16,6 +15,9 @@ LICENSE_FILE= ${WRKSRC}/COPYING
USES= pkgconfig ncurses
USE_GITHUB= nodefault
GH_TUPLE= imomaliev:tmux-bash-completion:e0f7021:bash
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--sysconfdir=${PREFIX}/etc
@ -49,7 +51,7 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/tmux ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/tmux.1 ${STAGEDIR}${MANPREFIX}/man/man1
@${MKDIR} ${STAGEDIR}${PREFIX}/etc/bash_completion.d
${INSTALL_DATA} ${WRKSRC}/examples/bash_completion_tmux.sh ${STAGEDIR}${PREFIX}/etc/bash_completion.d/tmux
${INSTALL_DATA} ${WRKSRC_bash}/completions/tmux ${STAGEDIR}${PREFIX}/etc/bash_completion.d/tmux
do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
@ -57,6 +59,6 @@ do-install-DOCS-on:
do-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/example* ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>

View file

@ -1,2 +1,5 @@
SHA256 (tmux-2.1.tar.gz) = 31564e7bf4bcef2defb3cb34b9e596bd43a3937cad9e5438701a81a5a9af6176
SIZE (tmux-2.1.tar.gz) = 462965
TIMESTAMP = 1468847551
SHA256 (tmux-2.2.tar.gz) = bc28541b64f99929fe8e3ae7a02291263f3c97730781201824c0f05d7c8e19e4
SIZE (tmux-2.2.tar.gz) = 466852
SHA256 (imomaliev-tmux-bash-completion-e0f7021_GH0.tar.gz) = 5957606b43ec4010084e20d7028044e23cc516ea100c4138d48984de53a7941b
SIZE (imomaliev-tmux-bash-completion-e0f7021_GH0.tar.gz) = 1661

View file

@ -1,6 +1,6 @@
--- tty-keys.c.orig 2015-09-27 09:42:08 UTC
--- tty-keys.c.orig 2016-03-02 18:08:46 UTC
+++ tty-keys.c
@@ -545,8 +545,6 @@ first_key:
@@ -572,8 +572,6 @@ first_key:
* used. termios should have a better idea.
*/
bspace = tty->tio.c_cc[VERASE];

View file

@ -1,34 +0,0 @@
From 8c8cddbe022af5ece9949804cacffbee6b8972fa Mon Sep 17 00:00:00 2001
From: nicm <nicm>
Date: Tue, 20 Oct 2015 14:19:27 +0000
Subject: [PATCH] The table could change when retrying so don't save it at
start of server_client_handle_key.
--- server-client.c.orig 2015-09-27 09:42:08 UTC
+++ server-client.c
@@ -540,7 +540,7 @@ server_client_handle_key(struct client *
struct window *w;
struct window_pane *wp;
struct timeval tv;
- struct key_table *table = c->keytable;
+ struct key_table *table;
struct key_binding bd_find, *bd;
int xtimeout;
@@ -606,7 +606,7 @@ server_client_handle_key(struct client *
retry:
/* Try to see if there is a key binding in the current table. */
bd_find.key = key;
- bd = RB_FIND(key_bindings, &table->key_bindings, &bd_find);
+ bd = RB_FIND(key_bindings, &c->keytable->key_bindings, &bd_find);
if (bd != NULL) {
/*
* Key was matched in this table. If currently repeating but a
@@ -624,6 +624,7 @@ retry:
* Take a reference to this table to make sure the key binding
* doesn't disappear.
*/
+ table = c->keytable;
table->references++;
/*