Add kdrill, a kanji tutor/quiz program.
Submitted by: Seth Kingsley <sethk@osd.bsdi.com>
This commit is contained in:
parent
b1f98cec11
commit
c9a003239e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=35053
8 changed files with 101 additions and 0 deletions
|
@ -107,6 +107,7 @@
|
|||
SUBDIR += kappa20
|
||||
SUBDIR += kbanner
|
||||
SUBDIR += kcc
|
||||
SUBDIR += kdrill
|
||||
SUBDIR += kebook
|
||||
SUBDIR += kinput2-canna
|
||||
SUBDIR += kinput2-canna+freewnn
|
||||
|
|
45
japanese/kdrill/Makefile
Normal file
45
japanese/kdrill/Makefile
Normal file
|
@ -0,0 +1,45 @@
|
|||
# New ports collection makefile for: kdrill
|
||||
# Date created: 14 November 2000
|
||||
# Whom: Seth Kingsley <sethk@osd.bsdi.com>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= kdrill
|
||||
PORTVERSION= 5.10
|
||||
CATEGORIES= japanese
|
||||
MASTER_SITES= ftp://ftp.bolthole.com/kdrill/
|
||||
DISTNAME= ${PORTNAME}${PORTVERSION}
|
||||
|
||||
MAINTAINER= sethk@osd.bsdi.com
|
||||
|
||||
MAN1= kdrill.1 makedic.1 makeedict.1
|
||||
MANCOMPRESSED= yes
|
||||
USE_IMAKE= yes
|
||||
MAKE_ENV+= LOCALBASE=${LOCALBASE}
|
||||
|
||||
RUN_DEPENDS+= xjdic:${PORTSDIR}/japanese/edict
|
||||
|
||||
post-build:
|
||||
@cd ${WRKSRC}/makedic && ${MAKE} ${MAKE_ENV} clean all
|
||||
|
||||
DATADIR= ${PREFIX}/share/dict/kdrill
|
||||
post-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/makedic/makedic ${PREFIX}/bin
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/makedic/makeedict ${PREFIX}/bin
|
||||
.if !defined(NOPORTDOCS)
|
||||
${INSTALL_MAN} ${WRKSRC}/makedic/makedic.1 \
|
||||
${PREFIX}/man/man1
|
||||
${GZIP_CMD} ${PREFIX}/man/man1/makedic.1
|
||||
${INSTALL_MAN} ${WRKSRC}/makedic/makeedict.1 \
|
||||
${PREFIX}/man/man1
|
||||
${GZIP_CMD} ${PREFIX}/man/man1/makeedict.1
|
||||
.endif
|
||||
${MKDIR} ${DATADIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/makedic/fullkatahira.edic ${DATADIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/makedic/hira.edic ${DATADIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/makedic/hiraplus.edic ${DATADIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/makedic/kata.edic ${DATADIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/makedic/kataplus.edic ${DATADIR}
|
||||
|
||||
.include <bsd.port.mk>
|
1
japanese/kdrill/distinfo
Normal file
1
japanese/kdrill/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (kdrill5.10.tar.gz) = 7eb37b9fe771f726f9b1a8d742d0053d
|
13
japanese/kdrill/files/patch-Imakefile
Normal file
13
japanese/kdrill/files/patch-Imakefile
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- Imakefile.orig Sun Nov 12 00:57:27 2000
|
||||
+++ Imakefile Sun Nov 12 03:38:54 2000
|
||||
@@ -32,8 +32,8 @@
|
||||
/* You can change these here, and KDrill.ad will
|
||||
* get created with the matching values. Yaaay!
|
||||
*/
|
||||
-DICTLOCATION= /usr/local/lib/kanjidic.gz
|
||||
-EDICTLOCATION= /usr/local/lib/edict.gz
|
||||
+DICTLOCATION= $(LOCALBASE)/share/dict/edict/kanjidic
|
||||
+EDICTLOCATION= $(LOCALBASE)/share/dict/edict/edict
|
||||
|
||||
# If for some reason, the user prefs stuff isn't working for you,
|
||||
# and you can't compile, uncomment this
|
18
japanese/kdrill/files/patch-makedic-Makefile
Normal file
18
japanese/kdrill/files/patch-makedic-Makefile
Normal file
|
@ -0,0 +1,18 @@
|
|||
--- makedic/Makefile.orig Sun Nov 12 16:18:27 2000
|
||||
+++ makedic/Makefile Sun Nov 12 16:19:21 2000
|
||||
@@ -5,13 +5,13 @@
|
||||
all: makeedict makedic
|
||||
|
||||
makeedict: makeedict.c
|
||||
- gcc -o $@ makeedict.c
|
||||
+ $(CC) $(CFLAGS) -o $@ makeedict.c
|
||||
|
||||
#This old version is just kept here for posterity's sake
|
||||
#It's doubtful you will want to make a new kanjidic entry.
|
||||
#but if you do, it's here
|
||||
makedic: makedic.c
|
||||
- gcc -o $@ makedic.c
|
||||
+ $(CC) $(CFLAGS) -o $@ makedic.c
|
||||
|
||||
DICTS=hira.edic hiraplus.edic kata.edic kataplus.edic fullkatahira.edic
|
||||
|
1
japanese/kdrill/pkg-comment
Normal file
1
japanese/kdrill/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
A program to quiz you on the meanings of Kanji
|
13
japanese/kdrill/pkg-descr
Normal file
13
japanese/kdrill/pkg-descr
Normal file
|
@ -0,0 +1,13 @@
|
|||
Kdrill is a program to quiz folks on
|
||||
{ English } { English }
|
||||
{ Kanji } <-> { Kanji }
|
||||
{ Kana } { Kana }
|
||||
|
||||
It will quiz you on either the whole dictionary [around 6000 Kanji?]
|
||||
or specific Kanji, that you hand-pick. There are also other ways to
|
||||
narrow down which Kanji you are quizzed on.
|
||||
|
||||
WWW: http://www.bolthole.com/kdrill/
|
||||
|
||||
- Seth
|
||||
sethk@osd.bsdi.com
|
9
japanese/kdrill/pkg-plist
Normal file
9
japanese/kdrill/pkg-plist
Normal file
|
@ -0,0 +1,9 @@
|
|||
bin/kdrill
|
||||
bin/makedic
|
||||
bin/makeedict
|
||||
share/dict/kdrill/fullkatahira.edic
|
||||
share/dict/kdrill/hira.edic
|
||||
share/dict/kdrill/hiraplus.edic
|
||||
share/dict/kdrill/kata.edic
|
||||
share/dict/kdrill/kataplus.edic
|
||||
@dirrm share/dict/kdrill
|
Loading…
Reference in a new issue