devel/gps: Upgrade version 5.2.1 => 6.1.0.0
Adacore releases the GNAT Programming Studio annually along with several other packages. It is under constant development, so the source tarballs contain specific versions of xmlada, gtkada, and all the other dependencies. However those dependencies are under development as well and the current versions in the port collections were too new for the actual 2014 GPS release (which was frozen 7 months ago). So I packaged the working version of the upcoming 6.1.0 version instead (the 4th digit means "working" and it increments each time the distfile is upgraded). Several options were removed because they are expected by GPS components to be present (e.g. sqlite and gtk). The Iconv support was intended to be optional, but turning it on crashes GPS after the splash popup. Until the issue is resolved, the Iconv option has been removed and the GPS has been configured without it. GPS 6.x differences from the 5.x series in that the GTK3 toolkit is used instead of GTK2. It also has language support for SPARK 2014, syntax highlighting, tooltips for Ada 2012 and SPARK 2014, enhancements to the scripting API and various editor enhancements. Release Notes with lots of pictures illustrate new capabilities here: http://docs.adacore.com/gps-docs/release_notes/build/singlehtml
This commit is contained in:
parent
c30df23be5
commit
c9d842267a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=355141
15 changed files with 317 additions and 285 deletions
|
@ -2,119 +2,124 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= gps
|
||||
PORTVERSION= 5.2.1
|
||||
PORTREVISION= 3
|
||||
PORTVERSION= 6.1.0.0
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= http://downloads.dragonlace.net/src/
|
||||
DISTNAME= gps-5.2.1-1-src
|
||||
PKGNAMESUFFIX= -ide
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= marino@FreeBSD.org
|
||||
COMMENT= GNAT Programming Studio - IDE for Ada and many other languages
|
||||
|
||||
LICENSE= GPLv3
|
||||
|
||||
BUILD_DEPENDS= gtkada>=2.24:${PORTSDIR}/x11-toolkits/gtkada \
|
||||
xmlada>=3.2:${PORTSDIR}/textproc/xmlada \
|
||||
gprbuild>=20120510:${PORTSDIR}/devel/gprbuild \
|
||||
sphinx-build:${PORTSDIR}/textproc/py-sphinx
|
||||
LIB_DEPENDS= gmp:${PORTSDIR}/math/gmp
|
||||
BUILD_DEPENDS= gprbuild>=20140417:${PORTSDIR}/devel/gprbuild \
|
||||
gnat_util>=20140422_2:${PORTSDIR}/lang/gnat_util \
|
||||
xmlada>=4.4:${PORTSDIR}/textproc/xmlada \
|
||||
templates_parser>11:${PORTSDIR}/textproc/templates_parser
|
||||
LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp \
|
||||
libgtkada.so:${PORTSDIR}/x11-toolkits/gtkada3
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_BZIP2= yes
|
||||
USES= ada gmake perl5 pkgconfig tar:bzip2
|
||||
USE_PERL5= build
|
||||
USE_GNOME= glib20
|
||||
USE_PYTHON= yes
|
||||
USE_GNOME= pygobject3
|
||||
PYCOMPILE= ${PREFIX}/lib/${PYTHON_VERSION}/compileall.py
|
||||
AWKREVDATE= '/Last Changed Date/ {print "\"s|unknown date|" $$4 "|\""}'
|
||||
GPSVER= GPS_VERSION=${PORTVERSION}
|
||||
ALL_TARGET= default
|
||||
NO_MTREE= yes
|
||||
USES= ada gmake perl5 pkgconfig
|
||||
WRKSRC= ${WRKDIR}/gps-release-ide-${PORTVERSION}-src
|
||||
|
||||
OPTIONS_DEFINE= READLINE SYSLOG PGSQL DEBUG DOCS EXAMPLES
|
||||
OPTIONS_DEFAULT= READLINE SYSLOG
|
||||
OPTIONS_SUB= yes
|
||||
DOCS_BUILD_DEPENDS= sphinx-build:${PORTSDIR}/textproc/py-sphinx
|
||||
SYSLOG_CONFIGURE_ENABLE=syslog
|
||||
|
||||
CONFIGURE_TARGET= ${ARCH:S/amd64/x86_64/}-aux-${OPSYS:tl}${OSREL}
|
||||
CONFIGURE_ENV+= AWK=/usr/bin/awk
|
||||
MAKE_ENV+= PROCESSORS=${MAKE_JOBS_NUMBER}
|
||||
MAKE_ARGS+= Build=Production
|
||||
|
||||
OPTIONS_DEFINE= SYSLOG SQLITE PGSQL PYTHON READLINE
|
||||
OPTIONS_DEFAULT= SYSLOG SQLITE PYTHON READLINE
|
||||
|
||||
PYTHON_DESC= Enable Python console
|
||||
CONFIGURE_ARGS= --with-gmp=${PREFIX} \
|
||||
--with-gtk=3.0 \
|
||||
--with-sqlite=embedded \
|
||||
--with-python=${PREFIX} \
|
||||
--enable-pygobject \
|
||||
--disable-shared \
|
||||
--disable-pygtk
|
||||
MAKE_ARGS+= PROCESSORS=${MAKE_JOBS_NUMBER}
|
||||
MAKE_ARGS+= PYTHON_CMD=${PYTHON_CMD}
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
.if ${OPSYS} == FreeBSD
|
||||
CONFIGURE_TARGET= ${ARCH:S/amd64/x86_64/}-portbld-${OPSYS:tl}${OSREL}
|
||||
.if ${PORT_OPTIONS:MDEBUG}
|
||||
MAKE_ARGS+= Build=Debug
|
||||
.else
|
||||
MAKE_ARGS+= Build=Production
|
||||
.endif
|
||||
|
||||
CONFIGURE_ARGS+= --disable-shared --with-gmp=${PREFIX}
|
||||
|
||||
################
|
||||
## READLINE ##
|
||||
################
|
||||
|
||||
.if ${PORT_OPTIONS:MREADLINE}
|
||||
USES+= readline
|
||||
USES+= readline:port
|
||||
CONFIGURE_ARGS+= --enable-gpl
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-readline
|
||||
.endif
|
||||
|
||||
##############
|
||||
## SYSLOG ##
|
||||
##############
|
||||
|
||||
.if !${PORT_OPTIONS:MSYSLOG}
|
||||
CONFIGURE_ARGS+= --disable-syslog
|
||||
.endif
|
||||
|
||||
##############
|
||||
## SQLITE ##
|
||||
##############
|
||||
|
||||
.if ${PORT_OPTIONS:MSQLITE}
|
||||
CONFIGURE_ARGS+= --with-sqlite=embedded
|
||||
.else
|
||||
CONFIGURE_ARGS+= --without-sqlite
|
||||
.endif
|
||||
|
||||
##################
|
||||
## POSTGRESQL ##
|
||||
##################
|
||||
|
||||
.if ${PORT_OPTIONS:MPGSQL}
|
||||
USES+= pgsql
|
||||
CONFIGURE_ARGS+= --with-postgresql=${PREFIX}
|
||||
USE_PGSQL= true
|
||||
.endif
|
||||
|
||||
#####################
|
||||
## PYTHON / PYGTK ##
|
||||
#####################
|
||||
|
||||
.if ${PORT_OPTIONS:MPYTHON}
|
||||
CONFIGURE_ARGS+= --with-python=${PREFIX}
|
||||
USE_PYTHON= 2
|
||||
USE_GNOME= pygtk2
|
||||
PYCOMPILE= ${PREFIX}/lib/${PYTHON_VERSION}/compileall.py
|
||||
.else
|
||||
CONFIGURE_ARGS+= --without-python \
|
||||
--disable-pygtk \
|
||||
--disable-pygobject
|
||||
CONFIGURE_ARGS+= --without-postgresql
|
||||
.endif
|
||||
|
||||
# Iconv option crashes GPS almost immediately.
|
||||
# GNATColl needs to be examined before attempting to support Iconv again
|
||||
.if 0 #${PORT_OPTIONS: MICONV}
|
||||
USES+= iconv
|
||||
CONFIGURE_ARGS+= --with-iconv=${ICONV_PREFIX}
|
||||
.else
|
||||
CONFIGURE_ARGS+= --without-iconv
|
||||
.endif
|
||||
|
||||
post-extract:
|
||||
@${MV} ${WRKSRC}/templates_parser ${WRKSRC}/TP.ignore
|
||||
@${MV} ${WRKSRC}/Makefile.gnat ${WRKSRC}/Makefile.gnat.ignore
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e "s|@PREFIX@|${PREFIX}|g" \
|
||||
${WRKSRC}/gnatlib/src/gnatcoll_readline.gpr.in
|
||||
@${ECHO} "GNAT_SOURCES=" > ${WRKSRC}/Makefile.gnat
|
||||
@${REINPLACE_CMD} -e 's/^with .*templates_parser\//with "/g' \
|
||||
${WRKSRC}/docgen2/docgen2.gpr \
|
||||
${WRKSRC}/gnatdoc/gnatdoc.gpr \
|
||||
${WRKSRC}/vcs/vcs.gpr
|
||||
@${REINPLACE_CMD} -e 's|@PREFIX@|${PREFIX}|g' \
|
||||
${WRKSRC}/gnatlib/src/gnatcoll_readline.gpr.in \
|
||||
${WRKSRC}/widgets/widgets.gpr
|
||||
@${REINPLACE_CMD} -e 's| gnat/sdefault/sdefault.adb | |' \
|
||||
${WRKSRC}/gnatlib/configure \
|
||||
${WRKSRC}/gnatlib/configure.in
|
||||
@${REINPLACE_CMD} -e 's|gnatlib/gnat_src|distrib|' \
|
||||
${WRKSRC}/distrib/from_impunit.pl
|
||||
@${REINPLACE_CMD} -e 's|, "-fdump-xref"||g' \
|
||||
${WRKSRC}/gnatlib/gnatcoll_shared.gpr.in \
|
||||
${WRKSRC}/shared.gpr
|
||||
@${REINPLACE_CMD} -e "s|GPS_VERSION=.*|${GPSVER}|" \
|
||||
${WRKSRC}/configure
|
||||
@${AWK} ${AWKREVDATE} ${WRKSRC}/REVISION | ${XARGS} -I sub \
|
||||
${SED} -i.bak -e sub ${WRKSRC}/common/core/src/config.ads.in
|
||||
|
||||
do-build:
|
||||
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} default
|
||||
|
||||
pre-install:
|
||||
.if ${PORT_OPTIONS:MPYTHON}
|
||||
@${CP} ${PREFIX}/include/gnat_util/impunit.* ${WRKSRC}/distrib
|
||||
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} \
|
||||
${MAKE_CMD} ${MAKE_ARGS} ${ALL_TARGET}
|
||||
cd ${WRKSRC}/docs && ${SETENV} ${MAKE_ENV} \
|
||||
${MAKE_CMD} ${MAKE_ARGS} all
|
||||
${PYTHON_CMD} ${PYCOMPILE} ${WRKSRC}/share/plug-ins
|
||||
${PYTHON_CMD} ${PYCOMPILE} ${WRKSRC}/share/library
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
${RM} -rf ${STAGEDIR}${PREFIX}/share/doc/gps/html/users_guide/_sources
|
||||
${RM} -rf ${STAGEDIR}${PREFIX}/share/doc/gps/html/tutorial/_sources
|
||||
echo "This is the GPS GPL Edition for the FreeBSD Ports Collection." \
|
||||
> ${STAGEDIR}${PREFIX}/share/gps/about.txt
|
||||
@cd ${STAGEDIR}${PREFIX}; ${FIND} * -type d -empty -print | ${XARGS} ${RMDIR}
|
||||
@cd ${STAGEDIR}${PREFIX}; ${FIND} * \( -type f -or -type l \) | \
|
||||
${SORT} >> ${TMPPLIST}
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (gps-5.2.1-1-src.tgz) = 34775c02ccdb70bf4eef0ef6378cd947da8aa66edc9f06bc26ab14a6da549132
|
||||
SIZE (gps-5.2.1-1-src.tgz) = 27925475
|
||||
SHA256 (gps-6.1.0.0.tar.bz2) = f930d89a5b69ff8a4562832b5f2902322ad002ef17633556d87f51733ef955c0
|
||||
SIZE (gps-6.1.0.0.tar.bz2) = 12034437
|
||||
|
|
|
@ -1,105 +1,51 @@
|
|||
--- Makefile.in.orig 2012-06-08 09:54:29.000000000 +0000
|
||||
--- Makefile.in.orig 2014-05-23 09:12:18.000000000 +0000
|
||||
+++ Makefile.in
|
||||
@@ -32,11 +32,12 @@ test-clean:
|
||||
(cd scripts; ./testsuites clean)
|
||||
@@ -5,14 +5,14 @@ RMDIR = rm -rf
|
||||
STRIP = strip
|
||||
AWK = @AWK@
|
||||
PERL = perl
|
||||
-PYTHON = python
|
||||
+PYTHON = $(PYTHON_CMD)
|
||||
INSTALL = @INSTALL@
|
||||
INSTALL_PROGRAM = @INSTALL_PROGRAM@
|
||||
INSTALL_DATA = @INSTALL_DATA@
|
||||
prefix = @prefix@
|
||||
-bindir = $(prefix)/bin
|
||||
-sharedir = $(prefix)/share
|
||||
-examplesdir = $(prefix)/share/examples/gps
|
||||
+bindir = $(DESTDIR)$(prefix)/bin
|
||||
+sharedir = $(DESTDIR)$(prefix)/share
|
||||
+examplesdir = $(DESTDIR)$(prefix)/share/examples/gps
|
||||
|
||||
install-common:
|
||||
- $(MKDIR) $(bindir)
|
||||
- $(MKDIR) $(sharedir)
|
||||
- $(MKDIR) $(examplesdir)
|
||||
- $(MKDIR) $(sharedir)/gps
|
||||
- $(MKDIR) $(sharedir)/gps/docgen2
|
||||
+ $(MKDIR) $(DESTDIR)$(bindir)
|
||||
+ $(MKDIR) $(DESTDIR)$(sharedir)
|
||||
+ $(MKDIR) $(DESTDIR)$(examplesdir)
|
||||
+ $(MKDIR) $(DESTDIR)$(sharedir)/gps
|
||||
+ $(MKDIR) $(DESTDIR)$(sharedir)/gps/docgen2
|
||||
+ $(MKDIR) $(DESTDIR)$(sharedir)/gps/plug-ins
|
||||
ifeq ($(OS),Windows_NT)
|
||||
# On Windows we distribute two versions of subversion.xml, one that
|
||||
# supports Cygwin/Subversion and one for native Subversion.
|
||||
@@ -49,39 +50,34 @@ ifeq ($(OS),Windows_NT)
|
||||
all default:
|
||||
$(MAKE) -C gps default
|
||||
@@ -49,16 +49,6 @@ ifeq ($(OS),Windows_NT)
|
||||
share/plug-ins/_subversion_ \
|
||||
> share/plug-ins/subversion_native_windows.xml
|
||||
> share/plug-ins/subversion_native_windows.py
|
||||
endif
|
||||
- $(RM) -f $(sharedir)/gps/GPS_old
|
||||
- $(RM) $(sharedir)/gps/library/*.py
|
||||
- $(RM) $(sharedir)/gps/library/*.xml
|
||||
- $(RM) $(sharedir)/gps/plug-ins/*.py
|
||||
- $(RM) $(sharedir)/gps/plug-ins/*.xml
|
||||
- $(RM) -r $(sharedir)/gps/plug-ins/spark
|
||||
- $(RM) $(sharedir)/gps/support/core/*.py
|
||||
- $(RM) $(sharedir)/gps/support/ui/*.py
|
||||
- ${RM} ${sharedir}/gps/perspectives.xml
|
||||
- $(RMDIR) $(sharedir)/gps/templates
|
||||
# update runtime.xml before copying the plug-ins files.
|
||||
(cd distrib; $(PERL) from_impunit.pl)
|
||||
- (cd share; tar cf - plug-ins/*.xml) | (cd $(sharedir)/gps; tar xf -)
|
||||
+ (cd share; tar cf - plug-ins/*.xml) | (cd $(DESTDIR)$(sharedir)/gps; tar xf -)
|
||||
ifeq ($(OS),Windows_NT)
|
||||
# Clean-up changes made above for Windows.
|
||||
$(MV) share/plug-ins/_subversion_ share/plug-ins/subversion.xml
|
||||
$(RM) share/plug-ins/subversion_native_windows.xml
|
||||
-(cd distrib; $(PERL) from_impunit.pl)
|
||||
# update light icon set
|
||||
@@ -71,12 +61,9 @@ ifeq ($(OS),Windows_NT)
|
||||
$(MV) share/plug-ins/_subversion_ share/plug-ins/subversion.py
|
||||
$(RM) share/plug-ins/subversion_native_windows.py
|
||||
endif
|
||||
- $(AWK) -f distrib/gnat_switches.awk < gnat/gnat_ugn.texi > $(sharedir)/gps/plug-ins/gnat_switches.py
|
||||
- (cd share; tar cf - plug-ins/*.py) | (cd $(sharedir)/gps; tar xf -)
|
||||
- (cd share; tar cf - plug-ins/gps_utils/*.py) | (cd $(sharedir)/gps; tar xf -)
|
||||
- (cd share; tar cf - plug-ins/spark/*.py) | (cd $(sharedir)/gps; tar xf -)
|
||||
- (cd share; tar cf - plug-ins/*.png) | (cd $(sharedir)/gps; tar xf -)
|
||||
- (cd share; tar cf - plug-ins/images/*.png) | (cd $(sharedir)/gps; tar xf -)
|
||||
- (cd share; tar cf - library/*.xml) | (cd $(sharedir)/gps; tar xf -)
|
||||
- (cd share; tar cf - library/*.py) | (cd $(sharedir)/gps; tar xf -)
|
||||
- (cd share; tar cf - library/pygps/*.py) | (cd $(sharedir)/gps; tar xf -)
|
||||
- $(RM) $(sharedir)/gps/plug-ins/emacs.xml
|
||||
- $(RM) $(sharedir)/gps/plug-ins/python_doc.py
|
||||
- $(RM) $(sharedir)/gps/plug-ins/python_doc.pyc
|
||||
- $(RM) $(sharedir)/gps/shell_commands.xml
|
||||
- (cd share; tar cf - icons/) | (cd $(sharedir)/gps; tar xf -)
|
||||
- (cd share; tar cf - templates/) | (cd $(sharedir)/gps; tar xf -)
|
||||
- (cd share; tar cf - *.*) | (cd $(sharedir)/gps; tar xf -)
|
||||
+ $(AWK) -f distrib/gnat_switches.awk < gnat/gnat_ugn.texi > $(DESTDIR)$(sharedir)/gps/plug-ins/gnat_switches.py
|
||||
+ (cd share; tar cf - plug-ins/*.py) | (cd $(DESTDIR)$(sharedir)/gps; tar xf -)
|
||||
+ (cd share; tar cf - plug-ins/gps_utils/*.py) | (cd $(DESTDIR)$(sharedir)/gps; tar xf -)
|
||||
+ (cd share; tar cf - plug-ins/spark/*.py) | (cd $(DESTDIR)$(sharedir)/gps; tar xf -)
|
||||
+ (cd share; tar cf - plug-ins/*.png) | (cd $(DESTDIR)$(sharedir)/gps; tar xf -)
|
||||
+ (cd share; tar cf - plug-ins/images/*.png) | (cd $(DESTDIR)$(sharedir)/gps; tar xf -)
|
||||
+ (cd share; tar cf - library/*.xml) | (cd $(DESTDIR)$(sharedir)/gps; tar xf -)
|
||||
+ (cd share; tar cf - library/*.py) | (cd $(DESTDIR)$(sharedir)/gps; tar xf -)
|
||||
+ (cd share; tar cf - library/pygps/*.py) | (cd $(DESTDIR)$(sharedir)/gps; tar xf -)
|
||||
+ $(RM) $(DESTDIR)$(sharedir)/gps/plug-ins/emacs.xml
|
||||
+ $(RM) $(DESTDIR)$(sharedir)/gps/plug-ins/python_doc.py
|
||||
+ $(RM) $(DESTDIR)$(sharedir)/gps/plug-ins/python_doc.pyc
|
||||
+ $(RM) $(DESTDIR)$(sharedir)/gps/shell_commands.xml
|
||||
+ (cd share; tar cf - icons/) | (cd $(DESTDIR)$(sharedir)/gps; tar xf -)
|
||||
+ (cd share; tar cf - templates/) | (cd $(DESTDIR)$(sharedir)/gps; tar xf -)
|
||||
+ (cd share; tar cf - *.*) | (cd $(DESTDIR)$(sharedir)/gps; tar xf -)
|
||||
(cd docgen2/resources; tar cf - *.tmpl custom/*.css support/*.css support/*.js support/images/*.png) \
|
||||
- | (cd $(sharedir)/gps/docgen2; tar xf -)
|
||||
+ | (cd $(DESTDIR)$(sharedir)/gps/docgen2; tar xf -)
|
||||
$(MAKE) -C docs install
|
||||
- (cd examples; tar cf - --exclude .svn . ) | (cd $(examplesdir); tar xf -)
|
||||
+ (cd examples; tar cf - --exclude .svn . ) | (cd $(DESTDIR)$(examplesdir); tar xf -)
|
||||
|
||||
install: install-common
|
||||
ifeq ($(OS),Windows_NT)
|
||||
@@ -90,9 +86,9 @@ ifeq ($(OS),Windows_NT)
|
||||
$(INSTALL_PROGRAM) spark/obj/gnatspark.exe $(bindir)
|
||||
$(MAKE) -C common/expect install
|
||||
else
|
||||
- $(INSTALL_PROGRAM) gps/obj/gps $(bindir)
|
||||
- $(INSTALL_PROGRAM) gnatlib/src/obj/gnatinspect $(bindir)
|
||||
- $(INSTALL_PROGRAM) spark/obj/gnatspark $(bindir)
|
||||
+ $(INSTALL_PROGRAM) gps/obj/gps $(DESTDIR)$(bindir)
|
||||
+ $(INSTALL_PROGRAM) gnatlib/src/obj/gnatinspect $(DESTDIR)$(bindir)
|
||||
+ $(INSTALL_PROGRAM) spark/obj/gnatspark $(DESTDIR)$(bindir)
|
||||
endif
|
||||
|
||||
install-strip: install-common
|
||||
@@ -102,9 +98,9 @@ ifeq ($(OS),Windows_NT)
|
||||
$(INSTALL_PROGRAM) distrib/gps_run.cmd $(bindir)
|
||||
$(MAKE) -C common/expect install-strip
|
||||
else
|
||||
- $(INSTALL_PROGRAM) -s gps/obj/gps $(bindir)/gps_exe
|
||||
- $(INSTALL_PROGRAM) -s spark/obj/gnatspark $(bindir)
|
||||
- $(INSTALL_PROGRAM) distrib/.gps_wrapper $(bindir)/gps
|
||||
+ $(INSTALL_PROGRAM) -s gps/obj/gps $(DESTDIR)$(bindir)/gps_exe
|
||||
+ $(INSTALL_PROGRAM) -s spark/obj/gnatspark $(DESTDIR)$(bindir)
|
||||
+ $(INSTALL_PROGRAM) distrib/.gps_wrapper $(DESTDIR)$(bindir)/gps
|
||||
endif
|
||||
|
||||
test: force
|
||||
(cd share; tar cf - plug-ins/images/*.png) | (cd $(sharedir)/gps; tar xf -)
|
||||
(cd share; tar cf - library/*.py) | (cd $(sharedir)/gps; tar xf -)
|
||||
- (cd share; tar cf - library/GPS_old/*.py) | (cd $(sharedir)/gps; tar xf -)
|
||||
(cd share; tar cf - support/) | (cd $(sharedir)/gps; tar xf -)
|
||||
- $(AWK) -f distrib/gnat_switches.awk < gnat/gnat_ugn.texi > $(sharedir)/gps/support/core/gnat_switches.py
|
||||
$(RM) $(sharedir)/gps/plug-ins/emacs.xml
|
||||
$(RM) $(sharedir)/gps/plug-ins/python_doc.py
|
||||
$(RM) $(sharedir)/gps/plug-ins/python_doc.pyc
|
||||
|
|
133
devel/gps/files/patch-browsers_src_browsers-scripts.adb
Normal file
133
devel/gps/files/patch-browsers_src_browsers-scripts.adb
Normal file
|
@ -0,0 +1,133 @@
|
|||
--- browsers/src/browsers-scripts.adb.orig 2014-05-23 17:24:28.000000000 +0000
|
||||
+++ browsers/src/browsers-scripts.adb
|
||||
@@ -70,27 +70,27 @@ package body Browsers.Scripts is
|
||||
P_Font_Color : constant := 10;
|
||||
P_Font_LS : constant := 11;
|
||||
P_Font_Halign : constant := 12;
|
||||
- P_Font_Valign : constant := 13;
|
||||
- P_Arrow_From_Head : constant := 14;
|
||||
- P_Arrow_From_Length : constant := 15;
|
||||
- P_Arrow_From_Angle : constant := 16;
|
||||
- P_Arrow_From_Stroke : constant := 17;
|
||||
- P_Arrow_From_Fill : constant := 18;
|
||||
- P_Arrow_From_Width : constant := 19;
|
||||
- P_Arrow_To_Head : constant := 20;
|
||||
- P_Arrow_To_Length : constant := 21;
|
||||
- P_Arrow_To_Angle : constant := 22;
|
||||
- P_Arrow_To_Stroke : constant := 23;
|
||||
- P_Arrow_To_Fill : constant := 24;
|
||||
- P_Arrow_To_Width : constant := 25;
|
||||
- P_Symbol_From_Name : constant := 26;
|
||||
- P_Symbol_From_Stroke : constant := 27;
|
||||
- P_Symbol_From_Dist : constant := 28;
|
||||
- P_Symbol_From_Width : constant := 29;
|
||||
- P_Symbol_To_Name : constant := 30;
|
||||
- P_Symbol_To_Stroke : constant := 31;
|
||||
- P_Symbol_To_Dist : constant := 32;
|
||||
- P_Symbol_To_Width : constant := 33;
|
||||
+ P_Arrow_From_Head : constant := 13;
|
||||
+ P_Arrow_From_Length : constant := 14;
|
||||
+ P_Arrow_From_Angle : constant := 15;
|
||||
+ P_Arrow_From_Stroke : constant := 16;
|
||||
+ P_Arrow_From_Fill : constant := 17;
|
||||
+ P_Arrow_From_Width : constant := 18;
|
||||
+ P_Arrow_To_Head : constant := 19;
|
||||
+ P_Arrow_To_Length : constant := 20;
|
||||
+ P_Arrow_To_Angle : constant := 21;
|
||||
+ P_Arrow_To_Stroke : constant := 22;
|
||||
+ P_Arrow_To_Fill : constant := 23;
|
||||
+ P_Arrow_To_Width : constant := 24;
|
||||
+ P_Symbol_From_Name : constant := 25;
|
||||
+ P_Symbol_From_Stroke : constant := 26;
|
||||
+ P_Symbol_From_Dist : constant := 27;
|
||||
+ P_Symbol_From_Width : constant := 28;
|
||||
+ P_Symbol_To_Name : constant := 29;
|
||||
+ P_Symbol_To_Stroke : constant := 30;
|
||||
+ P_Symbol_To_Dist : constant := 31;
|
||||
+ P_Symbol_To_Width : constant := 32;
|
||||
+ P_Shadow_Color : constant := 33;
|
||||
-- All the parameters to GPS.Browsers.Style.__init__
|
||||
|
||||
PA_Item : constant := 2;
|
||||
@@ -1123,6 +1123,7 @@ package body Browsers.Scripts is
|
||||
M : Margins := No_Margins;
|
||||
Item : Container_Item;
|
||||
X, Y : Gdouble := Gdouble'First;
|
||||
+ AnchorX, AnchorY : Gdouble;
|
||||
Pos : Gtkada.Style.Point;
|
||||
begin
|
||||
if Command = Constructor_Method then
|
||||
@@ -1139,7 +1140,20 @@ package body Browsers.Scripts is
|
||||
Y := Gdouble (Nth_Arg (Data, 3, Float'First));
|
||||
end if;
|
||||
|
||||
- Canvas_Item (Get_Item (Inst)).Set_Position ((X, Y));
|
||||
+ AnchorX := Gdouble (Nth_Arg (Data, 4, 0.0));
|
||||
+ AnchorY := Gdouble (Nth_Arg (Data, 5, 0.0));
|
||||
+
|
||||
+ Container_Item (Get_Item (Inst)).Set_Position
|
||||
+ ((X, Y), Anchor_X => AnchorX, Anchor_Y => AnchorY);
|
||||
+
|
||||
+ elsif Command = "parent" then
|
||||
+ Inst := Nth_Arg (Data, 1);
|
||||
+ if Get_Item (Inst).Parent /= null then
|
||||
+ Set_Return_Value
|
||||
+ (Data,
|
||||
+ Get_Instance (Python_Item_Access (Get_Item (Inst).Parent),
|
||||
+ Get_Script (Data)));
|
||||
+ end if;
|
||||
|
||||
elsif Command = "x" then
|
||||
Inst := Nth_Arg (Data, 1);
|
||||
@@ -1383,9 +1397,10 @@ package body Browsers.Scripts is
|
||||
Line_Spacing => Gint (Nth_Arg (Data, P_Font_LS, 0)),
|
||||
Halign => Alignment'Val
|
||||
(Integer'(Nth_Arg (Data, P_Font_Halign,
|
||||
- Alignment'Pos (Pango_Align_Left)))),
|
||||
- Valign => Gdouble (Nth_Arg (Data, P_Font_Valign, 0.0))
|
||||
- ),
|
||||
+ Alignment'Pos (Pango_Align_Left))))),
|
||||
+ Shadow =>
|
||||
+ (Color => Color_From_Param (P_Shadow_Color, Null_RGBA),
|
||||
+ others => <>),
|
||||
Arrow_From =>
|
||||
(Head => Arrow_Head'Val
|
||||
(Nth_Arg (Data, P_Arrow_From_Head, Arrow_Head'Pos (None))),
|
||||
@@ -1713,7 +1728,6 @@ package body Browsers.Scripts is
|
||||
P_Font_Color => Param ("fontColor", True),
|
||||
P_Font_LS => Param ("fontLineSpacing", True),
|
||||
P_Font_Halign => Param ("fontHalign", True),
|
||||
- P_Font_Valign => Param ("fontValign", True),
|
||||
P_Arrow_From_Head => Param ("arrowFrom", True),
|
||||
P_Arrow_From_Length => Param ("arrowFromLength", True),
|
||||
P_Arrow_From_Angle => Param ("arrowFromAngle", True),
|
||||
@@ -1733,7 +1747,8 @@ package body Browsers.Scripts is
|
||||
P_Symbol_To_Name => Param ("symbolTo", True),
|
||||
P_Symbol_To_Stroke => Param ("symbolToStroke", True),
|
||||
P_Symbol_To_Dist => Param ("symbolToDist", True),
|
||||
- P_Symbol_To_Width => Param ("symbolToWidth", True)),
|
||||
+ P_Symbol_To_Width => Param ("symbolToWidth", True),
|
||||
+ P_Shadow_Color => Param ("shadowColor", True)),
|
||||
Class => Style_Class,
|
||||
Handler => Style_Handler'Access);
|
||||
|
||||
@@ -1904,11 +1919,18 @@ package body Browsers.Scripts is
|
||||
(Kernel.Scripts,
|
||||
"set_position",
|
||||
Params => (Param ("x", Optional => True),
|
||||
- Param ("y", Optional => True)),
|
||||
+ Param ("y", Optional => True),
|
||||
+ Param ("anchorx", Optional => True),
|
||||
+ Param ("anchory", Optional => True)),
|
||||
Class => Module.Item_Class,
|
||||
Handler => Item_Handler'Access);
|
||||
Register_Property
|
||||
(Kernel.Scripts,
|
||||
+ "parent",
|
||||
+ Class => Module.Item_Class,
|
||||
+ Getter => Item_Handler'Access);
|
||||
+ Register_Property
|
||||
+ (Kernel.Scripts,
|
||||
"x",
|
||||
Class => Module.Item_Class,
|
||||
Getter => Item_Handler'Access);
|
|
@ -1,49 +1,37 @@
|
|||
--- docs/Makefile.in.orig 2012-05-31 13:21:06.000000000 +0000
|
||||
--- docs/Makefile.in.orig 2014-05-23 09:12:23.000000000 +0000
|
||||
+++ docs/Makefile.in
|
||||
@@ -15,29 +15,29 @@ gps_pg:
|
||||
make -C programers_guide html
|
||||
@@ -1,6 +1,6 @@
|
||||
prefix = @prefix@
|
||||
-docdir = $(prefix)/share/doc/gps
|
||||
-sharedir = $(prefix)/share/gps
|
||||
+docdir = $(DESTDIR)$(prefix)/share/doc/gps
|
||||
+sharedir = $(DESTDIR)$(prefix)/share/gps
|
||||
|
||||
MKDIR = mkdir -p
|
||||
INSTALL = @INSTALL@
|
||||
@@ -12,20 +12,20 @@ all: ug tutorial gps_pg relnotes gnatdoc
|
||||
static:
|
||||
|
||||
gps_pg:
|
||||
- make -C programmers_guide html
|
||||
+ $(MAKE) -C programmers_guide html
|
||||
|
||||
relnotes:
|
||||
- make -C release_notes singlehtml
|
||||
+ $(MAKE) -C release_notes singlehtml
|
||||
|
||||
ug:
|
||||
- make -C users_guide html latexpdf
|
||||
+ make -C users_guide html
|
||||
+ $(MAKE) -C users_guide html
|
||||
|
||||
gnatdoc:
|
||||
- make -C ../gnatdoc/docs/users_guide html latexpdf
|
||||
+ $(MAKE) -C ../gnatdoc/docs/users_guide html
|
||||
|
||||
.PHONY: tutorial
|
||||
tutorial:
|
||||
make -C tutorial html
|
||||
- make -C tutorial html
|
||||
+ $(MAKE) -C tutorial html
|
||||
|
||||
install:
|
||||
- $(MKDIR) $(docdir)
|
||||
- $(MKDIR) $(docdir)/html
|
||||
- $(MKDIR) $(docdir)/pdf
|
||||
- -$(INSTALL_DATA) gps-welcome.html $(docdir)/html
|
||||
- -$(CP) users_guide/GPS.py $(sharedir)/library/GPS_doc.py
|
||||
-
|
||||
- ${MKDIR} $(docdir)/html/users_guide/
|
||||
- -${CP} -r users_guide/_build/html/* $(docdir)/html/users_guide/
|
||||
- -${CP} users_guide/_build/latex/GPS.pdf $(docdir)/pdf/gps.pdf
|
||||
-
|
||||
- ${MKDIR} $(docdir)/html/tutorial/
|
||||
- -${CP} -r tutorial/_build/html/* $(docdir)/html/tutorial/
|
||||
-
|
||||
- -$(INSTALL_DATA) gps-splash.png $(sharedir)
|
||||
- -${INSTALL_DATA} gps_index.xml ${docdir}/html
|
||||
- -${INSTALL_DATA} help_index.html ${docdir}/html
|
||||
+ $(MKDIR) $(DESTDIR)$(docdir)
|
||||
+ $(MKDIR) $(DESTDIR)$(docdir)/html
|
||||
+ $(MKDIR) $(DESTDIR)$(docdir)/pdf
|
||||
+ -$(INSTALL_DATA) gps-welcome.html $(DESTDIR)$(docdir)/html
|
||||
+ -$(CP) users_guide/GPS.py $(DESTDIR)$(sharedir)/library/GPS_doc.py
|
||||
+
|
||||
+ ${MKDIR} $(DESTDIR)$(docdir)/html/users_guide/
|
||||
+ -${CP} -r users_guide/_build/html/* $(DESTDIR)$(docdir)/html/users_guide/
|
||||
+ -${CP} users_guide/_build/latex/GPS.pdf $(DESTDIR)$(docdir)/pdf/gps.pdf
|
||||
+
|
||||
+ ${MKDIR} $(DESTDIR)$(docdir)/html/tutorial/
|
||||
+ -${CP} -r tutorial/_build/html/* $(DESTDIR)$(docdir)/html/tutorial/
|
||||
+
|
||||
+ -$(INSTALL_DATA) gps-splash.png $(DESTDIR)$(sharedir)
|
||||
+ -${INSTALL_DATA} gps_index.xml $(DESTDIR)${docdir}/html
|
||||
+ -${INSTALL_DATA} help_index.html $(DESTDIR)${docdir}/html
|
||||
|
||||
clean:
|
||||
-${RM} -rf */_build/
|
||||
$(MKDIR) $(docdir)
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- gnatlib/gnatcoll_shared.gpr.in.orig 2010-12-04 00:20:09 +0000
|
||||
+++ gnatlib/gnatcoll_shared.gpr.in
|
||||
@@ -45,7 +45,7 @@ project GnatColl_Shared is
|
||||
for Switches ("Ada") use
|
||||
("-g", "-O1", "-gnata", "-gnatVa", "-gnatQ", "-gnaty",
|
||||
"-gnatwaCJe", "-gnat05");
|
||||
- for Switches ("C") use ("-g", "-fdump-xref");
|
||||
+ for Switches ("C") use ("-g");
|
||||
when "Production" =>
|
||||
for Switches ("Ada") use
|
||||
("-O2", "-gnatn", "-gnatws", "-gnat05");
|
|
@ -1,11 +0,0 @@
|
|||
--- gnatlib/aclocal.m4.orig 2012-09-13 12:50:01.000000000 +0000
|
||||
+++ gnatlib/aclocal.m4
|
||||
@@ -643,7 +643,7 @@ AC_HELP_STRING(
|
||||
ia64-*hp-hpux11* )
|
||||
PYTHON_LIBS="-ldld -ldl -lm -Wl,-E ${PYTHON_LIBS}"
|
||||
;;
|
||||
- *-freebsd* )
|
||||
+ *-dragonfly* | *-freebsd* | *-netbsd* | *-openbsd* )
|
||||
PYTHON_LIBS="-lm -lutil ${PYTHON_LIBS}"
|
||||
;;
|
||||
esac
|
|
@ -1,11 +0,0 @@
|
|||
--- gnatlib/configure.orig 2012-09-13 12:50:01.000000000 +0000
|
||||
+++ gnatlib/configure
|
||||
@@ -4083,7 +4083,7 @@ $as_echo_n "checking if we can link with
|
||||
ia64-*hp-hpux11* )
|
||||
PYTHON_LIBS="-ldld -ldl -lm -Wl,-E ${PYTHON_LIBS}"
|
||||
;;
|
||||
- *-freebsd* )
|
||||
+ *-dragonfly* | *-freebsd* | *-netbsd* | *-openbsd* )
|
||||
PYTHON_LIBS="-lm -lutil ${PYTHON_LIBS}"
|
||||
;;
|
||||
esac
|
12
devel/gps/files/patch-gnatlib_src_gnatcoll__iconv.gpr
Normal file
12
devel/gps/files/patch-gnatlib_src_gnatcoll__iconv.gpr
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- gnatlib/src/gnatcoll_iconv.gpr.orig 2014-04-10 13:47:58.000000000 +0000
|
||||
+++ gnatlib/src/gnatcoll_iconv.gpr
|
||||
@@ -27,7 +27,8 @@ project GnatColl_Iconv is
|
||||
package Compiler is
|
||||
for Switches ("Ada") use GnatColl_Shared.Compiler'Switches ("Ada");
|
||||
for Switches ("C") use GnatColl_Shared.Compiler'Switches ("C")
|
||||
- & GnatColl_Shared.Iconv_Include;
|
||||
+ & ("-nostdinc") & GnatColl_Shared.Iconv_Include
|
||||
+ & ("-I/usr/include");
|
||||
end Compiler;
|
||||
|
||||
package Builder renames GnatColl_Shared.Builder;
|
|
@ -1,4 +1,4 @@
|
|||
--- gnatlib/src/gnatcoll_readline.gpr.in.orig 2012-07-13 14:11:00.000000000 +0000
|
||||
--- gnatlib/src/gnatcoll_readline.gpr.in.orig 2014-04-10 13:47:58.000000000 +0000
|
||||
+++ gnatlib/src/gnatcoll_readline.gpr.in
|
||||
@@ -6,7 +6,7 @@ project GnatColl_Readline is
|
||||
when "yes" =>
|
||||
|
|
|
@ -0,0 +1,11 @@
|
|||
--- gnatlib/src/iconv/with_iconv/iconv_support.c.orig 2013-08-21 12:16:12.000000000 +0000
|
||||
+++ gnatlib/src/iconv/with_iconv/iconv_support.c
|
||||
@@ -25,7 +25,7 @@ int gnatcoll_iconv_close(iconv_t cd) {
|
||||
return iconv_close (cd);
|
||||
}
|
||||
|
||||
-#if _LIBICONV_VERSION >= 0x010D
|
||||
+#if defined (__FreeBSD__) || defined (__DragonFly__)
|
||||
size_t gnatcoll_iconv
|
||||
(iconv_t cd, const char** inbuf, size_t *inbytesleft, char** outbuf,
|
||||
size_t *outbytesleft)
|
|
@ -1,14 +0,0 @@
|
|||
$NetBSD: patch-gps_gps.gpr,v 1.2 2012/05/16 17:56:49 marino Exp $
|
||||
|
||||
--- gps/gps.gpr.orig 2012-01-28 15:08:25.689555000 +0000
|
||||
+++ gps/gps.gpr
|
||||
@@ -73,7 +73,8 @@ project GPS is
|
||||
when "Windows_NT" =>
|
||||
for Default_Switches ("Ada") use ("obj/gps.res");
|
||||
when "unix" =>
|
||||
- null;
|
||||
+ for Default_Switches ("Ada") use ("-lXrender", "-lX11",
|
||||
+ "-lgmodule-2.0");
|
||||
end case;
|
||||
-- for Default_Switches ("Ada") use ("-lgmem");
|
||||
-- for Default_Switches ("Ada") use ("-pg");
|
|
@ -1,11 +0,0 @@
|
|||
--- src_editor/src/src_editor_buffer.adb.orig 2012-09-28 15:42:43.000000000 +0000
|
||||
+++ src_editor/src/src_editor_buffer.adb
|
||||
@@ -5820,7 +5820,7 @@ package body Src_Editor_Buffer is
|
||||
|
||||
while Result
|
||||
and then not Ends_Line (Iter)
|
||||
- and then Is_Space (Get_Char (Iter))
|
||||
+ and then Glib.Unicode.Is_Space (Gtk.Text_Iter.Get_Char (Iter))
|
||||
loop
|
||||
Forward_Char (Iter, Result);
|
||||
Offset := Offset + 1;
|
|
@ -1,19 +0,0 @@
|
|||
--- src_editor/src/src_editor_view.adb.orig 2012-07-02 09:23:20.000000000 +0000
|
||||
+++ src_editor/src/src_editor_view.adb
|
||||
@@ -1789,6 +1789,7 @@ package body Src_Editor_View is
|
||||
is
|
||||
View : constant Source_View := Source_View (Widget);
|
||||
Dummy_Gint : Gint;
|
||||
+ Dummy2_Gint : Gint;
|
||||
W, H, D : Gint;
|
||||
Button_Y : Gint;
|
||||
Lower, Upper : Gdouble;
|
||||
@@ -1807,7 +1808,7 @@ package body Src_Editor_View is
|
||||
Button_Y := Gint (Get_Y (Event));
|
||||
|
||||
Get_Geometry
|
||||
- (Get_Window (View.Area), Dummy_Gint, Dummy_Gint, W, H, D);
|
||||
+ (Get_Window (View.Area), Dummy_Gint, Dummy2_Gint, W, H, D);
|
||||
|
||||
Adj := Get_Vadjustment (View.Scroll);
|
||||
Lower := Get_Lower (Adj);
|
14
devel/gps/files/patch-widgets_widgets.gpr
Normal file
14
devel/gps/files/patch-widgets_widgets.gpr
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- widgets/widgets.gpr.orig 2013-03-05 14:31:25.000000000 +0000
|
||||
+++ widgets/widgets.gpr
|
||||
@@ -5,7 +5,10 @@ with "../shared";
|
||||
project Widgets is
|
||||
|
||||
for Languages use ("C", "Ada");
|
||||
- for Source_Dirs use ("src");
|
||||
+ for Source_Dirs use ("src", "@PREFIX@/include/gtk-3.0",
|
||||
+ "@PREFIX@/include/glib-2.0", "@PREFIX@/include/pango-1.0",
|
||||
+ "@PREFIX@/include/cairo", "@PREFIX@/include/gdk-pixbuf-2.0",
|
||||
+ "@PREFIX@/include/atk-1.0");
|
||||
for Object_Dir use Shared'Object_Dir;
|
||||
|
||||
package Compiler renames Shared.Compiler;
|
Loading…
Reference in a new issue