Update to 0.8

This commit is contained in:
Lars Thegler 2005-01-08 17:51:34 +00:00
parent 60cb8cbb85
commit ca291ad019
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=125853
4 changed files with 18 additions and 25 deletions

View file

@ -6,7 +6,7 @@
#
PORTNAME= Email-FolderType
PORTVERSION= 0.7
PORTVERSION= 0.8
CATEGORIES= mail perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Email
@ -15,21 +15,23 @@ PKGNAMEPREFIX= p5-
MAINTAINER= lth@FreeBSD.org
COMMENT= Determine the type of a mail folder
PERL_CONFIGURE= yes
BUILD_DEPENDS= ${SITE_PERL}/Module/Pluggable.pm:${PORTSDIR}/devel/p5-Module-Pluggable
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_MODBUILD= yes
MAN3= Email::FolderType.3 \
Email::FolderType::Local.3 \
Email::FolderType::Register.3
Email::FolderType::Ezmlm.3 \
Email::FolderType::MH.3 \
Email::FolderType::Maildir.3 \
Email::FolderType::Mbox.3
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} <= 500503
EXTRA_PATCHES= ${PATCHDIR}/5.005-t::05_register.t
# make PREFIX-clean under perl 5.005_03
post-configure:
${PERL} -pi -e 's,/usr/local/,\$$(PREFIX)/,g' ${WRKSRC}/Makefile
post-patch:
@${PERL} -pi -e 's/^our\s+([\$$\@\%]\w+)/use vars qw($$1); $$1/;' \
${WRKSRC}/lib/Email/FolderType.pm
.endif
.include <bsd.port.post.mk>

View file

@ -1,2 +1,2 @@
MD5 (Email-FolderType-0.7.tar.gz) = 92fdcdd0f59aee9b53fadddf2b9833c4
SIZE (Email-FolderType-0.7.tar.gz) = 4695
MD5 (Email-FolderType-0.8.tar.gz) = ce8a9c1471882e939af5a4ec1603ac91
SIZE (Email-FolderType-0.8.tar.gz) = 11556

View file

@ -1,8 +0,0 @@
--- t/05_register.t.orig Mon May 17 22:48:40 2004
+++ t/05_register.t Mon May 17 22:49:30 2004
@@ -1,4 +1,4 @@
-use Test::More qw[no_plan];
+use Test::More tests => 3;
use Email::FolderType::Register qw[register_type];
use Email::FolderType qw[folder_type];

View file

@ -1,8 +1,7 @@
%%SITE_PERL%%/Email/FolderType.pm
%%SITE_PERL%%/Email/FolderType/Local.pm
%%SITE_PERL%%/Email/FolderType/Register.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Email/FolderType/.packlist
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Email/FolderType
@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Email 2>/dev/null || true
%%SITE_PERL%%/Email/FolderType/Ezmlm.pm
%%SITE_PERL%%/Email/FolderType/MH.pm
%%SITE_PERL%%/Email/FolderType/Maildir.pm
%%SITE_PERL%%/Email/FolderType/Mbox.pm
@unexec rmdir %D/%%SITE_PERL%%/Email/FolderType 2>/dev/null || true
@unexec rmdir %D/%%SITE_PERL%%/Email 2>/dev/null || true