- Add NO_ARCH
- Simplify installation (do-install is simpler and more straightforward than changing whole upstream makefile)
This commit is contained in:
parent
e8bff628db
commit
ca65dd8a92
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=421107
2 changed files with 9 additions and 16 deletions
|
@ -11,10 +11,17 @@ MAINTAINER= ports@FreeBSD.org
|
|||
COMMENT= Remove leading quotations from mail/news and wrap lines to fixed width
|
||||
|
||||
USES= python
|
||||
NO_ARCH= yes
|
||||
NO_BUILD= yes
|
||||
|
||||
OPTIONS_DEFINE= DOCS
|
||||
|
||||
post-install:
|
||||
do-install:
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
|
||||
${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1.gz ${STAGEDIR}${MAN1PREFIX}/man/man1
|
||||
|
||||
do-install-DOCS-on:
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
@${INSTALL_DATA} ${WRKSRC}/mailfmt-license.txt ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/mailfmt-license.txt ${STAGEDIR}${DOCSDIR}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,14 +0,0 @@
|
|||
--- Makefile.orig 2002-10-10 03:43:16.000000000 +0800
|
||||
+++ Makefile 2014-07-10 21:12:43.040252063 +0800
|
||||
@@ -4,7 +4,7 @@
|
||||
all: # Do nothing - this is a python script that needs no build
|
||||
|
||||
install:
|
||||
- install -c -o root -g wheel -m 755 ./mailfmt ${PREFIX}/bin
|
||||
- mkdir ${PREFIX}/share/doc/mailfmt
|
||||
- install -c -o root -g wheel -m 644 ./mailfmt.1.gz ${PREFIX}/man/man1
|
||||
- install -c -o root -g wheel -m 644 ./mailfmt-license.txt ${PREFIX}/share/doc/mailfmt
|
||||
+ $(BSD_INSTALL_SCRIPT) ./mailfmt $(DESTDIR)${PREFIX}/bin
|
||||
+# mkdir ${PREFIX}/share/doc/mailfmt
|
||||
+ $(BSD_INSTALL_MAN) ./mailfmt.1.gz $(DESTDIR)${PREFIX}/man/man1
|
||||
+# install -c -o root -g wheel -m 644 ./mailfmt-license.txt ${PREFIX}/share/doc/mailfmt
|
Loading…
Reference in a new issue