New port: textproc/libcyaml: C library for reading and writing YAML
This commit is contained in:
parent
85086b2633
commit
ca699f0065
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=492970
5 changed files with 63 additions and 0 deletions
|
@ -417,6 +417,7 @@
|
|||
SUBDIR += libcss
|
||||
SUBDIR += libcsv
|
||||
SUBDIR += libcue
|
||||
SUBDIR += libcyaml
|
||||
SUBDIR += libdiff
|
||||
SUBDIR += libe-book
|
||||
SUBDIR += libebml
|
||||
|
|
28
textproc/libcyaml/Makefile
Normal file
28
textproc/libcyaml/Makefile
Normal file
|
@ -0,0 +1,28 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= libcyaml
|
||||
DISTVERSION= 0.1.0
|
||||
CATEGORIES= textproc
|
||||
|
||||
MAINTAINER= yuri@FreeBSD.org
|
||||
COMMENT= C library for reading and writing YAML
|
||||
|
||||
LICENSE= ISCL
|
||||
|
||||
LIB_DEPENDS= libyaml.so:textproc/libyaml
|
||||
|
||||
USES= gmake localbase:ldflags
|
||||
USE_GITLAB= yes
|
||||
GL_SITE= https://git.zrythm.org
|
||||
GL_ACCOUNT= zrythm
|
||||
GL_COMMIT= 3b568c9df39b5a95f1d652db43414fada3b1cc61
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
PLIST_FILES= include/cyaml/cyaml.h \
|
||||
lib/libcyaml.a \
|
||||
lib/libcyaml.so \
|
||||
lib/libcyaml.so.0 \
|
||||
lib/libcyaml.so.0.1.0 \
|
||||
libdata/pkgconfig/libcyaml.pc
|
||||
|
||||
.include <bsd.port.mk>
|
3
textproc/libcyaml/distinfo
Normal file
3
textproc/libcyaml/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
TIMESTAMP = 1550204598
|
||||
SHA256 (zrythm-libcyaml-3b568c9df39b5a95f1d652db43414fada3b1cc61_GL0.tar.gz) = 8a574dab6205f94eb2c2a55ecb9d84f328d8fca069b0e8373e17a7e5fd5d7325
|
||||
SIZE (zrythm-libcyaml-3b568c9df39b5a95f1d652db43414fada3b1cc61_GL0.tar.gz) = 69120
|
27
textproc/libcyaml/files/patch-Makefile
Normal file
27
textproc/libcyaml/files/patch-Makefile
Normal file
|
@ -0,0 +1,27 @@
|
|||
--- Makefile.orig 2019-02-04 13:46:44 UTC
|
||||
+++ Makefile
|
||||
@@ -37,7 +37,7 @@ INCLUDEDIR ?= include
|
||||
CC ?= gcc
|
||||
AR ?= ar
|
||||
MKDIR = mkdir -p
|
||||
-INSTALL ?= install -c -D
|
||||
+INSTALL ?= install -c
|
||||
VALGRIND = valgrind --leak-check=full --track-origins=yes
|
||||
|
||||
VERSION_FLAGS = -DVERSION_MAJOR=$(VERSION_MAJOR) \
|
||||
@@ -154,13 +154,14 @@ clean:
|
||||
rm -rf build/
|
||||
|
||||
install: $(BUILDDIR)/$(LIB_SH_MAJ) $(BUILDDIR)/$(LIB_STATIC) $(BUILDDIR)/$(LIB_PKGCON)
|
||||
- $(INSTALL) $(BUILDDIR)/$(LIB_SH_MAJ) $(DESTDIR)$(PREFIX)/$(LIBDIR)/$(LIB_SH_VER)
|
||||
+ $(INSTALL) -s $(BUILDDIR)/$(LIB_SH_MAJ) $(DESTDIR)$(PREFIX)/$(LIBDIR)/$(LIB_SH_VER)
|
||||
(cd $(DESTDIR)$(PREFIX)/$(LIBDIR) && { ln -s -f $(LIB_SH_VER) $(LIB_SH_MAJ) || { rm -f $(LIB_SH_MAJ) && ln -s $(LIB_SH_VER) $(LIB_SH_MAJ); }; })
|
||||
(cd $(DESTDIR)$(PREFIX)/$(LIBDIR) && { ln -s -f $(LIB_SH_VER) $(LIB_SHARED) || { rm -f $(LIB_SHARED) && ln -s $(LIB_SH_VER) $(LIB_SHARED); }; })
|
||||
$(INSTALL) $(BUILDDIR)/$(LIB_STATIC) $(DESTDIR)$(PREFIX)/$(LIBDIR)/$(LIB_STATIC)
|
||||
chmod 644 $(DESTDIR)$(PREFIX)/$(LIBDIR)/$(LIB_STATIC)
|
||||
$(INSTALL) -d $(DESTDIR)$(PREFIX)/$(INCLUDEDIR)/cyaml
|
||||
$(INSTALL) -m 644 include/cyaml/* $(DESTDIR)$(PREFIX)/$(INCLUDEDIR)/cyaml
|
||||
+ $(INSTALL) -d $(DESTDIR)$(PREFIX)/$(LIBDIR)/pkgconfig
|
||||
$(INSTALL) -m 644 $(BUILDDIR)/$(LIB_PKGCON) $(DESTDIR)$(PREFIX)/$(LIBDIR)/pkgconfig/$(LIB_PKGCON)
|
||||
|
||||
examples: $(BUILDDIR)/planner $(BUILDDIR)/numerical
|
4
textproc/libcyaml/pkg-descr
Normal file
4
textproc/libcyaml/pkg-descr
Normal file
|
@ -0,0 +1,4 @@
|
|||
LibCYAML is a C library for reading and writing structured YAML documents. It
|
||||
is written in ISO C11 and licensed under the ISC licence.
|
||||
|
||||
WWW: https://git.zrythm.org/zrythm/libcyaml
|
Loading…
Reference in a new issue